- update to 2.0.53

- move prefork/worker modules comparison to %check
This commit is contained in:
jorton 2005-02-09 09:02:54 +00:00
parent 3eb2bca222
commit 439691b8b5
5 changed files with 33 additions and 38 deletions

View File

@ -1,3 +1,2 @@
httpd-2.0.52.tar.gz httpd-2.0.53.tar.gz
migration.html httpd-2.0.53
status.*

View File

@ -6,9 +6,9 @@ Upstream-HEAD: needed
Upstream-2.0: omit Upstream-2.0: omit
Upstream-Status: EXPORT_DIRS change is conditional on using shared apr Upstream-Status: EXPORT_DIRS change is conditional on using shared apr
--- httpd-2.0.48/server/main.c.export --- httpd-2.0.53/server/main.c.export
+++ httpd-2.0.48/server/main.c +++ httpd-2.0.53/server/main.c
@@ -669,28 +669,6 @@ @@ -627,28 +627,6 @@
return 0; /* Termination 'ok' */ return 0; /* Termination 'ok' */
} }
@ -37,14 +37,16 @@ Upstream-Status: EXPORT_DIRS change is conditional on using shared apr
#ifdef AP_USING_AUTOCONF #ifdef AP_USING_AUTOCONF
/* This ugly little hack pulls any function referenced in exports.c into /* This ugly little hack pulls any function referenced in exports.c into
* the web server. exports.c is generated during the build, and it * the web server. exports.c is generated during the build, and it
--- httpd-2.0.48/server/Makefile.in.export --- httpd-2.0.53/server/Makefile.in.export
+++ httpd-2.0.48/server/Makefile.in +++ httpd-2.0.53/server/Makefile.in
@@ -30,7 +30,7 @@ @@ -59,10 +59,6 @@
for dir in $(EXPORT_DIRS); do \
ls $$dir/*.h >> $$tmp; \
done; \
- for dir in $(EXPORT_DIRS_APR); do \
- ls $$dir/ap[ru].h >> $$tmp; \
- ls $$dir/ap[ru]_*.h >> $$tmp; \
- done; \
sort -u $$tmp > $@; \
rm -f $$tmp
util.lo: test_char.h
-EXPORT_DIRS = $(top_srcdir)/include $(top_srcdir)/os/$(OS_DIR) $(APR_INCLUDEDIR) $(APU_INCLUDEDIR) $(top_srcdir)/modules/http
+EXPORT_DIRS = $(top_srcdir)/include $(top_srcdir)/os/$(OS_DIR) $(top_srcdir)/modules/http
# If export_files is a dependency here, but we remove it during this stage,
# when exports.c is generated, make will not detect that export_files is no

View File

@ -6,8 +6,8 @@
Summary: Apache HTTP Server Summary: Apache HTTP Server
Name: httpd Name: httpd
Version: 2.0.52 Version: 2.0.53
Release: 7 Release: 1
URL: http://httpd.apache.org/ URL: http://httpd.apache.org/
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
Source1: index.html Source1: index.html
@ -51,8 +51,6 @@ Patch28: httpd-2.0.48-worker.patch
Patch29: httpd-2.0.48-workerhup.patch Patch29: httpd-2.0.48-workerhup.patch
Patch30: httpd-2.0.48-davmisc.patch Patch30: httpd-2.0.48-davmisc.patch
Patch39: httpd-2.0.50-reclaim.patch Patch39: httpd-2.0.50-reclaim.patch
Patch40: httpd-2.0.52-sslauth.patch
Patch41: httpd-2.0.52-savebrigade.patch
# Features/functional changes # Features/functional changes
Patch70: httpd-2.0.48-release.patch Patch70: httpd-2.0.48-release.patch
Patch71: httpd-2.0.40-xfsz.patch Patch71: httpd-2.0.40-xfsz.patch
@ -72,9 +70,6 @@ Patch89: httpd-2.0.49-headerssl.patch
Patch90: httpd-2.0.49-workerstack.patch Patch90: httpd-2.0.49-workerstack.patch
Patch91: httpd-2.0.46-testhook.patch Patch91: httpd-2.0.46-testhook.patch
Patch92: httpd-2.0.46-dumpcerts.patch Patch92: httpd-2.0.46-dumpcerts.patch
# Security fixes
Patch120: httpd-2.0.52-CAN-2004-0885.patch
Patch121: httpd-2.0.52-CAN-2004-0942.patch
License: Apache Software License License: Apache Software License
Group: System Environment/Daemons Group: System Environment/Daemons
BuildRoot: %{_tmppath}/%{name}-root BuildRoot: %{_tmppath}/%{name}-root
@ -168,8 +163,6 @@ executed by SSI pages) as a user other than the 'apache' user.
%patch29 -p1 -b .workerhup %patch29 -p1 -b .workerhup
%patch30 -p1 -b .davmisc %patch30 -p1 -b .davmisc
%patch39 -p1 -b .reclaim %patch39 -p1 -b .reclaim
%patch40 -p1 -b .sslauth
%patch41 -p1 -b .savebrigade
%patch71 -p0 -b .xfsz %patch71 -p0 -b .xfsz
%patch72 -p1 -b .pod %patch72 -p1 -b .pod
@ -189,9 +182,6 @@ executed by SSI pages) as a user other than the 'apache' user.
%patch91 -p1 -b .testhook %patch91 -p1 -b .testhook
%patch92 -p1 -b .dumpcerts %patch92 -p1 -b .dumpcerts
%patch120 -p1 -b .can0885
%patch121 -p1 -b .can0942
# Patch in vendor/release string # Patch in vendor/release string
sed "s/@RELEASE@/%{vstring}/" < %{PATCH70} | patch -p1 sed "s/@RELEASE@/%{vstring}/" < %{PATCH70} | patch -p1
@ -297,14 +287,6 @@ mpmbuild prefork --enable-mods-shared=all \
# easiest way seems to be enable them shared. # easiest way seems to be enable them shared.
mpmbuild worker --enable-mods-shared=all mpmbuild worker --enable-mods-shared=all
# Verify that the same modules were built into the two httpd binaries
./prefork/httpd -l | grep -v prefork > prefork.mods
./worker/httpd -l | grep -v worker > worker.mods
if ! diff -u prefork.mods worker.mods; then
: Different modules built into httpd binaries, will not proceed
exit 1
fi
%install %install
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -507,6 +489,14 @@ if readelf -d $RPM_BUILD_ROOT%{_libdir}/httpd/modules/*.so | grep TEXTREL; then
exit 1 exit 1
fi fi
# Verify that the same modules were built into the two httpd binaries
./prefork/httpd -l | grep -v prefork > prefork.mods
./worker/httpd -l | grep -v worker > worker.mods
if ! diff -u prefork.mods worker.mods; then
: Different modules built into httpd binaries, will not proceed
exit 1
fi
%clean %clean
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
@ -604,6 +594,10 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man8/suexec.8* %{_mandir}/man8/suexec.8*
%changelog %changelog
* Wed Feb 9 2005 Joe Orton <jorton@redhat.com> 2.0.53-4
- update to 2.0.53
- move prefork/worker modules comparison to %%check
* Mon Feb 7 2005 Joe Orton <jorton@redhat.com> 2.0.52-7 * Mon Feb 7 2005 Joe Orton <jorton@redhat.com> 2.0.52-7
- fix cosmetic issues in "service httpd reload" - fix cosmetic issues in "service httpd reload"
- move User/Group higher in httpd.conf (#146793) - move User/Group higher in httpd.conf (#146793)

View File

@ -1 +1 @@
eba528fa8613dc5bfb0615a69c11f053 httpd-2.0.52.tar.gz b089bdc7065c3be166bcc516b0d92416 httpd-2.0.53.tar.gz

View File

@ -1 +1 @@
httpd-2.0.52.tar.gz httpd-2.0.53.tar.gz