auto-import changelog data from httpd-2.0.49-7.src.rpm
Wed Jun 16 2004 Joe Orton <jorton@redhat.com> 2.0.49-7 - don't install or use bundled pcreposix.h - bump default MaxClients to 256 - drop default Timeout to 2 minutes - merge from upstream: add fix for VirtualHost multiple address handling (Jeff Trawick)
This commit is contained in:
parent
22faa81e86
commit
436bfeb65b
@ -1,3 +1,7 @@
|
|||||||
|
|
||||||
|
Change the server version string appropriately, without changing
|
||||||
|
the PLATFORM macro throughout the cod.
|
||||||
|
|
||||||
--- httpd-2.0.48/server/core.c.release
|
--- httpd-2.0.48/server/core.c.release
|
||||||
+++ httpd-2.0.48/server/core.c
|
+++ httpd-2.0.48/server/core.c
|
||||||
@@ -2386,7 +2386,7 @@
|
@@ -2386,7 +2386,7 @@
|
||||||
|
@ -48,7 +48,7 @@ ServerTokens OS
|
|||||||
#
|
#
|
||||||
# NOTE! If you intend to place this on an NFS (or otherwise network)
|
# NOTE! If you intend to place this on an NFS (or otherwise network)
|
||||||
# mounted filesystem then please read the LockFile documentation
|
# mounted filesystem then please read the LockFile documentation
|
||||||
# (available at <URL:http://httpd.apache.org/docs-2.0/mod/core.html#lockfile>);
|
# (available at <URL:http://httpd.apache.org/docs-2.0/mod/mpm_common.html#lockfile>);
|
||||||
# you will save yourself a lot of trouble.
|
# you will save yourself a lot of trouble.
|
||||||
#
|
#
|
||||||
# Do NOT add a slash at the end of the directory path.
|
# Do NOT add a slash at the end of the directory path.
|
||||||
@ -64,7 +64,7 @@ PidFile run/httpd.pid
|
|||||||
#
|
#
|
||||||
# Timeout: The number of seconds before receives and sends time out.
|
# Timeout: The number of seconds before receives and sends time out.
|
||||||
#
|
#
|
||||||
Timeout 300
|
Timeout 120
|
||||||
|
|
||||||
#
|
#
|
||||||
# KeepAlive: Whether or not to allow persistent connections (more than
|
# KeepAlive: Whether or not to allow persistent connections (more than
|
||||||
@ -93,13 +93,15 @@ KeepAliveTimeout 15
|
|||||||
# StartServers: number of server processes to start
|
# StartServers: number of server processes to start
|
||||||
# MinSpareServers: minimum number of server processes which are kept spare
|
# MinSpareServers: minimum number of server processes which are kept spare
|
||||||
# MaxSpareServers: maximum number of server processes which are kept spare
|
# MaxSpareServers: maximum number of server processes which are kept spare
|
||||||
|
# ServerLimit: maximum value for MaxClients for the lifetime of the server
|
||||||
# MaxClients: maximum number of server processes allowed to start
|
# MaxClients: maximum number of server processes allowed to start
|
||||||
# MaxRequestsPerChild: maximum number of requests a server process serves
|
# MaxRequestsPerChild: maximum number of requests a server process serves
|
||||||
<IfModule prefork.c>
|
<IfModule prefork.c>
|
||||||
StartServers 8
|
StartServers 8
|
||||||
MinSpareServers 5
|
MinSpareServers 5
|
||||||
MaxSpareServers 20
|
MaxSpareServers 20
|
||||||
MaxClients 150
|
ServerLimit 256
|
||||||
|
MaxClients 256
|
||||||
MaxRequestsPerChild 4000
|
MaxRequestsPerChild 4000
|
||||||
</IfModule>
|
</IfModule>
|
||||||
|
|
||||||
|
22
httpd.spec
22
httpd.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: Apache HTTP Server
|
Summary: Apache HTTP Server
|
||||||
Name: httpd
|
Name: httpd
|
||||||
Version: 2.0.49
|
Version: 2.0.49
|
||||||
Release: 6
|
Release: 7
|
||||||
URL: http://httpd.apache.org/
|
URL: http://httpd.apache.org/
|
||||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
|
||||||
Source1: index.html
|
Source1: index.html
|
||||||
@ -56,6 +56,7 @@ Patch36: httpd-2.0.49-nolcrash.patch
|
|||||||
Patch37: httpd-2.0.46-autoindex.patch
|
Patch37: httpd-2.0.46-autoindex.patch
|
||||||
Patch38: httpd-2.0.46-deflate2.patch
|
Patch38: httpd-2.0.46-deflate2.patch
|
||||||
Patch39: httpd-2.0.49-suexecsuid.patch
|
Patch39: httpd-2.0.49-suexecsuid.patch
|
||||||
|
Patch40: httpd-2.0.49-vhostaddr.patch
|
||||||
# Features/functional changes
|
# Features/functional changes
|
||||||
Patch70: httpd-2.0.48-release.patch
|
Patch70: httpd-2.0.48-release.patch
|
||||||
Patch71: httpd-2.0.40-xfsz.patch
|
Patch71: httpd-2.0.40-xfsz.patch
|
||||||
@ -168,6 +169,7 @@ Security (TLS) protocols.
|
|||||||
%patch37 -p1 -b .autoindex
|
%patch37 -p1 -b .autoindex
|
||||||
%patch38 -p1 -b .deflate2
|
%patch38 -p1 -b .deflate2
|
||||||
%patch39 -p1 -b .suexecsuid
|
%patch39 -p1 -b .suexecsuid
|
||||||
|
%patch40 -p1 -b .vhostaddr
|
||||||
|
|
||||||
%patch71 -p0 -b .xfsz
|
%patch71 -p0 -b .xfsz
|
||||||
%patch72 -p1 -b .pod
|
%patch72 -p1 -b .pod
|
||||||
@ -219,8 +221,12 @@ fi
|
|||||||
: Building for '%{distro}' with MMN %{mmn} and vendor string '%{vstring}'
|
: Building for '%{distro}' with MMN %{mmn} and vendor string '%{vstring}'
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
# forcibly prevent use of bundled apr, apr-util, pcre
|
||||||
|
rm -rf srclib/{apr,apr-util,pcre}
|
||||||
|
rm -f include/pcreposix.h
|
||||||
|
|
||||||
# regenerate configure scripts
|
# regenerate configure scripts
|
||||||
./buildconf
|
autoheader && autoconf || exit 1
|
||||||
|
|
||||||
# Limit size of CHANGES to recent history
|
# Limit size of CHANGES to recent history
|
||||||
echo '1,/Changes with Apache MPM/wq' | ed CHANGES
|
echo '1,/Changes with Apache MPM/wq' | ed CHANGES
|
||||||
@ -232,9 +238,6 @@ echo '1,/Changes with Apache MPM/wq' | ed CHANGES
|
|||||||
%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
|
%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
|
||||||
support/apachectl.in
|
support/apachectl.in
|
||||||
|
|
||||||
# forcibly prevent use of bundled apr, apr-util
|
|
||||||
rm -rf srclib/{apr,apr-util}
|
|
||||||
|
|
||||||
# Build the migration guide
|
# Build the migration guide
|
||||||
sed 's/@DISTRO@/%{distro}/' < $RPM_SOURCE_DIR/migration.xml > migration.xml
|
sed 's/@DISTRO@/%{distro}/' < $RPM_SOURCE_DIR/migration.xml > migration.xml
|
||||||
xmlto --skip-validation -x $RPM_SOURCE_DIR/html.xsl html-nochunks migration.xml
|
xmlto --skip-validation -x $RPM_SOURCE_DIR/html.xsl html-nochunks migration.xml
|
||||||
@ -579,7 +582,14 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/httpd/build/libtool
|
%{_libdir}/httpd/build/libtool
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
* Wed Jun 16 2004 Joe Orton <jorton@redhat.com> 2.0.49-7
|
||||||
|
- don't install or use bundled pcreposix.h
|
||||||
|
- bump default MaxClients to 256
|
||||||
|
- drop default Timeout to 2 minutes
|
||||||
|
- merge from upstream:
|
||||||
|
* add fix for VirtualHost multiple address handling (Jeff Trawick)
|
||||||
|
|
||||||
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> 2.0.49-6
|
||||||
- rebuilt
|
- rebuilt
|
||||||
|
|
||||||
* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 2.0.49-5
|
* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 2.0.49-5
|
||||||
|
Loading…
Reference in New Issue
Block a user