mod_unique_id: replace use of hostname + pid with PRNG output (#976666)
- apxs: mention -p option in manpage
This commit is contained in:
parent
2d5641e8a1
commit
3b5640856d
@ -1,45 +0,0 @@
|
||||
# ./pullrev.sh 1374214 1375445
|
||||
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1374214
|
||||
http://svn.apache.org/viewvc?view=revision&revision=1375445
|
||||
|
||||
--- httpd-2.4.2/modules/ssl/ssl_engine_init.c
|
||||
+++ httpd-2.4.2/modules/ssl/ssl_engine_init.c
|
||||
@@ -1381,7 +1381,7 @@
|
||||
for (n = 0; n < ncerts; n++) {
|
||||
X509_INFO *inf = sk_X509_INFO_value(sk, n);
|
||||
|
||||
- if (!inf->x509 || !inf->x_pkey) {
|
||||
+ if (!inf->x509 || !inf->x_pkey || !inf->x_pkey->dec_pkey) {
|
||||
sk_X509_INFO_free(sk);
|
||||
ap_log_error(APLOG_MARK, APLOG_STARTUP, 0, s, APLOGNO(02252)
|
||||
"incomplete client cert configured for SSL proxy "
|
||||
@@ -1389,6 +1389,15 @@
|
||||
ssl_die(s);
|
||||
return;
|
||||
}
|
||||
+
|
||||
+ if (X509_check_private_key(inf->x509, inf->x_pkey->dec_pkey) != 1) {
|
||||
+ ssl_log_xerror(SSLLOG_MARK, APLOG_STARTUP, 0, ptemp, s, inf->x509,
|
||||
+ APLOGNO(02326) "proxy client certificate and "
|
||||
+ "private key do not match");
|
||||
+ ssl_log_ssl_error(SSLLOG_MARK, APLOG_ERR, s);
|
||||
+ ssl_die(s);
|
||||
+ return;
|
||||
+ }
|
||||
}
|
||||
|
||||
ap_log_error(APLOG_MARK, APLOG_DEBUG, 0, s, APLOGNO(02207)
|
||||
@@ -1401,7 +1410,11 @@
|
||||
return;
|
||||
}
|
||||
|
||||
- /* Load all of the CA certs and construct a chain */
|
||||
+ /* If SSLProxyMachineCertificateChainFile is configured, load all
|
||||
+ * the CA certs and have OpenSSL attempt to construct a full chain
|
||||
+ * from each configured end-entity cert up to a root. This will
|
||||
+ * allow selection of the correct cert given a list of root CA
|
||||
+ * names in the certificate request from the server. */
|
||||
pkp->ca_certs = (STACK_OF(X509) **) apr_pcalloc(p, ncerts * sizeof(sk));
|
||||
sctx = X509_STORE_CTX_new();
|
||||
|
@ -1,486 +0,0 @@
|
||||
diff -urN httpd-2.4.4/build/config.guess httpd-2.4.4-aarch64/build/config.guess
|
||||
--- httpd-2.4.4/build/config.guess 2013-02-18 14:28:21.000000000 -0600
|
||||
+++ httpd-2.4.4-aarch64/build/config.guess 2013-03-03 05:26:09.407150467 -0600
|
||||
@@ -2,9 +2,9 @@
|
||||
# Attempt to guess a canonical system name.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
-# 2011 Free Software Foundation, Inc.
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2011-05-11'
|
||||
+timestamp='2012-09-25'
|
||||
|
||||
# This file is free software; you can redistribute it and/or modify it
|
||||
# under the terms of the GNU General Public License as published by
|
||||
@@ -17,9 +17,7 @@
|
||||
# General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -57,8 +55,8 @@
|
||||
|
||||
Originally written by Per Bothner.
|
||||
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
|
||||
-Software Foundation, Inc.
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -145,7 +143,7 @@
|
||||
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
|
||||
*:NetBSD:*:*)
|
||||
# NetBSD (nbsd) targets should (where applicable) match one or
|
||||
- # more of the tupples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
+ # more of the tuples: *-*-netbsdelf*, *-*-netbsdaout*,
|
||||
# *-*-netbsdecoff* and *-*-netbsd*. For targets that recently
|
||||
# switched to ELF, *-*-netbsd* would select the old
|
||||
# object file format. This provides both forward
|
||||
@@ -202,6 +200,10 @@
|
||||
# CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM is used.
|
||||
echo "${machine}-${os}${release}"
|
||||
exit ;;
|
||||
+ *:Bitrig:*:*)
|
||||
+ UNAME_MACHINE_ARCH=`arch | sed 's/Bitrig.//'`
|
||||
+ echo ${UNAME_MACHINE_ARCH}-unknown-bitrig${UNAME_RELEASE}
|
||||
+ exit ;;
|
||||
*:OpenBSD:*:*)
|
||||
UNAME_MACHINE_ARCH=`arch | sed 's/OpenBSD.//'`
|
||||
echo ${UNAME_MACHINE_ARCH}-unknown-openbsd${UNAME_RELEASE}
|
||||
@@ -304,7 +306,7 @@
|
||||
arm:RISC*:1.[012]*:*|arm:riscix:1.[012]*:*)
|
||||
echo arm-acorn-riscix${UNAME_RELEASE}
|
||||
exit ;;
|
||||
- arm:riscos:*:*|arm:RISCOS:*:*)
|
||||
+ arm*:riscos:*:*|arm*:RISCOS:*:*)
|
||||
echo arm-unknown-riscos
|
||||
exit ;;
|
||||
SR2?01:HI-UX/MPP:*:* | SR8000:HI-UX/MPP:*:*)
|
||||
@@ -792,21 +794,26 @@
|
||||
echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
|
||||
exit ;;
|
||||
*:FreeBSD:*:*)
|
||||
- case ${UNAME_MACHINE} in
|
||||
- pc98)
|
||||
- echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ UNAME_PROCESSOR=`/usr/bin/uname -p`
|
||||
+ case ${UNAME_PROCESSOR} in
|
||||
amd64)
|
||||
echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
*)
|
||||
- echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
+ echo ${UNAME_PROCESSOR}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
|
||||
esac
|
||||
exit ;;
|
||||
i*:CYGWIN*:*)
|
||||
echo ${UNAME_MACHINE}-pc-cygwin
|
||||
exit ;;
|
||||
+ *:MINGW64*:*)
|
||||
+ echo ${UNAME_MACHINE}-pc-mingw64
|
||||
+ exit ;;
|
||||
*:MINGW*:*)
|
||||
echo ${UNAME_MACHINE}-pc-mingw32
|
||||
exit ;;
|
||||
+ i*:MSYS*:*)
|
||||
+ echo ${UNAME_MACHINE}-pc-msys
|
||||
+ exit ;;
|
||||
i*:windows32*:*)
|
||||
# uname -m includes "-pc" on this system.
|
||||
echo ${UNAME_MACHINE}-mingw32
|
||||
@@ -861,6 +868,13 @@
|
||||
i*86:Minix:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-minix
|
||||
exit ;;
|
||||
+ aarch64:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ aarch64_be:Linux:*:*)
|
||||
+ UNAME_MACHINE=aarch64_be
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
alpha:Linux:*:*)
|
||||
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
|
||||
EV5) UNAME_MACHINE=alphaev5 ;;
|
||||
@@ -895,13 +909,16 @@
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
cris:Linux:*:*)
|
||||
- echo cris-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
crisv32:Linux:*:*)
|
||||
- echo crisv32-axis-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-axis-linux-gnu
|
||||
exit ;;
|
||||
frv:Linux:*:*)
|
||||
- echo frv-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
+ exit ;;
|
||||
+ hexagon:Linux:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
i*86:Linux:*:*)
|
||||
LIBC=gnu
|
||||
@@ -943,7 +960,7 @@
|
||||
test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
|
||||
;;
|
||||
or32:Linux:*:*)
|
||||
- echo or32-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
padre:Linux:*:*)
|
||||
echo sparc-unknown-linux-gnu
|
||||
@@ -978,13 +995,13 @@
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
tile*:Linux:*:*)
|
||||
- echo ${UNAME_MACHINE}-tilera-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
vax:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-dec-linux-gnu
|
||||
exit ;;
|
||||
x86_64:Linux:*:*)
|
||||
- echo x86_64-unknown-linux-gnu
|
||||
+ echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
exit ;;
|
||||
xtensa*:Linux:*:*)
|
||||
echo ${UNAME_MACHINE}-unknown-linux-gnu
|
||||
@@ -1191,6 +1208,9 @@
|
||||
BePC:Haiku:*:*) # Haiku running on Intel PC compatible.
|
||||
echo i586-pc-haiku
|
||||
exit ;;
|
||||
+ x86_64:Haiku:*:*)
|
||||
+ echo x86_64-unknown-haiku
|
||||
+ exit ;;
|
||||
SX-4:SUPER-UX:*:*)
|
||||
echo sx4-nec-superux${UNAME_RELEASE}
|
||||
exit ;;
|
||||
@@ -1246,7 +1266,7 @@
|
||||
NEO-?:NONSTOP_KERNEL:*:*)
|
||||
echo neo-tandem-nsk${UNAME_RELEASE}
|
||||
exit ;;
|
||||
- NSE-?:NONSTOP_KERNEL:*:*)
|
||||
+ NSE-*:NONSTOP_KERNEL:*:*)
|
||||
echo nse-tandem-nsk${UNAME_RELEASE}
|
||||
exit ;;
|
||||
NSR-?:NONSTOP_KERNEL:*:*)
|
||||
@@ -1315,11 +1335,11 @@
|
||||
i*86:AROS:*:*)
|
||||
echo ${UNAME_MACHINE}-pc-aros
|
||||
exit ;;
|
||||
+ x86_64:VMkernel:*:*)
|
||||
+ echo ${UNAME_MACHINE}-unknown-esx
|
||||
+ exit ;;
|
||||
esac
|
||||
|
||||
-#echo '(No uname command or uname output not recognized.)' 1>&2
|
||||
-#echo "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" 1>&2
|
||||
-
|
||||
eval $set_cc_for_build
|
||||
cat >$dummy.c <<EOF
|
||||
#ifdef _SEQUENT_
|
||||
diff -urN httpd-2.4.4/build/config.sub httpd-2.4.4-aarch64/build/config.sub
|
||||
--- httpd-2.4.4/build/config.sub 2013-02-18 14:28:21.000000000 -0600
|
||||
+++ httpd-2.4.4-aarch64/build/config.sub 2013-03-03 05:26:09.451145380 -0600
|
||||
@@ -2,9 +2,9 @@
|
||||
# Configuration validation subroutine script.
|
||||
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
|
||||
# 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010,
|
||||
-# 2011 Free Software Foundation, Inc.
|
||||
+# 2011, 2012 Free Software Foundation, Inc.
|
||||
|
||||
-timestamp='2011-03-23'
|
||||
+timestamp='2012-10-10'
|
||||
|
||||
# This file is (in principle) common to ALL GNU software.
|
||||
# The presence of a machine in this file suggests that SOME GNU software
|
||||
@@ -21,9 +21,7 @@
|
||||
# GNU General Public License for more details.
|
||||
#
|
||||
# You should have received a copy of the GNU General Public License
|
||||
-# along with this program; if not, write to the Free Software
|
||||
-# Foundation, Inc., 51 Franklin Street - Fifth Floor, Boston, MA
|
||||
-# 02110-1301, USA.
|
||||
+# along with this program; if not, see <http://www.gnu.org/licenses/>.
|
||||
#
|
||||
# As a special exception to the GNU General Public License, if you
|
||||
# distribute this file as part of a program that contains a
|
||||
@@ -76,8 +74,8 @@
|
||||
GNU config.sub ($timestamp)
|
||||
|
||||
Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000,
|
||||
-2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free
|
||||
-Software Foundation, Inc.
|
||||
+2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012
|
||||
+Free Software Foundation, Inc.
|
||||
|
||||
This is free software; see the source for copying conditions. There is NO
|
||||
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
|
||||
@@ -125,13 +123,17 @@
|
||||
maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
|
||||
case $maybe_os in
|
||||
nto-qnx* | linux-gnu* | linux-android* | linux-dietlibc | linux-newlib* | \
|
||||
- linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
|
||||
+ linux-musl* | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | \
|
||||
knetbsd*-gnu* | netbsd*-gnu* | \
|
||||
kopensolaris*-gnu* | \
|
||||
storm-chaos* | os2-emx* | rtmk-nova*)
|
||||
os=-$maybe_os
|
||||
basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
|
||||
;;
|
||||
+ android-linux)
|
||||
+ os=-linux-android
|
||||
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`-unknown
|
||||
+ ;;
|
||||
*)
|
||||
basic_machine=`echo $1 | sed 's/-[^-]*$//'`
|
||||
if [ $basic_machine != $1 ]
|
||||
@@ -154,7 +156,7 @@
|
||||
-convergent* | -ncr* | -news | -32* | -3600* | -3100* | -hitachi* |\
|
||||
-c[123]* | -convex* | -sun | -crds | -omron* | -dg | -ultra | -tti* | \
|
||||
-harris | -dolphin | -highlevel | -gould | -cbm | -ns | -masscomp | \
|
||||
- -apple | -axis | -knuth | -cray | -microblaze)
|
||||
+ -apple | -axis | -knuth | -cray | -microblaze*)
|
||||
os=
|
||||
basic_machine=$1
|
||||
;;
|
||||
@@ -223,6 +225,12 @@
|
||||
-isc*)
|
||||
basic_machine=`echo $1 | sed -e 's/86-.*/86-pc/'`
|
||||
;;
|
||||
+ -lynx*178)
|
||||
+ os=-lynxos178
|
||||
+ ;;
|
||||
+ -lynx*5)
|
||||
+ os=-lynxos5
|
||||
+ ;;
|
||||
-lynx*)
|
||||
os=-lynxos
|
||||
;;
|
||||
@@ -247,20 +255,25 @@
|
||||
# Some are omitted here because they have special meanings below.
|
||||
1750a | 580 \
|
||||
| a29k \
|
||||
+ | aarch64 | aarch64_be \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
| am33_2.0 \
|
||||
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
+ | be32 | be64 \
|
||||
| bfin \
|
||||
| c4x | clipper \
|
||||
| d10v | d30v | dlx | dsp16xx \
|
||||
+ | epiphany \
|
||||
| fido | fr30 | frv \
|
||||
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
|
||||
+ | hexagon \
|
||||
| i370 | i860 | i960 | ia64 \
|
||||
| ip2k | iq2000 \
|
||||
+ | le32 | le64 \
|
||||
| lm32 \
|
||||
| m32c | m32r | m32rle | m68000 | m68k | m88k \
|
||||
- | maxq | mb | microblaze | mcore | mep | metag \
|
||||
+ | maxq | mb | microblaze | microblazeel | mcore | mep | metag \
|
||||
| mips | mipsbe | mipseb | mipsel | mipsle \
|
||||
| mips16 \
|
||||
| mips64 | mips64el \
|
||||
@@ -291,7 +304,7 @@
|
||||
| pdp10 | pdp11 | pj | pjl \
|
||||
| powerpc | powerpc64 | powerpc64le | powerpcle \
|
||||
| pyramid \
|
||||
- | rx \
|
||||
+ | rl78 | rx \
|
||||
| score \
|
||||
| sh | sh[1234] | sh[24]a | sh[24]aeb | sh[23]e | sh[34]eb | sheb | shbe | shle | sh[1234]le | sh3ele \
|
||||
| sh64 | sh64le \
|
||||
@@ -300,7 +313,7 @@
|
||||
| spu \
|
||||
| tahoe | tic4x | tic54x | tic55x | tic6x | tic80 | tron \
|
||||
| ubicom32 \
|
||||
- | v850 | v850e \
|
||||
+ | v850 | v850e | v850e1 | v850e2 | v850es | v850e2v3 \
|
||||
| we32k \
|
||||
| x86 | xc16x | xstormy16 | xtensa \
|
||||
| z8k | z80)
|
||||
@@ -315,8 +328,7 @@
|
||||
c6x)
|
||||
basic_machine=tic6x-unknown
|
||||
;;
|
||||
- m6811 | m68hc11 | m6812 | m68hc12 | picochip)
|
||||
- # Motorola 68HC11/12.
|
||||
+ m6811 | m68hc11 | m6812 | m68hc12 | m68hcs12x | picochip)
|
||||
basic_machine=$basic_machine-unknown
|
||||
os=-none
|
||||
;;
|
||||
@@ -329,7 +341,10 @@
|
||||
strongarm | thumb | xscale)
|
||||
basic_machine=arm-unknown
|
||||
;;
|
||||
-
|
||||
+ xgate)
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
+ os=-none
|
||||
+ ;;
|
||||
xscaleeb)
|
||||
basic_machine=armeb-unknown
|
||||
;;
|
||||
@@ -352,11 +367,13 @@
|
||||
# Recognize the basic CPU types with company name.
|
||||
580-* \
|
||||
| a29k-* \
|
||||
+ | aarch64-* | aarch64_be-* \
|
||||
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphaev6[78]-* \
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
||||
| avr-* | avr32-* \
|
||||
+ | be32-* | be64-* \
|
||||
| bfin-* | bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c4x-* \
|
||||
| clipper-* | craynv-* | cydra-* \
|
||||
@@ -365,12 +382,15 @@
|
||||
| f30[01]-* | f700-* | fido-* | fr30-* | frv-* | fx80-* \
|
||||
| h8300-* | h8500-* \
|
||||
| hppa-* | hppa1.[01]-* | hppa2.0-* | hppa2.0[nw]-* | hppa64-* \
|
||||
+ | hexagon-* \
|
||||
| i*86-* | i860-* | i960-* | ia64-* \
|
||||
| ip2k-* | iq2000-* \
|
||||
+ | le32-* | le64-* \
|
||||
| lm32-* \
|
||||
| m32c-* | m32r-* | m32rle-* \
|
||||
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
|
||||
- | m88110-* | m88k-* | maxq-* | mcore-* | metag-* | microblaze-* \
|
||||
+ | m88110-* | m88k-* | maxq-* | mcore-* | metag-* \
|
||||
+ | microblaze-* | microblazeel-* \
|
||||
| mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
|
||||
| mips16-* \
|
||||
| mips64-* | mips64el-* \
|
||||
@@ -400,7 +420,7 @@
|
||||
| pdp10-* | pdp11-* | pj-* | pjl-* | pn-* | power-* \
|
||||
| powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* \
|
||||
| pyramid-* \
|
||||
- | romp-* | rs6000-* | rx-* \
|
||||
+ | rl78-* | romp-* | rs6000-* | rx-* \
|
||||
| sh-* | sh[1234]-* | sh[24]a-* | sh[24]aeb-* | sh[23]e-* | sh[34]eb-* | sheb-* | shbe-* \
|
||||
| shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
|
||||
| sparc-* | sparc64-* | sparc64b-* | sparc64v-* | sparc86x-* | sparclet-* \
|
||||
@@ -408,10 +428,11 @@
|
||||
| sparcv8-* | sparcv9-* | sparcv9b-* | sparcv9v-* | sv1-* | sx?-* \
|
||||
| tahoe-* \
|
||||
| tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
|
||||
- | tile-* | tilegx-* \
|
||||
+ | tile*-* \
|
||||
| tron-* \
|
||||
| ubicom32-* \
|
||||
- | v850-* | v850e-* | vax-* \
|
||||
+ | v850-* | v850e-* | v850e1-* | v850es-* | v850e2-* | v850e2v3-* \
|
||||
+ | vax-* \
|
||||
| we32k-* \
|
||||
| x86-* | x86_64-* | xc16x-* | xps100-* \
|
||||
| xstormy16-* | xtensa*-* \
|
||||
@@ -711,7 +732,6 @@
|
||||
i370-ibm* | ibm*)
|
||||
basic_machine=i370-ibm
|
||||
;;
|
||||
-# I'm not sure what "Sysv32" means. Should this be sysv3.2?
|
||||
i*86v32)
|
||||
basic_machine=`echo $1 | sed -e 's/86.*/86-pc/'`
|
||||
os=-sysv32
|
||||
@@ -769,9 +789,13 @@
|
||||
basic_machine=ns32k-utek
|
||||
os=-sysv
|
||||
;;
|
||||
- microblaze)
|
||||
+ microblaze*)
|
||||
basic_machine=microblaze-xilinx
|
||||
;;
|
||||
+ mingw64)
|
||||
+ basic_machine=x86_64-pc
|
||||
+ os=-mingw64
|
||||
+ ;;
|
||||
mingw32)
|
||||
basic_machine=i386-pc
|
||||
os=-mingw32
|
||||
@@ -808,10 +832,18 @@
|
||||
ms1-*)
|
||||
basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
|
||||
;;
|
||||
+ msys)
|
||||
+ basic_machine=i386-pc
|
||||
+ os=-msys
|
||||
+ ;;
|
||||
mvs)
|
||||
basic_machine=i370-ibm
|
||||
os=-mvs
|
||||
;;
|
||||
+ nacl)
|
||||
+ basic_machine=le32-unknown
|
||||
+ os=-nacl
|
||||
+ ;;
|
||||
ncr3000)
|
||||
basic_machine=i486-ncr
|
||||
os=-sysv4
|
||||
@@ -1120,13 +1152,8 @@
|
||||
basic_machine=t90-cray
|
||||
os=-unicos
|
||||
;;
|
||||
- # This must be matched before tile*.
|
||||
- tilegx*)
|
||||
- basic_machine=tilegx-unknown
|
||||
- os=-linux-gnu
|
||||
- ;;
|
||||
tile*)
|
||||
- basic_machine=tile-unknown
|
||||
+ basic_machine=$basic_machine-unknown
|
||||
os=-linux-gnu
|
||||
;;
|
||||
tx39)
|
||||
@@ -1330,15 +1357,15 @@
|
||||
| -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
|
||||
| -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
|
||||
| -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
|
||||
- | -openbsd* | -solidbsd* \
|
||||
+ | -bitrig* | -openbsd* | -solidbsd* \
|
||||
| -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
|
||||
| -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
|
||||
| -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
|
||||
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
|
||||
| -chorusos* | -chorusrdb* | -cegcc* \
|
||||
- | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
- | -mingw32* | -linux-gnu* | -linux-android* \
|
||||
- | -linux-newlib* | -linux-uclibc* \
|
||||
+ | -cygwin* | -msys* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
|
||||
+ | -mingw32* | -mingw64* | -linux-gnu* | -linux-android* \
|
||||
+ | -linux-newlib* | -linux-musl* | -linux-uclibc* \
|
||||
| -uxpv* | -beos* | -mpeix* | -udk* \
|
||||
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
|
||||
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
|
||||
@@ -1521,6 +1548,9 @@
|
||||
c4x-* | tic4x-*)
|
||||
os=-coff
|
||||
;;
|
||||
+ hexagon-*)
|
||||
+ os=-elf
|
||||
+ ;;
|
||||
tic54x-*)
|
||||
os=-coff
|
||||
;;
|
||||
@@ -1548,9 +1578,6 @@
|
||||
;;
|
||||
m68000-sun)
|
||||
os=-sunos3
|
||||
- # This also exists in the configure program, but was not the
|
||||
- # default.
|
||||
- # os=-sunos4
|
||||
;;
|
||||
m68*-cisco)
|
||||
os=-aout
|
@ -1,21 +0,0 @@
|
||||
--- trunk/docs/man/apxs.1 2013/06/20 12:27:08 1494951
|
||||
+++ trunk/docs/man/apxs.1 2013/06/20 12:30:20 1494952
|
||||
@@ -19,7 +19,7 @@
|
||||
.el .ne 3
|
||||
.IP "\\$1" \\$2
|
||||
..
|
||||
-.TH "APXS" 1 "2012-01-09" "Apache HTTP Server" "apxs"
|
||||
+.TH "APXS" 1 "2013-06-20" "Apache HTTP Server" "apxs"
|
||||
|
||||
.SH NAME
|
||||
apxs \- APache eXtenSion tool
|
||||
@@ -139,6 +139,9 @@
|
||||
.TP
|
||||
-Wl,\fIlinker-flags\fR
|
||||
This option passes \fIlinker-flags\fR as additional flags to the libtool --mode=link command\&. Use this to add local linker-specific options\&.
|
||||
+.TP
|
||||
+-p
|
||||
+This option causes apxs to link against the apr/apr-util libraries\&. This is useful when compiling helper programs that use the apr/apr-util libraries\&.
|
||||
|
||||
.SS "DSO Installation and Configuration Options"
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/modules/cache/mod_cache.c
|
||||
+++ a/modules/cache/mod_cache.c
|
||||
@@ -1773,7 +1773,7 @@ static void *merge_dir_config(apr_pool_t *p, void *basev, void *addv) {
|
||||
|
||||
static void * create_cache_config(apr_pool_t *p, server_rec *s)
|
||||
{
|
||||
- const char *tmppath;
|
||||
+ const char *tmppath = NULL;
|
||||
cache_server_conf *ps = apr_pcalloc(p, sizeof(cache_server_conf));
|
||||
|
||||
/* array of URL prefixes for which caching is enabled */
|
@ -1,110 +0,0 @@
|
||||
Index: support/passwd_common.c
|
||||
===================================================================
|
||||
--- a/support/passwd_common.c (revision 1476673)
|
||||
+++ b/support/passwd_common.c (working copy)
|
||||
@@ -113,17 +113,17 @@
|
||||
|
||||
int get_password(struct passwd_ctx *ctx)
|
||||
{
|
||||
+ char buf[MAX_STRING_LEN + 1];
|
||||
if (ctx->passwd_src == PW_STDIN) {
|
||||
- char *buf = ctx->out;
|
||||
apr_file_t *file_stdin;
|
||||
apr_size_t nread;
|
||||
if (apr_file_open_stdin(&file_stdin, ctx->pool) != APR_SUCCESS) {
|
||||
ctx->errstr = "Unable to read from stdin.";
|
||||
return ERR_GENERAL;
|
||||
}
|
||||
- if (apr_file_read_full(file_stdin, buf, ctx->out_len - 1,
|
||||
+ if (apr_file_read_full(file_stdin, buf, sizeof(buf) - 1,
|
||||
&nread) != APR_EOF
|
||||
- || nread == ctx->out_len - 1) {
|
||||
+ || nread == sizeof(buf) - 1) {
|
||||
goto err_too_long;
|
||||
}
|
||||
buf[nread] = '\0';
|
||||
@@ -133,21 +133,24 @@
|
||||
buf[nread-2] = '\0';
|
||||
}
|
||||
apr_file_close(file_stdin);
|
||||
+ ctx->passwd = apr_pstrdup(ctx->pool, buf);
|
||||
}
|
||||
else {
|
||||
- char buf[MAX_STRING_LEN + 1];
|
||||
apr_size_t bufsize = sizeof(buf);
|
||||
- if (apr_password_get("New password: ", ctx->out, &ctx->out_len) != 0)
|
||||
+ if (apr_password_get("New password: ", buf, &bufsize) != 0)
|
||||
goto err_too_long;
|
||||
+ ctx->passwd = apr_pstrdup(ctx->pool, buf);
|
||||
+ bufsize = sizeof(buf);
|
||||
+ buf[0] = '\0';
|
||||
apr_password_get("Re-type new password: ", buf, &bufsize);
|
||||
- if (strcmp(ctx->out, buf) != 0) {
|
||||
+ if (strcmp(ctx->passwd, buf) != 0) {
|
||||
ctx->errstr = "password verification error";
|
||||
- memset(ctx->out, '\0', ctx->out_len);
|
||||
+ memset(ctx->passwd, '\0', strlen(ctx->passwd));
|
||||
memset(buf, '\0', sizeof(buf));
|
||||
return ERR_PWMISMATCH;
|
||||
}
|
||||
- memset(buf, '\0', sizeof(buf));
|
||||
}
|
||||
+ memset(buf, '\0', sizeof(buf));
|
||||
return 0;
|
||||
|
||||
err_too_long:
|
||||
@@ -164,7 +167,6 @@
|
||||
int mkhash(struct passwd_ctx *ctx)
|
||||
{
|
||||
char *pw;
|
||||
- char pwin[MAX_STRING_LEN];
|
||||
char salt[16];
|
||||
apr_status_t rv;
|
||||
int ret = 0;
|
||||
@@ -177,14 +179,11 @@
|
||||
"Warning: Ignoring -C argument for this algorithm." NL);
|
||||
}
|
||||
|
||||
- if (ctx->passwd != NULL) {
|
||||
- pw = ctx->passwd;
|
||||
- }
|
||||
- else {
|
||||
+ if (ctx->passwd == NULL) {
|
||||
if ((ret = get_password(ctx)) != 0)
|
||||
return ret;
|
||||
- pw = pwin;
|
||||
}
|
||||
+ pw = ctx->passwd;
|
||||
|
||||
switch (ctx->alg) {
|
||||
case ALG_APSHA:
|
||||
@@ -224,7 +223,7 @@
|
||||
|
||||
apr_cpystrn(ctx->out, cbuf, ctx->out_len - 1);
|
||||
if (strlen(pw) > 8) {
|
||||
- char *truncpw = strdup(pw);
|
||||
+ char *truncpw = apr_pstrdup(ctx->pool, pw);
|
||||
truncpw[8] = '\0';
|
||||
if (!strcmp(ctx->out, crypt(truncpw, salt))) {
|
||||
apr_file_printf(errfile, "Warning: Password truncated to 8 "
|
||||
Index: support/htpasswd.c
|
||||
===================================================================
|
||||
--- a/support/htpasswd.c (revision 1476673)
|
||||
+++ b/support/htpasswd.c (working copy)
|
||||
@@ -253,7 +253,6 @@
|
||||
int main(int argc, const char * const argv[])
|
||||
{
|
||||
apr_file_t *fpw = NULL;
|
||||
- const char *errstr = NULL;
|
||||
char line[MAX_STRING_LEN];
|
||||
char *pwfilename = NULL;
|
||||
char *user = NULL;
|
||||
@@ -345,7 +344,7 @@
|
||||
if (!(mask & APHTP_DELUSER)) {
|
||||
i = mkrecord(&ctx, user);
|
||||
if (i != 0) {
|
||||
- apr_file_printf(errfile, "%s: %s" NL, argv[0], errstr);
|
||||
+ apr_file_printf(errfile, "%s: %s" NL, argv[0], ctx.errstr);
|
||||
exit(i);
|
||||
}
|
||||
if (mask & APHTP_NOFILE) {
|
14
httpd.spec
14
httpd.spec
@ -13,8 +13,8 @@
|
||||
|
||||
Summary: Apache HTTP Server
|
||||
Name: httpd
|
||||
Version: 2.4.4
|
||||
Release: 12%{?dist}
|
||||
Version: 2.4.6
|
||||
Release: 1%{?dist}
|
||||
URL: http://httpd.apache.org/
|
||||
Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
|
||||
Source1: index.html
|
||||
@ -51,7 +51,6 @@ Patch2: httpd-2.4.3-apxs.patch
|
||||
Patch3: httpd-2.4.1-deplibs.patch
|
||||
Patch5: httpd-2.4.3-layout.patch
|
||||
Patch6: httpd-2.4.3-apctl-systemd.patch
|
||||
Patch7: httpd-2.4.4-aarch64.patch
|
||||
# Features/functional changes
|
||||
Patch23: httpd-2.4.4-export.patch
|
||||
Patch24: httpd-2.4.1-corelimit.patch
|
||||
@ -63,14 +62,10 @@ Patch29: httpd-2.4.3-mod_systemd.patch
|
||||
Patch30: httpd-2.4.4-cachehardmax.patch
|
||||
Patch31: httpd-2.4.4-sslmultiproxy.patch
|
||||
# Bug fixes
|
||||
Patch50: httpd-2.4.2-r1374214+.patch
|
||||
Patch51: httpd-2.4.3-sslsninotreq.patch
|
||||
Patch52: httpd-2.4.4-r1476674.patch
|
||||
Patch53: httpd-2.4.4-mod_cache-tmppath.patch
|
||||
Patch54: httpd-2.4.4-dump-vhost-twice.patch
|
||||
Patch55: httpd-2.4.4-malformed-host.patch
|
||||
Patch56: httpd-2.4.4-mod_unique_id.patch
|
||||
Patch57: httpd-2.4.4-apxs-man-p.patch
|
||||
License: ASL 2.0
|
||||
Group: System Environment/Daemons
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
@ -182,7 +177,6 @@ interface for storing and accessing per-user session data.
|
||||
%patch3 -p1 -b .deplibs
|
||||
%patch5 -p1 -b .layout
|
||||
%patch6 -p1 -b .apctlsystemd
|
||||
%patch7 -p1 -b .aarch64
|
||||
|
||||
%patch23 -p1 -b .export
|
||||
%patch24 -p1 -b .corelimit
|
||||
@ -194,14 +188,10 @@ interface for storing and accessing per-user session data.
|
||||
%patch30 -p1 -b .cachehardmax
|
||||
%patch31 -p1 -b .sslmulti
|
||||
|
||||
%patch50 -p1 -b .r1374214+
|
||||
%patch51 -p1 -b .sninotreq
|
||||
%patch52 -p1 -b .r1476674
|
||||
%patch53 -p1 -b .tmppath
|
||||
%patch54 -p1 -b .vhosttwice
|
||||
%patch55 -p1 -b .malformedhost
|
||||
%patch56 -p1 -b .uniqueid
|
||||
%patch57 -p1 -b .apxsman
|
||||
|
||||
# Patch in the vendor string
|
||||
sed -i '/^#define PLATFORM/s/Unix/%{vstring}/' os/unix/os.h
|
||||
|
Loading…
Reference in New Issue
Block a user