diff --git a/Makefile b/Makefile
index 299e139..8376717 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
# Makefile for source rpm: httpd
-# $Id: Makefile,v 1.3 2004/09/17 10:28:46 jorton Exp $
+# $Id: Makefile,v 1.4 2004/10/13 10:44:51 jorton Exp $
NAME := httpd
SPECFILE = $(firstword $(wildcard *.spec))
UPSTREAM_CHECKS = asc
@@ -9,12 +9,12 @@ include ../common/Makefile.common
migration.html: migration.xml html.xsl
xmlto -x html.xsl html-nochunks migration.xml
-migration-view: migration.html
+view-migration: migration.html
gnome-moz-remote `pwd`/migration.html
ALL_PATCHES := $(wildcard *.patch)
-status.xml: $(ALL_PATCHES)
+status.xml: $(ALL_PATCHES) mkstatus.sh
@./mkstatus.sh $(ALL_PATCHES) > $@
status.html: status.xml status-html.xsl
diff --git a/httpd-2.0.40-xfsz.patch b/httpd-2.0.40-xfsz.patch
index ea7882c..f3bcfbf 100644
--- a/httpd-2.0.40-xfsz.patch
+++ b/httpd-2.0.40-xfsz.patch
@@ -4,7 +4,8 @@ E2BIG rather than killing the process
Upstream-HEAD: omit
Upstream-2.0: omit
-Upstream-Status: Obsoleted by proper LFS support in APR 1.0
+Upstream-Status: Obsoleted by proper LFS support in APR
+Upstream-PR: 13511
--- ./server/mpm/prefork/prefork.c.xfsz Wed Jul 17 22:39:55 2002
+++ ./server/mpm/prefork/prefork.c Mon Aug 26 15:40:24 2002
diff --git a/httpd-2.0.45-deplibs.patch b/httpd-2.0.45-deplibs.patch
index 27754dc..8fd05cf 100644
--- a/httpd-2.0.45-deplibs.patch
+++ b/httpd-2.0.45-deplibs.patch
@@ -2,9 +2,9 @@
apr and apr-util are patched to correctly depend on their deps, so
it's sufficient to just link httpd against the .la file.
-Upstream-HEAD: pending
+Upstream-HEAD: needed
Upstream-2.0: omit
-Upstream-Status: apr-util fixes pending on 0.9 branch, OK for HEAD
+Upstream-Status: apr-util still to be fixed properly on HEAD
--- httpd-2.0.45/configure.in.deplibs 2003-04-29 10:27:05.000000000 +0100
+++ httpd-2.0.45/configure.in 2003-04-29 10:26:45.000000000 +0100
diff --git a/httpd-2.0.45-export.patch b/httpd-2.0.45-export.patch
index 7aa7051..0ba3081 100644
--- a/httpd-2.0.45-export.patch
+++ b/httpd-2.0.45-export.patch
@@ -2,7 +2,7 @@
There is no need to "suck in" the apr/apr-util symbols when using
a shared libapr{,util}, it just bloats the symbol table; so don't.
-Upstream-HEAD:
+Upstream-HEAD: needed
Upstream-2.0: omit
Upstream-Status: EXPORT_DIRS change is conditional on using shared apr
diff --git a/mkstatus.sh b/mkstatus.sh
index 12d77c4..5bd0cf4 100755
--- a/mkstatus.sh
+++ b/mkstatus.sh
@@ -7,7 +7,14 @@ for f in $*; do
s_HEAD=`grep ^Upstream-HEAD $f | sed 's/Upstream-HEAD: //'`
s_20=`grep ^Upstream-2.0: $f | sed 's/Upstream-2.0: //'`
s_Com=`grep ^Upstream-Status: $f | sed 's/Upstream-Status: //'`
- printf '\n' \
- $n "$s_HEAD" "$s_20" "$s_Com"
+ s_PR=`grep ^Upstream-PR: $f | sed 's/Upstream-PR: //'`
+ printf ' \n' $n
+ printf ' %s\n' "$s_HEAD"
+ printf ' %s\n' "$s_20"
+ printf ' %s\n' "$s_Com"
+ if [ -n "$s_PR" ]; then
+ printf ' \n' "$s_PR"
+ fi
+ printf ' \n'
done
echo ''