diff --git a/apachectl.xml b/apachectl.xml
new file mode 100644
index 0000000..0294374
--- /dev/null
+++ b/apachectl.xml
@@ -0,0 +1,173 @@
+
+[
+
+]>
+
+
+
+ apachectl
+ httpd
+ Apache Software Foundation
+ Fedora man pageDanaFrankferdnyc@gmail.com
+
+
+
+ apachectl
+ 8
+
+
+
+ apachectl
+ Server control interface for httpd
+
+
+
+
+ apachectl
+ command
+
+
+
+
+
+
+ DESCRIPTION
+
+ apachectl is a front end to the Apache HyperText
+ Transfer Protocol (HTTP) server. It is designed to help the
+ administrator control the functioning of the Apache
+ httpd daemon.
+
+ The apachectl script takes one-word arguments like
+ ,
+ , and
+ , and translates them
+ into appropriate signals to httpd.
+
+ The apachectl script returns a 0 exit value on
+ success, and >0 if an error occurs.
+
+
+
+
+ OPTIONS
+
+
+
+
+ Start the Apache httpd daemon. Gives an error if it
+ is already running. This is equivalent to systemctl start httpd.service.
+
+
+
+
+
+
+ Stops the Apache httpd daemon. This is equivalent to
+ systemctl stop httpd.service.
+
+
+
+
+
+
+ Restarts the Apache httpd daemon. If the daemon is
+ not running, it is started. This is equivalent
+ to systemctl restart httpd.service.
+
+
+
+
+
+
+ Displays a brief status report. This is equivalent to systemctl status httpd.service.
+
+
+
+
+
+
+ Gracefully restarts the Apache httpd daemon. If the
+ daemon is not running, it is started. This differs from a normal
+ restart in that currently open connections are not aborted. A side
+ effect is that old log files will not be closed immediately. This
+ means that if used in a log rotation script, a substantial delay may
+ be necessary to ensure that the old log files are closed before
+ processing them. This is equivalent to
+ systemctl kill --signal=SIGUSR1 --kill-who=main httpd.service.
+
+
+
+
+
+
+ Gracefully stops the Apache httpd daemon.
+ This differs from a normal stop in that currently open connections are not
+ aborted. A side effect is that old log files will not be closed immediately.
+ This is equivalent to
+ systemctl kill --signal=SIGWINCH --kill-who=main httpd.service.
+
+
+
+
+
+
+ Run a configuration file syntax test. It parses the configuration
+ files and either reports Syntax Ok
+ or detailed information about the particular syntax error. This is
+ equivalent to httpd -t.
+
+
+
+
+ The following options were available in earlier versions but have been removed.
+
+
+
+
+
+ Displays a full status report from mod_status.
+ For this to work, you need to have mod_status enabled
+ on your server and a text-based browser such as lynx
+ available on your system. The URL used to access the status report
+ can be set by editing the STATUSURL variable in the
+ script.
+
+
+
+
+
+
+ To start httpd with SSL support, you should edit
+ your configuration file to include the relevant directives and then
+ use the normal apachectl start.
+
+
+
+
+
+
+ BUGS
+ Please report bugs by filing an issue against the "httpd" component of the "Fedora"
+ project, in RedHat Bugzilla.
+
+
+
diff --git a/httpd.spec b/httpd.spec
index 51ea1da..8c94a49 100644
--- a/httpd.spec
+++ b/httpd.spec
@@ -13,7 +13,7 @@
Summary: Apache HTTP Server
Name: httpd
Version: 2.4.41
-Release: 9%{?dist}
+Release: 10%{?dist}
URL: https://httpd.apache.org/
Source0: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
Source1: https://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2.asc
@@ -59,6 +59,7 @@ Source43: httpd-ssl-gencerts
Source44: httpd@.service
Source45: config.layout
Source46: apachectl.sh
+Source47: apachectl.xml
# build/scripts patches
Patch2: httpd-2.4.9-apxs.patch
@@ -269,6 +270,9 @@ xmlto man ./httpd.conf.xml
xmlto man $RPM_SOURCE_DIR/htcacheclean.service.xml
xmlto man $RPM_SOURCE_DIR/httpd.service.xml
+# apachectl.xml => apachectl.8
+xmlto man %{SOURCE47}
+
: Building with MMN %{mmn}, MMN-ISA %{mmnisa}
: Default MPM is %{mpm}, vendor string is '%{vstring}'
@@ -498,7 +502,7 @@ install -m 644 -p $RPM_SOURCE_DIR/httpd.logrotate \
# Install man pages
install -d $RPM_BUILD_ROOT%{_mandir}/man8 $RPM_BUILD_ROOT%{_mandir}/man5
install -m 644 -p httpd.service.8 httpd-init.service.8 httpd.socket.8 \
- httpd@.service.8 htcacheclean.service.8 \
+ httpd@.service.8 htcacheclean.service.8 apachectl.8 \
$RPM_BUILD_ROOT%{_mandir}/man8
install -m 644 -p httpd.conf.5 \
$RPM_BUILD_ROOT%{_mandir}/man5
@@ -749,6 +753,9 @@ exit $rv
%{_rpmconfigdir}/macros.d/macros.httpd
%changelog
+* Sat Dec 7 2019 FeRD (Frank Dana) - 2.4.41-10
+- apachectl: Add man page for Fedora version
+
* Thu Nov 21 2019 Joe Orton - 2.4.41-9
- mod_ssl: fix request body buffering w/TLSv1.3 PHA (#1775146)