Add patch status tracking.

This commit is contained in:
jorton 2004-10-13 10:44:51 +00:00
parent 8596424b2d
commit 0ba3e33bdc
8 changed files with 46 additions and 1 deletions

View File

@ -1,2 +1,3 @@
httpd-2.0.52.tar.gz httpd-2.0.52.tar.gz
migration.html migration.html
status.*

View File

@ -1,5 +1,5 @@
# Makefile for source rpm: httpd # Makefile for source rpm: httpd
# $Id: Makefile,v 1.2 2004/09/15 15:09:00 jorton Exp $ # $Id: Makefile,v 1.3 2004/09/17 10:28:46 jorton Exp $
NAME := httpd NAME := httpd
SPECFILE = $(firstword $(wildcard *.spec)) SPECFILE = $(firstword $(wildcard *.spec))
UPSTREAM_CHECKS = asc UPSTREAM_CHECKS = asc
@ -12,3 +12,13 @@ migration.html: migration.xml html.xsl
migration-view: migration.html migration-view: migration.html
gnome-moz-remote `pwd`/migration.html gnome-moz-remote `pwd`/migration.html
ALL_PATCHES := $(wildcard *.patch)
status.xml: $(ALL_PATCHES)
@./mkstatus.sh $(ALL_PATCHES) > $@
status.html: status.xml status-html.xsl
@xsltproc status-html.xsl $< > $@
view-status: status.html
gnome-moz-remote `pwd`/$<

View File

@ -2,6 +2,10 @@
Set SIGXFSZ to be ignored, so a write() beyond 2gb will fail with Set SIGXFSZ to be ignored, so a write() beyond 2gb will fail with
E2BIG rather than killing the process E2BIG rather than killing the process
Upstream-HEAD: omit
Upstream-2.0: omit
Upstream-Status: Obsoleted by proper LFS support in APR 1.0
--- ./server/mpm/prefork/prefork.c.xfsz Wed Jul 17 22:39:55 2002 --- ./server/mpm/prefork/prefork.c.xfsz Wed Jul 17 22:39:55 2002
+++ ./server/mpm/prefork/prefork.c Mon Aug 26 15:40:24 2002 +++ ./server/mpm/prefork/prefork.c Mon Aug 26 15:40:24 2002
@@ -461,7 +461,7 @@ @@ -461,7 +461,7 @@

View File

@ -2,6 +2,10 @@
apr and apr-util are patched to correctly depend on their deps, so apr and apr-util are patched to correctly depend on their deps, so
it's sufficient to just link httpd against the .la file. it's sufficient to just link httpd against the .la file.
Upstream-HEAD: pending
Upstream-2.0: omit
Upstream-Status: apr-util fixes pending on 0.9 branch, OK for HEAD
--- httpd-2.0.45/configure.in.deplibs 2003-04-29 10:27:05.000000000 +0100 --- httpd-2.0.45/configure.in.deplibs 2003-04-29 10:27:05.000000000 +0100
+++ httpd-2.0.45/configure.in 2003-04-29 10:26:45.000000000 +0100 +++ httpd-2.0.45/configure.in 2003-04-29 10:26:45.000000000 +0100
@@ -455,7 +455,7 @@ @@ -455,7 +455,7 @@

View File

@ -2,6 +2,10 @@
There is no need to "suck in" the apr/apr-util symbols when using There is no need to "suck in" the apr/apr-util symbols when using
a shared libapr{,util}, it just bloats the symbol table; so don't. a shared libapr{,util}, it just bloats the symbol table; so don't.
Upstream-HEAD:
Upstream-2.0: omit
Upstream-Status: EXPORT_DIRS change is conditional on using shared apr
--- httpd-2.0.48/server/main.c.export --- httpd-2.0.48/server/main.c.export
+++ httpd-2.0.48/server/main.c +++ httpd-2.0.48/server/main.c
@@ -669,28 +669,6 @@ @@ -669,28 +669,6 @@

View File

@ -2,6 +2,10 @@
Automatically raise the core file size limit if CoreDumpDirectory Automatically raise the core file size limit if CoreDumpDirectory
is configured. is configured.
Upstream-HEAD: submitted
Upstream-Status: Not so useful on Solaris, discussed
Upstream-Discuss: http://marc.theaimsgroup.com/?l=apache-httpd-dev&m=107831370002083&w=2
--- httpd-2.0.48/server/core.c.corelimit --- httpd-2.0.48/server/core.c.corelimit
+++ httpd-2.0.48/server/core.c +++ httpd-2.0.48/server/core.c
@@ -4233,6 +4233,25 @@ @@ -4233,6 +4233,25 @@

View File

@ -1,3 +1,8 @@
Upstream-HEAD: vendor
Upstream-2.0: vendor
Upstream-Status: vendor-specific change
--- httpd-2.0.48/server/core.c.release --- httpd-2.0.48/server/core.c.release
+++ httpd-2.0.48/server/core.c +++ httpd-2.0.48/server/core.c
@@ -2386,7 +2386,7 @@ @@ -2386,7 +2386,7 @@

13
mkstatus.sh Executable file
View File

@ -0,0 +1,13 @@
#!/bin/sh
echo '<?xml version="1.0" encoding="UTF-8"?>'
echo '<patches>'
for f in $*; do
n=${f//httpd-[0-9.]*-/}
n=${n//.patch/}
s_HEAD=`grep ^Upstream-HEAD $f | sed 's/Upstream-HEAD: //'`
s_20=`grep ^Upstream-2.0: $f | sed 's/Upstream-2.0: //'`
s_Com=`grep ^Upstream-Status: $f | sed 's/Upstream-Status: //'`
printf '<patch name="%s" status-head="%s" status-2.0="%s" status-comment="%s"/>\n' \
$n "$s_HEAD" "$s_20" "$s_Com"
done
echo '</patches>'