Initial commit

This commit is contained in:
Stanislav Ochotnicky 2010-12-23 11:05:58 +01:00
parent 95c18bb0b1
commit bd5d27dea1
4 changed files with 283 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/httpcomponents-core-4.1-src.tar.gz

View File

@ -0,0 +1,178 @@
From 8f27e169ae72b1cecb91c6a911e4ded5aeac7005 Mon Sep 17 00:00:00 2001
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
Date: Fri, 17 Dec 2010 15:22:06 +0100
Subject: [PATCH] Remove unneeded pom dependencies
---
httpcore-nio/pom.xml | 26 ----------------------
httpcore/pom.xml | 26 ----------------------
pom.xml | 58 --------------------------------------------------
3 files changed, 0 insertions(+), 110 deletions(-)
diff --git a/httpcore-nio/pom.xml b/httpcore-nio/pom.xml
index 7eba598..14aa177 100644
--- a/httpcore-nio/pom.xml
+++ b/httpcore-nio/pom.xml
@@ -103,24 +103,6 @@
</archive>
</configuration>
</plugin>
- <plugin>
- <groupId>com.atlassian.maven.plugins</groupId>
- <artifactId>maven-clover2-plugin</artifactId>
- <configuration>
- <flushPolicy>threaded</flushPolicy>
- <flushInterval>100</flushInterval>
- <targetPercentage>50%</targetPercentage>
- </configuration>
- <executions>
- <execution>
- <id>site</id>
- <phase>pre-site</phase>
- <goals>
- <goal>instrument</goal>
- </goals>
- </execution>
- </executions>
- </plugin>
</plugins>
</build>
@@ -146,14 +128,6 @@
</plugin>
<plugin>
- <groupId>com.atlassian.maven.plugins</groupId>
- <artifactId>maven-clover2-plugin</artifactId>
- <configuration>
- <jdk>1.5</jdk>
- </configuration>
- </plugin>
-
- <plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>clirr-maven-plugin</artifactId>
<configuration>
diff --git a/httpcore/pom.xml b/httpcore/pom.xml
index e01f182..c0ca7ed 100644
--- a/httpcore/pom.xml
+++ b/httpcore/pom.xml
@@ -111,24 +111,6 @@
</archive>
</configuration>
</plugin>
- <plugin>
- <groupId>com.atlassian.maven.plugins</groupId>
- <artifactId>maven-clover2-plugin</artifactId>
- <configuration>
- <flushPolicy>threaded</flushPolicy>
- <flushInterval>100</flushInterval>
- <targetPercentage>50%</targetPercentage>
- </configuration>
- <executions>
- <execution>
- <id>site</id>
- <phase>pre-site</phase>
- <goals>
- <goal>instrument</goal>
- </goals>
- </execution>
- </executions>
- </plugin>
</plugins>
</build>
@@ -153,14 +135,6 @@
</plugin>
<plugin>
- <groupId>com.atlassian.maven.plugins</groupId>
- <artifactId>maven-clover2-plugin</artifactId>
- <configuration>
- <jdk>1.4</jdk>
- </configuration>
- </plugin>
-
- <plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>clirr-maven-plugin</artifactId>
<configuration>
diff --git a/pom.xml b/pom.xml
index 6305d73..45e5e2c 100644
--- a/pom.xml
+++ b/pom.xml
@@ -91,21 +91,6 @@
<build>
<plugins>
<plugin>
- <artifactId>maven-notice-plugin</artifactId>
- <groupId>org.apache.httpcomponents</groupId>
- <executions>
- <execution>
- <id>attach-notice-license</id>
- <goals>
- <goal>generate</goal>
- </goals>
- </execution>
- </executions>
- <configuration>
- <projectTitle>Apache HttpComponents</projectTitle>
- </configuration>
- </plugin>
- <plugin>
<artifactId>maven-source-plugin</artifactId>
<executions>
<execution>
@@ -166,49 +151,6 @@
</configuration>
</plugin>
<plugin>
- <groupId>com.agilejava.docbkx</groupId>
- <artifactId>docbkx-maven-plugin</artifactId>
- <dependencies>
- <dependency>
- <groupId>org.docbook</groupId>
- <artifactId>docbook-xml</artifactId>
- <version>4.4</version>
- <scope>runtime</scope>
- </dependency>
- </dependencies>
- <configuration>
- <includes>index.xml</includes>
- <chunkedOutput>true</chunkedOutput>
- <xincludeSupported>true</xincludeSupported>
- <foCustomization>src/docbkx/resources/xsl/fopdf.xsl</foCustomization>
- <htmlCustomization>src/docbkx/resources/xsl/html_chunk.xsl</htmlCustomization>
- <htmlStylesheet>css/hc-tutorial.css</htmlStylesheet>
- <entities>
- <entity>
- <name>version</name>
- <value>${project.version}</value>
- </entity>
- </entities>
- <postProcess>
- <copy todir="target/site/tutorial">
- <fileset dir="target/docbkx">
- <include name="**/*.html" />
- <include name="**/*.pdf" />
- </fileset>
- </copy>
- <copy todir="target/site/tutorial/html">
- <fileset dir="src/docbkx/resources">
- <include name="**/*.css" />
- <include name="**/*.png" />
- <include name="**/*.gif" />
- <include name="**/*.jpg" />
- </fileset>
- </copy>
- <move file="target/site/tutorial/pdf/index.pdf" tofile="target/site/tutorial/pdf/httpcore-tutorial.pdf" failonerror="false" />
- </postProcess>
- </configuration>
- </plugin>
- <plugin>
<artifactId>maven-resources-plugin</artifactId>
<executions>
<execution>
--
1.7.3.3

103
httpcomponents-core.spec Normal file
View File

@ -0,0 +1,103 @@
Name: httpcomponents-core
Summary: Set of low level Java HTTP transport components for HTTP services
Version: 4.1
Release: 2%{?dist}
Group: Development/Libraries
License: ASL 2.0
URL: http://hc.apache.org/
Source0: http://www.apache.org/dist/httpcomponents/httpcore/source/httpcomponents-core-%{version}-src.tar.gz
Patch0: 0001-Remove-unneeded-pom-dependencies.patch
BuildArch: noarch
BuildRequires: httpcomponents-project
BuildRequires: java >= 1:1.6.0
BuildRequires: jpackage-utils
Requires: java >= 1:1.6.0
Requires: jpackage-utils
Requires(post): jpackage-utils
Requires(postun): jpackage-utils
%description
HttpCore is a set of low level HTTP transport components that can be
used to build custom client and server side HTTP services with a
minimal footprint. HttpCore supports two I/O models: blocking I/O
model based on the classic Java I/O and non-blocking, event driven I/O
model based on Java NIO.
The blocking I/O model may be more appropriate for data intensive, low
latency scenarios, whereas the non-blocking model may be more
appropriate for high latency scenarios where raw data throughput is
less important than the ability to handle thousands of simultaneous
HTTP connections in a resource efficient manner.
%package javadoc
Summary: API documentation for %{name}
Group: Documentation
Requires: jpackage-utils
%description javadoc
%{summary}.
%prep
%setup -q
%patch0 -p1
%build
export maven_repo_local=$(pwd)/.m2/repository
install -d $maven_repo_local
# start using install again when bundle plugin is updated to 2.1.0
mvn-jpp -Dmaven.repo.local=$maven_repo_local \
package javadoc:aggregate
%install
install -d %{buildroot}/%{_mavenpomdir}
install -d %{buildroot}/%{_javadir}/%{name}
for m in httpcore httpcore-nio httpcore-osgi; do
# poms
install -m 0644 $m/pom.xml %{buildroot}/%{_mavenpomdir}/JPP.%{name}-$m.pom
# jars - osgi doesn't have one
if [ -f $m/target/$m-%{version}.jar ];then
install -m 0644 $m/target/$m-%{version}.jar %{buildroot}%{_javadir}/%{name}/$m.jar
fi
%add_to_maven_depmap org.apache.httpcomponents $m %{version} JPP/%{name} $m
done
# parent
install -D -m 0644 pom.xml %{buildroot}/%{_mavenpomdir}/JPP.%{name}-%{name}.pom
%add_to_maven_depmap org.apache.httpcomponents %{name} %{version} JPP/%{name} %{name}
# javadocs
install -dm 755 %{buildroot}%{_javadocdir}/%{name}
cp -pr target/site/api*/* %{buildroot}%{_javadocdir}/%{name}
%post
%update_maven_depmap
%postun
%update_maven_depmap
%files
%defattr(-,root,root,-)
%doc README.txt LICENSE.txt RELEASE_NOTES.txt
%{_mavendepmapfragdir}/%{name}
%{_mavenpomdir}/JPP.%{name}*.pom
%{_javadir}/%{name}
%files javadoc
%doc LICENSE.txt
%defattr(-,root,root,-)
%doc %{_javadocdir}/*
%changelog
* Wed Dec 22 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.1-2
- Added license to javadoc subpackage
* Fri Dec 17 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.1-1
- Initial package

View File

@ -0,0 +1 @@
5921a41284b6452a259c2ae55b1f78b6 httpcomponents-core-4.1-src.tar.gz