Initial commit
This commit is contained in:
parent
0346094360
commit
b2bae1b18c
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
||||
/httpcomponents-client-4.0.3-src.tar.gz
|
95
0001-Cleanup-pom.patch
Normal file
95
0001-Cleanup-pom.patch
Normal file
@ -0,0 +1,95 @@
|
||||
From 00e8bdbfe680691c28ab6da5a40ca4ff020d5837 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Ochotnicky <sochotnicky@redhat.com>
|
||||
Date: Mon, 20 Dec 2010 15:56:06 +0100
|
||||
Subject: [PATCH] Cleanup pom
|
||||
|
||||
---
|
||||
pom.xml | 72 ---------------------------------------------------------------
|
||||
1 files changed, 0 insertions(+), 72 deletions(-)
|
||||
|
||||
diff --git a/pom.xml b/pom.xml
|
||||
index 3d0d20a..fce1fdd 100644
|
||||
--- a/pom.xml
|
||||
+++ b/pom.xml
|
||||
@@ -144,78 +144,6 @@
|
||||
</tasks>
|
||||
</configuration>
|
||||
</plugin>
|
||||
- <plugin>
|
||||
- <groupId>com.atlassian.maven.plugins</groupId>
|
||||
- <artifactId>maven-clover2-plugin</artifactId>
|
||||
- <configuration>
|
||||
- <flushPolicy>threaded</flushPolicy>
|
||||
- <flushInterval>100</flushInterval>
|
||||
- <targetPercentage>50%</targetPercentage>
|
||||
- </configuration>
|
||||
- <executions>
|
||||
- <execution>
|
||||
- <id>site</id>
|
||||
- <phase>pre-site</phase>
|
||||
- <goals>
|
||||
- <goal>instrument</goal>
|
||||
- <goal>aggregate</goal>
|
||||
- <goal>save-history</goal>
|
||||
- </goals>
|
||||
- </execution>
|
||||
- </executions>
|
||||
- </plugin>
|
||||
- <plugin>
|
||||
- <groupId>com.agilejava.docbkx</groupId>
|
||||
- <artifactId>docbkx-maven-plugin</artifactId>
|
||||
- <executions>
|
||||
- <execution>
|
||||
- <goals>
|
||||
- <goal>generate-html</goal>
|
||||
- <goal>generate-pdf</goal>
|
||||
- </goals>
|
||||
- <phase>pre-site</phase>
|
||||
- </execution>
|
||||
- </executions>
|
||||
- <dependencies>
|
||||
- <dependency>
|
||||
- <groupId>org.docbook</groupId>
|
||||
- <artifactId>docbook-xml</artifactId>
|
||||
- <version>4.4</version>
|
||||
- <scope>runtime</scope>
|
||||
- </dependency>
|
||||
- </dependencies>
|
||||
- <configuration>
|
||||
- <includes>index.xml</includes>
|
||||
- <chunkedOutput>true</chunkedOutput>
|
||||
- <xincludeSupported>true</xincludeSupported>
|
||||
- <foCustomization>src/docbkx/resources/xsl/fopdf.xsl</foCustomization>
|
||||
- <htmlCustomization>src/docbkx/resources/xsl/html_chunk.xsl</htmlCustomization>
|
||||
- <htmlStylesheet>css/hc-tutorial.css</htmlStylesheet>
|
||||
- <entities>
|
||||
- <entity>
|
||||
- <name>version</name>
|
||||
- <value>${pom.version}</value>
|
||||
- </entity>
|
||||
- </entities>
|
||||
- <postProcess>
|
||||
- <copy todir="target/site/tutorial">
|
||||
- <fileset dir="target/docbkx">
|
||||
- <include name="**/*.html" />
|
||||
- <include name="**/*.pdf" />
|
||||
- </fileset>
|
||||
- </copy>
|
||||
- <copy todir="target/site/tutorial/html">
|
||||
- <fileset dir="src/docbkx/resources">
|
||||
- <include name="**/*.css" />
|
||||
- <include name="**/*.png" />
|
||||
- <include name="**/*.gif" />
|
||||
- <include name="**/*.jpg" />
|
||||
- </fileset>
|
||||
- </copy>
|
||||
- <move file="target/site/tutorial/pdf/index.pdf" tofile="target/site/tutorial/pdf/httpclient-tutorial.pdf" failonerror="false" />
|
||||
- </postProcess>
|
||||
- </configuration>
|
||||
- </plugin>
|
||||
|
||||
</plugins>
|
||||
</build>
|
||||
--
|
||||
1.7.3.3
|
||||
|
101
httpcomponents-client.spec
Normal file
101
httpcomponents-client.spec
Normal file
@ -0,0 +1,101 @@
|
||||
Name: httpcomponents-client
|
||||
Summary: HTTP agent implementation based on httpcomponents HttpCore
|
||||
Version: 4.0.3
|
||||
Release: 2%{?dist}
|
||||
Group: Development/Libraries
|
||||
License: ASL 2.0
|
||||
URL: http://hc.apache.org/
|
||||
Source0: http://www.apache.org/dist/httpcomponents/httpclient/source/httpcomponents-client-%{version}-src.tar.gz
|
||||
# Remove optional build deps not available in Fedora
|
||||
Patch0: 0001-Cleanup-pom.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
|
||||
BuildRequires: httpcomponents-project
|
||||
BuildRequires: httpcomponents-core
|
||||
|
||||
|
||||
Requires: java >= 1:1.6.0
|
||||
Requires: jpackage-utils
|
||||
Requires: httpcomponents-core
|
||||
|
||||
Requires(post): jpackage-utils
|
||||
Requires(postun): jpackage-utils
|
||||
|
||||
%description
|
||||
HttpClient is a HTTP/1.1 compliant HTTP agent implementation based on
|
||||
httpcomponents HttpCore. It also provides reusable components for
|
||||
client-side authentication, HTTP state management, and HTTP connection
|
||||
management. HttpComponents Client is a successor of and replacement
|
||||
for Commons HttpClient 3.x. Users of Commons HttpClient are strongly
|
||||
encouraged to upgrade.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
Group: Documentation
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description javadoc
|
||||
%{summary}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# skip httpmime, httpclient only. For httpmime we need org.apache.james:apache-mime4j
|
||||
cd httpclient
|
||||
export maven_repo_local=$(pwd)/.m2/repository
|
||||
install -d $maven_repo_local
|
||||
|
||||
mvn-jpp -Dmaven.repo.local=$maven_repo_local \
|
||||
install javadoc:javadoc
|
||||
|
||||
|
||||
%install
|
||||
cd httpclient
|
||||
# jars
|
||||
install -D -m 0644 target/httpclient-%{version}.jar %{buildroot}%{_javadir}/%{name}/httpclient.jar
|
||||
|
||||
# pom
|
||||
install -D -m 0644 pom.xml \
|
||||
%{buildroot}/%{_mavenpomdir}/JPP.%{name}-httpclient.pom
|
||||
%add_to_maven_depmap org.apache.httpcomponents httpclient %{version} JPP/%{name} httpclient
|
||||
|
||||
# main pom
|
||||
install -D -m 0644 ../pom.xml \
|
||||
%{buildroot}/%{_mavenpomdir}/JPP.%{name}-httpcomponents-client.pom
|
||||
%add_to_maven_depmap org.apache.httpcomponents httpcomponents-client %{version} JPP/%{name} httpcomponents-client
|
||||
|
||||
# javadocs
|
||||
install -dm 755 %{buildroot}%{_javadocdir}/%{name}
|
||||
cp -pr target/site/api*/* %{buildroot}%{_javadocdir}/%{name}
|
||||
|
||||
|
||||
%post
|
||||
%update_maven_depmap
|
||||
|
||||
%postun
|
||||
%update_maven_depmap
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README.txt LICENSE.txt RELEASE_NOTES.txt
|
||||
%{_mavendepmapfragdir}/%{name}
|
||||
%{_mavenpomdir}/JPP.%{name}*.pom
|
||||
%{_javadir}/%{name}
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENSE.txt
|
||||
%doc %{_javadocdir}/*
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 22 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.0.3-2
|
||||
- Added license to javadoc subpackage
|
||||
|
||||
* Mon Dec 20 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.0.3-1
|
||||
- Initial version
|
Loading…
Reference in New Issue
Block a user