diff --git a/.gitignore b/.gitignore
index fd7dffe..0a44ac6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -21,3 +21,4 @@ httpcomponents-client-4.1-src.tar.gz
/httpcomponents-client-4.5.2-src.tar.gz
/httpcomponents-client-4.5.3-src.tar.gz
/httpcomponents-client-4.5.5-src.tar.gz
+/httpcomponents-client-4.5.6-src.tar.gz
diff --git a/httpcomponents-client.spec b/httpcomponents-client.spec
index 1a4ea65..602b1cf 100644
--- a/httpcomponents-client.spec
+++ b/httpcomponents-client.spec
@@ -3,8 +3,8 @@
Name: httpcomponents-client
Summary: HTTP agent implementation based on httpcomponents HttpCore
-Version: 4.5.5
-Release: 5%{?dist}
+Version: 4.5.6
+Release: 1%{?dist}
License: ASL 2.0
URL: http://hc.apache.org/
Source0: http://www.apache.org/dist/httpcomponents/httpclient/source/%{name}-%{version}-src.tar.gz
@@ -75,7 +75,6 @@ Summary: API documentation for %{name}
rm httpclient/src/test/java/org/apache/http/conn/ssl/TestSSLSocketFactory.java
# Don't compile/run httpclient-cache tests - they are incompatible with EasyMock 3.3
-%pom_remove_plugin org.apache.maven.plugins:maven-jar-plugin httpclient-cache
%pom_remove_dep org.easymock:easymockclassextension
for dep in org.easymock:easymockclassextension org.slf4j:slf4j-jcl; do
%pom_remove_dep $dep httpclient-cache
@@ -84,49 +83,30 @@ rm -rf httpclient-cache/src/test
%pom_remove_plugin :download-maven-plugin httpclient
-# Add proper Apache felix bundle plugin instructions
-# so that we get a reasonable OSGi manifest.
-for module in httpclient httpmime httpclient-cache fluent-hc; do
- %pom_xpath_remove "pom:project/pom:packaging" $module
- %pom_xpath_inject "pom:project" "bundle" $module
-done
+%pom_xpath_inject "pom:archive" "
+ \${project.build.outputDirectory}/META-INF/MANIFEST.MF"
+
+%pom_xpath_inject pom:build/pom:plugins "
+
+ org.apache.felix
+ maven-bundle-plugin
+
+
+ bundle-manifest
+ process-classes
+
+ manifest
+
+
+
+ "
-# Make fluent-hc into bundle
%pom_xpath_inject pom:build "
-
+
+
org.apache.felix
maven-bundle-plugin
- true
-
-" fluent-hc
-
-# Make httpmime into bundle
-%pom_xpath_inject pom:build/pom:plugins "
-
- org.apache.felix
- maven-bundle-plugin
- true
- " httpmime
-
-# Make httpclient into bundle
-%pom_xpath_inject pom:reporting/pom:plugins "
-
- org.apache.felix
- maven-bundle-plugin
-
-
- *
-
- !org.apache.avalon.framework.logger,!org.apache.log,!org.apache.log4j,*
-
-
- " httpclient
-%pom_xpath_inject pom:build/pom:plugins "
-
- org.apache.felix
- maven-bundle-plugin
- true
org.apache.http.*,!org.apache.http.param
@@ -136,10 +116,14 @@ done
true
- " httpclient
+
+
+
+" httpclient
-# Make httpclient-cache into bundle
-%pom_xpath_inject pom:build/pom:plugins "
+%pom_xpath_inject pom:build "
+
+
org.apache.felix
maven-bundle-plugin
@@ -153,7 +137,9 @@ done
true
- " httpclient-cache
+
+
+" httpclient-cache
# requires network
rm httpclient/src/test/java/org/apache/http/client/config/TestRequestConfig.java
@@ -185,6 +171,9 @@ rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/ehcache
%doc LICENSE.txt NOTICE.txt
%changelog
+* Mon Oct 8 2018 Mikolaj Izdebski - 4.5.6-1
+- Update to upstream version 4.5.6
+
* Fri Jul 13 2018 Fedora Release Engineering - 4.5.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
diff --git a/sources b/sources
index c0f98e5..67eecbd 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (httpcomponents-client-4.5.5-src.tar.gz) = 8cfe5879f043c8a1dc7291567363a101c2ea653e99cbc640a18f1a498fc68b60e5321f953bd6765af61b551d45e1e635544328a363e01f13a1d8bd1dfe063e00
+SHA512 (httpcomponents-client-4.5.6-src.tar.gz) = c674ccc464eedc5a10c76d49bb87c6f0faf8abe6bf8209ade76af82e3efab8b9ed6cf2967b5f880f486d60de4876be26278b77e99a414aff3400346b57891c82