diff --git a/0001-Cleanup-pom.patch b/0001-Cleanup-pom.patch
index ac7b967..2ed82da 100644
--- a/0001-Cleanup-pom.patch
+++ b/0001-Cleanup-pom.patch
@@ -1,76 +1,5 @@
---- httpclient/pom.xml.sav 2011-01-17 22:00:53.000000000 +0200
-+++ httpclient/pom.xml 2011-02-18 13:38:36.221371560 +0200
-@@ -38,7 +38,7 @@
- HttpComponents Client (base module)
-
- http://hc.apache.org/httpcomponents-client
-- jar
-+ bundle
-
-
-
-@@ -71,12 +71,6 @@
- ${easymock.version}
- test
-
--
-- org.easymock
-- easymockclassextension
-- ${easymock.version}
-- test
--
-
-
-
-@@ -122,25 +116,12 @@
-
-
-
--
-- com.atlassian.maven.plugins
-- maven-clover2-plugin
--
-- threaded
-- 100
-- 50%
--
--
--
-- site
-- pre-site
--
-- instrument
--
--
--
--
--
-+
-+ org.apache.felix
-+ maven-bundle-plugin
-+ true
-+
-+
-
-
-
-@@ -165,14 +146,6 @@
-
-
-
-- com.atlassian.maven.plugins
-- maven-clover2-plugin
--
-- 1.5
--
--
--
--
- maven-jxr-plugin
-
-
---- pom.xml.sav 2011-01-17 22:00:53.000000000 +0200
-+++ pom.xml 2011-02-25 20:17:20.519335750 +0200
+--- pom.xml.sav 2011-01-17 15:00:53.000000000 -0500
++++ pom.xml 2011-03-10 09:45:01.330282001 -0500
@@ -81,28 +81,11 @@
httpclient
@@ -183,8 +112,82 @@
---- httpmime/pom.xml.sav 2011-01-17 22:00:44.000000000 +0200
-+++ httpmime/pom.xml 2011-02-25 20:19:09.191564653 +0200
+--- httpclient/pom.xml.sav 2011-01-17 15:00:53.000000000 -0500
++++ httpclient/pom.xml 2011-03-10 09:50:50.829281988 -0500
+@@ -38,7 +38,7 @@
+ HttpComponents Client (base module)
+
+ http://hc.apache.org/httpcomponents-client
+- jar
++ bundle
+
+
+
+@@ -71,12 +71,6 @@
+ ${easymock.version}
+ test
+
+-
+- org.easymock
+- easymockclassextension
+- ${easymock.version}
+- test
+-
+
+
+
+@@ -122,25 +116,17 @@
+
+
+
+-
+- com.atlassian.maven.plugins
+- maven-clover2-plugin
++
++ org.apache.felix
++ maven-bundle-plugin
++ true
+
+- threaded
+- 100
+- 50%
++
++ *
++
+
+-
+-
+- site
+- pre-site
+-
+- instrument
+-
+-
+-
+-
+-
++
++
+
+
+
+@@ -165,14 +151,6 @@
+
+
+
+- com.atlassian.maven.plugins
+- maven-clover2-plugin
+-
+- 1.5
+-
+-
+-
+-
+ maven-jxr-plugin
+
+
+--- httpmime/pom.xml.sav 2011-01-17 15:00:44.000000000 -0500
++++ httpmime/pom.xml 2011-03-10 09:45:01.330282001 -0500
@@ -38,7 +38,7 @@
HttpComponents HttpClient - MIME coded entities
diff --git a/httpcomponents-client.spec b/httpcomponents-client.spec
index b2bf294..3cce83e 100644
--- a/httpcomponents-client.spec
+++ b/httpcomponents-client.spec
@@ -3,7 +3,7 @@
Name: httpcomponents-client
Summary: HTTP agent implementation based on httpcomponents HttpCore
Version: 4.1
-Release: 4%{?dist}
+Release: 5%{?dist}
Group: Development/Libraries
License: ASL 2.0
URL: http://hc.apache.org/
@@ -92,6 +92,9 @@ cp -pr target/site/api*/* %{buildroot}%{_javadocdir}/%{name}
%changelog
+* Thu Mar 10 2011 Alexander Kurtakov 4.1-5
+- OSGi export more packages.
+
* Fri Feb 25 2011 Alexander Kurtakov 4.1-4
- Build httpmime module.