diff --git a/httpcomponents-client.spec b/httpcomponents-client.spec
index cbe24ae..c943535 100644
--- a/httpcomponents-client.spec
+++ b/httpcomponents-client.spec
@@ -42,12 +42,6 @@ management. HttpComponents Client is a successor of and replacement
for Commons HttpClient 3.x. Users of Commons HttpClient are strongly
encouraged to upgrade.
-%package cache
-Summary: Cache module for %{name}
-
-%description cache
-This package provides client side caching for %{name}.
-
%{?javadoc_package}
%prep
@@ -56,7 +50,6 @@ This package provides client side caching for %{name}.
%patch1 -p1
%mvn_package :::tests: __noinstall
-%mvn_package :httpclient-cache cache
# Change scope of commons-logging to provided
%pom_change_dep :commons-logging :::provided
@@ -64,6 +57,9 @@ This package provides client side caching for %{name}.
# Remove optional build deps not available in Fedora
%pom_disable_module httpclient-osgi
%pom_disable_module httpclient-win
+%pom_disable_module fluent-hc
+%pom_disable_module httpmime
+%pom_disable_module httpclient-cache
%pom_remove_plugin :docbkx-maven-plugin
%pom_remove_plugin :clirr-maven-plugin
%pom_remove_plugin :maven-checkstyle-plugin
@@ -75,13 +71,6 @@ This package provides client side caching for %{name}.
# Fails due to strict crypto policy - uses DSA in test data
rm httpclient/src/test/java/org/apache/http/conn/ssl/TestSSLSocketFactory.java
-# Don't compile/run httpclient-cache tests - they are incompatible with EasyMock 3.3
-%pom_remove_dep org.easymock:easymockclassextension
-for dep in org.easymock:easymockclassextension org.slf4j:slf4j-jcl; do
- %pom_remove_dep $dep httpclient-cache
-done
-rm -rf httpclient-cache/src/test
-
%pom_remove_plugin :download-maven-plugin httpclient
%pom_xpath_inject "pom:archive" "
@@ -122,34 +111,9 @@ rm -rf httpclient-cache/src/test
" httpclient
-%pom_xpath_inject pom:build "
-
-
-
- org.apache.felix
- maven-bundle-plugin
- true
-
-
- *
- net.sf.ehcache;resolution:=optional,net.spy.memcached;resolution:=optional,*
-
- <_nouses>true
-
- true
-
-
-
-" httpclient-cache
-
# requires network
rm httpclient/src/test/java/org/apache/http/client/config/TestRequestConfig.java
-rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/memcached
-%pom_remove_dep :spymemcached httpclient-cache
-rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/ehcache
-%pom_remove_dep :ehcache-core httpclient-cache
-
%build
%mvn_file ":{*}" httpcomponents/@1
@@ -162,8 +126,6 @@ rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/ehcache
%license LICENSE.txt NOTICE.txt
%doc README.txt RELEASE_NOTES.txt
-%files cache -f .mfiles-cache
-
%changelog
* Fri May 24 2019 Mikolaj Izdebski - 4.5.8-2
- Mass rebuild for javapackages-tools 201901