diff --git a/httpcomponents-client.spec b/httpcomponents-client.spec
index 67d076a..ecb30e9 100644
--- a/httpcomponents-client.spec
+++ b/httpcomponents-client.spec
@@ -7,7 +7,7 @@
Name: httpcomponents-client
Summary: HTTP agent implementation based on httpcomponents HttpCore
Version: 4.5.2
-Release: 1%{?dist}
+Release: 2%{?dist}
License: ASL 2.0
URL: http://hc.apache.org/
Source0: http://www.apache.org/dist/httpcomponents/httpclient/source/%{name}-%{version}-src.tar.gz
@@ -80,11 +80,21 @@ rm -rf httpclient-cache/src/test
# Add proper Apache felix bundle plugin instructions
# so that we get a reasonable OSGi manifest.
-for module in httpclient httpmime httpclient-cache; do
+for module in httpclient httpmime httpclient-cache fluent-hc; do
%pom_xpath_remove "pom:project/pom:packaging" $module
%pom_xpath_inject "pom:project" "bundle" $module
done
+# Make fluent-hc into bundle
+%pom_xpath_inject pom:build "
+
+
+ org.apache.felix
+ maven-bundle-plugin
+ true
+
+" fluent-hc
+
# Make httpmime into bundle
%pom_xpath_inject pom:build/pom:plugins "
@@ -160,6 +170,9 @@ rm httpclient/src/test/java/org/apache/http/client/config/TestRequestConfig.java
%doc LICENSE.txt NOTICE.txt
%changelog
+* Wed Mar 16 2016 Sopot Cela - 4.5.2-2
+- Make the fluent API into a bundle
+
* Mon Feb 29 2016 Mikolaj Izdebski - 4.5.2-1
- Update to upstream version 4.5.2