diff --git a/.gitignore b/.gitignore
index bd21843..daf3251 100644
--- a/.gitignore
+++ b/.gitignore
@@ -26,3 +26,4 @@ httpcomponents-client-4.1-src.tar.gz
/httpcomponents-client-4.5.8-src.tar.gz
/httpcomponents-client-4.5.9-src.tar.gz
/httpcomponents-client-4.5.10-src.tar.gz
+/httpcomponents-client-4.5.11-src.tar.gz
diff --git a/httpcomponents-client.spec b/httpcomponents-client.spec
index e4b6c89..a811b0a 100644
--- a/httpcomponents-client.spec
+++ b/httpcomponents-client.spec
@@ -1,40 +1,36 @@
-%bcond_with memcached
-%bcond_with ehcache
+%bcond_with bootstrap
Name: httpcomponents-client
Summary: HTTP agent implementation based on httpcomponents HttpCore
-Version: 4.5.10
-Release: 6%{?dist}
+Version: 4.5.11
+Release: 2%{?dist}
License: ASL 2.0
URL: http://hc.apache.org/
-Source0: http://www.apache.org/dist/httpcomponents/httpclient/source/%{name}-%{version}-src.tar.gz
+Source0: https://www.apache.org/dist/httpcomponents/httpclient/source/%{name}-%{version}-src.tar.gz
+BuildArch: noarch
Patch0: 0001-Use-system-copy-of-effective_tld_names.dat.patch
Patch1: 0002-Port-to-mockito-2.patch
-BuildArch: noarch
-
-BuildRequires: maven-local
+BuildRequires: maven-local-openjdk8
+%if %{with bootstrap}
+BuildRequires: javapackages-bootstrap
+%else
BuildRequires: mvn(commons-codec:commons-codec)
BuildRequires: mvn(commons-logging:commons-logging)
BuildRequires: mvn(junit:junit)
-%if %{with ehcache}
-BuildRequires: mvn(net.sf.ehcache:ehcache-core)
-%endif
-%if %{with memcached}
-BuildRequires: mvn(net.spy:spymemcached)
-%endif
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.apache.httpcomponents:httpcomponents-parent:pom:)
BuildRequires: mvn(org.apache.httpcomponents:httpcore)
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
BuildRequires: mvn(org.mockito:mockito-core)
+%endif
+%if %{without bootstrap}
BuildRequires: publicsuffix-list
+%endif
Requires: publicsuffix-list
-Obsoletes: %{name}-tests < 4.4
-
%description
HttpClient is a HTTP/1.1 compliant HTTP agent implementation based on
httpcomponents HttpCore. It also provides reusable components for
@@ -43,17 +39,7 @@ management. HttpComponents Client is a successor of and replacement
for Commons HttpClient 3.x. Users of Commons HttpClient are strongly
encouraged to upgrade.
-%package cache
-Summary: Cache module for %{name}
-
-%description cache
-This package provides client side caching for %{name}.
-
-%package javadoc
-Summary: API documentation for %{name}
-
-%description javadoc
-%{summary}.
+%{?javadoc_package}
%prep
%setup -q -n %{name}-%{version}
@@ -61,11 +47,16 @@ Summary: API documentation for %{name}
%patch1 -p1
%mvn_package :::tests: __noinstall
-%mvn_package :httpclient-cache cache
+
+# Change scope of commons-logging to provided
+%pom_change_dep :commons-logging :::provided httpclient
# Remove optional build deps not available in Fedora
%pom_disable_module httpclient-osgi
%pom_disable_module httpclient-win
+%pom_disable_module fluent-hc
+%pom_disable_module httpmime
+%pom_disable_module httpclient-cache
%pom_remove_plugin :docbkx-maven-plugin
%pom_remove_plugin :clirr-maven-plugin
%pom_remove_plugin :maven-checkstyle-plugin
@@ -77,12 +68,6 @@ Summary: API documentation for %{name}
# Fails due to strict crypto policy - uses DSA in test data
rm httpclient/src/test/java/org/apache/http/conn/ssl/TestSSLSocketFactory.java
-# Don't compile/run httpclient-cache tests - they are incompatible with EasyMock 3.3
-%pom_remove_dep org.easymock:easymockclassextension
-%pom_remove_dep org.slf4j:slf4j-jcl httpclient-cache
-%pom_remove_dep :::test httpclient-cache
-rm -rf httpclient-cache/src/test
-
%pom_remove_plugin :download-maven-plugin httpclient
%pom_xpath_inject "pom:archive" "
@@ -123,54 +108,20 @@ rm -rf httpclient-cache/src/test
" httpclient
-%pom_xpath_inject pom:build "
-
-
-
- org.apache.felix
- maven-bundle-plugin
- true
-
-
- *
- net.sf.ehcache;resolution:=optional,net.spy.memcached;resolution:=optional,*
-
- <_nouses>true
-
- true
-
-
-
-" httpclient-cache
-
# requires network
rm httpclient/src/test/java/org/apache/http/client/config/TestRequestConfig.java
-%if %{without memcached}
-rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/memcached
-%pom_remove_dep :spymemcached httpclient-cache
-%endif
-%if %{without ehcache}
-rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/ehcache
-%pom_remove_dep :ehcache-core httpclient-cache
-%endif
-
+%build
%mvn_file ":{*}" httpcomponents/@1
-%build
-%mvn_build -- -Dmaven.compiler.release=8
+%mvn_build
%install
%mvn_install
-
-%files -f .mfiles
-%doc LICENSE.txt NOTICE.txt README.txt RELEASE_NOTES.txt
-
-%files cache -f .mfiles-cache
-
-%files javadoc -f .mfiles-javadoc
-%doc LICENSE.txt NOTICE.txt
+%files -n %{?module_prefix}%{name} -f .mfiles
+%license LICENSE.txt NOTICE.txt
+%doc README.txt RELEASE_NOTES.txt
%changelog
* Wed Feb 17 2021 Fabio Valentini - 4.5.10-6
@@ -188,15 +139,36 @@ rm -r httpclient-cache/src/*/java/org/apache/http/impl/client/cache/ehcache
* Wed Jan 29 2020 Fedora Release Engineering - 4.5.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+* Sat Jan 25 2020 Mikolaj Izdebski - 4.5.11-2
+- Build with OpenJDK 8
+
+* Wed Jan 22 2020 Marian Koncek - 4.5.11-1
+- Update to upstream version 4.5.11
+
+* Tue Nov 05 2019 Mikolaj Izdebski - 4.5.10-2
+- Mass rebuild for javapackages-tools 201902
+
+* Mon Sep 16 2019 Marian Koncek - 4.5.10-1
+- Update to upstream version 4.5.10
+
* Mon Sep 16 2019 Marian Koncek - 4.5.10-1
- Update to upstream version 4.5.10
* Thu Aug 29 2019 Fabio Valentini - 4.5.7-3
- Disable memcached and ehcache support.
+* Mon Jul 29 2019 Marian Koncek - 4.5.9-1
+- Update to upstream version 4.5.9
+
* Thu Jul 25 2019 Fedora Release Engineering - 4.5.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+* Fri May 24 2019 Mikolaj Izdebski - 4.5.8-2
+- Mass rebuild for javapackages-tools 201901
+
+* Mon May 13 2019 Mikolaj Izdebski - 4.5.8-1
+- Update to upstream version 4.5.8
+
* Mon Feb 04 2019 Marian Koncek - 4.5.7-1
- Update to upstream version 4.5.7
- Fixes: RHBZ #1669148
diff --git a/sources b/sources
index a5c5640..6aa3297 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (httpcomponents-client-4.5.10-src.tar.gz) = 9bd1290d5947a5d84b24f18c5c138cdbb0a305a119536c3f1c35befcac6e3c4c8156b972dbe0f28169b6dbfcd0a97580b8721d5e25fad9deb12ba5a6cc74b710
+SHA512 (httpcomponents-client-4.5.11-src.tar.gz) = e2f005a7866ac0cb6d8d7c1b0d9d516cd28f6f175722a48d3ec86e63d5af6ff9df633aee1e736453ea4360a12abfbdc7e1cf9e9b8b3fac5229ffcad3eebe376f