Sync with upstream hspell-1.2
This commit is contained in:
parent
6e40c62564
commit
b1e68ffded
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
hspell-0.9.tar.gz
|
||||
hspell-1.0.tar.gz
|
||||
/hspell-1.2.tar.gz
|
||||
|
@ -1,66 +0,0 @@
|
||||
Index: hspell-1.0/Makefile.in
|
||||
===================================================================
|
||||
--- hspell-1.0.orig/Makefile.in
|
||||
+++ hspell-1.0/Makefile.in
|
||||
@@ -51,7 +51,7 @@ LDFLAGS=@LDFLAGS@
|
||||
|
||||
# Our TARGETS variable chooses what to compile. Some things are
|
||||
# optionally compiled depending on --enable-* paramters to configure.
|
||||
-TARGETS = @TARGETS@
|
||||
+TARGETS = @TARGETS@ libhspell.a
|
||||
all: $(TARGETS)
|
||||
|
||||
# SEDCMD controls on whether objective-kinuyim - about 130,000 rare verb
|
||||
@@ -76,7 +76,8 @@ clean:
|
||||
hebrew.wgz.lingsizes.tmp dmask.c install.js \
|
||||
spell-he.xpi he.dic he.aff README-he.txt \
|
||||
README_he_IL.txt he_IL.dic he_IL.aff he_IL.zip \
|
||||
- specfilter.o specfilter
|
||||
+ specfilter.o specfilter \
|
||||
+ libhspell.so.0 libhspell.so *.lo
|
||||
rm -f hebeng/install.js hebeng/heb-eng.aff hebeng/heb-eng.dic \
|
||||
hebeng/README-he.txt hebeng/README-en-US.txt \
|
||||
hebeng/spell-heb-eng.xpi
|
||||
@@ -113,6 +114,9 @@ install: all
|
||||
test -d $(DESTDIR)$(LIBDIR) || mkdir -m 755 -p $(DESTDIR)$(LIBDIR)
|
||||
cp libhspell.a $(DESTDIR)$(LIBDIR)/
|
||||
chmod 644 $(DESTDIR)$(LIBDIR)/libhspell.a
|
||||
+ cp libhspell.so.0 $(DESTDIR)$(LIBDIR)/
|
||||
+ chmod 755 $(DESTDIR)$(LIBDIR)/libhspell.so.0
|
||||
+ ln -sf libhspell.so.0 $(DESTDIR)$(LIBDIR)/libhspell.so
|
||||
test -d $(DESTDIR)$(INCLUDEDIR) || mkdir -m 755 -p $(DESTDIR)$(INCLUDEDIR)
|
||||
cp hspell.h linginfo.h $(DESTDIR)$(INCLUDEDIR)/
|
||||
chmod 644 $(DESTDIR)$(INCLUDEDIR)/hspell.h $(DESTDIR)$(INCLUDEDIR)/linginfo.h
|
||||
@@ -166,19 +170,30 @@ libhspell.a: dict_radix.o gimatria.o cor
|
||||
ar cr $@ $^
|
||||
-ranlib $@
|
||||
|
||||
-$(HSPELL_EXECUTABLE): hspell.o tclHash.o libhspell.a
|
||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o $(HSPELL_EXECUTABLE) hspell.o tclHash.o libhspell.a $(LIBS)
|
||||
+EXTRAOBJECTSPIC=$(EXTRAOBJECTS:.o=.lo)
|
||||
+
|
||||
+%.lo: %.c
|
||||
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -o $@ $<
|
||||
+
|
||||
+libhspell.so.0: dict_radix.lo gimatria.lo corlist.lo libhspell.lo $(EXTRAOBJECTSPIC)
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -shared -Wl,-soname,libhspell.so.0 $^ -lz
|
||||
+ ln -sf libhspell.so.0 libhspell.so
|
||||
+
|
||||
+$(HSPELL_EXECUTABLE): hspell.o tclHash.o libhspell.so.0
|
||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(HSPELL_EXECUTABLE) hspell.o tclHash.o libhspell.so.0 $(LIBS)
|
||||
|
||||
# remember to update this dependency list once in a while...
|
||||
libhspell.o dict_radix.o find_sizes.o: dict_radix.h
|
||||
dict_radix.o linginfo.o: gzbuffered.h
|
||||
libhspell.o mk_he_affix.o: prefixes.c
|
||||
+libhspell.lo mk_he_affix.lo: prefixes.c
|
||||
hspell.o: hash.h tclHash.h
|
||||
tclHash.o: tclHash.h
|
||||
corlist.o gimatria.o hspell.o libhspell.o: hspell.h
|
||||
hspell.o libhspell.o linginfo.o: linginfo.h hspell.h
|
||||
linginfo.o: dmask.c
|
||||
specfilter.o: prefixes.c
|
||||
+specfilter.lo: prefixes.c
|
||||
|
||||
prefixes.c: genprefixes.pl PrefixBits.pl
|
||||
$(PERL) -w ./genprefixes.pl >prefixes.c
|
37
hspell.spec
37
hspell.spec
@ -1,14 +1,14 @@
|
||||
Summary: A Hebrew spell checker
|
||||
Name: hspell
|
||||
Version: 1.1
|
||||
Release: 5%{?dist}
|
||||
Version: 1.2
|
||||
Release: 1%{?dist}
|
||||
URL: http://hspell.ivrix.org.il
|
||||
Source: http://hspell.ivrix.org.il/hspell-%{version}.tar.gz
|
||||
License: GPLv2
|
||||
License: AGPLv3
|
||||
Group: Applications/Text
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: zlib-devel hunspell-devel
|
||||
Patch0: hspell-1.0.sharedlib.patch
|
||||
#Patch0: hspell-1.2.sharedlib.patch
|
||||
|
||||
%description
|
||||
Hspell is a Hebrew SPELLer and morphological analyzer. It provides a mostly
|
||||
@ -43,26 +43,13 @@ Hebrew hunspell dictionaries.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .sharedlib.patch
|
||||
#%patch0 -p1 -b .sharedlib.patch
|
||||
/usr/bin/iconv -f hebrew -t utf8 -o WHATSNEW WHATSNEW
|
||||
|
||||
%build
|
||||
%configure --enable-fatverb --enable-linginfo
|
||||
%configure --enable-fatverb --enable-linginfo --enable-shared
|
||||
make CFLAGS="$RPM_OPT_FLAGS" STRIP=:
|
||||
make hunspell
|
||||
cat >> hunspell/new_he.aff << EOF
|
||||
MAP 10
|
||||
MAP ךכח
|
||||
MAP םמ
|
||||
MAP ןנ
|
||||
MAP ףפ
|
||||
MAP ץצ
|
||||
MAP כק
|
||||
MAP אע # for English
|
||||
MAP גה # for Russian
|
||||
MAP צס # for Arabic
|
||||
MAP חכר # for French
|
||||
EOF
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
@ -70,8 +57,12 @@ make DESTDIR=%{buildroot} install
|
||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/libhspell.a
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/myspell
|
||||
cp -p hunspell/new_he.dic $RPM_BUILD_ROOT/%{_datadir}/myspell/he_IL.dic
|
||||
cp -p hunspell/new_he.aff $RPM_BUILD_ROOT/%{_datadir}/myspell/he_IL.aff
|
||||
cp -p he.dic $RPM_BUILD_ROOT/%{_datadir}/myspell/he_IL.dic
|
||||
cp -p he.aff $RPM_BUILD_ROOT/%{_datadir}/myspell/he_IL.aff
|
||||
|
||||
%check
|
||||
# there are three known failures
|
||||
! make test | grep FAILED | egrep -v '1/aspell/[489]'
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
@ -102,8 +93,8 @@ rm -rf %{buildroot}
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
* Wed Feb 29 2012 Dan Kenigsberg <danken@cs.technion.ac.il> - 1.2-1
|
||||
- Sync with upstream hspell-1.2
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user