give in to requests for libhspell.so

This commit is contained in:
Dan Kenigsberg 2008-05-14 22:04:14 +00:00
parent f7fc6cc1fb
commit 54b45d84b5
2 changed files with 75 additions and 2 deletions

View File

@ -0,0 +1,66 @@
Index: hspell-1.0/Makefile.in
===================================================================
--- hspell-1.0.orig/Makefile.in
+++ hspell-1.0/Makefile.in
@@ -51,7 +51,7 @@ LDFLAGS=@LDFLAGS@
# Our TARGETS variable chooses what to compile. Some things are
# optionally compiled depending on --enable-* paramters to configure.
-TARGETS = @TARGETS@
+TARGETS = @TARGETS@ libhspell.a
all: $(TARGETS)
# SEDCMD controls on whether objective-kinuyim - about 130,000 rare verb
@@ -76,7 +76,8 @@ clean:
hebrew.wgz.lingsizes.tmp dmask.c install.js \
spell-he.xpi he.dic he.aff README-he.txt \
README_he_IL.txt he_IL.dic he_IL.aff he_IL.zip \
- specfilter.o specfilter
+ specfilter.o specfilter \
+ libhspell.so.0 libhspell.so *.lo
rm -f hebeng/install.js hebeng/heb-eng.aff hebeng/heb-eng.dic \
hebeng/README-he.txt hebeng/README-en-US.txt \
hebeng/spell-heb-eng.xpi
@@ -113,6 +114,9 @@ install: all
test -d $(DESTDIR)$(LIBDIR) || mkdir -m 755 -p $(DESTDIR)$(LIBDIR)
cp libhspell.a $(DESTDIR)$(LIBDIR)/
chmod 644 $(DESTDIR)$(LIBDIR)/libhspell.a
+ cp libhspell.so.0 $(DESTDIR)$(LIBDIR)/
+ chmod 755 $(DESTDIR)$(LIBDIR)/libhspell.so.0
+ ln -sf libhspell.so.0 $(DESTDIR)$(LIBDIR)/libhspell.so
test -d $(DESTDIR)$(INCLUDEDIR) || mkdir -m 755 -p $(DESTDIR)$(INCLUDEDIR)
cp hspell.h linginfo.h $(DESTDIR)$(INCLUDEDIR)/
chmod 644 $(DESTDIR)$(INCLUDEDIR)/hspell.h $(DESTDIR)$(INCLUDEDIR)/linginfo.h
@@ -166,19 +170,30 @@ libhspell.a: dict_radix.o gimatria.o cor
ar cr $@ $^
-ranlib $@
-$(HSPELL_EXECUTABLE): hspell.o tclHash.o libhspell.a
- $(CC) $(CFLAGS) $(LDFLAGS) -o $(HSPELL_EXECUTABLE) hspell.o tclHash.o libhspell.a $(LIBS)
+EXTRAOBJECTSPIC=$(EXTRAOBJECTS:.o=.lo)
+
+%.lo: %.c
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -o $@ $<
+
+libhspell.so.0: dict_radix.lo gimatria.lo corlist.lo libhspell.lo $(EXTRAOBJECTSPIC)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -shared -Wl,-soname,libhspell.so.0 $^ -lz
+ ln -sf libhspell.so.0 libhspell.so
+
+$(HSPELL_EXECUTABLE): hspell.o tclHash.o libhspell.so.0
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(HSPELL_EXECUTABLE) hspell.o tclHash.o libhspell.so.0 $(LIBS)
# remember to update this dependency list once in a while...
libhspell.o dict_radix.o find_sizes.o: dict_radix.h
dict_radix.o linginfo.o: gzbuffered.h
libhspell.o mk_he_affix.o: prefixes.c
+libhspell.lo mk_he_affix.lo: prefixes.c
hspell.o: hash.h tclHash.h
tclHash.o: tclHash.h
corlist.o gimatria.o hspell.o libhspell.o: hspell.h
hspell.o libhspell.o linginfo.o: linginfo.h hspell.h
linginfo.o: dmask.c
specfilter.o: prefixes.c
+specfilter.lo: prefixes.c
prefixes.c: genprefixes.pl PrefixBits.pl
$(PERL) -w ./genprefixes.pl >prefixes.c

View File

@ -1,7 +1,7 @@
Summary: A Hebrew spell checker
Name: hspell
Version: 1.0
Release: 8%{?dist}
Release: 9%{?dist}
URL: http://ivrix.org.il/projects/spell-checker/
Source: http://ivrix.org.il/projects/spell-checker/hspell-%{version}.tar.gz
License: GPL
@ -10,6 +10,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel
Obsoletes: hspell-fat
Provides: hspell-fat = %{version}-%{release}
Patch0: hspell-1.0.sharedlib.patch
%description
Hspell is a Hebrew SPELLer . It currently provides a mostly spell-like
@ -54,6 +55,7 @@ Hebrew hunspell dictionaries.
%prep
%setup -q
%patch -p1 -b .sharedlib.patch
sed -i -e '/^\s\+strip\s/d' Makefile.in
sed -i -e 's/gzip/gzip -n/g' Makefile.in
@ -67,6 +69,7 @@ make myspell
%install
rm -rf %{buildroot}
make DESTDIR=%{buildroot} install
rm -f $RPM_BUILD_ROOT/%{_libdir}/libhspell.a
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/myspell
cp -p he.dic $RPM_BUILD_ROOT/%{_datadir}/myspell/he_IL.dic
@ -82,13 +85,14 @@ rm -rf %{buildroot}
%{_bindir}/hspell
%{_bindir}/hspell-i
%{_bindir}/multispell
%{_libdir}/libhspell.so.0
%{_mandir}/man1/hspell.1*
%{_datadir}/hspell/
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/libhspell.a
%{_libdir}/libhspell.so
%{_mandir}/man3/hspell.3*
%files -n hunspell-he
@ -97,6 +101,9 @@ rm -rf %{buildroot}
%{_datadir}/myspell/*
%changelog
* Wed May 14 2008 Caolan McNamara <caolanm@redhat.com> - 1.0-9
- Resolves: rhbz#313231 build hspell.so instead of a .a
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0-8
- Autorebuild for GCC 4.3