3b7ae335f3
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/hplip#7cb6f648cdb35a0f018b511d10b516d6d9e4d638
102 lines
4.3 KiB
Diff
102 lines
4.3 KiB
Diff
diff -up hplip-3.18.12/Makefile.am.libimageprocessor-removal hplip-3.18.12/Makefile.am
|
|
--- hplip-3.18.12/Makefile.am.libimageprocessor-removal 2019-01-08 12:51:08.629447883 +0100
|
|
+++ hplip-3.18.12/Makefile.am 2019-01-08 12:51:08.710447208 +0100
|
|
@@ -166,7 +166,7 @@ if !HPLIP_CLASS_DRIVER
|
|
dist_hplip_SCRIPTS = hpssd.py __init__.py hpdio.py
|
|
endif #HPLIP_CLASS_DRIVER
|
|
|
|
-dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template prnt/hpcups/libImageProcessor-x86_64.so prnt/hpcups/libImageProcessor-x86_32.so
|
|
+dist_noinst_DATA += prnt/drv/hpijs.drv.in.template prnt/drv/hpcups.drv.in.template
|
|
dist_noinst_SCRIPTS += dat2drv.py install.py hplip-install init-suse-firewall init-iptables-firewall class_rpm_build.sh hplipclassdriver.spec createPPD.sh Makefile_dat2drv hpijs-drv
|
|
|
|
if !HPLIP_CLASS_DRIVER
|
|
@@ -594,7 +594,7 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilte
|
|
prnt/hpcups/ImageProcessor.h
|
|
|
|
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
|
|
-hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lImageProcessor -lcups -lcupsimage -lz $(DBUS_LIBS)
|
|
+hpcups_LDADD = -L./prnt/hpcups/ -ljpeg -ldl -lcups -lcupsimage -lz $(DBUS_LIBS)
|
|
#else
|
|
#hpcupsdir = $(cupsfilterdir)
|
|
#hpcups_PROGRAMS = hpcups
|
|
@@ -684,16 +684,6 @@ endif #HPLIP_CLASS_DRIVER
|
|
|
|
install-data-hook:
|
|
if HPLIP_BUILD
|
|
- if [ \( "$(UNAME)" = "x86_64" -a -d "$(libdir)/" \) ]; then \
|
|
- cp prnt/hpcups/libImageProcessor-x86_64.so $(libdir)/ ; \
|
|
- chmod 775 $(libdir)/libImageProcessor-x86_64.so ; \
|
|
- ln -sf $(libdir)/libImageProcessor-x86_64.so $(libdir)/libImageProcessor.so ; \
|
|
- fi; \
|
|
- if [ \( \( "$(UNAME)" = "i686" -o "$(UNAME)" = "i386" \) -a -d "$(libdir)/" \) ]; then \
|
|
- cp prnt/hpcups/libImageProcessor-x86_32.so $(libdir)/ ; \
|
|
- chmod 775 $(libdir)/libImageProcessor-x86_32.so ; \
|
|
- ln -sf $(libdir)/libImageProcessor-x86_32.so $(libdir)/libImageProcessor.so ; \
|
|
- fi
|
|
if !HPLIP_CLASS_DRIVER
|
|
# If scanner build, add hpaio entry to sane dll.conf.
|
|
if [ "$(scan_build)" = "yes" ]; then \
|
|
diff -up hplip-3.18.12/prnt/hpcups/HPCupsFilter.cpp.libimageprocessor-removal hplip-3.18.12/prnt/hpcups/HPCupsFilter.cpp
|
|
--- hplip-3.18.12/prnt/hpcups/HPCupsFilter.cpp.libimageprocessor-removal 2019-01-08 12:51:08.619447966 +0100
|
|
+++ hplip-3.18.12/prnt/hpcups/HPCupsFilter.cpp 2019-01-08 12:52:39.321686854 +0100
|
|
@@ -31,7 +31,6 @@
|
|
\*****************************************************************************/
|
|
|
|
#include "HPCupsFilter.h"
|
|
-#include "ImageProcessor.h"
|
|
|
|
#include <signal.h>
|
|
#include <sys/wait.h>
|
|
@@ -645,16 +644,10 @@ int HPCupsFilter::processRasterData(cups
|
|
|
|
|
|
snprintf(hpPreProcessedRasterFile, sizeof (hpPreProcessedRasterFile), "%s/hp_%s_cups_SwapedPagesXXXXXX",CUPS_TMP_DIR, m_JA.user_name);
|
|
- image_processor_t* imageProcessor = imageProcessorCreate();
|
|
|
|
while (cupsRasterReadHeader2(cups_raster, &cups_header))
|
|
{
|
|
|
|
- IMAGE_PROCESSOR_ERROR result = imageProcessorStartPage(imageProcessor, &cups_header);
|
|
- if (result != IPE_SUCCESS){
|
|
- dbglog("DEBUG: imageProcessorStartPage failed result = %d\n", result);
|
|
- }
|
|
-
|
|
current_page_number++;
|
|
|
|
if (current_page_number == 1) {
|
|
@@ -753,12 +746,6 @@ int HPCupsFilter::processRasterData(cups
|
|
color_raster = rgbRaster;
|
|
black_raster = kRaster;
|
|
|
|
- result = imageProcessorProcessLine(imageProcessor, m_pPrinterBuffer, cups_header.cupsBytesPerLine);
|
|
- if (result != IPE_SUCCESS){
|
|
- dbglog("DEBUG: imageProcessorProcessLine failed result = %d\n", result);
|
|
- }
|
|
-
|
|
-
|
|
if ((y == 0) && !is_ljmono) {
|
|
//For ljmono, make sure that first line is not a blankRaster line.Otherwise printer
|
|
//may not skip blank lines before actual data
|
|
@@ -788,12 +775,6 @@ int HPCupsFilter::processRasterData(cups
|
|
}
|
|
} // for() loop end
|
|
|
|
- result = imageProcessorEndPage(imageProcessor);
|
|
- if (result != IPE_SUCCESS){
|
|
- dbglog("DEBUG: imageProcessorEndPage failed result = %d\n", result);
|
|
- }
|
|
-
|
|
-
|
|
m_Job.NewPage();
|
|
if (err != NO_ERROR) {
|
|
break;
|
|
@@ -808,8 +789,6 @@ int HPCupsFilter::processRasterData(cups
|
|
rgbRaster = NULL;
|
|
}
|
|
|
|
- imageProcessorDestroy(imageProcessor);
|
|
-
|
|
unlink(hpPreProcessedRasterFile);
|
|
return ret_status;
|
|
}
|