hplip/hplip-nocdmfilter.patch
2023-06-06 16:15:52 +02:00

48 lines
2.2 KiB
Diff

diff --git a/Makefile.am b/Makefile.am
index 751c265..a3be3f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -216,7 +216,7 @@ endif #HPLIP_CLASS_DRIVER
if FAX_BUILD
if !HPLIP_CLASS_DRIVER
faxdir = $(hplipdir)/fax
-dist_fax_DATA = fax/fax.py fax/__init__.py fax/coverpages.py fax/pmlfax.py fax/ledmfax.py fax/cdmfax.py fax/soapfax.py fax/ledmsoapfax.py fax/marvellfax.py \
+dist_fax_DATA = fax/fax.py fax/__init__.py fax/coverpages.py fax/pmlfax.py fax/ledmfax.py fax/soapfax.py fax/ledmsoapfax.py fax/marvellfax.py \
fax/faxdevice.py fax/filters/pstotiff fax/filters/pstotiff.convs fax/filters/pstotiff.types
fax_filtersdir = $(mimedir)
dist_fax_filters_DATA = fax/filters/pstotiff.convs fax/filters/pstotiff.types
@@ -228,7 +228,7 @@ if HPIJS_INSTALL
dist_hpijsfaxppd_DATA = fax/ppd/HP-Fax-hpijs.ppd.gz fax/ppd/HP-Fax2-hpijs.ppd.gz fax/ppd/HP-Fax3-hpijs.ppd.gz fax/ppd/HP-Fax4-hpijs.ppd.gz
endif # HPIJS_INSTALL
if HPCUPS_INSTALL
-dist_hpcupsfaxppd_DATA = fax/ppd/HP-Fax-hpcups.ppd.gz fax/ppd/HP-Fax2-hpcups.ppd.gz fax/ppd/HP-Fax3-hpcups.ppd.gz fax/ppd/HP-Fax4-hpcups.ppd.gz fax/ppd/HP-Fax-CDM-hpcups.ppd.gz
+dist_hpcupsfaxppd_DATA = fax/ppd/HP-Fax-hpcups.ppd.gz fax/ppd/HP-Fax2-hpcups.ppd.gz fax/ppd/HP-Fax3-hpcups.ppd.gz fax/ppd/HP-Fax4-hpcups.ppd.gz
endif # HPCUPS_INSTALL
endif # HPLIP_CLASS_DRIVER
endif # FAX_BUILD
@@ -613,12 +613,6 @@ hpcupsfax_PROGRAMS = hpcupsfax
hpcupsfax_SOURCES = prnt/hpijs/hpcupsfax.cpp prnt/hpijs/hpcupsfax.h common/utils.h common/utils.c
hpcupsfax_LDADD = libhpip.la -lcups -lcupsimage -ldl
-# hpcdmfax
-hpcdmfaxdir = $(cupsfilterdir)
-hpcdmfax_PROGRAMS = hpcdmfax
-hpcdmfax_SOURCES = fax/filters/cdmfax/hpcupscdmfax.cpp fax/filters/cdmfax/hpcupscdmfax.h fax/filters/cdmfax/jetlib.cpp fax/filters/cdmfax/jetlib.h
-hpcdmfax_LDADD = libhpip.la -lcups -lcupsimage -ldl -ljpeg
-
endif # HPLIP_CLASS_DRIVER
endif # FAX_BUILD
endif # HPCUPS ONLY
diff --git a/hplip.list.in b/hplip.list.in
index 909f41d..f2b5e47 100644
--- a/hplip.list.in
+++ b/hplip.list.in
@@ -94,7 +94,6 @@ f 0755 root root $cupsfilter/pstotiff fax/filters/pstotiff
%if !print_only_exclude
f 0755 root root $cupsfilter/hpcupsfax .libs/hpcupsfax
-f 0755 root root $cupsfilter/hpcdmfax .libs/hpcdmfax
%endif
%if foomatic-drv-install