1951922 - hp-systray doesn't support a valid --qt5 option
This commit is contained in:
parent
613fa6c3de
commit
fd0b4b17ec
14
hplip-systray-qt5.patch
Normal file
14
hplip-systray-qt5.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff --git a/base/module.py b/base/module.py
|
||||
index 04ac5b8..56be168 100644
|
||||
--- a/base/module.py
|
||||
+++ b/base/module.py
|
||||
@@ -301,6 +301,9 @@ class Module(object):
|
||||
if UI_TOOLKIT_QT4 in self.supported_ui_toolkits and UI_TOOLKIT_QT4 in self.installed_ui_toolkits:
|
||||
long_params.extend(['qt4', 'use-qt4'])
|
||||
|
||||
+ if UI_TOOLKIT_QT5 in self.supported_ui_toolkits and UI_TOOLKIT_QT5 in self.installed_ui_toolkits:
|
||||
+ long_params.extend(['qt5', 'use-qt5'])
|
||||
+
|
||||
if extra_params is not None:
|
||||
params = ''.join([params, extra_params])
|
||||
|
10
hplip.spec
10
hplip.spec
@ -7,7 +7,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.21.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -176,6 +176,9 @@ Patch60: hplip-fab-import.patch
|
||||
# it fails further down - break out earlier with a message
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/1916114
|
||||
Patch61: hplip-hpsetup-noscanjets.patch
|
||||
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1925480
|
||||
Patch62: hplip-systray-qt5.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui if you want to have GUI
|
||||
@ -469,6 +472,8 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
# if an user tries to install scanner via hp-setup (printer/fax utility)
|
||||
# it fails further down - break out earlier with a message
|
||||
%patch61 -p1 -b .hpsetup-noscanjets
|
||||
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
||||
%patch62 -p1 -b .systray-qt5
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui should be installed if you want GUI
|
||||
@ -817,6 +822,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Thu Apr 22 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-2
|
||||
- 1951922 - hp-systray doesn't support a valid --qt5 option
|
||||
|
||||
* Fri Feb 19 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-1
|
||||
- 1929977 - hplip-3.21.2 is available
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user