Merge branch 'f14' into f15
This commit is contained in:
commit
ef4ea0cef9
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.11.3a.tar.gz
|
||||
/hplip-3.11.5.tar.gz
|
||||
/hplip-3.11.7.tar.gz
|
||||
/hplip-3.11.10.tar.gz
|
||||
|
7
hplip-3.11.10.tar.gz.asc
Normal file
7
hplip-3.11.10.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk6H1w0ACgkQc9dwzaWQR7nTGwCfdrOZAl0nguWBYFpEgWh4Vm5l
|
||||
TIYAoJ/mlrUoMMeTnqZjTNs7NMyFu3lq
|
||||
=DGE1
|
||||
-----END PGP SIGNATURE-----
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk4sb9YACgkQc9dwzaWQR7l98wCfT9DH91wml2LcfPvsKq5BLSOp
|
||||
EW4AoI2tK03vh/o+Q3NOjKkIJ++a/NDB
|
||||
=vlbG
|
||||
-----END PGP SIGNATURE-----
|
@ -1,21 +0,0 @@
|
||||
diff -up hplip-3.11.7/prnt/hpijs/hpcupsfax.cpp.CVE-2011-2722 hplip-3.11.7/prnt/hpijs/hpcupsfax.cpp
|
||||
--- hplip-3.11.7/prnt/hpijs/hpcupsfax.cpp.CVE-2011-2722 2011-07-29 10:21:37.404874641 +0100
|
||||
+++ hplip-3.11.7/prnt/hpijs/hpcupsfax.cpp 2011-07-29 10:28:10.071298117 +0100
|
||||
@@ -625,8 +625,15 @@ int send_data_to_stdout(int fromFD)
|
||||
fp = NULL;
|
||||
if (iLogLevel & SAVE_PCL_FILE)
|
||||
{
|
||||
- fp = fopen ("/tmp/hpcupsfax.out", "w");
|
||||
- system ("chmod 666 /tmp/hpcupsfax.out");
|
||||
+ int fd;
|
||||
+
|
||||
+ unlink ("/tmp/hpcupsfax.out");
|
||||
+ fd = open ("/tmp/hpcupsfax.out", O_WRONLY | O_CREAT | O_EXCL,
|
||||
+ S_IRUSR | S_IWUSR | S_IRGRP);
|
||||
+ if (fd != -1)
|
||||
+ {
|
||||
+ fp = fdopen (fd, "w");
|
||||
+ }
|
||||
}
|
||||
|
||||
while ((len = read (fromFD, pTmp, iSize)) > 0)
|
@ -1,11 +0,0 @@
|
||||
diff -up hplip-3.11.5/prnt/hpps/hppsfilter.c.cups15 hplip-3.11.5/prnt/hpps/hppsfilter.c
|
||||
--- hplip-3.11.5/prnt/hpps/hppsfilter.c.cups15 2011-06-10 11:44:25.933781345 +0100
|
||||
+++ hplip-3.11.5/prnt/hpps/hppsfilter.c 2011-06-10 11:46:24.474510996 +0100
|
||||
@@ -38,6 +38,7 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <cups/cups.h>
|
||||
+#include <cups/ppd.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.11.7/prnt/hpcups/ModeJbig.cpp.hpcups-crash hplip-3.11.7/prnt/hpcups/ModeJbig.cpp
|
||||
--- hplip-3.11.7/prnt/hpcups/ModeJbig.cpp.hpcups-crash 2011-09-02 16:04:58.118437727 +0100
|
||||
+++ hplip-3.11.7/prnt/hpcups/ModeJbig.cpp 2011-09-02 16:06:27.625795462 +0100
|
||||
@@ -99,6 +99,8 @@ const BYTE ModeJbig::szByte2[256] =
|
||||
|
||||
ModeJbig::ModeJbig (unsigned int RasterSize) : Compressor (RasterSize, false)
|
||||
{
|
||||
+ m_hHPLibHandle = 0;
|
||||
+ m_pszInputRasterData = 0;
|
||||
m_iWidth = ((RasterSize + 31) / 32) * 4;
|
||||
m_iPlaneNumber = 0;
|
||||
m_iCurrentPlane = 0;
|
@ -1,25 +0,0 @@
|
||||
diff -up hplip-3.11.7/scan/sane/bb_ledm.c.sane-crash hplip-3.11.7/scan/sane/bb_ledm.c
|
||||
--- hplip-3.11.7/scan/sane/bb_ledm.c.sane-crash 2011-07-24 21:01:23.000000000 +0200
|
||||
+++ hplip-3.11.7/scan/sane/bb_ledm.c 2011-09-06 16:58:04.101315124 +0200
|
||||
@@ -808,10 +808,10 @@ int bb_start_scan(struct ledm_session *p
|
||||
len = snprintf(buf, sizeof(buf), CREATE_SCAN_JOB_REQUEST,
|
||||
ps->currentResolution,
|
||||
ps->currentResolution,
|
||||
- (int) (ps->currentTlx / 5548.7133 ),
|
||||
+ (int) (ps->currentTlx / 5548.7133),
|
||||
(int) (ps->currentTly / 5548.7133),
|
||||
- (int) (ps->currentBrx / 5548.7133),
|
||||
- (int) (ps->currentBry / 5548.7133),
|
||||
+ (int) ((ps->currentBrx / 5548.7133) - (ps->currentTlx / 5548.7133)),
|
||||
+ (int) ((ps->currentBry / 5548.7133) - (ps->currentTly / 5548.7133)),
|
||||
"Jpeg",
|
||||
(! strcmp(ce_element[ps->currentScanMode], "Color8")) ? "Color" : (! strcmp(ce_element[ps->currentScanMode], "Gray8")) ? "Gray" : "Gray",
|
||||
((! strcmp(ce_element[ps->currentScanMode], "Color8")) || (! strcmp(ce_element[ps->currentScanMode], "Gray8"))) ? 8: 8,
|
||||
@@ -844,6 +844,7 @@ int bb_start_scan(struct ledm_session *p
|
||||
|
||||
char joblist[64];
|
||||
char* jl=strstr(buf, "Location:");
|
||||
+ if (!jl) goto bugout;
|
||||
jl=jl+10;
|
||||
|
||||
int i=0;
|
113
hplip.spec
113
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.11.7
|
||||
Release: 5%{?dist}
|
||||
Version: 3.11.10
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -26,7 +26,6 @@ Patch9: hplip-snmp-quirks.patch
|
||||
Patch10: hplip-discovery-method.patch
|
||||
Patch11: hplip-hpijs-marker-supply.patch
|
||||
Patch12: hplip-clear-old-state-reasons.patch
|
||||
Patch13: hplip-hpcups-crash.patch
|
||||
Patch14: hplip-hpcups-sigpipe.patch
|
||||
Patch15: hplip-fax-ppd.patch
|
||||
Patch16: hplip-bad-low-ink-warning.patch
|
||||
@ -34,9 +33,7 @@ Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-no-system-tray.patch
|
||||
Patch21: hplip-cups15.patch
|
||||
Patch22: hplip-ppd-ImageableArea.patch
|
||||
Patch23: hplip-sane-crash.patch
|
||||
Patch25: hplip-raw_deviceID-traceback.patch
|
||||
Patch26: hplip-UnicodeDecodeError.patch
|
||||
Patch27: hplip-emit-SIGNAL.patch
|
||||
@ -49,9 +46,6 @@ Patch33: hplip-dbus-threads.patch
|
||||
Patch34: hplip-notification-exception.patch
|
||||
Patch35: hplip-CVE-2010-4267.patch
|
||||
Patch36: hplip-wifisetup.patch
|
||||
Patch37: hplip-CVE-2011-2722.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Requires(pre): /sbin/service
|
||||
Requires(post): /sbin/chkconfig
|
||||
@ -145,7 +139,6 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
SANE driver for scanners in HP's multi-function devices (from HPOJ).
|
||||
|
||||
%prep
|
||||
rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
%setup -q
|
||||
|
||||
# The pstotiff filter is rubbish so replace it (launchpad #528394).
|
||||
@ -161,21 +154,23 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
%patch4 -p1 -b .no-asm
|
||||
|
||||
# Corrected several IEEE 1284 Device IDs using foomatic data.
|
||||
# HP LaserJet P1007 (bug #585272).
|
||||
# HP LaserJet P1505 (bug #680951).
|
||||
# HP Color LaserJet CM1312nfi (bug #581005).
|
||||
# HP Color LaserJet 3800 (bug #581935).
|
||||
# HP Color LaserJet 2840 (bug #582215).
|
||||
# HP Color LaserJet CP1518ni (bug #613689).
|
||||
# HP Color LaserJet 2600n (bug #613712).
|
||||
# HP LaserJet 4050 Series/4100 Series/2100 Series/4350/5100 Series/8000 Series
|
||||
# P3005/P3010 Series/P4014/P4515 (bug #659039).
|
||||
# HP Color LaserJet 2500/3700/4550/4600/4650/4700/5550/CP1515n/CP2025n
|
||||
# CP3525/CP4520 Series/CM2320nf (bug #659040).
|
||||
# HP Color LaserJet CP2025dn (bug #651509).
|
||||
# HP Color LaserJet CM4730 MFP (bug #658831).
|
||||
# HP Color LaserJet CM3530 MFP (bug #659381).
|
||||
# HP LaserJet Professional P1606dn (bug #708472).
|
||||
# LaserJet P1007 (bug #585272)
|
||||
# LaserJet P1505 (bug #680951)
|
||||
# Color LaserJet CM1312nfi (bug #581005)
|
||||
# Color LaserJet 3800 (bug #581935)
|
||||
# Color LaserJet 2840 (bug #582215)
|
||||
# Color LaserJet CP1518ni (bug #613689)
|
||||
# Color LaserJet 2600n (bug #613712)
|
||||
# LaserJet 4050 Series/4100 Series/2100 Series/4350/5100 Series/8000 Series
|
||||
# P3005/P3010 Series/P4014/P4515 (bug #659039)
|
||||
# Color LaserJet 2500/3700/4550/4600/4650/4700/5550/CP1515n/CP2025n
|
||||
# CP3525/CP4520 Series/CM2320nf (bug #659040)
|
||||
# Color LaserJet CP2025dn (bug #651509)
|
||||
# Color LaserJet CM4730 MFP (bug #658831)
|
||||
# Color LaserJet CM3530 MFP (bug #659381)
|
||||
# LaserJet Professional P1606dn (bug #708472)
|
||||
# LaserJet Professional M1212nf MFP (bug #742490)
|
||||
# Officejet 6300 series (bug #689378)
|
||||
%patch5 -p1 -b .deviceIDs-drv
|
||||
chmod +x %{SOURCE2}
|
||||
mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
||||
@ -206,9 +201,6 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
||||
# Clear old printer-state-reasons we used to manage (bug #510926).
|
||||
%patch12 -p1 -b .clear-old-state-reasons
|
||||
|
||||
# Fixed hpcups crash when required plugin missing (bug #733461).
|
||||
%patch13 -p1 -b .hpcups-crash
|
||||
|
||||
# Avoid busy loop in hpcups when backend has exited (bug #525944).
|
||||
%patch14 -p1 -b .hpcups-sigpipe
|
||||
|
||||
@ -219,20 +211,20 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
||||
%patch16 -p1 -b .bad-low-ink-warning
|
||||
|
||||
# Add Device ID for
|
||||
# HP LaserJet 1200 (bug #577308)
|
||||
# HP LaserJet 1320 series (bug #579920)
|
||||
# HP LaserJet 2300 (bug #576928)
|
||||
# HP LaserJet P2015 Series (bug #580231)
|
||||
# HP LaserJet 4250 (bug #585499).
|
||||
# HP Color LaserJet 2605dn (bug #583953).
|
||||
# HP Color LaserJet 3800 (bug #581935).
|
||||
# HP Color LaserJet 2840 (bug #582215).
|
||||
# HP LaserJet 4050 Series/4100 Series/2100 Series/2420/4200/4300/4350/5100 Series
|
||||
# 8000 Series/M3027 MFP/M3035 MFP/P3005/P3010 Series (bug #659039).
|
||||
# HP Color LaserJet 2500/2550/2605dn/3700/4550/4600
|
||||
# 4650/4700/5550/CP3525 (bug #659040).
|
||||
# HP Color LaserJet CM4730 MFP (bug #658831).
|
||||
# HP Color LaserJet CM3530 MFP (bug #659381).
|
||||
# LaserJet 1200 (bug #577308)
|
||||
# LaserJet 1320 series (bug #579920)
|
||||
# LaserJet 2300 (bug #576928)
|
||||
# LaserJet P2015 Series (bug #580231)
|
||||
# LaserJet 4250 (bug #585499)
|
||||
# Color LaserJet 2605dn (bug #583953)
|
||||
# Color LaserJet 3800 (bug #581935)
|
||||
# Color LaserJet 2840 (bug #582215)
|
||||
# LaserJet 4050 Series/4100 Series/2100 Series/2420/4200/4300/4350/5100 Series
|
||||
# 8000 Series/M3027 MFP/M3035 MFP/P3005/P3010 Series (bug #659039)
|
||||
# Color LaserJet 2500/2550/2605dn/3700/4550/4600
|
||||
# 4650/4700/5550/CP3525 (bug #659040)
|
||||
# Color LaserJet CM4730 MFP (bug #658831)
|
||||
# Color LaserJet CM3530 MFP (bug #659381)
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
@ -252,9 +244,6 @@ done
|
||||
# Wait longer to see if a system tray becomes available (bug #569969).
|
||||
%patch20 -p1 -b .no-system-tray
|
||||
|
||||
# Fix building against CUPS 1.5.
|
||||
%patch21 -p1 -b .cups15
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
do
|
||||
@ -266,9 +255,6 @@ do
|
||||
gzip -n ${ppd_file#*/}
|
||||
done
|
||||
|
||||
# Fixed xsane crash when doing a multi-image scan (bug #725878)
|
||||
%patch23 -p1 -b .sane-crash
|
||||
|
||||
# Fixed traceback on error condition in device.py (bug #628125).
|
||||
%patch25 -p1 -b .raw_deviceID-traceback
|
||||
|
||||
@ -306,7 +292,6 @@ done
|
||||
|
||||
# Avoid KeyError in ui4/wifisetupdialog.py (bug #680939).
|
||||
%patch36 -p1 -b .wifisetup
|
||||
%patch37 -p1 -b .CVE-2011-2722
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -331,7 +316,6 @@ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
@ -382,15 +366,12 @@ rm -rf %{buildroot}%{_datadir}/hplip/install.*
|
||||
rm -f %{buildroot}%{_datadir}/hplip/hpijs.drv.in.template
|
||||
rm -f %{buildroot}%{_datadir}/cups/mime/pstotiff.types
|
||||
rm -f %{buildroot}%{_datadir}/hplip/fax/pstotiff*
|
||||
rm -f %{buildroot}/usr/lib/cups/filter/hpcac
|
||||
rm -f %{buildroot}%{_cups_serverbin}/filter/hpcac
|
||||
|
||||
# The systray applet doesn't work properly (displays icon as a
|
||||
# window), so don't ship the launcher yet.
|
||||
rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING doc/*
|
||||
@ -419,12 +400,10 @@ rm -rf %{buildroot}
|
||||
%{_bindir}/hp-timedate
|
||||
%{_bindir}/hp-unload
|
||||
%{_bindir}/hp-wificonfig
|
||||
# Note: this must be /usr/lib not %%{_libdir}, since that's the
|
||||
# CUPS serverbin directory.
|
||||
/usr/lib/cups/backend/hp
|
||||
/usr/lib/cups/backend/hpfax
|
||||
/usr/lib/cups/filter/pstotiff
|
||||
/usr/lib/cups/filter/hpps
|
||||
%{_cups_serverbin}/backend/hp
|
||||
%{_cups_serverbin}/backend/hpfax
|
||||
%{_cups_serverbin}/filter/pstotiff
|
||||
%{_cups_serverbin}/filter/hpps
|
||||
%{_datadir}/cups/mime/pstotiff.convs
|
||||
# Files
|
||||
%{_datadir}/hplip/align.py*
|
||||
@ -510,11 +489,9 @@ rm -rf %{buildroot}
|
||||
%dir %{_datadir}/ppd/HP
|
||||
%{_datadir}/ppd/HP/*.ppd.gz
|
||||
%{_datadir}/cups/drv/*
|
||||
# Note: this must be /usr/lib not %%{_libdir}, since that's the
|
||||
# CUPS serverbin directory.
|
||||
/usr/lib/cups/filter/hpcups
|
||||
/usr/lib/cups/filter/hpcupsfax
|
||||
/usr/lib/cups/filter/hplipjs
|
||||
%{_cups_serverbin}/filter/hpcups
|
||||
%{_cups_serverbin}/filter/hpcupsfax
|
||||
%{_cups_serverbin}/filter/hplipjs
|
||||
|
||||
%files -n libsane-hpaio
|
||||
%defattr(-,root,root)
|
||||
@ -542,6 +519,14 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Oct 04 2011 Jiri Popelka <jpopelka@redhat.com> 3.11.10-1
|
||||
- 3.11.10
|
||||
- Use _cups_serverbin macro from cups-devel for where to put driver executables.
|
||||
- No need to define BuildRoot and clean it in clean and install section anymore.
|
||||
- Corrected IEEE 1284 Device IDs:
|
||||
Officejet 6300 series (bug #689378)
|
||||
LaserJet Professional M1212nf MFP (bug #742490)
|
||||
|
||||
* Fri Sep 23 2011 Tim Waugh <twaugh@redhat.com> 3.11.7-5
|
||||
- Fixed broken patch for pstotiff.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user