3.12.11
This commit is contained in:
parent
fb67ace543
commit
e56d6f6466
1
.gitignore
vendored
1
.gitignore
vendored
@ -50,3 +50,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.12.9.tar.gz
|
||||
/hplip-3.12.10.tar.gz
|
||||
/hplip-3.12.10a.tar.gz
|
||||
/hplip-3.12.11.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlB1E4cACgkQc9dwzaWQR7m+UgCfQupDDON0Du6+BRtPdNBVS8fb
|
||||
BecAn36X7iBEmOWKe7XPgxT4c0QAm6Li
|
||||
=LzcJ
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.12.11.tar.gz.asc
Normal file
7
hplip-3.12.11.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlCrVGsACgkQc9dwzaWQR7lb0ACg3RMaZRdPeALex3ClAostXvF8
|
||||
McMAoO41OLwnkT7Mbl78GPh8kU/Y8Mfy
|
||||
=9ARz
|
||||
-----END PGP SIGNATURE-----
|
@ -1,23 +1,23 @@
|
||||
diff -up hplip-3.12.9/io/hpmud/musb.c.hplip-IEEE-1284-4 hplip-3.12.9/io/hpmud/musb.c
|
||||
--- hplip-3.12.9/io/hpmud/musb.c.hplip-IEEE-1284-4 2012-09-04 14:33:58.000000000 +0200
|
||||
+++ hplip-3.12.9/io/hpmud/musb.c 2012-09-20 10:11:53.759116729 +0200
|
||||
@@ -708,7 +708,8 @@ static libusb_device *get_libusb_device(
|
||||
{
|
||||
if ((altptr->bInterfaceClass == LIBUSB_CLASS_PRINTER ) && /* Printer */
|
||||
(altptr->bInterfaceSubClass == 1) &&
|
||||
- (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2)) /* Unidirectional or Bidirectional*/
|
||||
+ (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2
|
||||
+ || altptr->bInterfaceProtocol == 3)) /* Unidirectional, Bidirectional or 1284.4 */
|
||||
{
|
||||
if (is_uri(dev, uri))
|
||||
{
|
||||
@@ -2061,7 +2062,8 @@ int __attribute__ ((visibility ("hidden"
|
||||
{
|
||||
if ((altptr->bInterfaceClass == LIBUSB_CLASS_PRINTER ) && /* Printer */
|
||||
(altptr->bInterfaceSubClass == 1) &&
|
||||
- (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2)) /* Unidirectional or Bidirectional*/
|
||||
+ (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2
|
||||
+ || altptr->bInterfaceProtocol == 3)) /* Unidirectional, Bidirectional or 1284.4 */
|
||||
{
|
||||
libusb_open(dev, &hd);
|
||||
if (hd == NULL)
|
||||
diff -up hplip-3.12.11/io/hpmud/musb.c.hplip-IEEE-1284-4 hplip-3.12.11/io/hpmud/musb.c
|
||||
--- hplip-3.12.11/io/hpmud/musb.c.hplip-IEEE-1284-4 2012-11-20 10:55:09.000000000 +0100
|
||||
+++ hplip-3.12.11/io/hpmud/musb.c 2012-11-27 11:49:16.633107366 +0100
|
||||
@@ -712,7 +712,8 @@ static libusb_device *get_libusb_device(
|
||||
{
|
||||
if ((altptr->bInterfaceClass == LIBUSB_CLASS_PRINTER ) && /* Printer */
|
||||
(altptr->bInterfaceSubClass == 1) &&
|
||||
- (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2)) /* Unidirectional or Bidirectional*/
|
||||
+ (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2
|
||||
+ || altptr->bInterfaceProtocol == 3)) /* Unidirectional, Bidirectional or 1284.4 */
|
||||
{
|
||||
if (is_uri(dev, uri))
|
||||
{
|
||||
@@ -2065,7 +2066,8 @@ int __attribute__ ((visibility ("hidden"
|
||||
{
|
||||
if ((altptr->bInterfaceClass == LIBUSB_CLASS_PRINTER ) && /* Printer */
|
||||
(altptr->bInterfaceSubClass == 1) &&
|
||||
- (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2)) /* Unidirectional or Bidirectional*/
|
||||
+ (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2
|
||||
+ || altptr->bInterfaceProtocol == 3)) /* Unidirectional, Bidirectional or 1284.4 */
|
||||
{
|
||||
libusb_open(dev, &hd);
|
||||
if (hd == NULL)
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,6 +1,6 @@
|
||||
diff -up hplip-3.12.10a/fax/backend/hpfax.py.logdir hplip-3.12.10a/fax/backend/hpfax.py
|
||||
--- hplip-3.12.10a/fax/backend/hpfax.py.logdir 2012-10-17 09:56:43.979656073 +0100
|
||||
+++ hplip-3.12.10a/fax/backend/hpfax.py 2012-10-17 09:57:33.286890599 +0100
|
||||
diff -up hplip-3.12.11/fax/backend/hpfax.py.logdir hplip-3.12.11/fax/backend/hpfax.py
|
||||
--- hplip-3.12.11/fax/backend/hpfax.py.logdir 2012-11-20 10:55:06.000000000 +0100
|
||||
+++ hplip-3.12.11/fax/backend/hpfax.py 2012-11-27 10:09:25.298698254 +0100
|
||||
@@ -244,7 +244,7 @@ else:
|
||||
input_fd = 0
|
||||
|
||||
@ -10,9 +10,9 @@ diff -up hplip-3.12.10a/fax/backend/hpfax.py.logdir hplip-3.12.10a/fax/backend/h
|
||||
|
||||
|
||||
pipe_name = os.path.join(tmp_dir, "hpfax-pipe-%d" % job_id)
|
||||
diff -up hplip-3.12.10a/logcapture.py.logdir hplip-3.12.10a/logcapture.py
|
||||
--- hplip-3.12.10a/logcapture.py.logdir 2012-10-10 07:14:21.000000000 +0100
|
||||
+++ hplip-3.12.10a/logcapture.py 2012-10-17 09:56:29.396578082 +0100
|
||||
diff -up hplip-3.12.11/logcapture.py.logdir hplip-3.12.11/logcapture.py
|
||||
--- hplip-3.12.11/logcapture.py.logdir 2012-11-20 10:55:15.000000000 +0100
|
||||
+++ hplip-3.12.11/logcapture.py 2012-11-27 10:09:25.298698254 +0100
|
||||
@@ -39,7 +39,7 @@ CUPS_BACKUP_FILE='/etc/cups/cupsd.conf_o
|
||||
LOG_FOLDER_PATH='./'
|
||||
LOG_FOLDER_NAME='hplip_troubleshoot_logs'
|
||||
@ -31,9 +31,9 @@ diff -up hplip-3.12.10a/logcapture.py.logdir hplip-3.12.10a/logcapture.py
|
||||
if File_list:
|
||||
sts,out = utils.run('cp -f %s %s'%(File_list_str, LOG_FILES))
|
||||
if sts != 0:
|
||||
diff -up hplip-3.12.10a/prnt/filters/hplipjs.c.logdir hplip-3.12.10a/prnt/filters/hplipjs.c
|
||||
--- hplip-3.12.10a/prnt/filters/hplipjs.c.logdir 2012-10-17 09:58:20.298135510 +0100
|
||||
+++ hplip-3.12.10a/prnt/filters/hplipjs.c 2012-10-17 09:58:47.431276326 +0100
|
||||
diff -up hplip-3.12.11/prnt/filters/hplipjs.c.logdir hplip-3.12.11/prnt/filters/hplipjs.c
|
||||
--- hplip-3.12.11/prnt/filters/hplipjs.c.logdir 2012-11-20 10:50:44.000000000 +0100
|
||||
+++ hplip-3.12.11/prnt/filters/hplipjs.c 2012-11-27 10:09:25.299698225 +0100
|
||||
@@ -275,7 +275,8 @@ int main (int argc, char **argv)
|
||||
{
|
||||
fprintf (stderr, "DEBUG: HPLIPJS: argv[%d] = %s\n", i, argv[i]);
|
||||
@ -44,9 +44,9 @@ diff -up hplip-3.12.10a/prnt/filters/hplipjs.c.logdir hplip-3.12.10a/prnt/filter
|
||||
|
||||
HPFp = fopen (szPSFile, "w");
|
||||
#endif
|
||||
diff -up hplip-3.12.10a/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.12.10a/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.12.10a/prnt/hpcups/HPCupsFilter.cpp.logdir 2012-10-17 09:56:29.391578055 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpcups/HPCupsFilter.cpp 2012-10-17 09:56:29.397578087 +0100
|
||||
diff -up hplip-3.12.11/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.12.11/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.12.11/prnt/hpcups/HPCupsFilter.cpp.logdir 2012-11-27 10:09:25.291698453 +0100
|
||||
+++ hplip-3.12.11/prnt/hpcups/HPCupsFilter.cpp 2012-11-27 10:13:34.958640524 +0100
|
||||
@@ -31,16 +31,24 @@
|
||||
\*****************************************************************************/
|
||||
|
||||
@ -85,21 +85,34 @@ diff -up hplip-3.12.10a/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.12.10a/prnt/
|
||||
|
||||
|
||||
while (cupsRasterReadHeader2(cups_raster, &cups_header))
|
||||
@@ -647,9 +656,9 @@ int HPCupsFilter::processRasterData(cups
|
||||
@@ -647,13 +656,13 @@ int HPCupsFilter::processRasterData(cups
|
||||
|
||||
if (m_iLogLevel & SAVE_INPUT_RASTERS)
|
||||
{
|
||||
- char szFileName[64];
|
||||
+ char szFileName[PATH_MAX];
|
||||
memset(szFileName, 0, sizeof(szFileName));
|
||||
- snprintf (szFileName, sizeof(szFileName), "/var/log/hp/tmp/hpcupsfilterc_%d.bmp", current_page_number);
|
||||
+ snprintf (szFileName, sizeof(szFileName), "%s/hpcupsfilterc_%d.bmp", env_tmpdir, current_page_number);
|
||||
|
||||
if (cups_header.cupsColorSpace == CUPS_CSPACE_RGBW ||
|
||||
cups_header.cupsColorSpace == CUPS_CSPACE_RGB)
|
||||
diff -up hplip-3.12.10a/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.12.10a/prnt/hpcups/LJZjStream.cpp
|
||||
--- hplip-3.12.10a/prnt/hpcups/LJZjStream.cpp.logdir 2012-10-10 07:08:46.000000000 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpcups/LJZjStream.cpp 2012-10-17 09:56:29.397578087 +0100
|
||||
{
|
||||
- snprintf (szFileName, sizeof(szFileName), "/var/log/hp/tmp/hpcupsfilterc_%d.bmp", current_page_number);
|
||||
+ snprintf (szFileName, sizeof(szFileName), "%s/hpcupsfilterc_%d.bmp", env_tmpdir, current_page_number);
|
||||
cfp = fopen (szFileName, "w");
|
||||
chmod (szFileName, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||
}
|
||||
@@ -661,7 +670,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
if (cups_header.cupsColorSpace == CUPS_CSPACE_RGBW ||
|
||||
cups_header.cupsColorSpace == CUPS_CSPACE_K)
|
||||
{
|
||||
- snprintf (szFileName, sizeof(szFileName), "/var/log/hp/tmp/hpcupsfilterk_%d.bmp", current_page_number);
|
||||
+ snprintf (szFileName, sizeof(szFileName), "%s/hpcupsfilterk_%d.bmp", env_tmpdir, current_page_number);
|
||||
kfp = fopen (szFileName, "w");
|
||||
chmod (szFileName, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||
}
|
||||
diff -up hplip-3.12.11/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.12.11/prnt/hpcups/LJZjStream.cpp
|
||||
--- hplip-3.12.11/prnt/hpcups/LJZjStream.cpp.logdir 2012-11-20 10:49:20.000000000 +0100
|
||||
+++ hplip-3.12.11/prnt/hpcups/LJZjStream.cpp 2012-11-27 10:16:24.878547224 +0100
|
||||
@@ -42,9 +42,12 @@
|
||||
#include "LJZjStream.h"
|
||||
#include "Utils.h"
|
||||
@ -117,20 +130,20 @@ diff -up hplip-3.12.10a/prnt/hpcups/LJZjStream.cpp.logdir hplip-3.12.10a/prnt/hp
|
||||
cups_raster_t *even_pages_raster=NULL;
|
||||
cups_raster_t *odd_pages_raster = NULL;
|
||||
BYTE* pPageDataBuffer = NULL;
|
||||
- char hpEvenPagesFile[64];
|
||||
- char hpOddPagesFile[64];
|
||||
- char hpEvenPagesFile[64]={0,};
|
||||
- char hpOddPagesFile[64]={0,};
|
||||
- snprintf(hpEvenPagesFile, sizeof(hpEvenPagesFile), "%s/hplipEvenPagesXXXXXX","/var/log/hp/tmp");
|
||||
- snprintf(hpOddPagesFile, sizeof(hpOddPagesFile), "%s/hplipOddPagesXXXXXX", "/var/log/hp/tmp");
|
||||
+ char hpEvenPagesFile[PATH_MAX];
|
||||
+ char hpOddPagesFile[PATH_MAX];
|
||||
+ snprintf(hpEvenPagesFile, sizeof(hpEvenPagesFile), "%s/hplipEvenPagesXXXXXX",env_tmpdir);
|
||||
+ char hpEvenPagesFile[PATH_MAX]={0,};
|
||||
+ char hpOddPagesFile[PATH_MAX]={0,};
|
||||
+ snprintf(hpEvenPagesFile, sizeof(hpEvenPagesFile), "%s/hplipEvenPagesXXXXXX", env_tmpdir);
|
||||
+ snprintf(hpOddPagesFile, sizeof(hpOddPagesFile), "%s/hplipOddPagesXXXXXX", env_tmpdir);
|
||||
|
||||
if (1 != m_pJA->pre_process_raster || !cups_header.Duplex){
|
||||
if (1 != m_pJA->pre_process_raster || !firstpage_cups_header->Duplex){
|
||||
return NO_ERROR;
|
||||
diff -up hplip-3.12.10a/prnt/hpcups/SystemServices.cpp.logdir hplip-3.12.10a/prnt/hpcups/SystemServices.cpp
|
||||
--- hplip-3.12.10a/prnt/hpcups/SystemServices.cpp.logdir 2012-10-10 07:08:46.000000000 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpcups/SystemServices.cpp 2012-10-17 09:56:29.397578087 +0100
|
||||
diff -up hplip-3.12.11/prnt/hpcups/SystemServices.cpp.logdir hplip-3.12.11/prnt/hpcups/SystemServices.cpp
|
||||
--- hplip-3.12.11/prnt/hpcups/SystemServices.cpp.logdir 2012-11-20 10:49:20.000000000 +0100
|
||||
+++ hplip-3.12.11/prnt/hpcups/SystemServices.cpp 2012-11-27 10:09:25.300698197 +0100
|
||||
@@ -30,14 +30,17 @@
|
||||
|
||||
#include "CommonDefinitions.h"
|
||||
@ -151,9 +164,9 @@ diff -up hplip-3.12.10a/prnt/hpcups/SystemServices.cpp.logdir hplip-3.12.10a/prn
|
||||
m_fp = fopen(fname, "w");
|
||||
chmod(fname, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||
}
|
||||
diff -up hplip-3.12.10a/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.12.10a/prnt/hpijs/hpcupsfax.cpp
|
||||
--- hplip-3.12.10a/prnt/hpijs/hpcupsfax.cpp.logdir 2012-10-10 07:08:50.000000000 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpijs/hpcupsfax.cpp 2012-10-17 09:56:29.397578087 +0100
|
||||
diff -up hplip-3.12.11/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.12.11/prnt/hpijs/hpcupsfax.cpp
|
||||
--- hplip-3.12.11/prnt/hpijs/hpcupsfax.cpp.logdir 2012-11-20 10:50:48.000000000 +0100
|
||||
+++ hplip-3.12.11/prnt/hpijs/hpcupsfax.cpp 2012-11-27 10:09:25.300698197 +0100
|
||||
@@ -29,6 +29,7 @@
|
||||
POSSIBILITY OF SUCH DAMAGE.
|
||||
\*****************************************************************************/
|
||||
@ -202,9 +215,9 @@ diff -up hplip-3.12.10a/prnt/hpijs/hpcupsfax.cpp.logdir hplip-3.12.10a/prnt/hpij
|
||||
|
||||
fdFax = mkstemp (hpFileName);
|
||||
if (fdFax < 0)
|
||||
diff -up hplip-3.12.10a/prnt/hpijs/hpijs.cpp.logdir hplip-3.12.10a/prnt/hpijs/hpijs.cpp
|
||||
--- hplip-3.12.10a/prnt/hpijs/hpijs.cpp.logdir 2012-10-17 09:56:29.390578050 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpijs/hpijs.cpp 2012-10-17 09:56:29.398578093 +0100
|
||||
diff -up hplip-3.12.11/prnt/hpijs/hpijs.cpp.logdir hplip-3.12.11/prnt/hpijs/hpijs.cpp
|
||||
--- hplip-3.12.11/prnt/hpijs/hpijs.cpp.logdir 2012-11-27 10:09:25.288698537 +0100
|
||||
+++ hplip-3.12.11/prnt/hpijs/hpijs.cpp 2012-11-27 10:09:25.301698169 +0100
|
||||
@@ -29,6 +29,7 @@
|
||||
POSSIBILITY OF SUCH DAMAGE.
|
||||
\*****************************************************************************/
|
||||
@ -255,9 +268,9 @@ diff -up hplip-3.12.10a/prnt/hpijs/hpijs.cpp.logdir hplip-3.12.10a/prnt/hpijs/hp
|
||||
if ((pSS->InitScript(szCapOutFile, TRUE)) != NO_ERROR)
|
||||
BUG("unable to init capture");
|
||||
#endif
|
||||
diff -up hplip-3.12.10a/prnt/hpijs/hpijsfax.cpp.logdir hplip-3.12.10a/prnt/hpijs/hpijsfax.cpp
|
||||
--- hplip-3.12.10a/prnt/hpijs/hpijsfax.cpp.logdir 2012-10-10 07:08:50.000000000 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpijs/hpijsfax.cpp 2012-10-17 09:56:29.398578093 +0100
|
||||
diff -up hplip-3.12.11/prnt/hpijs/hpijsfax.cpp.logdir hplip-3.12.11/prnt/hpijs/hpijsfax.cpp
|
||||
--- hplip-3.12.11/prnt/hpijs/hpijsfax.cpp.logdir 2012-11-20 10:50:48.000000000 +0100
|
||||
+++ hplip-3.12.11/prnt/hpijs/hpijsfax.cpp 2012-11-27 10:09:25.301698169 +0100
|
||||
@@ -31,6 +31,7 @@
|
||||
|
||||
#ifdef HAVE_LIBHPIP
|
||||
@ -284,44 +297,3 @@ diff -up hplip-3.12.10a/prnt/hpijs/hpijsfax.cpp.logdir hplip-3.12.10a/prnt/hpijs
|
||||
|
||||
|
||||
pFaxStruct = new HPIJSFax ();
|
||||
diff -up hplip-3.12.10a/prnt/hpps/hppsfilter.c.logdir hplip-3.12.10a/prnt/hpps/hppsfilter.c
|
||||
--- hplip-3.12.10a/prnt/hpps/hppsfilter.c.logdir 2012-10-17 10:00:07.937687485 +0100
|
||||
+++ hplip-3.12.10a/prnt/hpps/hppsfilter.c 2012-10-17 10:02:28.968378061 +0100
|
||||
@@ -48,13 +48,14 @@
|
||||
#define BOD_PJL "@PJL DMINFO ASCIIHEX=\"%s%s\"\012"
|
||||
#define BOD_DATETIME_FORMAT "%04d%02d%02d%02d%02d%02d"
|
||||
#define DBG_PSFILE "hpps_job"
|
||||
-#define DBG_TMP_FOLDER "/var/log/hp/tmp/"
|
||||
|
||||
#define LINE_SIZE 258
|
||||
#define FILE_NAME_SIZE 128
|
||||
|
||||
#define SAVE_PS_FILE 2
|
||||
|
||||
+static char *env_tmpdir;
|
||||
+
|
||||
/* save final output ps file: in cupsd.conf file value #hpLogLevel 15 */
|
||||
static int g_savepsfile = 0;
|
||||
|
||||
@@ -94,7 +95,7 @@ void open_dbg_outfile(char* szjob_id)
|
||||
if (g_savepsfile & SAVE_PS_FILE)
|
||||
{
|
||||
char sfile_name[FILE_NAME_SIZE] = {0};
|
||||
- sprintf(sfile_name, "%s/%s_%d.out",DBG_TMP_FOLDER,DBG_PSFILE, szjob_id);
|
||||
+ sprintf(sfile_name, "%s/%s_%d.out",env_tmpdir,DBG_PSFILE, szjob_id);
|
||||
g_fp_outdbgps= fopen(sfile_name, "w");
|
||||
chmod(sfile_name, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||
}
|
||||
@@ -163,7 +164,11 @@ int main (int argc, char **argv)
|
||||
{
|
||||
cups_file_t *fp_input = NULL; /* input file: stdin or physical file */
|
||||
char line[LINE_SIZE] = {0};
|
||||
-
|
||||
+
|
||||
+ env_tmpdir = getenv ("TMPDIR");
|
||||
+ if (!env_tmpdir)
|
||||
+ env_tmpdir = "/var/log/hp/tmp/";
|
||||
+
|
||||
get_LogLevel();
|
||||
setbuf (stderr, NULL);
|
||||
fprintf (stderr, "HP PS filter starting : %s \n", *argv);
|
||||
|
@ -1,26 +1,26 @@
|
||||
diff -up hplip-3.12.9/Makefile.in.chgrp hplip-3.12.9/Makefile.in
|
||||
--- hplip-3.12.9/Makefile.in.chgrp 2012-09-07 14:35:14.334691556 +0200
|
||||
+++ hplip-3.12.9/Makefile.in 2012-09-07 14:36:02.974988844 +0200
|
||||
@@ -8841,18 +8841,18 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
diff -up hplip-3.12.11/Makefile.in.chgrp hplip-3.12.11/Makefile.in
|
||||
--- hplip-3.12.11/Makefile.in.chgrp 2012-11-27 11:40:02.000000000 +0100
|
||||
+++ hplip-3.12.11/Makefile.in 2012-11-27 11:43:13.857379531 +0100
|
||||
@@ -8866,18 +8866,18 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
|
||||
install-dist_hplip_LogDATA:
|
||||
@FULL_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
-@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
+#@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
@FULL_BUILD_TRUE@ chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
@FULL_BUILD_TRUE@ chmod 777 $(DESTDIR)$(hplip_Logdir)
|
||||
@HPLIP_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
-@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
+#@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
@HPLIP_BUILD_TRUE@ chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
@HPLIP_BUILD_TRUE@ chmod 777 $(DESTDIR)$(hplip_Logdir)
|
||||
|
||||
install-dist_hplip_tmpDATA:
|
||||
@FULL_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
|
||||
-@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
|
||||
+#@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
|
||||
@FULL_BUILD_TRUE@ chmod 1774 $(DESTDIR)$(hplip_tmpdir)
|
||||
@FULL_BUILD_TRUE@ chmod 1777 $(DESTDIR)$(hplip_tmpdir)
|
||||
@HPLIP_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_tmpdir)" || mkdir -p $(DESTDIR)$(hplip_tmpdir)
|
||||
-@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
|
||||
+#@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_tmpdir)
|
||||
@HPLIP_BUILD_TRUE@ chmod 1774 $(DESTDIR)$(hplip_tmpdir)
|
||||
@HPLIP_BUILD_TRUE@ chmod 1777 $(DESTDIR)$(hplip_tmpdir)
|
||||
|
||||
install-dist_cronDATA:$(dist_cron_DATA)
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.12.2/io/hpmud/pp.c.release-parport hplip-3.12.2/io/hpmud/pp.c
|
||||
--- hplip-3.12.2/io/hpmud/pp.c.release-parport 2012-02-01 11:53:52.000000000 +0000
|
||||
+++ hplip-3.12.2/io/hpmud/pp.c 2012-03-21 16:43:31.876908024 +0000
|
||||
@@ -1240,6 +1240,8 @@ int __attribute__ ((visibility ("hidden"
|
||||
if (ma.support != HPMUD_SUPPORT_TYPE_HPLIP)
|
||||
{
|
||||
BUG("ignoring %s support=%d\n", dev, ma.support);
|
||||
+ release_pp(fd);
|
||||
+ close(fd);
|
||||
continue; /* ignor, not supported */
|
||||
}
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up hplip-3.12.6/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.12.6/prnt/drv/hpcups.drv.in
|
||||
--- hplip-3.12.6/prnt/drv/hpcups.drv.in.snmp-quirks 2012-06-19 10:58:26.121167716 +0200
|
||||
+++ hplip-3.12.6/prnt/drv/hpcups.drv.in 2012-06-19 10:59:16.880473528 +0200
|
||||
@@ -6653,6 +6653,8 @@ Manufacturer "HP"
|
||||
diff -up hplip-3.12.11/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.12.11/prnt/drv/hpcups.drv.in
|
||||
--- hplip-3.12.11/prnt/drv/hpcups.drv.in.snmp-quirks 2012-11-27 10:08:06.958516241 +0100
|
||||
+++ hplip-3.12.11/prnt/drv/hpcups.drv.in 2012-11-27 10:08:07.120513919 +0100
|
||||
@@ -6713,6 +6713,8 @@ Manufacturer "HP"
|
||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909a, $Version"
|
||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909a"
|
||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909a;DES:officejet pro 8500 a909a;"
|
||||
@ -10,7 +10,7 @@ diff -up hplip-3.12.6/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.12.6/prnt/drv/h
|
||||
PCFileName "hp-officejet_pro_8500_a909a.ppd"
|
||||
Attribute "Product" "" "(HP Officejet Pro 8500 All-in-one Printer - a909a)"
|
||||
}
|
||||
@@ -6669,6 +6671,8 @@ Manufacturer "HP"
|
||||
@@ -6729,6 +6731,8 @@ Manufacturer "HP"
|
||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909g, $Version"
|
||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909g"
|
||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909g;DES:officejet pro 8500 a909g;"
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up hplip-3.11.10/ui4/systemtray.py.dbus-exception hplip-3.11.10/ui4/systemtray.py
|
||||
--- hplip-3.11.10/ui4/systemtray.py.dbus-exception 2011-10-25 15:59:53.360181865 +0100
|
||||
+++ hplip-3.11.10/ui4/systemtray.py 2011-10-25 16:03:55.294815114 +0100
|
||||
@@ -707,7 +707,13 @@ def run(read_pipe):
|
||||
diff -up hplip-3.12.11/ui4/systemtray.py.systray-dbus-exception hplip-3.12.11/ui4/systemtray.py
|
||||
--- hplip-3.12.11/ui4/systemtray.py.systray-dbus-exception 2012-11-20 10:51:40.000000000 +0100
|
||||
+++ hplip-3.12.11/ui4/systemtray.py 2012-11-27 10:08:51.333805871 +0100
|
||||
@@ -802,7 +802,13 @@ def run(read_pipe):
|
||||
log.set_module("hp-systray(qt4)")
|
||||
log.debug("PID=%d" % os.getpid())
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up hplip-3.12.6/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.6/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.12.6/data/rules/56-hpmud_support.rules.udev-rules 2012-06-18 12:43:22.000000000 +0200
|
||||
+++ hplip-3.12.6/data/rules/56-hpmud_support.rules 2012-06-19 10:56:21.451872702 +0200
|
||||
diff -up hplip-3.12.11/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.11/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.12.11/data/rules/56-hpmud_support.rules.udev-rules 2012-11-20 10:53:51.000000000 +0100
|
||||
+++ hplip-3.12.11/data/rules/56-hpmud_support.rules 2012-11-27 10:07:00.377519016 +0100
|
||||
@@ -6,6 +6,7 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
|
||||
LABEL="pid_test"
|
||||
@ -9,10 +9,10 @@ diff -up hplip-3.12.6/data/rules/56-hpmud_support.rules.udev-rules hplip-3.12.6/
|
||||
# Check for LaserJet products (0x03f0xx17).
|
||||
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attrs{product}", ENV{hp_test}="yes"
|
||||
# Check for LaserJet products (0x03f0xx2a).
|
||||
diff -up hplip-3.12.6/Makefile.in.udev-rules hplip-3.12.6/Makefile.in
|
||||
--- hplip-3.12.6/Makefile.in.udev-rules 2012-06-18 12:44:46.000000000 +0200
|
||||
+++ hplip-3.12.6/Makefile.in 2012-06-19 10:57:37.812828378 +0200
|
||||
@@ -4274,7 +4274,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
diff -up hplip-3.12.11/Makefile.in.udev-rules hplip-3.12.11/Makefile.in
|
||||
--- hplip-3.12.11/Makefile.in.udev-rules 2012-11-20 10:55:50.000000000 +0100
|
||||
+++ hplip-3.12.11/Makefile.in 2012-11-27 10:07:00.380518971 +0100
|
||||
@@ -4353,7 +4353,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
@HPLIP_BUILD_TRUE@dist_cron_DATA = data/rules/hplip_cron
|
||||
|
||||
# hpmud.rules
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up hplip-3.9.6b/base/utils.py.ui-optional hplip-3.9.6b/base/utils.py
|
||||
--- hplip-3.9.6b/base/utils.py.ui-optional 2009-06-25 20:05:53.000000000 +0100
|
||||
+++ hplip-3.9.6b/base/utils.py 2009-07-28 10:10:57.984991878 +0100
|
||||
@@ -597,6 +597,13 @@ def checkPyQtImport(): # qt3
|
||||
diff -up hplip-3.12.11/base/utils.py.ui-optional hplip-3.12.11/base/utils.py
|
||||
--- hplip-3.12.11/base/utils.py.ui-optional 2012-11-20 10:55:15.000000000 +0100
|
||||
+++ hplip-3.12.11/base/utils.py 2012-11-27 10:03:21.909512264 +0100
|
||||
@@ -667,6 +667,13 @@ def checkPyQtImport(): # qt3
|
||||
if os.getenv('DISPLAY') and os.getenv('STARTED_FROM_MENU'):
|
||||
no_qt_message_gtk()
|
||||
|
||||
@ -15,7 +15,7 @@ diff -up hplip-3.9.6b/base/utils.py.ui-optional hplip-3.9.6b/base/utils.py
|
||||
log.error("PyQt not installed. GUI not available. Exiting.")
|
||||
return False
|
||||
|
||||
@@ -642,7 +649,10 @@ def checkPyQtImport(): # qt3
|
||||
@@ -712,7 +719,10 @@ def checkPyQtImport(): # qt3
|
||||
def checkPyQtImport4():
|
||||
try:
|
||||
import PyQt4
|
||||
|
18
hplip.spec
18
hplip.spec
@ -1,14 +1,12 @@
|
||||
%global posttag a
|
||||
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.12.10
|
||||
Release: 4.%{posttag}%{?dist}
|
||||
Version: 3.12.11
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
|
||||
Url: http://hplip.sourceforge.net/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/hplip/hplip-%{version}%{posttag}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/hplip/hplip-%{version}.tar.gz
|
||||
Source1: hpcups-update-ppds.sh
|
||||
Source2: copy-deviceids.py
|
||||
Patch1: hplip-pstotiff-is-rubbish.patch
|
||||
@ -30,7 +28,6 @@ Patch16: hplip-bad-low-ink-warning.patch
|
||||
Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-release-parport.patch
|
||||
Patch21: hplip-ppd-ImageableArea.patch
|
||||
Patch22: hplip-raw_deviceID-traceback.patch
|
||||
Patch23: hplip-UnicodeDecodeError.patch
|
||||
@ -138,7 +135,7 @@ Requires: %{name}-libs = %{version}-%{release}
|
||||
SANE driver for scanners in HP's multi-function devices (from HPOJ).
|
||||
|
||||
%prep
|
||||
%setup -q -n hplip-%{version}%{posttag}
|
||||
%setup -q
|
||||
|
||||
# The pstotiff filter is rubbish so replace it (launchpad #528394).
|
||||
%patch1 -p1 -b .pstotiff-is-rubbish
|
||||
@ -251,9 +248,6 @@ done
|
||||
# Added missing newline to string argument in dbglog() call (bug #585275).
|
||||
%patch19 -p1 -b .dbglog-newline
|
||||
|
||||
# Release parport if unsupported model connected (bug #699052).
|
||||
%patch20 -p1 -b .release-parport
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
do
|
||||
@ -526,6 +520,10 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Nov 27 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.11-1
|
||||
- 3.12.11
|
||||
-- release-parport.patch merged upstream
|
||||
|
||||
* Wed Oct 17 2012 Tim Waugh <twaugh@redhat.com> 3.12.10-4.a
|
||||
- Some more CUPS filters using the wrong temporary directory
|
||||
(bug #865603).
|
||||
|
Loading…
Reference in New Issue
Block a user