hp-check traceback due change in python-pillow
This commit is contained in:
parent
126f45009b
commit
bea4fa9d30
13
hplip-pillow-version.patch
Normal file
13
hplip-pillow-version.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/installer/dcheck.py b/installer/dcheck.py
|
||||
index 38bb76c..3d0624e 100644
|
||||
--- a/installer/dcheck.py
|
||||
+++ b/installer/dcheck.py
|
||||
@@ -370,7 +370,7 @@ def get_pil_version():
|
||||
except ImportError:
|
||||
return '-'
|
||||
else:
|
||||
- return Image.VERSION
|
||||
+ return Image.PILLOW_VERSION
|
||||
|
||||
def get_libpthread_version():
|
||||
try:
|
10
hplip.spec
10
hplip.spec
@ -7,7 +7,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.19.8
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -124,6 +124,10 @@ Patch51: hplip-dist-removed.patch
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1843592
|
||||
# bugzillas 1742949, 1740132, 1739855
|
||||
Patch52: hplip-missing-drivers.patch
|
||||
# hp-check tracebacks due change in python-pillow - PIL.Image.VERSION is removed,
|
||||
# so now it uses PIL.Image.PILLOW_VERSION
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1846218
|
||||
Patch53: hplip-pillow-version.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: python3-pillow
|
||||
@ -380,6 +384,7 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
%patch51 -p1 -b .dist-removed
|
||||
# 1742949, 1740132, 1739855 - missing drivers
|
||||
%patch52 -p1 -b .missing-drivers
|
||||
%patch53 -p1 -b .pillow-version
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -686,6 +691,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Tue Oct 01 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.8-2
|
||||
- hp-check traceback due change in python-pillow
|
||||
|
||||
* Tue Oct 01 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.8-1
|
||||
- 3.19.8
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user