1963114 - patch for hplip firmware load timeout fix
This commit is contained in:
parent
17cee5bcf6
commit
b7addb99c0
23
hplip-hpfirmware-timeout.patch
Normal file
23
hplip-hpfirmware-timeout.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff --git a/config_usb_printer.py b/config_usb_printer.py
|
||||||
|
index 946a2d4..fdab79d 100755
|
||||||
|
--- a/config_usb_printer.py
|
||||||
|
+++ b/config_usb_printer.py
|
||||||
|
@@ -28,6 +28,7 @@ __doc__ = "Udev invokes this tool. Tool detects the plugin, Smart Install (C/DVD
|
||||||
|
# Std Lib
|
||||||
|
import sys
|
||||||
|
import os
|
||||||
|
+import time
|
||||||
|
|
||||||
|
# Local
|
||||||
|
from base.g import *
|
||||||
|
@@ -181,8 +182,9 @@ try:
|
||||||
|
# ******************************* RUNNING FIRMWARE DOWNLOAD TO DEVICE FOR SUPPORTED PRINTER'S
|
||||||
|
fw_download_req = mq.get('fw-download', False)
|
||||||
|
if fw_download_req:
|
||||||
|
- fw_cmd = "hp-firmware -y3 -s %s"%param
|
||||||
|
+ fw_cmd = "hp-firmware -n -y3 -s %s"%param
|
||||||
|
log.info(fw_cmd)
|
||||||
|
+ time.sleep(5)
|
||||||
|
fw_sts, fw_out = utils.run(fw_cmd)
|
||||||
|
if fw_sts == 0:
|
||||||
|
log.debug("Firmware downloaded to %s "%device_uri)
|
10
hplip.spec
10
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.21.2
|
Version: 3.21.2
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -190,6 +190,9 @@ Patch61: hplip-hpsetup-noscanjets.patch
|
|||||||
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
||||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1925480
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1925480
|
||||||
Patch62: hplip-systray-qt5.patch
|
Patch62: hplip-systray-qt5.patch
|
||||||
|
# 1963114 - patch for hplip firmware load timeout fix
|
||||||
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1922404
|
||||||
|
Patch63: hplip-hpfirmware-timeout.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -483,6 +486,8 @@ done
|
|||||||
%patch61 -p1 -b .hpsetup-noscanjets
|
%patch61 -p1 -b .hpsetup-noscanjets
|
||||||
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
# 1951922 - hp-systray doesn't support a valid --qt5 option
|
||||||
%patch62 -p1 -b .systray-qt5
|
%patch62 -p1 -b .systray-qt5
|
||||||
|
# 1963114 - patch for hplip firmware load timeout fix
|
||||||
|
%patch63 -p1 -b .hpfirmware-timeout
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui should be installed if you want GUI
|
# mention hplip-gui should be installed if you want GUI
|
||||||
@ -831,6 +836,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 11 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-6
|
||||||
|
- 1963114 - patch for hplip firmware load timeout fix
|
||||||
|
|
||||||
* Wed Jun 09 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-5
|
* Wed Jun 09 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-5
|
||||||
- track hplip-repack.sh as source, to have it in srpm
|
- track hplip-repack.sh as source, to have it in srpm
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user