Merge #12 Rebase to 3.23.8
This commit is contained in:
commit
b7a8b0b5a8
1
.gitignore
vendored
1
.gitignore
vendored
@ -110,3 +110,4 @@ hplip-3.10.6.tar.gz
|
|||||||
/hplip-3.22.10-repack.tar.gz
|
/hplip-3.22.10-repack.tar.gz
|
||||||
/hplip-3.23.3-repack.tar.gz
|
/hplip-3.23.3-repack.tar.gz
|
||||||
/hplip-3.23.5-repack.tar.gz
|
/hplip-3.23.5-repack.tar.gz
|
||||||
|
/hplip-3.23.8-repack.tar.gz
|
||||||
|
@ -1,47 +0,0 @@
|
|||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index 751c265..a3be3f1 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -216,7 +216,7 @@ endif #HPLIP_CLASS_DRIVER
|
|
||||||
if FAX_BUILD
|
|
||||||
if !HPLIP_CLASS_DRIVER
|
|
||||||
faxdir = $(hplipdir)/fax
|
|
||||||
-dist_fax_DATA = fax/fax.py fax/__init__.py fax/coverpages.py fax/pmlfax.py fax/ledmfax.py fax/cdmfax.py fax/soapfax.py fax/ledmsoapfax.py fax/marvellfax.py \
|
|
||||||
+dist_fax_DATA = fax/fax.py fax/__init__.py fax/coverpages.py fax/pmlfax.py fax/ledmfax.py fax/soapfax.py fax/ledmsoapfax.py fax/marvellfax.py \
|
|
||||||
fax/faxdevice.py fax/filters/pstotiff fax/filters/pstotiff.convs fax/filters/pstotiff.types
|
|
||||||
fax_filtersdir = $(mimedir)
|
|
||||||
dist_fax_filters_DATA = fax/filters/pstotiff.convs fax/filters/pstotiff.types
|
|
||||||
@@ -228,7 +228,7 @@ if HPIJS_INSTALL
|
|
||||||
dist_hpijsfaxppd_DATA = fax/ppd/HP-Fax-hpijs.ppd.gz fax/ppd/HP-Fax2-hpijs.ppd.gz fax/ppd/HP-Fax3-hpijs.ppd.gz fax/ppd/HP-Fax4-hpijs.ppd.gz
|
|
||||||
endif # HPIJS_INSTALL
|
|
||||||
if HPCUPS_INSTALL
|
|
||||||
-dist_hpcupsfaxppd_DATA = fax/ppd/HP-Fax-hpcups.ppd.gz fax/ppd/HP-Fax2-hpcups.ppd.gz fax/ppd/HP-Fax3-hpcups.ppd.gz fax/ppd/HP-Fax4-hpcups.ppd.gz fax/ppd/HP-Fax-CDM-hpcups.ppd.gz
|
|
||||||
+dist_hpcupsfaxppd_DATA = fax/ppd/HP-Fax-hpcups.ppd.gz fax/ppd/HP-Fax2-hpcups.ppd.gz fax/ppd/HP-Fax3-hpcups.ppd.gz fax/ppd/HP-Fax4-hpcups.ppd.gz
|
|
||||||
endif # HPCUPS_INSTALL
|
|
||||||
endif # HPLIP_CLASS_DRIVER
|
|
||||||
endif # FAX_BUILD
|
|
||||||
@@ -613,12 +613,6 @@ hpcupsfax_PROGRAMS = hpcupsfax
|
|
||||||
hpcupsfax_SOURCES = prnt/hpijs/hpcupsfax.cpp prnt/hpijs/hpcupsfax.h common/utils.h common/utils.c
|
|
||||||
hpcupsfax_LDADD = libhpip.la -lcups -lcupsimage -ldl
|
|
||||||
|
|
||||||
-# hpcdmfax
|
|
||||||
-hpcdmfaxdir = $(cupsfilterdir)
|
|
||||||
-hpcdmfax_PROGRAMS = hpcdmfax
|
|
||||||
-hpcdmfax_SOURCES = fax/filters/cdmfax/hpcupscdmfax.cpp fax/filters/cdmfax/hpcupscdmfax.h fax/filters/cdmfax/jetlib.cpp fax/filters/cdmfax/jetlib.h
|
|
||||||
-hpcdmfax_LDADD = libhpip.la -lcups -lcupsimage -ldl -ljpeg
|
|
||||||
-
|
|
||||||
endif # HPLIP_CLASS_DRIVER
|
|
||||||
endif # FAX_BUILD
|
|
||||||
endif # HPCUPS ONLY
|
|
||||||
diff --git a/hplip.list.in b/hplip.list.in
|
|
||||||
index 909f41d..f2b5e47 100644
|
|
||||||
--- a/hplip.list.in
|
|
||||||
+++ b/hplip.list.in
|
|
||||||
@@ -94,7 +94,6 @@ f 0755 root root $cupsfilter/pstotiff fax/filters/pstotiff
|
|
||||||
|
|
||||||
%if !print_only_exclude
|
|
||||||
f 0755 root root $cupsfilter/hpcupsfax .libs/hpcupsfax
|
|
||||||
-f 0755 root root $cupsfilter/hpcdmfax .libs/hpcdmfax
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%if foomatic-drv-install
|
|
@ -1,55 +0,0 @@
|
|||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index a3be3f1..0c74a12 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -583,10 +583,8 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilter.cpp prnt/hpcups/HPCupsFilter.h prnt/hp
|
|
||||||
prnt/hpcups/dj3600ColorMaps.cpp prnt/hpcups/dj3320PrintModes.h \
|
|
||||||
prnt/hpcups/dj4100PrintModes.h \
|
|
||||||
prnt/hpcups/Hbpl1.cpp prnt/hpcups/Hbpl1.h prnt/hpcups/Hbpl1_Wrapper.h prnt/hpcups/PCLmGenerator.h \
|
|
||||||
- prnt/hpcups/flate_colorspace.h prnt/hpcups/RunLenEncoding.h prnt/hpcups/common_defines.h \
|
|
||||||
- prnt/hpcups/genPCLm.h \
|
|
||||||
- common/utils.c common/utils.h prnt/hpcups/Hbpl1_Wrapper.cpp prnt/hpcups/genPCLm.cpp \
|
|
||||||
- prnt/hpcups/genJPEGStrips.cpp prnt/hpcups/RunLenEncoding.cpp \
|
|
||||||
+ prnt/hpcups/flate_colorspace.h \
|
|
||||||
+ common/utils.c common/utils.h \
|
|
||||||
prnt/hpcups/ImageProcessor.h
|
|
||||||
|
|
||||||
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
|
|
||||||
diff --git a/prnt/hpcups/Hbpl1.cpp b/prnt/hpcups/Hbpl1.cpp
|
|
||||||
index 74a67f0..48f5f94 100644
|
|
||||||
--- a/prnt/hpcups/Hbpl1.cpp
|
|
||||||
+++ b/prnt/hpcups/Hbpl1.cpp
|
|
||||||
@@ -60,7 +60,7 @@ Hbpl1::Hbpl1 () : Encapsulator ()
|
|
||||||
m_ColorMode = COLORTYPE_BOTH; //Grayscale
|
|
||||||
m_ColorTheme = NONE;
|
|
||||||
|
|
||||||
- /*m_hHPLibHandle = load_plugin_library(UTILS_PRINT_PLUGIN_LIBRARY, PRNT_PLUGIN_HBPL1);
|
|
||||||
+ m_hHPLibHandle = load_plugin_library(UTILS_PRINT_PLUGIN_LIBRARY, PRNT_PLUGIN_HBPL1);
|
|
||||||
if (m_hHPLibHandle)
|
|
||||||
{
|
|
||||||
dlerror ();
|
|
||||||
@@ -71,12 +71,7 @@ Hbpl1::Hbpl1 () : Encapsulator ()
|
|
||||||
|
|
||||||
if ((m_pHbpl1Wrapper = fptr_create(this)) == NULL)
|
|
||||||
m_init = false;
|
|
||||||
- }*/
|
|
||||||
- m_pHbpl1Wrapper = new Hbpl1Wrapper(this);
|
|
||||||
- if(m_pHbpl1Wrapper == NULL)
|
|
||||||
- m_init = false;
|
|
||||||
- else
|
|
||||||
- m_init = true;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
Hbpl1::~Hbpl1()
|
|
||||||
@@ -93,8 +88,8 @@ Hbpl1::~Hbpl1()
|
|
||||||
if(fptr_destroy)
|
|
||||||
fptr_destroy( m_pHbpl1Wrapper );
|
|
||||||
|
|
||||||
- //unload_library(m_hHPLibHandle);
|
|
||||||
- //m_hHPLibHandle = NULL;
|
|
||||||
+ unload_library(m_hHPLibHandle);
|
|
||||||
+ m_hHPLibHandle = NULL;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
@ -13,9 +13,6 @@ fi
|
|||||||
tar -xaf hplip-$VERSION.tar.gz || exit 1
|
tar -xaf hplip-$VERSION.tar.gz || exit 1
|
||||||
|
|
||||||
# remove unwanted files - license-related ones reported here https://bugs.launchpad.net/hplip/+bug/2028938
|
# remove unwanted files - license-related ones reported here https://bugs.launchpad.net/hplip/+bug/2028938
|
||||||
rm hplip-$VERSION/prnt/hpcups/ErnieFilter.{cpp,h} hplip-$VERSION/prnt/hpijs/ernieplatform.h || exit 1
|
|
||||||
rm hplip-$VERSION/fax/filters/cdmfax/hpcupscdmfax.{cpp,h} hplip-$VERSION/fax/filters/cdmfax/jetlib.{cpp,h} hplip-$VERSION/fax/ppd/HP-Fax-CDM-hpcups.ppd.gz || exit 1
|
|
||||||
rm hplip-$VERSION/prnt/hpcups/Hbpl1_Wrapper.cpp hplip-$VERSION/prnt/hpcups/genPCLm.{cpp,h} hplip-$VERSION/prnt/hpcups/common_defines.h hplip-$VERSION/prnt/hpcups/genJPEGStrips.cpp hplip-$VERSION/prnt/hpcups/RunLenEncoding.{h,cpp}
|
|
||||||
rm hplip-$VERSION/locatedriver
|
rm hplip-$VERSION/locatedriver
|
||||||
|
|
||||||
# compress into a new tarball
|
# compress into a new tarball
|
||||||
|
23
hplip.spec
23
hplip.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.23.5
|
Version: 3.23.8
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
# most files (base/*, *, ui*/...) - GPL2+
|
# most files (base/*, *, ui*/...) - GPL2+
|
||||||
# prnt/hpijs/ jpeg related files - IJG
|
# prnt/hpijs/ jpeg related files - IJG
|
||||||
# prnt/* - BSD-3-Clause-HP - it is modified a little, asked here https://gitlab.com/fedora/legal/fedora-license-data/-/issues/267
|
# prnt/* - BSD-3-Clause-HP - it is modified a little, asked here https://gitlab.com/fedora/legal/fedora-license-data/-/issues/267
|
||||||
@ -224,13 +224,6 @@ Patch64: hplip-pcardext-disable.patch
|
|||||||
# undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
# undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
||||||
# Submitted upstream: <https://bugs.launchpad.net/hplip/+bug/1997875>
|
# Submitted upstream: <https://bugs.launchpad.net/hplip/+bug/1997875>
|
||||||
Patch65: hplip-sclpml-strcasestr.patch
|
Patch65: hplip-sclpml-strcasestr.patch
|
||||||
# hpcupscdmfilter for faxing requires jetlib header and source files,
|
|
||||||
# which have copyright note in the header comment, that the files can't
|
|
||||||
# be shared and copied for other than archival purposes without HP permission
|
|
||||||
# - this looks as incompatible conditional for Fedora, so the files are removed,
|
|
||||||
# hplip repacked and this patch removes its mentions in Makefile.am
|
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2028938
|
|
||||||
Patch66: hplip-nocdmfilter.patch
|
|
||||||
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2027972
|
# https://bugs.launchpad.net/hplip/+bug/2027972
|
||||||
Patch67: hplip-fix-parsing-lpstat.patch
|
Patch67: hplip-fix-parsing-lpstat.patch
|
||||||
@ -245,9 +238,6 @@ Patch69: hplip-no-readfp.patch
|
|||||||
# fix SyntaxWarning from python3.12
|
# fix SyntaxWarning from python3.12
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2029480
|
# https://bugs.launchpad.net/hplip/+bug/2029480
|
||||||
Patch70: hplip-use-raw-strings.patch
|
Patch70: hplip-use-raw-strings.patch
|
||||||
# more unfriendly licenses...
|
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2028938
|
|
||||||
Patch71: hplip-remove-hbpl.patch
|
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -592,9 +582,6 @@ done
|
|||||||
%patch -P 64 -p1 -b .pcardext-disable
|
%patch -P 64 -p1 -b .pcardext-disable
|
||||||
# C99 compatibility patch by fweimer - undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
# C99 compatibility patch by fweimer - undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
||||||
%patch -P 65 -p1 -b .sclpml-strcasestr
|
%patch -P 65 -p1 -b .sclpml-strcasestr
|
||||||
# jetlib.h/.c have suspicious license, root them out
|
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2028938
|
|
||||||
%patch -P 66 -p1 -b .nocdmfilter
|
|
||||||
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
||||||
# https://bugs.launchpad.net/hplip/+bug/2027972
|
# https://bugs.launchpad.net/hplip/+bug/2027972
|
||||||
%patch -P 67 -p1 -b .lpstat-parse
|
%patch -P 67 -p1 -b .lpstat-parse
|
||||||
@ -607,8 +594,6 @@ done
|
|||||||
# fix warnings
|
# fix warnings
|
||||||
# upstream https://bugs.launchpad.net/hplip/+bug/2029480
|
# upstream https://bugs.launchpad.net/hplip/+bug/2029480
|
||||||
%patch -P 70 -p1 -b .raw-strings
|
%patch -P 70 -p1 -b .raw-strings
|
||||||
# upstream https://bugs.launchpad.net/hplip/+bug/2028938
|
|
||||||
%patch -P 71 -p1 -b .hbpl
|
|
||||||
|
|
||||||
# Fedora specific patches now, don't put a generic patches under it
|
# Fedora specific patches now, don't put a generic patches under it
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
@ -864,6 +849,7 @@ find doc/images -type f -exec chmod 644 {} \;
|
|||||||
%{_cups_serverbin}/backend/hp
|
%{_cups_serverbin}/backend/hp
|
||||||
%{_cups_serverbin}/backend/hpfax
|
%{_cups_serverbin}/backend/hpfax
|
||||||
# ex-hpijs
|
# ex-hpijs
|
||||||
|
%{_cups_serverbin}/filter/hpcdmfax
|
||||||
%{_cups_serverbin}/filter/hpcups
|
%{_cups_serverbin}/filter/hpcups
|
||||||
%{_cups_serverbin}/filter/hpcupsfax
|
%{_cups_serverbin}/filter/hpcupsfax
|
||||||
%{_cups_serverbin}/filter/hpps
|
%{_cups_serverbin}/filter/hpps
|
||||||
@ -979,6 +965,9 @@ find doc/images -type f -exec chmod 644 {} \;
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 03 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.8-1
|
||||||
|
- 2239465 - hplip-3.23.8 is available
|
||||||
|
|
||||||
* Tue Oct 03 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.5-10
|
* Tue Oct 03 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.5-10
|
||||||
- BSD-3-Clause-HP and python-ldap are added into SPDX list
|
- BSD-3-Clause-HP and python-ldap are added into SPDX list
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (hplip-3.23.5-repack.tar.gz) = 7b16f86f18f77061396c4b70df47ebb2109a07a018fbadac550d873ee3d68edb9c1530fde3fec07ba5702f896243b81a6b9b23c4602953716ffbab7b025bbf86
|
SHA512 (hplip-3.23.8-repack.tar.gz) = 07df27ee2389f351c917011c939c221e835bbfe30211bfaa69bbb9b0897bb6cc33ab697b25ac4d614a587be60d96d60b681a51c92e4d8ea60043187275004d2e
|
||||||
|
Loading…
Reference in New Issue
Block a user