3.17.11
This commit is contained in:
parent
c5990f7d78
commit
b77fb66d56
1
.gitignore
vendored
1
.gitignore
vendored
@ -84,3 +84,4 @@ hplip-3.10.6.tar.gz
|
|||||||
/hplip-3.17.6.tar.gz
|
/hplip-3.17.6.tar.gz
|
||||||
/hplip-3.17.9.tar.gz
|
/hplip-3.17.9.tar.gz
|
||||||
/hplip-3.17.10.tar.gz
|
/hplip-3.17.10.tar.gz
|
||||||
|
/hplip-3.17.11.tar.gz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAlngfKAACgkQc9dwzaWQR7lKcgCfVITI7iQwJocWMsBZAAY5zAjo
|
|
||||||
mBYAn3RoLAk6hxma7BFBAbnBGgPPZGRM
|
|
||||||
=Wol9
|
|
||||||
-----END PGP SIGNATURE-----
|
|
@ -1,14 +1,16 @@
|
|||||||
diff -up hplip-3.17.4/installer/core_install.py.check-cups hplip-3.17.4/installer/core_install.py
|
diff -up hplip-3.17.11/installer/core_install.py.check-cups hplip-3.17.11/installer/core_install.py
|
||||||
--- hplip-3.17.4/installer/core_install.py.check-cups 2017-05-29 16:39:41.172572873 +0200
|
--- hplip-3.17.11/installer/core_install.py.check-cups 2017-12-07 15:34:24.855761874 +0100
|
||||||
+++ hplip-3.17.4/installer/core_install.py 2017-05-29 16:42:12.199386100 +0200
|
+++ hplip-3.17.11/installer/core_install.py 2017-12-07 15:38:44.749568860 +0100
|
||||||
@@ -338,9 +338,8 @@ class CoreInstall(object):
|
@@ -349,9 +349,9 @@ class CoreInstall(object):
|
||||||
# Required base packages
|
'automake': (True, ['prnt'], AUTOMAKE_STR, self.check_automake, DEPENDENCY_RUN_AND_COMPILE_TIME, '-', None, GENERALDEP),
|
||||||
'libjpeg': (True, ['base'], JPEG_STR, self.check_libjpeg, DEPENDENCY_RUN_AND_COMPILE_TIME,'-',None, GENERALDEP),
|
'libjpeg': (True, ['base', 'prnt'], JPEG_STR, self.check_libjpeg, DEPENDENCY_RUN_AND_COMPILE_TIME, '-', None, GENERALDEP),
|
||||||
'libtool': (True, ['base'], LIBTOOL_STR, self.check_libtool, DEPENDENCY_COMPILE_TIME,'-','libtool --version',COMPILEDEP),
|
'libtool': (True, ['base', 'prnt'], LIBTOOL_STR, self.check_libtool, DEPENDENCY_COMPILE_TIME, '-', 'libtool --version', COMPILEDEP),
|
||||||
- 'cups' : (True, ['base'], CUPS_STR, self.check_cups, DEPENDENCY_RUN_TIME,'1.1','cups-config --version', EXTERNALDEP),
|
- 'cups': (True, ['base', 'prnt'], CUPS_STR, self.check_cups, DEPENDENCY_RUN_TIME, '1.1', 'cups-config --version', EXTERNALDEP),
|
||||||
+ 'cups' : (True, ['base'], CUPS_STR, self.check_cups, DEPENDENCY_RUN_TIME,'1.1','rpm -qa cups', EXTERNALDEP),
|
- 'cups-devel': (True, ['base', 'prnt'], CUPS_DEV_STR, self.check_cups_devel, DEPENDENCY_COMPILE_TIME, '-', 'cups-config --version', GENERALDEP),
|
||||||
'cups-devel': (True, ['base'], CUPS_DEV_STR, self.check_cups_devel, DEPENDENCY_COMPILE_TIME,'-','cups-config --version', GENERALDEP),
|
- 'cups-image': (True, ['base', 'prnt'], CUPS_IMG_STR, self.check_cups_image, DEPENDENCY_COMPILE_TIME, '-', 'cups-config --version', GENERALDEP),
|
||||||
- 'cups-image': (True, ['base'], CUPS_IMG_STR, self.check_cups_image, DEPENDENCY_COMPILE_TIME,'-','cups-config --version', GENERALDEP),
|
+ 'cups': (True, ['base', 'prnt'], CUPS_STR, self.check_cups, DEPENDENCY_RUN_TIME, '1.1', 'lpstat -r', EXTERNALDEP),
|
||||||
'gcc' : (True, ['base'], GCC_STR, self.check_gcc, DEPENDENCY_COMPILE_TIME, '-','gcc --version',COMPILEDEP),
|
+ 'cups-devel': (True, ['base', 'prnt'], CUPS_DEV_STR, self.check_cups_devel, DEPENDENCY_COMPILE_TIME, '-', 'lpstat -r', GENERALDEP),
|
||||||
'make' : (True, ['base'], MAKE_STR, self.check_make, DEPENDENCY_COMPILE_TIME,'3.0','make --version',COMPILEDEP),
|
+ 'cups-image': (True, ['base', 'prnt'], CUPS_IMG_STR, self.check_cups_image, DEPENDENCY_COMPILE_TIME, '-', 'lpstat -r', GENERALDEP),
|
||||||
'libpthread' : (True, ['base'], THREAD_STR, self.check_libpthread, DEPENDENCY_RUN_AND_COMPILE_TIME, '-','FUNC#get_libpthread_version', GENERALDEP),
|
'gcc': (True, ['base', 'prnt'], GCC_STR, self.check_gcc, DEPENDENCY_COMPILE_TIME, '-', 'gcc --version', COMPILEDEP),
|
||||||
|
'make': (True, ['base', 'prnt'], MAKE_STR, self.check_make, DEPENDENCY_COMPILE_TIME, '3.0', 'make --version', COMPILEDEP),
|
||||||
|
'libpthread': (True, ['base', 'prnt'], THREAD_STR, self.check_libpthread, DEPENDENCY_RUN_AND_COMPILE_TIME, '-', 'FUNC#get_libpthread_version', GENERALDEP),
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,18 +1,18 @@
|
|||||||
diff -up hplip-3.13.4/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.13.4/prnt/drv/hpcups.drv.in
|
diff -up hplip-3.17.11/prnt/drv/hpcups.drv.in.snmp-quirks hplip-3.17.11/prnt/drv/hpcups.drv.in
|
||||||
--- hplip-3.13.4/prnt/drv/hpcups.drv.in.snmp-quirks 2013-04-09 12:11:58.447587815 +0200
|
--- hplip-3.17.11/prnt/drv/hpcups.drv.in.snmp-quirks 2017-12-07 15:21:34.149138400 +0100
|
||||||
+++ hplip-3.13.4/prnt/drv/hpcups.drv.in 2013-04-09 12:11:58.594585761 +0200
|
+++ hplip-3.17.11/prnt/drv/hpcups.drv.in 2017-12-07 15:33:32.443211804 +0100
|
||||||
@@ -6757,6 +6757,8 @@ Manufacturer "HP"
|
@@ -10831,6 +10831,8 @@ CustomMedia "B5/B5 176x250mm" 498.96 708
|
||||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909a, hpcups $Version"
|
Attribute "NickName" "" "HP Officejet Pro 8500 a909a, hpcups $Version"
|
||||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909a"
|
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909a hpijs"
|
||||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909a;DES:officejet pro 8500 a909a;"
|
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909a;DES:officejet pro 8500 a909a;"
|
||||||
+ // This device lies about its supplies capacity.
|
+ // This device lies about its supplies capacity.
|
||||||
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
||||||
PCFileName "hp-officejet_pro_8500_a909a.ppd"
|
PCFileName "hp-officejet_pro_8500_a909a.ppd"
|
||||||
Attribute "Product" "" "(HP Officejet Pro 8500 All-in-one Printer - a909a)"
|
Attribute "Product" "" "(HP Officejet Pro 8500 All-in-one Printer - a909a)"
|
||||||
}
|
}
|
||||||
@@ -6773,6 +6775,8 @@ Manufacturer "HP"
|
@@ -10839,6 +10841,8 @@ CustomMedia "B5/B5 176x250mm" 498.96 708
|
||||||
Attribute "NickName" "" "HP Officejet Pro 8500 a909g, hpcups $Version"
|
Attribute "NickName" "" "HP Officejet Pro 8500 a909g, hpcups $Version"
|
||||||
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909g"
|
Attribute "ShortNickName" "" "HP Officejet Pro 8500 a909g hpijs"
|
||||||
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909g;DES:officejet pro 8500 a909g;"
|
Attribute "1284DeviceID" "" "MFG:HP;MDL:officejet pro 8500 a909g;DES:officejet pro 8500 a909g;"
|
||||||
+ // This device lies about its supplies capacity.
|
+ // This device lies about its supplies capacity.
|
||||||
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
+ Attribute "cupsSNMPQuirks" "" "capacity"
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
diff -up hplip-3.15.11/Makefile.am.udev-rules hplip-3.15.11/Makefile.am
|
diff -up hplip-3.17.11/Makefile.am.udev-rules hplip-3.17.11/Makefile.am
|
||||||
--- hplip-3.15.11/Makefile.am.udev-rules 2015-11-12 11:29:04.000000000 +0100
|
--- hplip-3.17.11/Makefile.am.udev-rules 2017-12-07 13:44:04.472414453 +0100
|
||||||
+++ hplip-3.15.11/Makefile.am 2015-12-10 12:43:11.518518146 +0100
|
+++ hplip-3.17.11/Makefile.am 2017-12-07 15:20:18.544755557 +0100
|
||||||
@@ -118,7 +118,7 @@ rulessystemdir=/usr/lib/systemd/system
|
@@ -132,7 +132,7 @@ dist_rulessystem_DATA =data/rules/hplip-
|
||||||
dist_rulessystem_DATA =data/rules/hplip-printer@.service
|
|
||||||
|
|
||||||
# hpmud.rules
|
# hpmud.rules
|
||||||
|
if !HPLIP_CLASS_DRIVER
|
||||||
-rulesdir = /etc/udev/rules.d
|
-rulesdir = /etc/udev/rules.d
|
||||||
+rulesdir = /usr/lib/udev/rules.d
|
+rulesdir = /usr/lib/udev/rules.d
|
||||||
if UDEV_SYSFS_RULES
|
if UDEV_SYSFS_RULES
|
||||||
|
12
hplip.spec
12
hplip.spec
@ -6,8 +6,8 @@
|
|||||||
|
|
||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.17.10
|
Version: 3.17.11
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD
|
License: GPLv2+ and MIT and BSD
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -242,6 +242,8 @@ sed -i.env-python -e 's,^#!/usr/bin/env python,#!%{__python3},' \
|
|||||||
prnt/filters/hpps \
|
prnt/filters/hpps \
|
||||||
fax/filters/pstotiff
|
fax/filters/pstotiff
|
||||||
|
|
||||||
|
rm hpps hpcups dat2drv
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Work-around Makefile.am imperfections.
|
# Work-around Makefile.am imperfections.
|
||||||
sed -i 's|^AM_INIT_AUTOMAKE|AM_INIT_AUTOMAKE([foreign])|g' configure.in
|
sed -i 's|^AM_INIT_AUTOMAKE|AM_INIT_AUTOMAKE([foreign])|g' configure.in
|
||||||
@ -284,7 +286,8 @@ rm -rf %{buildroot}%{_sysconfdir}/sane.d \
|
|||||||
%{buildroot}%{_docdir} \
|
%{buildroot}%{_docdir} \
|
||||||
%{buildroot}%{_datadir}/hal/fdi \
|
%{buildroot}%{_datadir}/hal/fdi \
|
||||||
%{buildroot}%{_datadir}/hplip/pkservice.py \
|
%{buildroot}%{_datadir}/hplip/pkservice.py \
|
||||||
%{buildroot}%{_bindir}/hp-pkservice
|
%{buildroot}%{_bindir}/hp-pkservice \
|
||||||
|
%{buildroot}%{_datadir}/hplip/locatedriver*
|
||||||
|
|
||||||
rm -f %{buildroot}%{_bindir}/hp-logcapture \
|
rm -f %{buildroot}%{_bindir}/hp-logcapture \
|
||||||
%{buildroot}%{_bindir}/hp-doctor \
|
%{buildroot}%{_bindir}/hp-doctor \
|
||||||
@ -513,6 +516,9 @@ update-desktop-database &> /dev/null ||:
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 07 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.17.11-1
|
||||||
|
- 3.17.11
|
||||||
|
|
||||||
* Mon Nov 06 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.17.10-3
|
* Mon Nov 06 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.17.10-3
|
||||||
- 1509394 - Add support for HP ColorLaserjet MFP M278-M281
|
- 1509394 - Add support for HP ColorLaserjet MFP M278-M281
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (hplip-3.17.10.tar.gz) = 0c1c78730d269ec41f95bbde887a490aebb4c9c3dcb9784052a1c3b537c12093cbc426e1f79266c63dd5e7adecdda0735b9bf964ddc1307b2c6603f3fa0462a8
|
SHA512 (hplip-3.17.11.tar.gz) = 29899d58959d49a0b5e730520ef598f245570b084db33d322859b4773a934167387893888a5829c5cfd5a2e4b66848b173fc7c60973fccdb6d3f854105ad7665
|
||||||
|
Loading…
Reference in New Issue
Block a user