3.13.9: hplipjs filter removed, several patches applied upstream
This commit is contained in:
parent
e11c8fdf0c
commit
b5dbf8cf03
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.13.6.tar.gz
|
||||
/hplip-3.13.7.tar.gz
|
||||
/hplip-3.13.8.tar.gz
|
||||
/hplip-3.13.9.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlIB5JcACgkQc9dwzaWQR7maEgCfX+43fMtSH49bVmdMrzEtdF4T
|
||||
MjIAnimXchXoyEvw7VPuQkY3FGHaTYjz
|
||||
=1gPo
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.13.9.tar.gz.asc
Normal file
7
hplip-3.13.9.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlIoR1sACgkQc9dwzaWQR7lohwCfaoxhATOoQn1B2kcsDZrx5FB5
|
||||
tMYAn35uKn+H5/feIApEUN+DKjeam1/x
|
||||
=75MO
|
||||
-----END PGP SIGNATURE-----
|
@ -1,13 +0,0 @@
|
||||
diff -up hplip-3.13.2/io/hpmud/musb.c.hplip-IEEE-1284-4 hplip-3.13.2/io/hpmud/musb.c
|
||||
--- hplip-3.13.2/io/hpmud/musb.c.hplip-IEEE-1284-4 2013-02-13 17:38:44.000000000 +0100
|
||||
+++ hplip-3.13.2/io/hpmud/musb.c 2013-02-14 12:44:50.594152799 +0100
|
||||
@@ -713,7 +713,8 @@ static libusb_device *get_libusb_device(
|
||||
{
|
||||
if ((altptr->bInterfaceClass == LIBUSB_CLASS_PRINTER ) && /* Printer */
|
||||
(altptr->bInterfaceSubClass == 1) &&
|
||||
- (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2)) /* Unidirectional or Bidirectional*/
|
||||
+ (altptr->bInterfaceProtocol == 1 || altptr->bInterfaceProtocol == 2
|
||||
+ || altptr->bInterfaceProtocol == 3)) /* Unidirectional, Bidirectional or 1284.4 */
|
||||
{
|
||||
if (is_uri(dev, uri))
|
||||
{
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.10.9/ui4/printsettingstoolbox.py.UnicodeDecodeError hplip-3.10.9/ui4/printsettingstoolbox.py
|
||||
--- hplip-3.10.9/ui4/printsettingstoolbox.py.UnicodeDecodeError 2010-09-26 19:07:19.000000000 +0200
|
||||
+++ hplip-3.10.9/ui4/printsettingstoolbox.py 2010-10-22 15:01:13.000000000 +0200
|
||||
@@ -459,7 +459,7 @@ class PrintSettingsToolbox(QToolBox):
|
||||
|
||||
self.beginControlGroup(g, QString(text))
|
||||
|
||||
- log.debug(" Text: %s" % unicode(text))
|
||||
+ log.debug(" Text: %s" % repr(text))
|
||||
log.debug("Num subgroups: %d" % num_subgroups)
|
||||
|
||||
options = cups.getOptionList(g)
|
@ -1,188 +0,0 @@
|
||||
diff -up hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2013-05-14 15:01:34.288431852 +0200
|
||||
+++ hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp 2013-05-14 15:03:08.103139571 +0200
|
||||
@@ -471,7 +471,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
||||
|
||||
}
|
||||
- dbglog ("m_Job initialization failed with error = %d", err);
|
||||
+ dbglog ("m_Job initialization failed with error = %d\n", err);
|
||||
ppdClose(m_ppd);
|
||||
m_ppd = NULL;
|
||||
return err;
|
||||
@@ -564,7 +564,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
}
|
||||
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
@@ -576,7 +576,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
}
|
||||
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
@@ -728,7 +728,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
//Need to revisit to crosscheck if it is a firmware issue.
|
||||
|
||||
*m_pPrinterBuffer = 0x01;
|
||||
- dbglog("First raster data plane.." );
|
||||
+ dbglog("First raster data plane..\n" );
|
||||
}
|
||||
|
||||
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
||||
diff -up hplip-3.13.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.13.5/prnt/hpcups/Lidil.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||
+++ hplip-3.13.5/prnt/hpcups/Lidil.cpp 2013-05-14 15:01:34.985422251 +0200
|
||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
{
|
||||
- dbglog("Requested resolution not supported with requested printmode");
|
||||
+ dbglog("Requested resolution not supported with requested printmode\n");
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
|
||||
@@ -166,7 +166,7 @@ DRIVER_ERROR Lidil::StartJob(SystemServi
|
||||
|
||||
if (!selectPrintMode())
|
||||
{
|
||||
- dbglog("selectPrintMode failed, PrintMode name = %s", m_pQA->print_mode_name);
|
||||
+ dbglog("selectPrintMode failed, PrintMode name = %s\n", m_pQA->print_mode_name);
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
|
||||
@@ -174,7 +174,7 @@ DRIVER_ERROR Lidil::StartJob(SystemServi
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
{
|
||||
- dbglog("Requested resolution not supported with requested printmode");
|
||||
+ dbglog("Requested resolution not supported with requested printmode\n");
|
||||
dbglog(" m_pPM->BaseResX = %d\n",m_pPM->BaseResX);
|
||||
dbglog(" m_pPM->BaseResY = %d\n",m_pPM->BaseResY);
|
||||
dbglog(" m_pQA->horizontal_resolution = %d\n",m_pQA->horizontal_resolution);
|
||||
@@ -193,7 +193,7 @@ DRIVER_ERROR Lidil::StartJob(SystemServi
|
||||
err = allocateSwathBuffers();
|
||||
if (err != NO_ERROR)
|
||||
{
|
||||
- dbglog("allocateSwathBuffers failed, err = %d", err);
|
||||
+ dbglog("allocateSwathBuffers failed, err = %d\n", err);
|
||||
return err;
|
||||
}
|
||||
|
||||
@@ -625,7 +625,7 @@ bool Lidil::selectPrintMode()
|
||||
{
|
||||
if (m_pJA->printer_platform[0] == 0)
|
||||
{
|
||||
- dbglog("printer_platform is undefined");
|
||||
+ dbglog("printer_platform is undefined\n");
|
||||
return false;
|
||||
}
|
||||
for (unsigned int i = 0; i < sizeof(lidil_print_modes_table) / sizeof(lidil_print_modes_table[0]); i++)
|
||||
@@ -635,7 +635,7 @@ bool Lidil::selectPrintMode()
|
||||
return selectPrintMode(i);
|
||||
}
|
||||
}
|
||||
- dbglog("Unsupported printer_platform: %s", m_pJA->printer_platform);
|
||||
+ dbglog("Unsupported printer_platform: %s\n", m_pJA->printer_platform);
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.13.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.13.5/prnt/hpcups/Pcl3.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||
+++ hplip-3.13.5/prnt/hpcups/Pcl3.cpp 2013-05-14 15:01:34.985422251 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||
|
||||
if (!selectPrintMode())
|
||||
{
|
||||
- dbglog("selectPrintMode failed, PrintMode name = %s", m_pQA->print_mode_name);
|
||||
+ dbglog("selectPrintMode failed, PrintMode name = %s\n", m_pQA->print_mode_name);
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
{
|
||||
- dbglog("Requested resolution not supported with requested printmode");
|
||||
+ dbglog("Requested resolution not supported with requested printmode\n");
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
|
||||
@@ -220,7 +220,7 @@ void Pcl3::configureRasterData()
|
||||
{
|
||||
if (m_pPM == NULL)
|
||||
{
|
||||
- dbglog("configureRasterData: m_pPM is NULL");
|
||||
+ dbglog("configureRasterData: m_pPM is NULL\n");
|
||||
return;
|
||||
}
|
||||
BYTE *p = cur_pcl_buffer_ptr;
|
||||
@@ -255,7 +255,7 @@ bool Pcl3::selectPrintMode()
|
||||
{
|
||||
if (m_pJA->printer_platform[0] == 0)
|
||||
{
|
||||
- dbglog("printer_platform is undefined");
|
||||
+ dbglog("printer_platform is undefined\n");
|
||||
return false;
|
||||
}
|
||||
for (unsigned int i = 0; i < sizeof(pcl3_print_modes_table) / sizeof(pcl3_print_modes_table[0]); i++)
|
||||
@@ -265,7 +265,7 @@ bool Pcl3::selectPrintMode()
|
||||
return selectPrintMode(i);
|
||||
}
|
||||
}
|
||||
- dbglog("Unsupported printer_platform: %s", m_pJA->printer_platform);
|
||||
+ dbglog("Unsupported printer_platform: %s\n", m_pJA->printer_platform);
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2013-05-10 12:03:36.000000000 +0200
|
||||
+++ hplip-3.13.5/prnt/hpcups/Pcl3Gui.cpp 2013-05-14 15:01:34.986422237 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||
|
||||
if (!selectPrintMode())
|
||||
{
|
||||
- dbglog("selectPrintMode failed, PrintMode name = %s", m_pQA->print_mode_name);
|
||||
+ dbglog("selectPrintMode failed, PrintMode name = %s\n", m_pQA->print_mode_name);
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
{
|
||||
- dbglog("Requested resolution not supported with requested printmode");
|
||||
+ dbglog("Requested resolution not supported with requested printmode\n");
|
||||
return UNSUPPORTED_PRINTMODE;
|
||||
}
|
||||
|
||||
@@ -224,7 +224,7 @@ void Pcl3Gui::configureRasterData()
|
||||
{
|
||||
if (m_pPM == NULL)
|
||||
{
|
||||
- dbglog("configureRasterData: m_pPM is NULL");
|
||||
+ dbglog("configureRasterData: m_pPM is NULL\n");
|
||||
return;
|
||||
}
|
||||
BYTE *p = cur_pcl_buffer_ptr;
|
||||
@@ -259,7 +259,7 @@ bool Pcl3Gui::selectPrintMode()
|
||||
{
|
||||
if (m_pJA->printer_platform[0] == 0)
|
||||
{
|
||||
- dbglog("printer_platform is undefined");
|
||||
+ dbglog("printer_platform is undefined\n");
|
||||
return false;
|
||||
}
|
||||
for (unsigned int i = 0; i < sizeof(pcl3_gui_print_modes_table) / sizeof(pcl3_gui_print_modes_table[0]); i++)
|
||||
@@ -269,7 +269,7 @@ bool Pcl3Gui::selectPrintMode()
|
||||
return selectPrintMode(i);
|
||||
}
|
||||
}
|
||||
- dbglog("Unsupported printer_platform: %s", m_pJA->printer_platform);
|
||||
+ dbglog("Unsupported printer_platform: %s\n", m_pJA->printer_platform);
|
||||
return false;
|
||||
}
|
||||
|
@ -1,18 +0,0 @@
|
||||
diff -up hplip-3.10.9/ui4/sendfaxdialog.py~ hplip-3.10.9/ui4/sendfaxdialog.py
|
||||
--- hplip-3.10.9/ui4/sendfaxdialog.py~ 2010-09-26 18:07:19.000000000 +0100
|
||||
+++ hplip-3.10.9/ui4/sendfaxdialog.py 2010-12-13 16:44:56.857648866 +0000
|
||||
@@ -915,8 +915,12 @@ class SendFaxDialog(QDialog, Ui_Dialog):
|
||||
def CheckTimer_timeout(self):
|
||||
if not self.busy:
|
||||
#log.debug("Checking for incoming faxes...")
|
||||
- device_uri, printer_name, event_code, username, job_id, title, timedate, fax_file = \
|
||||
- self.service.CheckForWaitingFax(self.device_uri, prop.username, self.last_job_id)
|
||||
+ try:
|
||||
+ device_uri, printer_name, event_code, username, job_id, title, timedate, fax_file = \
|
||||
+ self.service.CheckForWaitingFax(self.device_uri, prop.username, self.last_job_id)
|
||||
+ except Exception, e:
|
||||
+ log.debug("Exception caught: %s" % e)
|
||||
+ fax_file = None
|
||||
|
||||
if fax_file:
|
||||
self.last_job_id = 0
|
@ -31,19 +31,6 @@ diff -up hplip-3.13.5/logcapture.py.logdir hplip-3.13.5/logcapture.py
|
||||
if File_list:
|
||||
sts,out = utils.run('cp -f %s %s'%(File_list_str, LOG_FILES))
|
||||
if sts != 0:
|
||||
diff -up hplip-3.13.5/prnt/filters/hplipjs.c.logdir hplip-3.13.5/prnt/filters/hplipjs.c
|
||||
--- hplip-3.13.5/prnt/filters/hplipjs.c.logdir 2013-05-10 12:04:50.000000000 +0200
|
||||
+++ hplip-3.13.5/prnt/filters/hplipjs.c 2013-05-14 14:57:19.459942157 +0200
|
||||
@@ -275,7 +275,8 @@ int main (int argc, char **argv)
|
||||
{
|
||||
fprintf (stderr, "DEBUG: HPLIPJS: argv[%d] = %s\n", i, argv[i]);
|
||||
}
|
||||
- snprintf(szPSFile, sizeof(szPSFile), "%s/output.ps","/var/log/hp/tmp");
|
||||
+ snprintf(szPSFile, sizeof(szPSFile), "%s/output.ps",
|
||||
+ getenv ("TMPDIR") ? : "/var/log/hp/tmp");
|
||||
|
||||
HPFp = fopen (szPSFile, "w");
|
||||
#endif
|
||||
diff -up hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.logdir hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp.logdir 2013-05-14 14:57:19.450942281 +0200
|
||||
+++ hplip-3.13.5/prnt/hpcups/HPCupsFilter.cpp 2013-05-14 14:59:45.745927028 +0200
|
||||
|
@ -1,16 +1,3 @@
|
||||
diff -up hplip-3.9.8/ip/ipmain.c.no-asm hplip-3.9.8/ip/ipmain.c
|
||||
--- hplip-3.9.8/ip/ipmain.c.no-asm 2009-08-04 22:37:28.000000000 +0100
|
||||
+++ hplip-3.9.8/ip/ipmain.c 2009-08-25 14:44:04.497202437 +0100
|
||||
@@ -265,9 +265,6 @@ static IP_XFORM_TBL * const xformJumpTab
|
||||
void fatalBreakPoint (void)
|
||||
{
|
||||
/* do nothing */
|
||||
-#if defined _DEBUG
|
||||
- __asm int 3;
|
||||
-#endif
|
||||
PRINT0 (_T("\nhit fatalBreakPoint!\n"));
|
||||
}
|
||||
|
||||
diff -up hplip-3.9.8/ip/xfax.c.no-asm hplip-3.9.8/ip/xfax.c
|
||||
--- hplip-3.9.8/ip/xfax.c.no-asm 2009-08-04 22:37:28.000000000 +0100
|
||||
+++ hplip-3.9.8/ip/xfax.c 2009-08-25 14:44:04.502202418 +0100
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up hplip-3.12.9/ui4/systemtray.py.notification-exception hplip-3.12.9/ui4/systemtray.py
|
||||
--- hplip-3.12.9/ui4/systemtray.py.notification-exception 2012-09-24 14:11:44.764151285 +0200
|
||||
+++ hplip-3.12.9/ui4/systemtray.py 2012-09-24 14:11:45.574138763 +0200
|
||||
@@ -761,7 +761,10 @@ class SystemTrayApp(QApplication):
|
||||
else:
|
||||
n.set_timeout(TRAY_MESSAGE_DELAY)
|
||||
|
||||
- n.show()
|
||||
+ try:
|
||||
+ n.show()
|
||||
+ except:
|
||||
+ log.error("Failed to show notification!")
|
||||
|
||||
else: # Use "standard" message bubbles
|
||||
icon = ERROR_STATE_TO_ICON.get(error_state, QSystemTrayIcon.Information)
|
@ -1,24 +0,0 @@
|
||||
diff -up hplip-3.10.9/base/device.py.raw_deviceID-traceback hplip-3.10.9/base/device.py
|
||||
--- hplip-3.10.9/base/device.py.raw_deviceID-traceback 2010-10-18 17:22:55.138868192 +0100
|
||||
+++ hplip-3.10.9/base/device.py 2010-10-18 17:24:02.965869220 +0100
|
||||
@@ -1368,6 +1368,8 @@ class Device(object):
|
||||
|
||||
def getDeviceID(self):
|
||||
needs_close = False
|
||||
+ self.raw_deviceID = ''
|
||||
+ self.deviceID = {}
|
||||
if self.io_state != IO_STATE_HP_OPEN:
|
||||
try:
|
||||
self.open()
|
||||
@@ -1377,10 +1379,7 @@ class Device(object):
|
||||
|
||||
result_code, data = hpmudext.get_device_id(self.device_id)
|
||||
|
||||
- if result_code != hpmudext.HPMUD_R_OK:
|
||||
- self.raw_deviceID = ''
|
||||
- self.deviceID = {}
|
||||
- else:
|
||||
+ if result_code == hpmudext.HPMUD_R_OK:
|
||||
self.raw_deviceID = data
|
||||
self.deviceID = parseDeviceID(data)
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up hplip-3.10.2/prnt/hpcups/LJColor.h.skip-blank-lines hplip-3.10.2/prnt/hpcups/LJColor.h
|
||||
--- hplip-3.10.2/prnt/hpcups/LJColor.h.skip-blank-lines 2010-02-24 23:04:09.000000000 +0000
|
||||
+++ hplip-3.10.2/prnt/hpcups/LJColor.h 2010-04-15 21:46:48.375754707 +0100
|
||||
@@ -48,6 +48,7 @@ public:
|
||||
DRIVER_ERROR Configure(Pipeline **pipeline);
|
||||
DRIVER_ERROR EndJob();
|
||||
DRIVER_ERROR FormFeed();
|
||||
+ bool CanSkipRasters() {return false;}
|
||||
protected:
|
||||
virtual DRIVER_ERROR addJobSettings();
|
||||
void configureRasterData();
|
@ -1,27 +0,0 @@
|
||||
diff -up hplip-3.13.7/ui4/systemtray.py.systray-dbus-exception hplip-3.13.7/ui4/systemtray.py
|
||||
--- hplip-3.13.7/ui4/systemtray.py.systray-dbus-exception 2013-07-23 06:13:40.000000000 +0100
|
||||
+++ hplip-3.13.7/ui4/systemtray.py 2013-08-05 15:52:44.904186798 +0100
|
||||
@@ -466,7 +466,7 @@ class SystemTrayApp(QApplication):
|
||||
try:
|
||||
self.service = self.session_bus.get_object('com.hplip.StatusService',
|
||||
"/com/hplip/StatusService")
|
||||
- except DBusException:
|
||||
+ except dbus.DBusException:
|
||||
log.warn("Unable to connect to StatusService. Retrying...")
|
||||
|
||||
t += 1
|
||||
@@ -820,7 +820,13 @@ def run(read_pipe):
|
||||
log.set_module("hp-systray(qt4)")
|
||||
log.debug("PID=%d" % os.getpid())
|
||||
|
||||
- app = SystemTrayApp(sys.argv, read_pipe)
|
||||
+ try:
|
||||
+ app = SystemTrayApp(sys.argv, read_pipe)
|
||||
+ except dbus.DBusException, e:
|
||||
+ # No session bus
|
||||
+ log.debug("Caught exception: %s" % e)
|
||||
+ sys.exit(1)
|
||||
+
|
||||
app.setQuitOnLastWindowClosed(False) # If not set, settings dlg closes app
|
||||
|
||||
i = 0
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.11.1/ui4/wifisetupdialog.py.wifisetup hplip-3.11.1/ui4/wifisetupdialog.py
|
||||
--- hplip-3.11.1/ui4/wifisetupdialog.py.wifisetup 2011-01-19 06:18:20.000000000 +0100
|
||||
+++ hplip-3.11.1/ui4/wifisetupdialog.py 2011-03-01 15:39:02.000000000 +0100
|
||||
@@ -301,7 +301,7 @@ class WifiSetupDialog(QDialog, Ui_Dialog
|
||||
self.dev.close()
|
||||
endWaitCursor()
|
||||
|
||||
- self.num_networks = self.networks['numberofscanentries']
|
||||
+ self.num_networks = self.networks.get('numberofscanentries')
|
||||
self.clearNetworksTable()
|
||||
|
||||
if self.num_networks:
|
92
hplip.spec
92
hplip.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.13.8
|
||||
Release: 2%{?dist}
|
||||
Version: 3.13.9
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
|
||||
@ -27,25 +27,16 @@ Patch9: hplip-snmp-quirks.patch
|
||||
Patch10: hplip-discovery-method.patch
|
||||
Patch11: hplip-hpijs-marker-supply.patch
|
||||
Patch12: hplip-clear-old-state-reasons.patch
|
||||
Patch13: hplip-systray-dbus-exception.patch
|
||||
Patch14: hplip-hpcups-sigpipe.patch
|
||||
Patch15: hplip-logdir.patch
|
||||
Patch16: hplip-bad-low-ink-warning.patch
|
||||
Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch21: hplip-ppd-ImageableArea.patch
|
||||
Patch22: hplip-raw_deviceID-traceback.patch
|
||||
Patch23: hplip-UnicodeDecodeError.patch
|
||||
Patch24: hplip-addprinter.patch
|
||||
Patch25: hplip-dbus-exception.patch
|
||||
Patch26: hplip-notification-exception.patch
|
||||
Patch28: hplip-wifisetup.patch
|
||||
Patch29: hplip-makefile-chgrp.patch
|
||||
Patch30: hplip-hpaio-localonly.patch
|
||||
Patch31: hplip-IEEE-1284-4.patch
|
||||
Patch32: hplip-check.patch
|
||||
Patch33: hplip-mkstemp.patch
|
||||
Patch13: hplip-hpcups-sigpipe.patch
|
||||
Patch14: hplip-logdir.patch
|
||||
Patch15: hplip-bad-low-ink-warning.patch
|
||||
Patch16: hplip-deviceIDs-ppd.patch
|
||||
Patch17: hplip-ppd-ImageableArea.patch
|
||||
Patch18: hplip-addprinter.patch
|
||||
Patch19: hplip-makefile-chgrp.patch
|
||||
Patch20: hplip-hpaio-localonly.patch
|
||||
Patch21: hplip-check.patch
|
||||
Patch22: hplip-mkstemp.patch
|
||||
|
||||
%global hpijs_epoch 1
|
||||
Requires: hpijs%{?_isa} = %{hpijs_epoch}:%{version}-%{release}
|
||||
@ -203,17 +194,14 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
||||
# Clear old printer-state-reasons we used to manage (bug #510926).
|
||||
%patch12 -p1 -b .clear-old-state-reasons
|
||||
|
||||
# Catch DBusException in hp-systray (bug #746024).
|
||||
%patch13 -p1 -b .systray-dbus-exception
|
||||
|
||||
# Avoid busy loop in hpcups when backend has exited (bug #525944).
|
||||
%patch14 -p1 -b .hpcups-sigpipe
|
||||
%patch13 -p1 -b .hpcups-sigpipe
|
||||
|
||||
# CUPS filters should use TMPDIR when available (bug #865603).
|
||||
%patch15 -p1 -b .logdir
|
||||
%patch14 -p1 -b .logdir
|
||||
|
||||
# Fixed Device ID parsing code in hpijs's dj9xxvip.c (bug #510926).
|
||||
%patch16 -p1 -b .bad-low-ink-warning
|
||||
%patch15 -p1 -b .bad-low-ink-warning
|
||||
|
||||
# Add Device ID for
|
||||
# LaserJet 1200 (bug #577308)
|
||||
@ -233,66 +221,42 @@ mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
|
||||
# Designjet T770 (bug #747957)
|
||||
# Color LaserJet CM4540 MFP (bug #968177)
|
||||
# Color LaserJet cp4005 (bug #980976)
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
for ppd_file in $(grep '^diff' %{PATCH16} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
done
|
||||
%patch17 -p1 -b .deviceIDs-ppd
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
%patch16 -p1 -b .deviceIDs-ppd
|
||||
for ppd_file in $(grep '^diff' %{PATCH16} | cut -d " " -f 4);
|
||||
do
|
||||
gzip -n ${ppd_file#*/}
|
||||
done
|
||||
|
||||
# Hpcups (ljcolor) was putting black lines where should be blank lines (bug #579461).
|
||||
%patch18 -p1 -b .skip-blank-lines
|
||||
|
||||
# Added missing newline to string argument in dbglog() call (bug #585275).
|
||||
%patch19 -p1 -b .dbglog-newline
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
done
|
||||
%patch21 -p1 -b .ImageableArea
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
%patch17 -p1 -b .ImageableArea
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
do
|
||||
gzip -n ${ppd_file#*/}
|
||||
done
|
||||
|
||||
# Fixed traceback on error condition in device.py (bug #628125).
|
||||
%patch22 -p1 -b .raw_deviceID-traceback
|
||||
|
||||
# Avoid UnicodeDecodeError in printsettingstoolbox.py (bug #645739).
|
||||
%patch23 -p1 -b .UnicodeDecodeError
|
||||
|
||||
# Call cupsSetUser in cupsext's addPrinter method before connecting so
|
||||
# that we can get an authentication callback (bug #538352).
|
||||
%patch24 -p1 -b .addprinter
|
||||
|
||||
# Catch D-Bus exceptions in fax dialog (bug #645316).
|
||||
%patch25 -p1 -b .dbus-exception
|
||||
|
||||
# Catch GError exception when notification showing failed (bug #665577).
|
||||
%patch26 -p1 -b .notification-exception
|
||||
|
||||
# Avoid KeyError in ui4/wifisetupdialog.py (bug #680939).
|
||||
%patch28 -p1 -b .wifisetup
|
||||
%patch18 -p1 -b .addprinter
|
||||
|
||||
# Don't run 'chgrp lp /var/log/hp' and 'chgrp lp /var/log/hp/tmp' in makefile
|
||||
%patch29 -p1 -b .chgrp
|
||||
%patch19 -p1 -b .chgrp
|
||||
|
||||
# Pay attention to the SANE localOnly flag in hpaio (bug #743593).
|
||||
%patch30 -p1 -b .hpaio-localonly
|
||||
|
||||
# Support IEEE 1284.4 protocol over USB (bug #858861).
|
||||
%patch31 -p1 -b .hplip-IEEE-1284-4
|
||||
%patch20 -p1 -b .hpaio-localonly
|
||||
|
||||
# Various adjustments to make 'hp-check' run more smoothly (bug #683007).
|
||||
%patch32 -p1 -b .check
|
||||
%patch21 -p1 -b .check
|
||||
|
||||
# Avoid several bugs in createTempFile (bug #925032).
|
||||
%patch33 -p1 -b .mkstemp
|
||||
%patch22 -p1 -b .mkstemp
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -509,7 +473,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_datadir}/cups/drv/*
|
||||
%{_cups_serverbin}/filter/hpcups
|
||||
%{_cups_serverbin}/filter/hpcupsfax
|
||||
%{_cups_serverbin}/filter/hplipjs
|
||||
%{_cups_serverbin}/filter/hpps
|
||||
|
||||
%files -n libsane-hpaio
|
||||
@ -524,6 +487,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Sep 10 2013 Jiri Popelka <jpopelka@redhat.com> - 3.13.9-1
|
||||
- 3.13.9: hplipjs filter removed, several patches applied upstream
|
||||
|
||||
* Wed Aug 14 2013 Tim Waugh <twaugh@redhat.com> - 3.13.8-2
|
||||
- Moved hpps filter to hpijs sub-package (bug #996852).
|
||||
- Fixed typo in systemtray.py (bug #991638).
|
||||
|
Loading…
Reference in New Issue
Block a user