1738321 - [abrt] hp-systray:BlockingIOError: [Errno 11] Resource temporarily unavailable
This commit is contained in:
parent
170d4940b3
commit
b4f9f5f620
20
hplip-systray-blockerror.patch
Normal file
20
hplip-systray-blockerror.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff --git a/systray.py b/systray.py
|
||||
index 07db0fa..3a35b30 100644
|
||||
--- a/systray.py
|
||||
+++ b/systray.py
|
||||
@@ -89,7 +89,14 @@ if __name__ == '__main__':
|
||||
log.debug("Creating pipe: hpssd (%d) ==> systemtray (%d)" % (w1, r1))
|
||||
|
||||
parent_pid = os.getpid()
|
||||
- child_pid1 = os.fork()
|
||||
+ try:
|
||||
+ child_pid1 = os.fork()
|
||||
+ except BlockingIOErrror as e:
|
||||
+ log.error("hp-systray: error during fork - %s" % e)
|
||||
+ os.close(w1)
|
||||
+ os.close(r1)
|
||||
+ mod.unlockInstance()
|
||||
+ sys.exit(1)
|
||||
|
||||
if child_pid1:
|
||||
# parent (UI)
|
11
hplip.spec
11
hplip.spec
@ -7,7 +7,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.19.6
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -110,6 +110,10 @@ Patch48: hplip-covscan.patch
|
||||
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1727162
|
||||
# upstream https://bugs.launchpad.net/hplip/+bug/1837846
|
||||
Patch49: hplip-logging-segfault.patch
|
||||
# Traceback in hp-systray when there are no resource
|
||||
# wanted to report upstream, but launchpad ends with timeout error
|
||||
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1738321
|
||||
Patch50: hplip-systray-blockerror.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: python3-pillow
|
||||
@ -360,6 +364,8 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
%patch48 -p1 -b .covscan
|
||||
# segfault during logging (1727162)
|
||||
%patch49 -p1 -b .logging-segfault
|
||||
# 1738321 - [abrt] hp-systray:BlockingIOError: [Errno 11] Resource temporarily unavailable
|
||||
%patch50 -p1 -b .systray-blockerror
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -664,6 +670,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Thu Aug 08 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.6-5
|
||||
- 1738321 - [abrt] hp-systray:BlockingIOError: [Errno 11] Resource temporarily unavailable
|
||||
|
||||
* Thu Aug 01 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.6-4
|
||||
- sks-keyservers.net seems more reliable
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user