- 3.10.5. No longer need tray-icon-crash.patch
- Increase the timeout for system tray availability checking (bug #569969).
This commit is contained in:
parent
ded481dbb4
commit
b4e3212ea8
@ -34,3 +34,4 @@ hplip-3.9.10.tar.gz
|
||||
hplip-3.9.12.tar.gz
|
||||
hplip-3.10.2.tar.gz
|
||||
hpcups-update-ppds.sh
|
||||
hplip-3.10.5.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAkuFslQACgkQc9dwzaWQR7mpowCgr3YlpISS+6eqBhwkTIdOhc3b
|
||||
470An0hYImtLZznLX6oljo/gw4zCoqvh
|
||||
=dMK4
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.10.5.tar.gz.asc
Normal file
7
hplip-3.10.5.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAkvrPtwACgkQc9dwzaWQR7kBQQCg5QMDPz05Oz1r9aQtk7drg8mQ
|
||||
wxEAoMYrbJ7YkjqWyhsK/04y8tqZ022U
|
||||
=H4Nc
|
||||
-----END PGP SIGNATURE-----
|
@ -1,7 +1,7 @@
|
||||
diff -up hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp
|
||||
--- hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning 2009-11-26 14:30:31.325303260 +0000
|
||||
+++ hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp 2009-11-26 14:31:10.125303367 +0000
|
||||
@@ -2222,7 +2222,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
diff -up hplip-3.10.5/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning hplip-3.10.5/prnt/hpijs/dj9xxvip.cpp
|
||||
--- hplip-3.10.5/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning 2010-05-13 01:48:58.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpijs/dj9xxvip.cpp 2010-05-17 14:56:31.000000000 +0200
|
||||
@@ -2239,7 +2239,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
{
|
||||
case '5':
|
||||
{
|
||||
@ -10,7 +10,7 @@ diff -up hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning hplip-3.9.10/p
|
||||
{
|
||||
if (err != NO_ERROR)
|
||||
{
|
||||
@@ -2237,7 +2237,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
@@ -2254,7 +2254,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
}
|
||||
case '6':
|
||||
{
|
||||
@ -19,7 +19,7 @@ diff -up hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning hplip-3.9.10/p
|
||||
{
|
||||
if (err != NO_ERROR)
|
||||
{
|
||||
@@ -2252,7 +2252,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
@@ -2269,7 +2269,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
}
|
||||
case '7':
|
||||
{
|
||||
@ -28,7 +28,7 @@ diff -up hplip-3.9.10/prnt/hpijs/dj9xxvip.cpp.bad-low-ink-warning hplip-3.9.10/p
|
||||
{
|
||||
if (err != NO_ERROR)
|
||||
{
|
||||
@@ -2268,7 +2268,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
@@ -2285,7 +2285,7 @@ DRIVER_ERROR DJ9xxVIP::CheckInkLevel()
|
||||
}
|
||||
case '8':
|
||||
{
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2010-04-27 12:20:42.000000000 +0200
|
||||
+++ hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp 2010-04-27 12:38:09.000000000 +0200
|
||||
diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2010-05-17 15:00:02.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
@@ -350,7 +350,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
(attr->value != NULL)) {
|
||||
strncpy(m_JA.printer_platform, attr->value, sizeof(m_JA.printer_platform)-1);
|
||||
@ -36,7 +36,7 @@ diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.2/p
|
||||
}
|
||||
|
||||
m_pPrinterBuffer = new BYTE[cups_header->cupsWidth * 4 + 32];
|
||||
@@ -495,7 +495,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
@@ -503,7 +503,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
@ -45,7 +45,7 @@ diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.2/p
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -505,7 +505,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
@@ -513,7 +513,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
@ -54,9 +54,9 @@ diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.2/p
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
diff -up hplip-3.10.2/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.10.2/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/Lidil.cpp.dbglog-newline 2010-02-25 00:04:09.000000000 +0100
|
||||
+++ hplip-3.10.2/prnt/hpcups/Lidil.cpp 2010-04-27 12:38:08.000000000 +0200
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Lidil.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Lidil.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
@ -109,9 +109,9 @@ diff -up hplip-3.10.2/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.10.2/prnt/hpc
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.10.2/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.10.2/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/Pcl3.cpp.dbglog-newline 2010-02-25 00:04:09.000000000 +0100
|
||||
+++ hplip-3.10.2/prnt/hpcups/Pcl3.cpp 2010-04-27 12:38:07.000000000 +0200
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Pcl3.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Pcl3.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||
|
||||
if (!selectPrintMode())
|
||||
@ -155,9 +155,9 @@ diff -up hplip-3.10.2/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.10.2/prnt/hpcu
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.10.2/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.10.2/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2010-02-25 00:04:09.000000000 +0100
|
||||
+++ hplip-3.10.2/prnt/hpcups/Pcl3Gui.cpp 2010-04-27 12:38:06.000000000 +0200
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||
|
||||
if (!selectPrintMode())
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,20 +1,20 @@
|
||||
diff -up hplip-3.10.2/ui4/systemtray.py.no-system-tray hplip-3.10.2/ui4/systemtray.py
|
||||
--- hplip-3.10.2/ui4/systemtray.py.no-system-tray 2010-05-11 14:40:57.000000000 +0200
|
||||
+++ hplip-3.10.2/ui4/systemtray.py 2010-05-11 15:25:20.000000000 +0200
|
||||
diff -up hplip-3.10.5/ui4/systemtray.py.no-system-tray hplip-3.10.5/ui4/systemtray.py
|
||||
--- hplip-3.10.5/ui4/systemtray.py.no-system-tray 2010-05-13 01:45:04.000000000 +0200
|
||||
+++ hplip-3.10.5/ui4/systemtray.py 2010-05-17 15:03:12.000000000 +0200
|
||||
@@ -74,6 +74,7 @@ HIDE_INACTIVE_DELAY = 5000
|
||||
BLIP_DELAY = 2000
|
||||
SET_MENU_DELAY = 1000
|
||||
MAX_MENU_EVENTS = 10
|
||||
+TRAY_AVAILABLE_DELAY = 30
|
||||
+TRAY_AVAILABLE_TIMEOUT = 180
|
||||
|
||||
ERROR_STATE_TO_ICON = {
|
||||
ERROR_STATE_CLEAR: QSystemTrayIcon.Information,
|
||||
@@ -707,7 +708,7 @@ def run(read_pipe):
|
||||
@@ -706,7 +707,7 @@ def run(read_pipe):
|
||||
app.setQuitOnLastWindowClosed(False) # If not set, settings dlg closes app
|
||||
|
||||
i = 0
|
||||
- while i < 10:
|
||||
+ while i < TRAY_AVAILABLE_DELAY:
|
||||
+ while i < TRAY_AVAILABLE_TIMEOUT:
|
||||
if QSystemTrayIcon.isSystemTrayAvailable():
|
||||
break
|
||||
time.sleep(1.0)
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up hplip-3.10.2/fax/filters/pstotiff.pstotiff-is-rubbish hplip-3.10.2/fax/filters/pstotiff
|
||||
--- hplip-3.10.2/fax/filters/pstotiff.pstotiff-is-rubbish 2010-02-24 23:07:09.000000000 +0000
|
||||
+++ hplip-3.10.2/fax/filters/pstotiff 2010-03-01 09:52:50.676611385 +0000
|
||||
@@ -1,43 +1,16 @@
|
||||
diff -up hplip-3.10.5/fax/filters/pstotiff.pstotiff-is-rubbish hplip-3.10.5/fax/filters/pstotiff
|
||||
--- hplip-3.10.5/fax/filters/pstotiff.pstotiff-is-rubbish 2010-05-13 01:44:57.000000000 +0200
|
||||
+++ hplip-3.10.5/fax/filters/pstotiff 2010-05-17 14:39:55.000000000 +0200
|
||||
@@ -1,40 +1,16 @@
|
||||
-#!/usr/bin/env python
|
||||
-
|
||||
-import os
|
||||
@ -21,14 +21,11 @@ diff -up hplip-3.10.2/fax/filters/pstotiff.pstotiff-is-rubbish hplip-3.10.2/fax/
|
||||
-temp_out_handle, temp_out_fname = tempfile.mkstemp()
|
||||
-
|
||||
-font = "-I/usr/share/cups/fonts"
|
||||
-device = "-sDEVICE=tiffg4 -dDEBUG -dNOPAUSE -dBATCH -dSAFER -dSHORTERRORS -dWRITESYSTEMDICT -dGHOSTSCRIPT -sstdout=%stderr -sOutputFile=" + temp_out_fname + " " + temp_in_file
|
||||
-device = "-sDEVICE=tiffg4 -dNOPAUSE -dBATCH -dSAFER -dPARANOIDSAFER -dSHORTERRORS -dWRITESYSTEMDICT -dGHOSTSCRIPT -sstdout=%stderr -sOutputFile=" + temp_out_fname + " " + temp_in_file
|
||||
-
|
||||
-gs_command = "/usr/bin/gs" + " " + font + " " + device
|
||||
-
|
||||
-exit_code = os.system(gs_command)
|
||||
-#if exit_code != 0:
|
||||
-# print("Ghostscript returned error (error code %d)!" % exit_code)
|
||||
-# sys.exit(exit_code)
|
||||
-
|
||||
-file_len = os.stat(temp_out_fname).st_size
|
||||
-if (file_len < READ_SIZE):
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up hplip-3.10.2/ui4/systemtray.py.tray-icon-crash hplip-3.10.2/ui4/systemtray.py
|
||||
--- hplip-3.10.2/ui4/systemtray.py.tray-icon-crash 2010-02-24 23:07:15.000000000 +0000
|
||||
+++ hplip-3.10.2/ui4/systemtray.py 2010-03-23 16:42:24.476504861 +0000
|
||||
@@ -489,6 +489,7 @@ class SystemTrayApp(QApplication):
|
||||
log.debug("Exiting")
|
||||
self.sendMessage('', '', EVENT_SYSTEMTRAY_EXIT)
|
||||
self.quit()
|
||||
+ del self.tray_icon
|
||||
|
||||
|
||||
def toolboxTriggered(self):
|
@ -1,15 +1,18 @@
|
||||
diff -up hplip-3.10.2/data/rules/56-hpmud_support.rules.udev-rules hplip-3.10.2/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.10.2/data/rules/56-hpmud_support.rules.udev-rules 2010-03-01 11:21:01.049740484 +0000
|
||||
+++ hplip-3.10.2/data/rules/56-hpmud_support.rules 2010-03-01 11:21:07.288609454 +0000
|
||||
@@ -7,8 +7,9 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
diff -up hplip-3.10.5/data/rules/56-hpmud_support.rules.udev-rules hplip-3.10.5/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.10.5/data/rules/56-hpmud_support.rules.udev-rules 2010-05-13 01:44:22.000000000 +0200
|
||||
+++ hplip-3.10.5/data/rules/56-hpmud_support.rules 2010-05-17 16:12:42.000000000 +0200
|
||||
@@ -6,10 +6,11 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
|
||||
LABEL="pid_test"
|
||||
|
||||
+ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
|
||||
# Check for LaserJet products (0x03f0xx17).
|
||||
-SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="??17", ENV{hp_model}="$sysfs{product}", ENV{hp_test}="yes"
|
||||
+ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
|
||||
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attr{product}", ENV{hp_test}="yes"
|
||||
|
||||
# Check for LaserJet products (0x03f0xx2a).
|
||||
-SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="??2a", ENV{hp_model}="$sysfs{product}", ENV{hp_test}="yes"
|
||||
-ENV{hp_test}=="yes", RUN+="bin/sh -c '/usr/bin/hp-mkuri -c &'"
|
||||
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??2a", ENV{hp_model}="$attr{product}", ENV{hp_test}="yes"
|
||||
+ENV{hp_test}=="yes", RUN+="/bin/sh -c '/usr/bin/hp-mkuri -c &'"
|
||||
|
||||
-LABEL="hpmud_rules_end"
|
||||
|
20
hplip.spec
20
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.10.2
|
||||
Release: 16%{?dist}
|
||||
Version: 3.10.5
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -22,7 +22,6 @@ Patch5: hplip-deviceIDs-drv.patch
|
||||
Patch6: hplip-mucks-with-spooldir.patch
|
||||
Patch7: hplip-udev-rules.patch
|
||||
Patch8: hplip-retry-open.patch
|
||||
Patch9: hplip-tray-icon-crash.patch
|
||||
Patch10: hplip-discovery-method.patch
|
||||
Patch11: hplip-device-reconnected.patch
|
||||
Patch12: hplip-clear-old-state-reasons.patch
|
||||
@ -138,10 +137,10 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
%patch4 -p1 -b .no-asm
|
||||
|
||||
# Corrected several IEEE 1284 Device IDs using foomatic data.
|
||||
# HP LaserJet P1007 (bug #585272).
|
||||
# HP Color LaserJet CM1312nfi (bug #581005).
|
||||
# HP Color LaserJet 3800 (bug #581935).
|
||||
# HP Color LaserJet 2840 (bug #582215).
|
||||
# HP LaserJet P1007 (bug #585272).
|
||||
%patch5 -p1 -b .deviceIDs-drv
|
||||
|
||||
# Stopped hpcups pointlessly trying to read spool files
|
||||
@ -155,9 +154,6 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
# Retry when connecting to device fails (bug #532112).
|
||||
%patch8 -p1 -b .retry-open
|
||||
|
||||
# Explicitly destroy tray icon on exit (bug #543286).
|
||||
%patch9 -p1 -b .tray-icon-crash
|
||||
|
||||
# Fixed hp-setup traceback when discovery page is skipped (bug #523685).
|
||||
%patch10 -p1 -b .discovery-method
|
||||
|
||||
@ -178,10 +174,10 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
||||
# HP LaserJet 1320 series (bug #579920)
|
||||
# HP LaserJet 2300 (bug #576928)
|
||||
# HP LaserJet P2015 Series (bug #580231)
|
||||
# HP Color LaserJet 3800 (bug #581935).
|
||||
# HP Color LaserJet 2840 (bug #582215).
|
||||
# HP LaserJet 4250 (bug #585499).
|
||||
# HP Color LaserJet 2605dn (bug #583953).
|
||||
# HP Color LaserJet 3800 (bug #581935).
|
||||
# HP Color LaserJet 2840 (bug #582215).
|
||||
for ppd_file in $(grep '^diff' %{PATCH17} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
@ -198,7 +194,7 @@ done
|
||||
# Added missing newline to string argument in dbglog() call (bug #585275).
|
||||
%patch19 -p1 -b .dbglog-newline
|
||||
|
||||
# Wait for max 30s to see if a system tray becomes available (bug #569969).
|
||||
# Wait longer to see if a system tray becomes available (bug #569969).
|
||||
%patch20 -p1 -b .no-system-tray
|
||||
|
||||
# Prevent segfault in cupsext when opening PPD file (bug #572775).
|
||||
@ -425,6 +421,10 @@ fi
|
||||
%{_bindir}/hpcups-update-ppds &>/dev/null ||:
|
||||
|
||||
%changelog
|
||||
* Mon May 17 2010 Jiri Popelka <jpopelka@redhat.com> - 3.10.5-1
|
||||
- 3.10.5. No longer need tray-icon-crash.patch
|
||||
- Increase the timeout for system tray availability checking (bug #569969).
|
||||
|
||||
* Wed May 12 2010 Jiri Popelka <jpopelka@redhat.com> - 3.10.2-16
|
||||
- Prevent segfault in cupsext when opening PPD file (bug #572775).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user