2139309 - hplip-3.22.10 is available
This commit is contained in:
parent
ca1713968e
commit
a960ac4214
1
.gitignore
vendored
1
.gitignore
vendored
@ -107,3 +107,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.22.2-repack.tar.gz
|
||||
/hplip-3.22.4-repack.tar.gz
|
||||
/hplip-3.22.6-repack.tar.gz
|
||||
/hplip-3.22.10-repack.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/ui5/fabwindow.py b/ui5/fabwindow.py
|
||||
index 0b95c94..631727c 100644
|
||||
--- a/ui5/fabwindow.py
|
||||
+++ b/ui5/fabwindow.py
|
||||
@@ -518,7 +518,7 @@ class FABWindow(QMainWindow, Ui_MainWindow):
|
||||
self.__tr("Import fax addresses from LDIF or vCard"),
|
||||
#user_conf.workingDirectory(),
|
||||
self.user_settings.working_dir,
|
||||
- "vCard (*.vcf);;LDIF (*.ldif *.ldi)"))
|
||||
+ "vCard (*.vcf);;LDIF (*.ldif *.ldi)")[0])
|
||||
|
||||
if result:
|
||||
working_directory = to_unicode(os.path.dirname(result))
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.21.12/base/password.py.osname-mismatch hplip-3.21.12/base/password.py
|
||||
--- hplip-3.21.12/base/password.py.osname-mismatch 2022-01-14 08:36:11.413431048 +0100
|
||||
+++ hplip-3.21.12/base/password.py 2022-01-14 09:14:57.315230889 +0100
|
||||
@@ -105,7 +105,7 @@ def get_distro_name():
|
||||
os_name = name.read().strip()
|
||||
name.close()
|
||||
|
||||
- os_name = os_name.lower()
|
||||
+ os_name = os_name.lower().replace(' ','')
|
||||
if 'MX' in distro_release_name:
|
||||
os_name = "mxlinux"
|
||||
if "redhatenterprise" in os_name:
|
45
hplip.spec
45
hplip.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.22.6
|
||||
Release: 5%{?dist}
|
||||
Version: 3.22.10
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -171,25 +171,19 @@ Patch53: hplip-revert-plugins.patch
|
||||
# non-sudoers cannot authenticate
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1904888
|
||||
Patch54: hplip-check-userperms.patch
|
||||
# 1919556 - hp-fab crashed: QFileDialog.getOpenFileName is not used correctly
|
||||
# getOpenFileName returns a tuple, but hp-fab expects a simple variable
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/1914743
|
||||
Patch55: hplip-fab-import.patch
|
||||
# if an user tries to install scanner via hp-setup (printer/fax utility)
|
||||
# it fails further down - break out earlier with a message
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/1916114
|
||||
Patch56: hplip-hpsetup-noscanjets.patch
|
||||
Patch55: hplip-hpsetup-noscanjets.patch
|
||||
# 1963114 - patch for hplip firmware load timeout fix
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1922404
|
||||
Patch57: hplip-hpfirmware-timeout.patch
|
||||
Patch56: hplip-hpfirmware-timeout.patch
|
||||
# 1985251 - Incorrect permission for gpg directory
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938442
|
||||
Patch58: hplip-gpgdir-perms.patch
|
||||
Patch57: hplip-gpgdir-perms.patch
|
||||
# 1987141 - hp-plugin installs malformed udev files
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1847477
|
||||
Patch59: hplip-plugin-udevissues.patch
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938504
|
||||
Patch60: hplip-osname-mismatch.patch
|
||||
Patch58: hplip-plugin-udevissues.patch
|
||||
# 2080235 - Misleading errors about missing shared libraries when scanning
|
||||
# downstream patch to prevent errors:
|
||||
# - when loading libhpmud.so - unversioned .so files belong into devel packages,
|
||||
@ -198,11 +192,11 @@ Patch60: hplip-osname-mismatch.patch
|
||||
# package (if libhpmud.so had been moved to -devel) the dlopen on unversioned .so file was
|
||||
# removed
|
||||
# - /lib64/libm.so is not symlink but ld script, which cannot be used in dlopen()
|
||||
Patch61: hplip-no-libhpmud-libm-warnings.patch
|
||||
Patch59: hplip-no-libhpmud-libm-warnings.patch
|
||||
# hplip 3.22.6 doesn't use the correct arguments for snprintf
|
||||
# reported as https://bugs.launchpad.net/hplip/+bug/1982185
|
||||
Patch62: hplip-snprintf-format.patch
|
||||
Patch63: hplip-plugin-script.patch
|
||||
Patch60: hplip-snprintf-format.patch
|
||||
Patch61: hplip-plugin-script.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui if you want to have GUI
|
||||
@ -510,24 +504,20 @@ done
|
||||
%patch53 -p1 -b .revert-plugins
|
||||
# 1899410 - non-sudoers cannot authenticate because of bad username in prompt
|
||||
%patch54 -p1 -b .check-userperms
|
||||
# 1919556 - hp-fab crashed: QFileDialog.getOpenFileName is not used correctly
|
||||
%patch55 -p1 -b .fab-import
|
||||
# if an user tries to install scanner via hp-setup (printer/fax utility)
|
||||
# it fails further down - break out earlier with a message
|
||||
%patch56 -p1 -b .hpsetup-noscanjets
|
||||
%patch55 -p1 -b .hpsetup-noscanjets
|
||||
# 1963114 - patch for hplip firmware load timeout fix
|
||||
%patch57 -p1 -b .hpfirmware-timeout
|
||||
%patch56 -p1 -b .hpfirmware-timeout
|
||||
# 1985251 - Incorrect permission for gpg directory
|
||||
%patch58 -p1 -b .gpgdir-perms
|
||||
%patch57 -p1 -b .gpgdir-perms
|
||||
# 1987141 - hp-plugin installs malformed udev files
|
||||
%patch59 -p1 -b .hpplugin-udevperms
|
||||
# upstream bug https://bugs.launchpad.net/hplip/+bug/1938504
|
||||
%patch60 -p1 -b .osname-mismatch
|
||||
%patch58 -p1 -b .hpplugin-udevperms
|
||||
# 2080235 - Misleading errors about missing shared libraries when scanning
|
||||
%patch61 -p1 -b .no-libm-libhpmud-warn
|
||||
%patch59 -p1 -b .no-libm-libhpmud-warn
|
||||
# hplip 3.22.6 doesn't use proper arguments for snprintf
|
||||
%patch62 -p1 -b .snprintf-format
|
||||
%patch63 -p1 -b .plugin-patch
|
||||
%patch60 -p1 -b .snprintf-format
|
||||
%patch61 -p1 -b .plugin-patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui should be installed if you want GUI
|
||||
@ -889,6 +879,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Wed Nov 23 2022 Zdenek Dohnal <zdohnal@redhat.com> - 3.22.10-1
|
||||
- 2139309 - hplip-3.22.10 is available
|
||||
|
||||
* Wed Oct 19 2022 Zdenek Dohnal <zdohnal@redhat.com> - 3.22.6-5
|
||||
- distutils will be removed in Python3.12, use setuptools now
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hplip-3.22.6-repack.tar.gz) = 6296bf9751b2202beb28e481b556fab838a82905fbc40429bcd654570491e6d9cf8fb9c6d4781924136968d71ad47cba32b4385577e7062ce4a8ee23df44b9da
|
||||
SHA512 (hplip-3.22.10-repack.tar.gz) = cc7cc12ed04e08cbded581351280b71e13525b06a333d43078d67ae591baeecd29773a7f7fb5ebfc3dd842b1e4c9a84af9c5747987ef1941d1eef405ecb65fc1
|
||||
|
Loading…
Reference in New Issue
Block a user