2252302 - hplip-3.23.12 is available
This commit is contained in:
parent
b7a8b0b5a8
commit
a6c2c2b70b
1
.gitignore
vendored
1
.gitignore
vendored
@ -111,3 +111,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.23.3-repack.tar.gz
|
||||
/hplip-3.23.5-repack.tar.gz
|
||||
/hplip-3.23.8-repack.tar.gz
|
||||
/hplip-3.23.12-repack.tar.gz
|
||||
|
@ -1,14 +1,3 @@
|
||||
--- hplip-3.20.3/prnt/hpps/hppsfilter.c.orig 2020-03-25 01:09:51.585129957 +0000
|
||||
+++ hplip-3.20.3/prnt/hpps/hppsfilter.c 2020-03-25 01:10:15.610058293 +0000
|
||||
@@ -104,7 +104,7 @@ static void open_tempbookletfile(char *m
|
||||
if(ptempbooklet_file == NULL)
|
||||
{
|
||||
fprintf(stderr, "ERROR: Unable to open temp file %s\n", temp_filename);
|
||||
- return 1;
|
||||
+ return;
|
||||
}
|
||||
chmod(temp_filename, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
|
||||
|
||||
--- hplip-3.20.3/scan/sane/hpaio.c.orig 2020-03-25 01:24:15.558732638 +0000
|
||||
+++ hplip-3.20.3/scan/sane/hpaio.c 2020-03-25 02:48:36.097054366 +0000
|
||||
@@ -406,20 +406,34 @@ extern SANE_Status sane_hpaio_open(SANE_
|
||||
|
@ -1,51 +0,0 @@
|
||||
diff -up hplip-3.23.3/protocol/hp_ipp.c.snprintf-format hplip-3.23.3/protocol/hp_ipp.c
|
||||
--- hplip-3.23.3/protocol/hp_ipp.c.snprintf-format 2023-03-28 09:26:11.000000000 +0200
|
||||
+++ hplip-3.23.3/protocol/hp_ipp.c 2023-05-29 14:21:30.872871575 +0200
|
||||
@@ -108,10 +108,10 @@ int addCupsPrinter(char *name, char *dev
|
||||
goto abort;
|
||||
}
|
||||
|
||||
- if ( info == NULL )
|
||||
- snprintf( info,sizeof(info), name );
|
||||
+ if ( info == NULL )
|
||||
+ info = name;
|
||||
|
||||
- sprintf(printer_uri, "ipp://localhost/printers/%s", name);
|
||||
+ snprintf( printer_uri, sizeof(printer_uri), "ipp://localhost/printers/%s", name);
|
||||
|
||||
cupsSetUser("root");
|
||||
/* Connect to the HTTP server */
|
||||
@@ -514,27 +514,27 @@ int __parsePrinterAttributes(ipp_t *resp
|
||||
|
||||
if ( strcmp(attr_name, "printer-name") == 0 &&
|
||||
val_tag == IPP_TAG_NAME ) {
|
||||
- snprintf(t_printer->name, sizeof(t_printer->name),ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->name, sizeof(t_printer->name), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "device-uri") == 0 &&
|
||||
val_tag == IPP_TAG_URI ) {
|
||||
- snprintf(t_printer->device_uri,sizeof(t_printer->device_uri), ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->device_uri, sizeof(t_printer->device_uri), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "printer-uri-supported") == 0 &&
|
||||
val_tag == IPP_TAG_URI ) {
|
||||
- snprintf(t_printer->printer_uri,sizeof(t_printer->printer_uri), ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->printer_uri, sizeof(t_printer->printer_uri), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "printer-info") == 0 &&
|
||||
val_tag == IPP_TAG_TEXT ) {
|
||||
- snprintf(t_printer->info,sizeof(t_printer->info), ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->info, sizeof(t_printer->info), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "printer-location") == 0 &&
|
||||
val_tag == IPP_TAG_TEXT ) {
|
||||
- snprintf(t_printer->location,sizeof(t_printer->location),ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->location, sizeof(t_printer->location), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "printer-make-and-model") == 0 &&
|
||||
val_tag == IPP_TAG_TEXT ) {
|
||||
- snprintf(t_printer->make_model,sizeof(t_printer->make_model),ippGetString(attr, 0, NULL) );
|
||||
+ snprintf(t_printer->make_model, sizeof(t_printer->make_model), "%s", ippGetString(attr, 0, NULL));
|
||||
}
|
||||
else if ( strcmp(attr_name, "printer-state") == 0 &&
|
||||
val_tag == IPP_TAG_ENUM ) {
|
@ -396,25 +396,3 @@ index 98f57fd..1a74d6d 100755
|
||||
("To specify the device URI to install:", "-d<device> or --device=<device> (--qt4 mode only)", "option", False),
|
||||
("Remove printers or faxes instead of setting-up:", "-r or --rm or --remove", "option", False),
|
||||
utils.USAGE_LANGUAGE,
|
||||
diff --git a/ui5/devmgr_ext.py b/ui5/devmgr_ext.py
|
||||
index 34b4977..6b7a61e 100644
|
||||
--- a/ui5/devmgr_ext.py
|
||||
+++ b/ui5/devmgr_ext.py
|
||||
@@ -12,7 +12,7 @@ class Ui_MainWindow_Derived(object):
|
||||
|
||||
self.latest_available_version = latest_available_version
|
||||
self.Is_autoInstaller_distro = Is_autoInstaller_distro
|
||||
- if self.latest_available_version is not "":
|
||||
+ if self.latest_available_version != "":
|
||||
self.tab_3 = QWidget()
|
||||
self.tab_3.setObjectName("tab_3")
|
||||
self.label = QLabel(self.tab_3)
|
||||
@@ -34,7 +34,7 @@ class Ui_MainWindow_Derived(object):
|
||||
|
||||
def retranslateUi(self, MainWindow):
|
||||
super(Ui_MainWindow_Derived, self).retranslateUi(MainWindow)
|
||||
- if self.latest_available_version is not "":
|
||||
+ if self.latest_available_version != "":
|
||||
self.label.setText(QApplication.translate("MainWindow", "New version of HPLIP-%s is available"%self.latest_available_version, None))
|
||||
self.Tabs.setTabText(self.Tabs.indexOf(self.tab_3), QApplication.translate("MainWindow", "Upgrade", None))
|
||||
if self.Is_autoInstaller_distro:
|
||||
|
12
hplip.spec
12
hplip.spec
@ -6,7 +6,7 @@
|
||||
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.23.8
|
||||
Version: 3.23.12
|
||||
Release: 1%{?dist}
|
||||
# most files (base/*, *, ui*/...) - GPL2+
|
||||
# prnt/hpijs/ jpeg related files - IJG
|
||||
@ -199,9 +199,6 @@ Patch57: hplip-plugin-udevissues.patch
|
||||
# removed
|
||||
# - /lib64/libm.so is not symlink but ld script, which cannot be used in dlopen()
|
||||
Patch58: hplip-no-libhpmud-libm-warnings.patch
|
||||
# hplip 3.22.6 doesn't use the correct arguments for snprintf
|
||||
# reported as https://bugs.launchpad.net/hplip/+bug/1982185
|
||||
Patch59: hplip-snprintf-format.patch
|
||||
Patch60: hplip-plugin-script.patch
|
||||
# C99 compatibility fixes by fweimer - use explicit int
|
||||
# Submitted upstream: <https://bugs.launchpad.net/hplip/+bug/1997875>
|
||||
@ -238,6 +235,7 @@ Patch69: hplip-no-readfp.patch
|
||||
# fix SyntaxWarning from python3.12
|
||||
# https://bugs.launchpad.net/hplip/+bug/2029480
|
||||
Patch70: hplip-use-raw-strings.patch
|
||||
Patch71: hplip-hpaio-c99.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui if you want to have GUI
|
||||
@ -563,8 +561,6 @@ done
|
||||
%patch -P 57 -p1 -b .hpplugin-udevperms
|
||||
# 2080235 - Misleading errors about missing shared libraries when scanning
|
||||
%patch -P 58 -p1 -b .no-libm-libhpmud-warn
|
||||
# hplip 3.22.6 doesn't use proper arguments for snprintf
|
||||
%patch -P 59 -p1 -b .snprintf-format
|
||||
%patch -P 60 -p1 -b .plugin-patch
|
||||
# C99 compatibility fixes by fweimer - use explicit int
|
||||
# Submitted upstream: <https://bugs.launchpad.net/hplip/+bug/1997875>
|
||||
@ -594,6 +590,7 @@ done
|
||||
# fix warnings
|
||||
# upstream https://bugs.launchpad.net/hplip/+bug/2029480
|
||||
%patch -P 70 -p1 -b .raw-strings
|
||||
%patch -P 71 -p1 -b .hpaio-c99
|
||||
|
||||
# Fedora specific patches now, don't put a generic patches under it
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
@ -965,6 +962,9 @@ find doc/images -type f -exec chmod 644 {} \;
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Mon Jan 08 2024 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.12-1
|
||||
- 2252302 - hplip-3.23.12 is available
|
||||
|
||||
* Tue Oct 03 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.8-1
|
||||
- 2239465 - hplip-3.23.8 is available
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hplip-3.23.8-repack.tar.gz) = 07df27ee2389f351c917011c939c221e835bbfe30211bfaa69bbb9b0897bb6cc33ab697b25ac4d614a587be60d96d60b681a51c92e4d8ea60043187275004d2e
|
||||
SHA512 (hplip-3.23.12-repack.tar.gz) = 7e4713e5769a59e686aeada778b91ec65a6f8a2e393bd13473fb77be4ef1e1c470ae355b22ffa13f4f2e2353533f6a855b9749a267543d2dfb1f630724fb7100
|
||||
|
Loading…
Reference in New Issue
Block a user