1727162 - [abrt] hplip: strlen(): hp killed by SIGSEGV
This commit is contained in:
parent
b11a4fdffa
commit
a47ba5b07f
13
hplip-logging-segfault.patch
Normal file
13
hplip-logging-segfault.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/io/hpmud/musb.c b/io/hpmud/musb.c
|
||||
index 755493e..6d9c7fc 100644
|
||||
--- a/io/hpmud/musb.c
|
||||
+++ b/io/hpmud/musb.c
|
||||
@@ -1454,7 +1454,7 @@ enum HPMUD_RESULT __attribute__ ((visibility ("hidden"))) musb_raw_channel_write
|
||||
BUG("unable to write data %s: %d second io timeout\n", msp->device[pc->dindex].uri, sec_timeout);
|
||||
}
|
||||
else
|
||||
- BUG("unable to write data (len = %d) %s: %m\n", msp->device[pc->dindex].uri, len);
|
||||
+ BUG("unable to write data (len = %d) %s: %m\n", len, msp->device[pc->dindex].uri);
|
||||
goto bugout;
|
||||
}
|
||||
if(len == 0 && size > 0)
|
11
hplip.spec
11
hplip.spec
@ -7,7 +7,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.19.6
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -106,6 +106,10 @@ Patch47: hplip-hpcups-crash.patch
|
||||
# Fixing the issues found by coverity scan
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1808145
|
||||
Patch48: hplip-covscan.patch
|
||||
# Segfault during logging to syslog because argument are switched
|
||||
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1727162
|
||||
# upstream https://bugs.launchpad.net/hplip/+bug/1837846
|
||||
Patch49: hplip-logging-segfault.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: python3-pillow
|
||||
@ -352,6 +356,8 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
%patch47 -p1 -b .hpcups-crash
|
||||
# fixing issues found by coverity scan
|
||||
%patch48 -p1 -b .covscan
|
||||
# segfault during logging (1727162)
|
||||
%patch49 -p1 -b .logging-segfault
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -656,6 +662,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Thu Jul 25 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.6-2
|
||||
- 1727162 - [abrt] hplip: strlen(): hp killed by SIGSEGV
|
||||
|
||||
* Fri Jul 12 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.19.6-1
|
||||
- 3.19.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user