fix #1722222 without downstream patch, just call desktop-install-file with
other parameters
This commit is contained in:
parent
6405abd5ed
commit
a2eb0cb89a
@ -1,11 +0,0 @@
|
|||||||
diff --git a/hp-uiscan.desktop.in b/hp-uiscan.desktop.in
|
|
||||||
index 4a551e5..82d9360 100644
|
|
||||||
--- a/hp-uiscan.desktop.in
|
|
||||||
+++ b/hp-uiscan.desktop.in
|
|
||||||
@@ -5,4 +5,5 @@ Type=Application
|
|
||||||
Terminal=false
|
|
||||||
Name=hp-uiscan
|
|
||||||
Exec=/usr/bin/hp-uiscan
|
|
||||||
-Icon=/usr/share/icons/Humanity/devices/48/printer.svg
|
|
||||||
+Icon=hp_logo
|
|
||||||
+Categories=Graphics;Scanning;
|
|
18
hplip.spec
18
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.18.12
|
Version: 3.18.12
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -111,10 +111,6 @@ Patch46: hplip-m278-m281-needs-plugin.patch
|
|||||||
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1695716
|
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1695716
|
||||||
# reported upstream
|
# reported upstream
|
||||||
Patch47: hplip-hpcups-crash.patch
|
Patch47: hplip-hpcups-crash.patch
|
||||||
# hp-uiscan has bad link and missing entry in its desktop file
|
|
||||||
# Reported upstream https://bugs.launchpad.net/hplip/+bug/1833510
|
|
||||||
# bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1722222
|
|
||||||
Patch48: hplip-uiscan-desktop.patch
|
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: python3-pillow
|
Requires: python3-pillow
|
||||||
@ -370,8 +366,6 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
|||||||
%patch46 -p1 -b .m278-m281-needs-plugin
|
%patch46 -p1 -b .m278-m281-needs-plugin
|
||||||
# 1695716 - hpcups crashes in Compressor destructor
|
# 1695716 - hpcups crashes in Compressor destructor
|
||||||
%patch47 -p1 -b .hpcups-crash
|
%patch47 -p1 -b .hpcups-crash
|
||||||
# 1722222 - Broken hp-uiscan.desktop (upstream bug).
|
|
||||||
%patch48 -p1 -b .uiscan-desktop
|
|
||||||
|
|
||||||
sed -i.duplex-constraints \
|
sed -i.duplex-constraints \
|
||||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||||
@ -477,18 +471,22 @@ desktop-file-validate hplip.desktop
|
|||||||
|
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
--dir %{buildroot}/%{_datadir}/applications \
|
--dir %{buildroot}/%{_datadir}/applications \
|
||||||
|
--add-category System \
|
||||||
|
--add-category Settings \
|
||||||
--add-category HardwareSettings \
|
--add-category HardwareSettings \
|
||||||
hplip.desktop
|
hplip.desktop
|
||||||
|
|
||||||
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/appdata/*.appdata.xml
|
appstream-util validate-relax --nonet %{buildroot}%{_datadir}/appdata/*.appdata.xml
|
||||||
|
|
||||||
# install hp-uiscan desktop file
|
# install hp-uiscan desktop file
|
||||||
sed -i 's/Humanity\/devices\/48\/printer.svg/\/hicolor\/32x32\/apps\/hp_logo.png/' hp-uiscan.desktop
|
sed -i 's/\/usr\/share\/icons\/Humanity\/devices\/48\/printer\.svg/hp_logo/' hp-uiscan.desktop
|
||||||
|
|
||||||
desktop-file-validate hp-uiscan.desktop
|
desktop-file-validate hp-uiscan.desktop
|
||||||
|
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
--dir %{buildroot}/%{_datadir}/applications \
|
--dir %{buildroot}/%{_datadir}/applications \
|
||||||
|
--add-category Graphics \
|
||||||
|
--add-category Scanning \
|
||||||
--add-category Application \
|
--add-category Application \
|
||||||
hp-uiscan.desktop
|
hp-uiscan.desktop
|
||||||
|
|
||||||
@ -672,6 +670,10 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 26 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.18.12-13
|
||||||
|
- fix #1722222 without downstream patch, just call desktop-install-file with
|
||||||
|
other parameters
|
||||||
|
|
||||||
* Thu Jun 20 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.18.12-12
|
* Thu Jun 20 2019 Zdenek Dohnal <zdohnal@redhat.com> - 3.18.12-12
|
||||||
- 1722222 - Broken hp-uiscan.desktop (upstream bug)
|
- 1722222 - Broken hp-uiscan.desktop (upstream bug)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user