Increased curl/wget/ping timeouts (bug #635388).
This commit is contained in:
parent
e5339eeb20
commit
9600251609
30
hplip-network-timeout.patch
Normal file
30
hplip-network-timeout.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -up hplip-3.10.6/installer/core_install.py.network-timeout hplip-3.10.6/installer/core_install.py
|
||||
--- hplip-3.10.6/installer/core_install.py.network-timeout 2010-07-19 04:17:37.000000000 +0200
|
||||
+++ hplip-3.10.6/installer/core_install.py 2010-09-20 11:35:54.000000000 +0200
|
||||
@@ -1546,7 +1546,7 @@ class CoreInstall(object):
|
||||
wget = utils.which("wget")
|
||||
if wget:
|
||||
wget = os.path.join(wget, "wget")
|
||||
- cmd = "%s --timeout=10 --output-document=- %s" % (wget, HTTP_GET_TARGET)
|
||||
+ cmd = "%s --timeout=30 --output-document=- %s" % (wget, HTTP_GET_TARGET)
|
||||
log.debug(cmd)
|
||||
status, output = self.run(cmd)
|
||||
log.debug("wget returned: %d" % status)
|
||||
@@ -1556,7 +1556,7 @@ class CoreInstall(object):
|
||||
curl = utils.which("curl")
|
||||
if curl:
|
||||
curl = os.path.join(curl, "curl")
|
||||
- cmd = "%s --output - --connect-timeout 5 --max-time 10 %s" % (curl, HTTP_GET_TARGET)
|
||||
+ cmd = "%s --output - --connect-timeout 15 --max-time 30 %s" % (curl, HTTP_GET_TARGET)
|
||||
log.debug(cmd)
|
||||
status, output = self.run(cmd)
|
||||
log.debug("curl returned: %d" % status)
|
||||
@@ -1567,7 +1567,7 @@ class CoreInstall(object):
|
||||
|
||||
if ping:
|
||||
ping = os.path.join(ping, "ping")
|
||||
- cmd = "%s -c1 -W1 -w10 %s" % (ping, PING_TARGET)
|
||||
+ cmd = "%s -c1 -W3 -w30 %s" % (ping, PING_TARGET)
|
||||
log.debug(cmd)
|
||||
status, output = self.run(cmd)
|
||||
log.debug("ping returned: %d" % status)
|
10
hplip.spec
10
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.10.6
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -36,6 +36,7 @@ Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-no-system-tray.patch
|
||||
Patch21: hplip-openPPD.patch
|
||||
Patch22: hplip-ppd-ImageableArea.patch
|
||||
Patch23: hplip-network-timeout.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -224,12 +225,14 @@ for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
done
|
||||
%patch22 -p1 -b .deviceIDs-ppd
|
||||
%patch22 -p1 -b .ImageableArea
|
||||
for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
do
|
||||
gzip -n ${ppd_file#*/}
|
||||
done
|
||||
|
||||
# Increase timeouts for curl, wget, ping for high latency networks (bug #635388).
|
||||
%patch23 -p1 -b .network-timeout
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -457,6 +460,9 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Sep 20 2010 Jiri Popelka <jpopelka@redhat.com> - 3.10.6-5
|
||||
- Increased timeouts for curl, wget, ping for high latency networks (bug #635388).
|
||||
|
||||
* Wed Sep 15 2010 Tim Waugh <twaugh@redhat.com>
|
||||
- Fixes from package review:
|
||||
- Main package and hpijs sub-package require cups for directories.
|
||||
|
Loading…
Reference in New Issue
Block a user