2015428 - python3.10 has Callable in collections.abc
This commit is contained in:
parent
8f08be8b1f
commit
8d02f877eb
26
hplip-py310-collections-abc.patch
Normal file
26
hplip-py310-collections-abc.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
diff --git a/base/exif.py b/base/exif.py
|
||||||
|
index 2b8c447..38dca63 100644
|
||||||
|
--- a/base/exif.py
|
||||||
|
+++ b/base/exif.py
|
||||||
|
@@ -798,7 +798,7 @@ class EXIF_header:
|
||||||
|
tag_name=tag_entry[0]
|
||||||
|
if len(tag_entry) != 1:
|
||||||
|
# optional 2nd tag element is present
|
||||||
|
- if isinstance(tag_entry[1], collections.Callable):
|
||||||
|
+ if isinstance(tag_entry[1], collections.abc.Callable):
|
||||||
|
# call mapping function
|
||||||
|
printable=tag_entry[1](values)
|
||||||
|
else:
|
||||||
|
diff --git a/ui5/devmgr5.py b/ui5/devmgr5.py
|
||||||
|
index 48b248f..aa911a5 100644
|
||||||
|
--- a/ui5/devmgr5.py
|
||||||
|
+++ b/ui5/devmgr5.py
|
||||||
|
@@ -1267,7 +1267,7 @@ class DevMgr5(Ui_MainWindow_Derived, Ui_MainWindow, QMainWindow):
|
||||||
|
def ActionsList_clicked(self, item):
|
||||||
|
if item is not None and self.click_lock is not item:
|
||||||
|
self.click_lock = item
|
||||||
|
- if item.cmd and isinstance(item.cmd, collections.Callable):
|
||||||
|
+ if item.cmd and isinstance(item.cmd, collections.abc.Callable):
|
||||||
|
dlg = item.cmd()
|
||||||
|
self.sendMessage('', '', EVENT_DEVICE_STOP_POLLING)
|
||||||
|
try:
|
10
hplip.spec
10
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.21.2
|
Version: 3.21.2
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -204,6 +204,9 @@ Patch65: hplip-gpgdir-perms.patch
|
|||||||
Patch66: hplip-plugin-udevissues.patch
|
Patch66: hplip-plugin-udevissues.patch
|
||||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938504
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938504
|
||||||
Patch67: hplip-osname-mismatch.patch
|
Patch67: hplip-osname-mismatch.patch
|
||||||
|
# 2015428 - python3.10 has Callable in collections.abc
|
||||||
|
# reported as https://bugs.launchpad.net/hplip/+bug/1948801
|
||||||
|
Patch68: hplip-py310-collections-abc.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -509,6 +512,8 @@ done
|
|||||||
%patch66 -p1 -b .hpplugin-udevperms
|
%patch66 -p1 -b .hpplugin-udevperms
|
||||||
# upstream bug https://bugs.launchpad.net/hplip/+bug/1938504
|
# upstream bug https://bugs.launchpad.net/hplip/+bug/1938504
|
||||||
%patch67 -p1 -b .osname-mismatch
|
%patch67 -p1 -b .osname-mismatch
|
||||||
|
# 2015428 - python3.10 has Callable in collections.abc
|
||||||
|
%patch68 -p1 -b .abc
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui should be installed if you want GUI
|
# mention hplip-gui should be installed if you want GUI
|
||||||
@ -857,6 +862,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 26 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-13
|
||||||
|
- 2015428 - python3.10 has Callable in collections.abc
|
||||||
|
|
||||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.21.2-12
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 3.21.2-12
|
||||||
- Rebuilt with OpenSSL 3.0.0
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user