Merge branch 'f24' into f25
This commit is contained in:
commit
7e0a835ef4
1
.gitignore
vendored
1
.gitignore
vendored
@ -80,3 +80,4 @@ hplip-3.10.6.tar.gz
|
|||||||
/hplip-3.16.9.tar.gz
|
/hplip-3.16.9.tar.gz
|
||||||
/hplip-3.16.10.tar.gz
|
/hplip-3.16.10.tar.gz
|
||||||
/hplip-3.16.11.tar.gz
|
/hplip-3.16.11.tar.gz
|
||||||
|
/hplip-3.17.4.tar.gz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.11 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAlg1MY8ACgkQc9dwzaWQR7nK8QCfT+tt+tvxPFv0XNOJ+9lRLkru
|
|
||||||
W/cAoIbp9Y+MohGJXH98Tx8bspwJp5US
|
|
||||||
=ncx7
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
hplip-3.17.4.tar.gz.asc
Normal file
7
hplip-3.17.4.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.4.11 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAljty0kACgkQc9dwzaWQR7mRAwCcCeOnZPH22yBMH8TKVCAk5vRC
|
||||||
|
tmQAn3uTUnklynBYgqC18ZuHQYhMw1+h
|
||||||
|
=UQnM
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,18 +0,0 @@
|
|||||||
diff -up hplip-3.16.8/prnt/filters/hpps.badwhitespace hplip-3.16.8/prnt/filters/hpps
|
|
||||||
--- hplip-3.16.8/prnt/filters/hpps.badwhitespace 2016-09-01 19:15:43.509068772 +0200
|
|
||||||
+++ hplip-3.16.8/prnt/filters/hpps 2016-09-01 19:32:47.861548645 +0200
|
|
||||||
@@ -197,11 +197,11 @@ if 'HPPinPrnt' in options and 'noHPPinPr
|
|
||||||
msg("Setting Pin to default")
|
|
||||||
else:
|
|
||||||
szKeyInitials = ['HPFIDigit', 'HPSEDigit', 'HPTHDigit', 'HPFTDigit']
|
|
||||||
- for x in szKeyInitials:
|
|
||||||
+ for x in szKeyInitials:
|
|
||||||
try:
|
|
||||||
- secpin += opts[x]
|
|
||||||
+ secpin += opts[x]
|
|
||||||
except KeyError:
|
|
||||||
- secpin += '0'
|
|
||||||
+ secpin += '0'
|
|
||||||
|
|
||||||
os.write(output_fd, to_bytes_utf8('@PJL SET HOLDKEY="%s"\x0a' % secpin))
|
|
||||||
|
|
13
hplip.spec
13
hplip.spec
@ -7,13 +7,13 @@
|
|||||||
# Hp-plugin-check is a switch, which allows testing if new hp-plugin is already available - SET TO 1 ONLY FOR LOCAL BUILDS WHEN REBASING,
|
# Hp-plugin-check is a switch, which allows testing if new hp-plugin is already available - SET TO 1 ONLY FOR LOCAL BUILDS WHEN REBASING,
|
||||||
# NO COMMITS WITH HPPLUGINCHECK 1 (lately HP ships new plugins a few days after new release, which makes hp-plugin non-functional
|
# NO COMMITS WITH HPPLUGINCHECK 1 (lately HP ships new plugins a few days after new release, which makes hp-plugin non-functional
|
||||||
# during this time). Any other time it should be set to 0.
|
# during this time). Any other time it should be set to 0.
|
||||||
%define hpplugincheck 0
|
%define hpplugincheck 1
|
||||||
%define urlplugin http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/%{name}-%{version}-plugin.run
|
%define urlplugin http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/%{name}-%{version}-plugin.run
|
||||||
|
|
||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.16.11
|
Version: 3.17.4
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD
|
License: GPLv2+ and MIT and BSD
|
||||||
|
|
||||||
Url: http://hplip.sourceforge.net/
|
Url: http://hplip.sourceforge.net/
|
||||||
@ -43,7 +43,6 @@ Patch21: hplip-strncpy.patch
|
|||||||
Patch22: hplip-no-write-bytecode.patch
|
Patch22: hplip-no-write-bytecode.patch
|
||||||
Patch23: hplip-silence-ioerror.patch
|
Patch23: hplip-silence-ioerror.patch
|
||||||
Patch24: hplip-3165-sourceoption.patch
|
Patch24: hplip-3165-sourceoption.patch
|
||||||
Patch25: hplip-badwhitespace.patch
|
|
||||||
|
|
||||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||||
Requires: python3-pillow
|
Requires: python3-pillow
|
||||||
@ -223,9 +222,6 @@ done
|
|||||||
# [abrt] hplip: hp-scan:663:<module>:NameError: name 'source_option' is not defined (bug #1341304)
|
# [abrt] hplip: hp-scan:663:<module>:NameError: name 'source_option' is not defined (bug #1341304)
|
||||||
%patch24 -p1 -b .sourceoption
|
%patch24 -p1 -b .sourceoption
|
||||||
|
|
||||||
# Bad whitespaces (bug #1372343)
|
|
||||||
%patch25 -p1 -b .badwhitespace
|
|
||||||
|
|
||||||
sed -i.duplex-constraints \
|
sed -i.duplex-constraints \
|
||||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||||
prnt/drv/hpcups.drv.in
|
prnt/drv/hpcups.drv.in
|
||||||
@ -488,6 +484,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 24 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.17.4-1
|
||||||
|
- rebase to 3.17.4
|
||||||
|
|
||||||
* Fri Jan 13 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.16.11-5
|
* Fri Jan 13 2017 Zdenek Dohnal <zdohnal@redhat.com> - 3.16.11-5
|
||||||
- reverting previous commit
|
- reverting previous commit
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user