3.12.2
This commit is contained in:
parent
3ecf8cedbe
commit
7b8837fb01
1
.gitignore
vendored
1
.gitignore
vendored
@ -44,3 +44,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.11.7.tar.gz
|
||||
/hplip-3.11.10.tar.gz
|
||||
/hplip-3.11.12.tar.gz
|
||||
/hplip-3.12.2.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk7h8FQACgkQc9dwzaWQR7nygQCg0B80Q754Q71F38ucXMWW21U2
|
||||
Dr8AoNHIrsvkf/cLHJspn40w3rBEAFmn
|
||||
=qCCO
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.12.2.tar.gz.asc
Normal file
7
hplip-3.12.2.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk8pKRgACgkQc9dwzaWQR7lm6wCg54kzo18JfmNyomd2/pPkvsXU
|
||||
K0IAn02+KiIK3aHL7lpv6eQ5mHHdVxgW
|
||||
=ExDh
|
||||
-----END PGP SIGNATURE-----
|
@ -1,20 +0,0 @@
|
||||
diff -up hplip-3.10.5/ui4/systemtray.py.no-system-tray hplip-3.10.5/ui4/systemtray.py
|
||||
--- hplip-3.10.5/ui4/systemtray.py.no-system-tray 2010-05-13 01:45:04.000000000 +0200
|
||||
+++ hplip-3.10.5/ui4/systemtray.py 2010-05-17 15:03:12.000000000 +0200
|
||||
@@ -74,6 +74,7 @@ HIDE_INACTIVE_DELAY = 5000
|
||||
BLIP_DELAY = 2000
|
||||
SET_MENU_DELAY = 1000
|
||||
MAX_MENU_EVENTS = 10
|
||||
+TRAY_AVAILABLE_TIMEOUT = 180
|
||||
|
||||
ERROR_STATE_TO_ICON = {
|
||||
ERROR_STATE_CLEAR: QSystemTrayIcon.Information,
|
||||
@@ -706,7 +707,7 @@ def run(read_pipe):
|
||||
app.setQuitOnLastWindowClosed(False) # If not set, settings dlg closes app
|
||||
|
||||
i = 0
|
||||
- while i < 10:
|
||||
+ while i < TRAY_AVAILABLE_TIMEOUT:
|
||||
if QSystemTrayIcon.isSystemTrayAvailable():
|
||||
break
|
||||
time.sleep(1.0)
|
17
hplip.spec
17
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.11.12
|
||||
Release: 3%{?dist}
|
||||
Version: 3.12.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -33,7 +33,6 @@ Patch16: hplip-bad-low-ink-warning.patch
|
||||
Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-no-system-tray.patch
|
||||
Patch21: hplip-ppd-ImageableArea.patch
|
||||
Patch22: hplip-raw_deviceID-traceback.patch
|
||||
Patch23: hplip-UnicodeDecodeError.patch
|
||||
@ -248,9 +247,6 @@ done
|
||||
# Added missing newline to string argument in dbglog() call (bug #585275).
|
||||
%patch19 -p1 -b .dbglog-newline
|
||||
|
||||
# Wait longer to see if a system tray becomes available (bug #569969).
|
||||
%patch20 -p1 -b .no-system-tray
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
do
|
||||
@ -368,7 +364,6 @@ rm -f %{buildroot}%{_cups_serverbin}/filter/hpcac
|
||||
rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING doc/*
|
||||
%{_bindir}/hp-align
|
||||
%{_bindir}/hp-check-plugin
|
||||
@ -449,7 +444,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%dir %attr(0774,root,lp) %{_localstatedir}/log/hp
|
||||
|
||||
%files common
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_sysconfdir}/udev/rules.d/*
|
||||
%dir %{_sysconfdir}/hp
|
||||
@ -459,7 +453,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_datadir}/hplip/data/models
|
||||
|
||||
%files libs
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libhpip.so.*
|
||||
# The so symlink is required here (see bug #489059).
|
||||
%{_libdir}/libhpmud.so*
|
||||
@ -467,7 +460,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{python_sitearch}/*
|
||||
|
||||
%files gui
|
||||
%defattr(-,root,root,-)
|
||||
%{_bindir}/hp-check
|
||||
%{_bindir}/hp-print
|
||||
%{_bindir}/hp-systray
|
||||
@ -483,7 +475,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_datadir}/hplip/ui4
|
||||
|
||||
%files -n hpijs
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/hpijs
|
||||
%{_bindir}/hpcups-update-ppds
|
||||
%dir %{_datadir}/ppd/HP
|
||||
@ -494,7 +485,6 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_cups_serverbin}/filter/hplipjs
|
||||
|
||||
%files -n libsane-hpaio
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/sane/libsane-*.so*
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
@ -519,6 +509,9 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Tue Feb 07 2012 Jiri Popelka <jpopelka@redhat.com> 3.12.2-1
|
||||
- 3.12.2
|
||||
|
||||
* Wed Jan 18 2012 Jiri Popelka <jpopelka@redhat.com> 3.11.12-3
|
||||
- Added IEEE 1284 Device ID for LaserJet P2035.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user