remove redundant files
This commit is contained in:
parent
f9aafff426
commit
76d7fdfefc
33
hplip-remove-hbpl.patch
Normal file
33
hplip-remove-hbpl.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index a3be3f1..0c74a12 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -583,10 +583,8 @@ hpcups_SOURCES = prnt/hpcups/HPCupsFilter.cpp prnt/hpcups/HPCupsFilter.h prnt/hp
|
||||
prnt/hpcups/dj3600ColorMaps.cpp prnt/hpcups/dj3320PrintModes.h \
|
||||
prnt/hpcups/dj4100PrintModes.h \
|
||||
prnt/hpcups/Hbpl1.cpp prnt/hpcups/Hbpl1.h prnt/hpcups/Hbpl1_Wrapper.h prnt/hpcups/PCLmGenerator.h \
|
||||
- prnt/hpcups/flate_colorspace.h prnt/hpcups/RunLenEncoding.h prnt/hpcups/common_defines.h \
|
||||
- prnt/hpcups/genPCLm.h \
|
||||
- common/utils.c common/utils.h prnt/hpcups/Hbpl1_Wrapper.cpp prnt/hpcups/genPCLm.cpp \
|
||||
- prnt/hpcups/genJPEGStrips.cpp prnt/hpcups/RunLenEncoding.cpp \
|
||||
+ prnt/hpcups/flate_colorspace.h \
|
||||
+ common/utils.c common/utils.h \
|
||||
prnt/hpcups/ImageProcessor.h
|
||||
|
||||
hpcups_CXXFLAGS = $(APDK_ENDIAN_FLAG) $(DBUS_CFLAGS)
|
||||
diff --git a/prnt/hpcups/Hbpl1.cpp b/prnt/hpcups/Hbpl1.cpp
|
||||
index 74a67f0..4cac4ab 100644
|
||||
--- a/prnt/hpcups/Hbpl1.cpp
|
||||
+++ b/prnt/hpcups/Hbpl1.cpp
|
||||
@@ -72,11 +72,6 @@ Hbpl1::Hbpl1 () : Encapsulator ()
|
||||
if ((m_pHbpl1Wrapper = fptr_create(this)) == NULL)
|
||||
m_init = false;
|
||||
}*/
|
||||
- m_pHbpl1Wrapper = new Hbpl1Wrapper(this);
|
||||
- if(m_pHbpl1Wrapper == NULL)
|
||||
- m_init = false;
|
||||
- else
|
||||
- m_init = true;
|
||||
}
|
||||
|
||||
Hbpl1::~Hbpl1()
|
@ -15,6 +15,8 @@ tar -xaf hplip-$VERSION.tar.gz || exit 1
|
||||
# remove unwanted files
|
||||
rm hplip-$VERSION/prnt/hpcups/ErnieFilter.{cpp,h} hplip-$VERSION/prnt/hpijs/ernieplatform.h || exit 1
|
||||
rm hplip-$VERSION/fax/filters/cdmfax/hpcupscdmfax.{cpp,h} hplip-$VERSION/fax/filters/cdmfax/jetlib.{cpp,h} hplip-$VERSION/fax/ppd/HP-Fax-CDM-hpcups.ppd.gz || exit 1
|
||||
rm hplip-$VERSION/prnt/hpcups/Hbpl1_Wrapper.cpp hplip-$VERSION/prnt/hpcups/genPCLm.{cpp,h} hplip-$VERSION/prnt/hpcups/common_defines.h hplip-$VERSION/prnt/hpcups/genJPEGStrips.cpp hplip-$VERSION/prnt/hpcups/RunLenEncoding.{h,cpp}
|
||||
rm hplip-$VERSION/locatedriver
|
||||
|
||||
# compress into a new tarball
|
||||
tar -cjvf hplip-$VERSION-repack.tar.gz hplip-$VERSION || exit 1
|
||||
|
@ -234,6 +234,8 @@ Patch68: hplip-plugin-curl.patch
|
||||
Patch69: hplip-no-readfp.patch
|
||||
# fix SyntaxWarning from python3.12
|
||||
Patch70: hplip-use-raw-strings.patch
|
||||
# more unfriendly licenses...
|
||||
Patch71: hplip-remove-hbpl.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui if you want to have GUI
|
||||
@ -587,6 +589,7 @@ done
|
||||
# Upstream https://bugs.launchpad.net/hplip/+bug/2028001
|
||||
%patch -P 69 -p1 -b .no-readfp
|
||||
%patch -P 70 -p1 -b .raw-strings
|
||||
%patch -P 71 -p1 -b .hbpl
|
||||
|
||||
# Fedora specific patches now, don't put a generic patches under it
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
@ -606,13 +609,12 @@ sed -i.env-python -e 's,^#!/usr/bin/env python,#!%{__python3},' \
|
||||
prnt/filters/hpps \
|
||||
fax/filters/pstotiff
|
||||
|
||||
rm locatedriver
|
||||
|
||||
cp -p %{SOURCE4} %{SOURCE5} ppd/hpcups
|
||||
|
||||
# 2129849 - move hp-plugin script into srcdir
|
||||
cp -p %{SOURCE7} .
|
||||
|
||||
|
||||
%build
|
||||
# Work-around Makefile.am imperfections.
|
||||
sed -i 's|^AM_INIT_AUTOMAKE|AM_INIT_AUTOMAKE([foreign])|g' configure.in
|
||||
@ -958,6 +960,9 @@ find doc/images -type f -exec chmod 644 {} \;
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Thu Jul 27 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.5-6
|
||||
- remove redundant files
|
||||
|
||||
* Fri Jul 21 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.5-6
|
||||
- fix syntax warnings
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hplip-3.23.5-repack.tar.gz) = 7616a088b6f2f5efbd5ec426b3de80099b56f435adb38c0acd1f60e7cd00e788f94a2e35136011a7d73dd48a891a3b713263132653c9a2acf0ba98d57a790b4c
|
||||
SHA512 (hplip-3.23.5-repack.tar.gz) = 7b16f86f18f77061396c4b70df47ebb2109a07a018fbadac550d873ee3d68edb9c1530fde3fec07ba5702f896243b81a6b9b23c4602953716ffbab7b025bbf86
|
||||
|
Loading…
Reference in New Issue
Block a user