3.10.9.
This commit is contained in:
commit
69f4e8d50d
1
.gitignore
vendored
1
.gitignore
vendored
@ -36,3 +36,4 @@ hplip-3.10.2.tar.gz
|
|||||||
hpcups-update-ppds.sh
|
hpcups-update-ppds.sh
|
||||||
hplip-3.10.5.tar.gz
|
hplip-3.10.5.tar.gz
|
||||||
hplip-3.10.6.tar.gz
|
hplip-3.10.6.tar.gz
|
||||||
|
/hplip-3.10.9.tar.gz
|
||||||
|
@ -1,7 +0,0 @@
|
|||||||
-----BEGIN PGP SIGNATURE-----
|
|
||||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
|
||||||
|
|
||||||
iEYEABECAAYFAkxDtwQACgkQc9dwzaWQR7nApgCcC0cVr7w9rEJdir1Gyl71m9rB
|
|
||||||
PEsAoK+qjoBn/ksBmhTiNQRYdr/XCE19
|
|
||||||
=MeCZ
|
|
||||||
-----END PGP SIGNATURE-----
|
|
7
hplip-3.10.9.tar.gz.asc
Normal file
7
hplip-3.10.9.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
-----BEGIN PGP SIGNATURE-----
|
||||||
|
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||||
|
|
||||||
|
iEYEABECAAYFAkyffvYACgkQc9dwzaWQR7krCACfZOWCMEx9/9g7IubrCDDVLqPe
|
||||||
|
3f0AoND9552Tt/dWtE9P3Yf4czYEOK6h
|
||||||
|
=bHV4
|
||||||
|
-----END PGP SIGNATURE-----
|
@ -1,36 +0,0 @@
|
|||||||
diff -up hplip-3.9.10/prnt/backend/hp.c.device-reconnected hplip-3.9.10/prnt/backend/hp.c
|
|
||||||
--- hplip-3.9.10/prnt/backend/hp.c.device-reconnected 2009-11-03 21:45:10.000000000 +0000
|
|
||||||
+++ hplip-3.9.10/prnt/backend/hp.c 2009-11-04 16:25:30.719129509 +0000
|
|
||||||
@@ -645,6 +645,7 @@ int main(int argc, char *argv[])
|
|
||||||
HPMUD_DEVICE hd=-1;
|
|
||||||
HPMUD_CHANNEL cd=-1;
|
|
||||||
int n, total=0, retry=0, size, pages;
|
|
||||||
+ int consecutive_failures=0;
|
|
||||||
enum HPMUD_RESULT stat;
|
|
||||||
char *printer = getenv("PRINTER");
|
|
||||||
|
|
||||||
@@ -809,11 +810,24 @@ int main(int argc, char *argv[])
|
|
||||||
{
|
|
||||||
exit_stat = BACKEND_STOP; /* stop queue */
|
|
||||||
goto bugout;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ if (++consecutive_failures == 5)
|
|
||||||
+ {
|
|
||||||
+ /* hpmud_write_channel has failed several times in
|
|
||||||
+ * succession but the Device ID-based status says
|
|
||||||
+ * the printer is happy. Time to face the fact that
|
|
||||||
+ * the device has probably reconnected, and our USB
|
|
||||||
+ * channel is invalidated. */
|
|
||||||
+
|
|
||||||
+ BUG("ERROR: device reconnected?");
|
|
||||||
+ goto bugout;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{
|
|
||||||
/* Data was sent to device successfully. */
|
|
||||||
+ consecutive_failures = 0;
|
|
||||||
if (pa.pjl_device)
|
|
||||||
{
|
|
||||||
/* Laserjets have a large data buffer, so manually check for operator intervention condition. */
|
|
@ -21,7 +21,7 @@ diff -up hplip-3.10.5/fax/filters/pstotiff.pstotiff-is-rubbish hplip-3.10.5/fax/
|
|||||||
-temp_out_handle, temp_out_fname = tempfile.mkstemp()
|
-temp_out_handle, temp_out_fname = tempfile.mkstemp()
|
||||||
-
|
-
|
||||||
-font = "-I/usr/share/cups/fonts"
|
-font = "-I/usr/share/cups/fonts"
|
||||||
-device = "-sDEVICE=tiffg4 -dNOPAUSE -dBATCH -dSAFER -dPARANOIDSAFER -dSHORTERRORS -dWRITESYSTEMDICT -dGHOSTSCRIPT -sstdout=%stderr -sOutputFile=" + temp_out_fname + " " + temp_in_file
|
-device = "-sDEVICE=tiffg4 -dMaxStripSize=0 -dNOPAUSE -dBATCH -dSAFER -dPARANOIDSAFER -dSHORTERRORS -dWRITESYSTEMDICT -dGHOSTSCRIPT -sstdout=%stderr -sOutputFile=" + temp_out_fname + " " + temp_in_file
|
||||||
-
|
-
|
||||||
-gs_command = "/usr/bin/gs" + " " + font + " " + device
|
-gs_command = "/usr/bin/gs" + " " + font + " " + device
|
||||||
-
|
-
|
||||||
|
11
hplip.spec
11
hplip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.10.6
|
Version: 3.10.9
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+ and MIT
|
License: GPLv2+ and MIT
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Conflicts: system-config-printer < 0.6.132
|
Conflicts: system-config-printer < 0.6.132
|
||||||
@ -24,7 +24,6 @@ Patch7: hplip-udev-rules.patch
|
|||||||
Patch8: hplip-retry-open.patch
|
Patch8: hplip-retry-open.patch
|
||||||
Patch9: hplip-snmp-quirks.patch
|
Patch9: hplip-snmp-quirks.patch
|
||||||
Patch10: hplip-discovery-method.patch
|
Patch10: hplip-discovery-method.patch
|
||||||
Patch11: hplip-device-reconnected.patch
|
|
||||||
Patch12: hplip-clear-old-state-reasons.patch
|
Patch12: hplip-clear-old-state-reasons.patch
|
||||||
Patch13: hplip-env-python.patch
|
Patch13: hplip-env-python.patch
|
||||||
Patch14: hplip-hpcups-sigpipe.patch
|
Patch14: hplip-hpcups-sigpipe.patch
|
||||||
@ -171,9 +170,6 @@ rm -rf $RPM_BUILD_DIR/%{name}-%{version}
|
|||||||
# Fixed hp-setup traceback when discovery page is skipped (bug #523685).
|
# Fixed hp-setup traceback when discovery page is skipped (bug #523685).
|
||||||
%patch10 -p1 -b .discovery-method
|
%patch10 -p1 -b .discovery-method
|
||||||
|
|
||||||
# Give up trying to print a job to a reconnected device (bug #515481).
|
|
||||||
%patch11 -p1 -b .device-reconnected
|
|
||||||
|
|
||||||
# Clear old printer-state-reasons we used to manage (bug #510926).
|
# Clear old printer-state-reasons we used to manage (bug #510926).
|
||||||
%patch12 -p1 -b .clear-old-state-reasons
|
%patch12 -p1 -b .clear-old-state-reasons
|
||||||
|
|
||||||
@ -460,6 +456,9 @@ fi
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 04 2010 Jiri Popelka <jpopelka@redhat.com> - 3.10.9-1
|
||||||
|
- 3.10.9.
|
||||||
|
|
||||||
* Wed Sep 22 2010 Tim Waugh <twaugh@redhat.com>
|
* Wed Sep 22 2010 Tim Waugh <twaugh@redhat.com>
|
||||||
- More fixes from package review:
|
- More fixes from package review:
|
||||||
- Avoided another macro in comment.
|
- Avoided another macro in comment.
|
||||||
|
Loading…
Reference in New Issue
Block a user