3.20.6
This commit is contained in:
parent
57dab6529d
commit
5eb8189bae
1
.gitignore
vendored
1
.gitignore
vendored
@ -98,3 +98,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.20.2.tar.gz
|
||||
/hplip-3.20.3.tar.gz
|
||||
/hplip-3.20.5.tar.gz
|
||||
/hplip-3.20.6.tar.gz
|
||||
|
@ -1,16 +1,10 @@
|
||||
commit cdf5cb36e5d5a86f6a690c5861666cdc2da70593
|
||||
Author: Tomas Korbar <tkorbar@redhat.com>
|
||||
Date: Wed Sep 19 15:33:03 2018 +0200
|
||||
|
||||
Fix TypeError in hpfax
|
||||
|
||||
diff --git a/fax/backend/hpfax.py b/fax/backend/hpfax.py
|
||||
index 9560e84..bc0912a 100755
|
||||
index a63051d..3e187c9 100755
|
||||
--- a/fax/backend/hpfax.py
|
||||
+++ b/fax/backend/hpfax.py
|
||||
@@ -89,7 +89,7 @@ try:
|
||||
from base import utils
|
||||
from prnt import cups
|
||||
#from prnt import cups
|
||||
except ImportError as e:
|
||||
- bug("Error importing HPLIP modules: %s\n" % (pid, e))
|
||||
+ bug("Error importing HPLIP modules: %s\n" % (e))
|
||||
|
@ -1,44 +1,7 @@
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index 57b2812..250e2dc 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -1542,6 +1542,7 @@ am__dist_ppd_DATA_DIST = prnt/ps/hp-designjet_z6810ps_42in-ps.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cm1418fnw-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025nw.ppd.gz \
|
||||
+ ppd/hpcups/hp-laserjet_cp_1025nw.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m1005.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m101-m106.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m1120_mfp.ppd.gz \
|
||||
@@ -1655,6 +1656,7 @@ am__dist_ppd_DATA_DIST = prnt/ps/hp-designjet_z6810ps_42in-ps.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p1608dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p1609dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p_1102w.ppd.gz \
|
||||
+ ppd/hpcups/hp-laserjet_professional_p1102w.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_240-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_320-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-neverstop_laser_100x.ppd.gz \
|
||||
@@ -3895,6 +3897,7 @@ dist_unrel_DATA =
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cm1418fnw-pcl3.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp1025.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp1025nw.ppd.gz \
|
||||
+@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp_1025nw.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m1005.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m101-m106.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m1120_mfp.ppd.gz \
|
||||
@@ -4007,6 +4010,7 @@ dist_unrel_DATA =
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1607dn.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1608dn.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1609dn.ppd.gz \
|
||||
+@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1102w.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p_1102w.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-mopier_240-pcl3.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-mopier_320-pcl3.ppd.gz \
|
||||
diff --git a/cups_drv.inc b/cups_drv.inc
|
||||
index 3863c52..50c570d 100644
|
||||
--- a/cups_drv.inc
|
||||
+++ b/cups_drv.inc
|
||||
@@ -398,6 +398,7 @@ cups_ppd_printers = \
|
||||
diff -up hplip-3.20.6/cups_drv.inc.missing-drivers hplip-3.20.6/cups_drv.inc
|
||||
--- hplip-3.20.6/cups_drv.inc.missing-drivers 2020-06-09 13:23:14.000000000 +0200
|
||||
+++ hplip-3.20.6/cups_drv.inc 2020-06-17 13:49:39.110952720 +0200
|
||||
@@ -407,6 +407,7 @@ cups_ppd_printers = \
|
||||
ppd/hpcups/hp-laserjet_cm1418fnw-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025nw.ppd.gz \
|
||||
@ -46,7 +9,7 @@ index 3863c52..50c570d 100644
|
||||
ppd/hpcups/hp-laserjet_m1005.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m101-m106.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m1120_mfp.ppd.gz \
|
||||
@@ -510,6 +511,7 @@ cups_ppd_printers = \
|
||||
@@ -520,6 +521,7 @@ cups_ppd_printers = \
|
||||
ppd/hpcups/hp-laserjet_professional_p1607dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p1608dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p1609dn.ppd.gz \
|
||||
@ -54,10 +17,9 @@ index 3863c52..50c570d 100644
|
||||
ppd/hpcups/hp-laserjet_professional_p_1102w.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_240-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_320-pcl3.ppd.gz \
|
||||
diff --git a/data/models/models.dat b/data/models/models.dat
|
||||
index 9dfcf3d..9da0acd 100644
|
||||
--- a/data/models/models.dat
|
||||
+++ b/data/models/models.dat
|
||||
diff -up hplip-3.20.6/data/models/models.dat.missing-drivers hplip-3.20.6/data/models/models.dat
|
||||
--- hplip-3.20.6/data/models/models.dat.missing-drivers 2020-06-17 13:49:39.080953000 +0200
|
||||
+++ hplip-3.20.6/data/models/models.dat 2020-06-17 13:49:39.120952626 +0200
|
||||
@@ -2104,7 +2104,7 @@ usb-pid=411
|
||||
usb-vid=3f0
|
||||
wifi-config=0
|
||||
@ -461,7 +423,7 @@ index 9dfcf3d..9da0acd 100644
|
||||
[officejet_100_mobile_l411]
|
||||
align-type=-1
|
||||
clean-type=1
|
||||
@@ -17865,6 +18229,58 @@ usb-pid=2c17
|
||||
@@ -17867,6 +18231,58 @@ usb-pid=2c17
|
||||
usb-vid=3f0
|
||||
wifi-config=0
|
||||
|
||||
@ -520,7 +482,7 @@ index 9dfcf3d..9da0acd 100644
|
||||
[hp_laserjet_cp1025nw]
|
||||
align-type=0
|
||||
clean-type=0
|
||||
@@ -18466,6 +18882,49 @@ usb-pid=3011
|
||||
@@ -18468,6 +18884,49 @@ usb-pid=3011
|
||||
usb-vid=3f0
|
||||
wifi-config=0
|
||||
|
||||
@ -570,15 +532,48 @@ index 9dfcf3d..9da0acd 100644
|
||||
[hp_laserjet_professional_p1102]
|
||||
align-type=0
|
||||
clean-type=0
|
||||
diff --git a/prnt/drv/hpcups.drv.in b/prnt/drv/hpcups.drv.in
|
||||
index 335b3da..d7a1872 100644
|
||||
--- a/prnt/drv/hpcups.drv.in
|
||||
+++ b/prnt/drv/hpcups.drv.in
|
||||
@@ -22258,6 +22258,14 @@ Group "RLT/HP Real Life Technologies"
|
||||
Attribute "Product" "" "(HP LaserJet Professional p1102 Printer)"
|
||||
diff -up hplip-3.20.6/Makefile.in.missing-drivers hplip-3.20.6/Makefile.in
|
||||
--- hplip-3.20.6/Makefile.in.missing-drivers 2020-06-09 13:23:20.000000000 +0200
|
||||
+++ hplip-3.20.6/Makefile.in 2020-06-17 13:49:39.110952720 +0200
|
||||
@@ -1571,6 +1571,7 @@ am__dist_ppd_DATA_DIST = prnt/ps/hp-lase
|
||||
ppd/hpcups/hp-laserjet_cm1418fnw-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_cp1025nw.ppd.gz \
|
||||
+ ppd/hpcups/hp-laserjet_cp_1025nw.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m1005.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m101-m106.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_m1120_mfp.ppd.gz \
|
||||
@@ -1685,6 +1686,7 @@ am__dist_ppd_DATA_DIST = prnt/ps/hp-lase
|
||||
ppd/hpcups/hp-laserjet_professional_p1608dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p1609dn.ppd.gz \
|
||||
ppd/hpcups/hp-laserjet_professional_p_1102w.ppd.gz \
|
||||
+ ppd/hpcups/hp-laserjet_professional_p1102w.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_240-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-mopier_320-pcl3.ppd.gz \
|
||||
ppd/hpcups/hp-neverstop_laser_100x.ppd.gz \
|
||||
@@ -3961,6 +3963,7 @@ dist_unrel_DATA =
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cm1418fnw-pcl3.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp1025.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp1025nw.ppd.gz \
|
||||
+@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_cp_1025nw.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m1005.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m101-m106.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_m1120_mfp.ppd.gz \
|
||||
@@ -4074,6 +4077,7 @@ dist_unrel_DATA =
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1607dn.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1608dn.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1609dn.ppd.gz \
|
||||
+@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p1102w.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-laserjet_professional_p_1102w.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-mopier_240-pcl3.ppd.gz \
|
||||
@HPLIP_CLASS_DRIVER_FALSE@ ppd/hpcups/hp-mopier_320-pcl3.ppd.gz \
|
||||
diff -up hplip-3.20.6/prnt/drv/hpcups.drv.in.missing-drivers hplip-3.20.6/prnt/drv/hpcups.drv.in
|
||||
--- hplip-3.20.6/prnt/drv/hpcups.drv.in.missing-drivers 2020-06-17 13:49:39.009953663 +0200
|
||||
+++ hplip-3.20.6/prnt/drv/hpcups.drv.in 2020-06-17 13:51:49.576733820 +0200
|
||||
@@ -22319,6 +22319,14 @@ Group "RLT/HP Real Life Technologies"
|
||||
Attribute "Product" "" "(HP LaserJet Professional p1102s Printer)"
|
||||
}
|
||||
+ {
|
||||
{
|
||||
+ ModelName "HP LaserJet Professional p1102w"
|
||||
+ Attribute "NickName" "" "HP LaserJet Professional p1102w, hpcups $Version, requires proprietary plugin"
|
||||
+ Attribute "ShortNickName" "" "HP LaserJet Professional p1102w hpijs"
|
||||
@ -586,10 +581,11 @@ index 335b3da..d7a1872 100644
|
||||
+ PCFileName "hp-laserjet_professional_p1102w.ppd"
|
||||
+ Attribute "Product" "" "(HP LaserJet Professional p1102w Printer)"
|
||||
+ }
|
||||
{
|
||||
+ {
|
||||
ModelName "HP LaserJet Professional p1106"
|
||||
Attribute "NickName" "" "HP LaserJet Professional p1106, hpcups $Version, requires proprietary plugin"
|
||||
@@ -22692,6 +22700,14 @@ Group "RLT/HP Real Life Technologies"
|
||||
Attribute "NickName" "" "HP LaserJet Professional p1106, hpcups $Version"
|
||||
Attribute "ShortNickName" "" "HP LJ Pro p1106 hpijs"
|
||||
@@ -22752,6 +22760,14 @@ Group "RLT/HP Real Life Technologies"
|
||||
PCFileName "hp-laserjet_cp1025nw.ppd"
|
||||
Attribute "Product" "" "(HP LaserJet Pro cp1025nw Color Printer Series)"
|
||||
}
|
||||
|
12
hplip.spec
12
hplip.spec
@ -6,8 +6,8 @@
|
||||
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.20.5
|
||||
Release: 6%{?dist}
|
||||
Version: 3.20.6
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -152,6 +152,10 @@ Patch54: hplip-find-driver.patch
|
||||
# bug https://bugzilla.redhat.com/show_bug.cgi?id=1833308
|
||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1882193
|
||||
Patch55: hplip-clean-ldl.patch
|
||||
# 3.20.6 turned off requirement for most devices which needed it
|
||||
# - it will cause malfunction of printing and scanning for them
|
||||
# https://bugs.launchpad.net/hplip/+bug/1883898
|
||||
Patch56: hplip-revert-plugins.patch
|
||||
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
@ -420,6 +424,7 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
%patch54 -p1 -b .find-driver
|
||||
# 1833308 - hp-clean cannot clean HP PSC1410 - Device I/O error
|
||||
%patch55 -p1 -b .clean-ldl
|
||||
%patch56 -p1 -b .revert-plugins
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -720,6 +725,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Wed Jun 17 2020 Zdenek Dohnal <zdohnal@redhat.com> - 3.20.6-1
|
||||
- 3.20.6
|
||||
|
||||
* Tue Jun 16 2020 Zdenek Dohnal <zdohnal@redhat.com> - 3.20.5-6
|
||||
- remove the check for scripts which are only in hplip-gui
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (hplip-3.20.5.tar.gz) = fce3c7b8a2f3b0d2875bafd2ff65a3312fae867b658cd45eea16d9f3663646b6b0b70b58e6c2b46eb24627cdeefb318b6ca9ccf5a0e9790ff19519518992da07
|
||||
SHA512 (hplip-3.20.6.tar.gz) = 6a5ce55465e3a537ecc0b6e7d198835dbe495e191522e674a507a4993e2061da3ea084a5239a74b2279c065c0775067d5b6a4aeb2a7791825106a299fb55e8f8
|
||||
|
Loading…
Reference in New Issue
Block a user