1985251 - Incorrect permission for gpg directory
This commit is contained in:
parent
0b9d626c35
commit
581db10c37
13
hplip-gpgdir-perms.patch
Normal file
13
hplip-gpgdir-perms.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/base/validation.py b/base/validation.py
|
||||||
|
index 96e65be..35f22eb 100644
|
||||||
|
--- a/base/validation.py
|
||||||
|
+++ b/base/validation.py
|
||||||
|
@@ -58,7 +58,7 @@ class GPG_Verification(DigiSign_Verification):
|
||||||
|
|
||||||
|
if not os.path.exists(self.__gpg_dir):
|
||||||
|
try:
|
||||||
|
- os.mkdir(self.__gpg_dir, 0o755)
|
||||||
|
+ os.mkdir(self.__gpg_dir, 0o700)
|
||||||
|
except OSError:
|
||||||
|
log.error("Failed to create %s" % self.__gpg_dir)
|
||||||
|
self.__change_owner()
|
10
hplip.spec
10
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.21.2
|
Version: 3.21.2
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -196,6 +196,9 @@ Patch63: hplip-hpfirmware-timeout.patch
|
|||||||
# 1976465 - [hplip] PY_SSIZE_T_CLEAN macro must be defined for '#' formats
|
# 1976465 - [hplip] PY_SSIZE_T_CLEAN macro must be defined for '#' formats
|
||||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1933973
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1933973
|
||||||
Patch64: hplip-pyssizet_clean.patch
|
Patch64: hplip-pyssizet_clean.patch
|
||||||
|
# 1985251 - Incorrect permission for gpg directory
|
||||||
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938442
|
||||||
|
Patch65: hplip-gpgdir-perms.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -495,6 +498,8 @@ done
|
|||||||
%patch63 -p1 -b .hpfirmware-timeout
|
%patch63 -p1 -b .hpfirmware-timeout
|
||||||
# 1976465 - [hplip] PY_SSIZE_T_CLEAN macro must be defined for '#' formats
|
# 1976465 - [hplip] PY_SSIZE_T_CLEAN macro must be defined for '#' formats
|
||||||
%patch64 -p1 -b .pyssizet_clean
|
%patch64 -p1 -b .pyssizet_clean
|
||||||
|
# 1985251 - Incorrect permission for gpg directory
|
||||||
|
%patch65 -p1 -b .gpgdir-perms
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui should be installed if you want GUI
|
# mention hplip-gui should be installed if you want GUI
|
||||||
@ -843,6 +848,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 30 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.21.2-10
|
||||||
|
- 1985251 - Incorrect permission for gpg directory
|
||||||
|
|
||||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.21.2-9
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.21.2-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user