3.11.1
This commit is contained in:
parent
f106c64c71
commit
2347ef53a2
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@ hpcups-update-ppds.sh
|
||||
hplip-3.10.5.tar.gz
|
||||
hplip-3.10.6.tar.gz
|
||||
/hplip-3.10.9.tar.gz
|
||||
/hplip-3.11.1.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAkyffvYACgkQc9dwzaWQR7krCACfZOWCMEx9/9g7IubrCDDVLqPe
|
||||
3f0AoND9552Tt/dWtE9P3Yf4czYEOK6h
|
||||
=bHV4
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.11.1.tar.gz.asc
Normal file
7
hplip-3.11.1.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk02dTEACgkQc9dwzaWQR7msfACeN0/IyBLgGwKxteNK9eK1xR0W
|
||||
b8kAn0nZXFOzvtEx+NHZ7N4STBngZXpI
|
||||
=rQyC
|
||||
-----END PGP SIGNATURE-----
|
@ -1,14 +0,0 @@
|
||||
diff -up hplip-3.10.9/base/utils.py.addgroup hplip-3.10.9/base/utils.py
|
||||
--- hplip-3.10.9/base/utils.py.addgroup 2010-10-14 10:52:34.000000000 +0200
|
||||
+++ hplip-3.10.9/base/utils.py 2010-10-14 11:35:17.000000000 +0200
|
||||
@@ -65,8 +65,8 @@ def addgroup():
|
||||
fp=open('/etc/cups/cupsd.conf')
|
||||
except IOError:
|
||||
try:
|
||||
- if "root" != grp.getgrgid(os.stat('/etc/cups/cupsd.conf').st_gid)[0]:
|
||||
- return grp.getgrgid(os.stat('/etc/cups/cupsd.conf').st_gid)[0]
|
||||
+ if "root" != grp.getgrgid(os.stat('/etc/cups/cupsd.conf').st_gid).gr_name:
|
||||
+ return [grp.getgrgid(os.stat('/etc/cups/cupsd.conf').st_gid).gr_name]
|
||||
except OSError:
|
||||
return lis
|
||||
|
@ -1,11 +1,11 @@
|
||||
diff -up hplip-3.10.9/prnt/cupsext/cupsext.c~ hplip-3.10.9/prnt/cupsext/cupsext.c
|
||||
--- hplip-3.10.9/prnt/cupsext/cupsext.c~ 2010-11-12 10:35:59.316957426 +0000
|
||||
+++ hplip-3.10.9/prnt/cupsext/cupsext.c 2010-11-12 15:58:27.467044126 +0000
|
||||
diff -up hplip-3.11.1/prnt/cupsext/cupsext.c.addprinter hplip-3.11.1/prnt/cupsext/cupsext.c
|
||||
--- hplip-3.11.1/prnt/cupsext/cupsext.c.addprinter 2011-01-19 06:15:27.000000000 +0100
|
||||
+++ hplip-3.11.1/prnt/cupsext/cupsext.c 2011-01-24 12:24:01.000000000 +0100
|
||||
@@ -510,6 +510,7 @@ PyObject * addPrinter( PyObject * self,
|
||||
strcpy( info, name );
|
||||
|
||||
/* Connect to the HTTP server */
|
||||
+ cupsSetUser ("root");
|
||||
if ( ( http = httpConnectEncrypt( cupsServer(), ippPort(), cupsEncryption() ) ) == NULL )
|
||||
{
|
||||
r = 0;
|
||||
strcpy( info, name );
|
||||
|
||||
/* Connect to the HTTP server */
|
||||
+ cupsSetUser ("root");
|
||||
if ( ( http = httpConnectEncrypt( cupsServer(), ippPort(), cupsEncryption() ) ) == NULL )
|
||||
{
|
||||
r = 0;
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up hplip-3.10.9/ui4/nodevicesdialog.py.cups-web hplip-3.10.9/ui4/nodevicesdialog.py
|
||||
--- hplip-3.10.9/ui4/nodevicesdialog.py.cups-web 2011-01-12 11:48:50.743722601 +0000
|
||||
+++ hplip-3.10.9/ui4/nodevicesdialog.py 2011-01-12 11:48:59.869475866 +0000
|
||||
@@ -71,7 +71,7 @@ class NoDevicesDialog(QDialog, Ui_NoDevi
|
||||
|
||||
def CUPSButton_clicked(self):
|
||||
self.close()
|
||||
- utils.openURL("http://localhost:631/admin?op=add-printer")
|
||||
+ utils.openURL("http://localhost:631/admin")
|
||||
|
||||
|
||||
def CloseButton_clicked(self):
|
||||
diff -up hplip-3.10.9/ui/nodevicesform.py.cups-web hplip-3.10.9/ui/nodevicesform.py
|
||||
--- hplip-3.10.9/ui/nodevicesform.py.cups-web 2011-01-12 11:48:31.161230788 +0000
|
||||
+++ hplip-3.10.9/ui/nodevicesform.py 2011-01-12 11:48:43.253920424 +0000
|
||||
@@ -43,7 +43,7 @@ class NoDevicesForm(NoDevicesForm_base):
|
||||
|
||||
def CUPSButton_clicked(self):
|
||||
self.close()
|
||||
- utils.openURL("http://localhost:631/admin?op=add-printer")
|
||||
+ utils.openURL("http://localhost:631/admin")
|
||||
|
||||
|
||||
def ExitButton_clicked(self):
|
@ -1,16 +1,16 @@
|
||||
diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2010-05-17 15:00:02.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
@@ -350,7 +350,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
diff -up hplip-3.11.1/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.11.1/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.1/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2011-01-24 12:01:19.000000000 +0100
|
||||
+++ hplip-3.11.1/prnt/hpcups/HPCupsFilter.cpp 2011-01-24 12:08:38.000000000 +0100
|
||||
@@ -352,7 +352,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
(attr->value != NULL)) {
|
||||
strncpy(m_JA.printer_platform, attr->value, sizeof(m_JA.printer_platform)-1);
|
||||
if (m_iLogLevel & BASIC_LOG) {
|
||||
- dbglog("HPCUPS: found Printer Platform, it is - %s", attr->value);
|
||||
+ dbglog("HPCUPS: found Printer Platform, it is - %s\n", attr->value);
|
||||
}
|
||||
}
|
||||
|
||||
@@ -365,7 +365,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
if(strcmp(m_JA.printer_platform, "ljzjscolor") == 0)
|
||||
{
|
||||
@@ -372,7 +372,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
}
|
||||
strncpy(m_JA.printer_language, attr->value, sizeof(m_JA.printer_language)-1);
|
||||
if (m_iLogLevel & BASIC_LOG) {
|
||||
@ -19,7 +19,7 @@ diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/p
|
||||
}
|
||||
|
||||
// Fill in the other PCL header info
|
||||
@@ -410,14 +410,14 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
@@ -417,14 +417,14 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
{
|
||||
if (err == PLUGIN_LIBRARY_MISSING)
|
||||
fputs ("STATE: +hplip.plugin-error\n", stderr);
|
||||
@ -36,7 +36,7 @@ diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/p
|
||||
}
|
||||
|
||||
m_pPrinterBuffer = new BYTE[cups_header->cupsWidth * 4 + 32];
|
||||
@@ -503,7 +503,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
@@ -510,7 +510,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
@ -45,7 +45,7 @@ diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/p
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -513,7 +513,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
@@ -520,7 +520,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
@ -54,9 +54,9 @@ diff -up hplip-3.10.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.10.5/p
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Lidil.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Lidil.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
diff -up hplip-3.11.1/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.1/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.11.1/prnt/hpcups/Lidil.cpp.dbglog-newline 2011-01-19 06:15:27.000000000 +0100
|
||||
+++ hplip-3.11.1/prnt/hpcups/Lidil.cpp 2011-01-24 12:01:20.000000000 +0100
|
||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
@ -109,9 +109,9 @@ diff -up hplip-3.10.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.10.5/prnt/hpc
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Pcl3.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Pcl3.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
diff -up hplip-3.11.1/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.1/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.11.1/prnt/hpcups/Pcl3.cpp.dbglog-newline 2011-01-19 06:15:27.000000000 +0100
|
||||
+++ hplip-3.11.1/prnt/hpcups/Pcl3.cpp 2011-01-24 12:01:20.000000000 +0100
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||
|
||||
if (!selectPrintMode())
|
||||
@ -155,9 +155,9 @@ diff -up hplip-3.10.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.10.5/prnt/hpcu
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2010-05-13 01:41:08.000000000 +0200
|
||||
+++ hplip-3.10.5/prnt/hpcups/Pcl3Gui.cpp 2010-05-17 15:00:02.000000000 +0200
|
||||
diff -up hplip-3.11.1/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.11.1/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.11.1/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2011-01-19 06:15:27.000000000 +0100
|
||||
+++ hplip-3.11.1/prnt/hpcups/Pcl3Gui.cpp 2011-01-24 12:01:20.000000000 +0100
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||
|
||||
if (!selectPrintMode())
|
||||
|
@ -1,17 +1,21 @@
|
||||
diff -up hplip-3.10.6/ui/setupform.py.fax-ppd hplip-3.10.6/ui/setupform.py
|
||||
--- hplip-3.10.6/ui/setupform.py.fax-ppd 2010-08-12 13:08:01.846853509 +0100
|
||||
+++ hplip-3.10.6/ui/setupform.py 2010-08-12 13:08:17.813979176 +0100
|
||||
@@ -886,13 +886,13 @@ class SetupForm(SetupForm_base):
|
||||
diff -up hplip-3.11.1/ui/setupform.py.fax-ppd hplip-3.11.1/ui/setupform.py
|
||||
--- hplip-3.11.1/ui/setupform.py.fax-ppd 2011-01-19 06:18:26.000000000 +0100
|
||||
+++ hplip-3.11.1/ui/setupform.py 2011-01-24 12:00:48.000000000 +0100
|
||||
@@ -886,16 +886,16 @@ class SetupForm(SetupForm_base):
|
||||
QApplication.setOverrideCursor(QApplication.waitCursor)
|
||||
|
||||
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_MARVELL:
|
||||
- fax_ppd_name = "HP-Fax3-hplip" # Fixed width (2528 pixels) and 300dpi rendering
|
||||
+ fax_ppd_name = "HP-Fax3-hpcups" # Fixed width (2528 pixels) and 300dpi rendering
|
||||
nick = "HP Fax 3"
|
||||
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_SOAP:
|
||||
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_SOAP or self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_LEDMSOAP:
|
||||
- fax_ppd_name = "HP-Fax2-hplip" # Fixed width (2528 pixels) and 300dpi rendering
|
||||
+ fax_ppd_name = "HP-Fax2-hpcups" # Fixed width (2528 pixels) and 300dpi rendering
|
||||
nick = "HP Fax 2"
|
||||
if self.mq.get('fax-type', FAX_TYPE_NONE) == FAX_TYPE_LEDM:
|
||||
- fax_ppd_name = "HP-Fax4-hplip" # Fixed width (1728 pixels) and 200dpi rendering
|
||||
+ fax_ppd_name = "HP-Fax4-hpcups" # Fixed width (1728 pixels) and 200dpi rendering
|
||||
nick = "HP Fax 4"
|
||||
else:
|
||||
- fax_ppd_name = "HP-Fax-hplip" # Standard
|
||||
+ fax_ppd_name = "HP-Fax-hpcups" # Standard
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -up hplip-3.10.2/prnt/cupsext/cupsext.c.openPPD hplip-3.10.2/prnt/cupsext/cupsext.c
|
||||
--- hplip-3.10.2/prnt/cupsext/cupsext.c.openPPD 2010-02-25 00:04:58.000000000 +0100
|
||||
+++ hplip-3.10.2/prnt/cupsext/cupsext.c 2010-03-17 19:54:19.000000000 +0100
|
||||
@@ -1221,9 +1221,18 @@ PyObject * openPPD( PyObject * self, PyO
|
||||
return Py_BuildValue( "" ); // None
|
||||
}
|
||||
|
||||
- g_ppd_file = cupsGetPPD( ( const char * ) printer );
|
||||
+ if ( ( g_ppd_file = cupsGetPPD( ( const char * ) printer ) ) == NULL )
|
||||
+ {
|
||||
+ goto bailout;
|
||||
+ }
|
||||
+
|
||||
+ if ( ( file = fopen( g_ppd_file, "r" )) == NULL )
|
||||
+ {
|
||||
+ unlink(g_ppd_file);
|
||||
+ g_ppd_file = NULL;
|
||||
+ goto bailout;
|
||||
+ }
|
||||
|
||||
- file = fopen( g_ppd_file, "r" );
|
||||
ppd = ppdOpen( file );
|
||||
ppdLocalize( ppd );
|
||||
fclose( file );
|
23
hplip.spec
23
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.10.9
|
||||
Release: 14%{?dist}
|
||||
Version: 3.11.1
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -31,10 +31,8 @@ Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-no-system-tray.patch
|
||||
Patch21: hplip-openPPD.patch
|
||||
Patch22: hplip-ppd-ImageableArea.patch
|
||||
Patch23: hplip-network-timeout.patch
|
||||
Patch24: hplip-addgroup.patch
|
||||
Patch25: hplip-raw_deviceID-traceback.patch
|
||||
Patch26: hplip-UnicodeDecodeError.patch
|
||||
Patch27: hplip-emit-SIGNAL.patch
|
||||
@ -45,8 +43,7 @@ Patch31: hplip-hpaio-segfault.patch
|
||||
Patch32: hplip-newline.patch
|
||||
Patch33: hplip-dbus-threads.patch
|
||||
Patch34: hplip-notification-exception.patch
|
||||
Patch35: hplip-cups-web.patch
|
||||
Patch36: hplip-CVE-2010-4267.patch
|
||||
Patch35: hplip-CVE-2010-4267.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -240,9 +237,6 @@ done
|
||||
# Wait longer to see if a system tray becomes available (bug #569969).
|
||||
%patch20 -p1 -b .no-system-tray
|
||||
|
||||
# Prevent segfault in cupsext when opening PPD file (bug #572775).
|
||||
%patch21 -p1 -b .openPPD
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
do
|
||||
@ -257,9 +251,6 @@ done
|
||||
# Increase timeouts for curl, wget, ping for high latency networks (bug #635388).
|
||||
%patch23 -p1 -b .network-timeout
|
||||
|
||||
# utils.addgroup() was returning string instead of array (bug #642771).
|
||||
%patch24 -p1 -b .addgroup
|
||||
|
||||
# Fixed traceback on error condition in device.py (bug #628125).
|
||||
%patch25 -p1 -b .raw_deviceID-traceback
|
||||
|
||||
@ -291,12 +282,9 @@ done
|
||||
# Catch GError exception when notification showing failed (bug #665577).
|
||||
%patch34 -p1 -b .notification-exception
|
||||
|
||||
# Fixed "CUPS Web Interface" button (bug #633899).
|
||||
%patch35 -p1 -b .cups-web
|
||||
|
||||
# Applied patch to fix CVE-2010-4267, remote stack overflow
|
||||
# vulnerability (bug #670252).
|
||||
%patch36 -p1 -b .CVE-2010-4267
|
||||
%patch35 -p1 -b .CVE-2010-4267
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -525,6 +513,9 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Jan 24 2011 Jiri Popelka <jpopelka@redhat.com> 3.11.1-1
|
||||
- 3.11.1
|
||||
|
||||
* Mon Jan 17 2011 Tim Waugh <twaugh@redhat.com> - 3.10.9-14
|
||||
- Applied patch to fix CVE-2010-4267, remote stack overflow
|
||||
vulnerability (bug #670252).
|
||||
|
Loading…
Reference in New Issue
Block a user