Merge branch 'f15' into f16
This commit is contained in:
commit
1eed8ce5ba
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@ hplip-3.10.6.tar.gz
|
||||
/hplip-3.11.5.tar.gz
|
||||
/hplip-3.11.7.tar.gz
|
||||
/hplip-3.11.10.tar.gz
|
||||
/hplip-3.11.12.tar.gz
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk6H1w0ACgkQc9dwzaWQR7nTGwCfdrOZAl0nguWBYFpEgWh4Vm5l
|
||||
TIYAoJ/mlrUoMMeTnqZjTNs7NMyFu3lq
|
||||
=DGE1
|
||||
-----END PGP SIGNATURE-----
|
7
hplip-3.11.12.tar.gz.asc
Normal file
7
hplip-3.11.12.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.9 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk7h8FQACgkQc9dwzaWQR7nygQCg0B80Q754Q71F38ucXMWW21U2
|
||||
Dr8AoNHIrsvkf/cLHJspn40w3rBEAFmn
|
||||
=qCCO
|
||||
-----END PGP SIGNATURE-----
|
@ -1,18 +1,17 @@
|
||||
diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons 2010-04-28 12:23:08.296730566 +0100
|
||||
+++ hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp 2010-04-28 12:25:25.493730293 +0100
|
||||
@@ -479,6 +479,14 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
signal(SIGTERM, HPCancelJob);
|
||||
|
||||
+/*
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.clear-old-state-reasons 2011-12-19 12:12:38.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:16:06.524701093 +0100
|
||||
@@ -502,6 +502,13 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
signal(SIGTERM, HPCancelJob);
|
||||
|
||||
+/*
|
||||
+ * Prior to the re-write of hpcups, this filter managed the
|
||||
+ * marker-supply-low-warning printer state reason. Make sure to
|
||||
+ * clear that state reason so that upgrades work correctly.
|
||||
+ */
|
||||
+
|
||||
+ fputs ("STATE: -marker-supply-low-warning\n", stderr);
|
||||
+
|
||||
cups_raster = cupsRasterOpen(fd, CUPS_RASTER_READ);
|
||||
|
||||
if (cups_raster == NULL) {
|
||||
+ */
|
||||
+ fputs ("STATE: -marker-supply-low-warning\n", stderr);
|
||||
+
|
||||
cups_raster = cupsRasterOpen(fd, CUPS_RASTER_READ);
|
||||
|
||||
if (cups_raster == NULL) {
|
||||
|
@ -1,62 +1,45 @@
|
||||
diff -up hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2011-05-12 13:21:09.000000000 +0200
|
||||
+++ hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp 2011-05-12 13:21:10.000000000 +0200
|
||||
@@ -350,7 +350,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
(attr->value != NULL)) {
|
||||
strncpy(m_JA.printer_platform, attr->value, sizeof(m_JA.printer_platform)-1);
|
||||
if (m_iLogLevel & BASIC_LOG) {
|
||||
- dbglog("HPCUPS: found Printer Platform, it is - %s", attr->value);
|
||||
+ dbglog("HPCUPS: found Printer Platform, it is - %s\n", attr->value);
|
||||
}
|
||||
if(strcmp(m_JA.printer_platform, "ljzjscolor") == 0)
|
||||
{
|
||||
@@ -370,7 +370,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
}
|
||||
strncpy(m_JA.printer_language, attr->value, sizeof(m_JA.printer_language)-1);
|
||||
if (m_iLogLevel & BASIC_LOG) {
|
||||
- dbglog("HPCUPS: found Printer Language, it is - %s", attr->value);
|
||||
+ dbglog("HPCUPS: found Printer Language, it is - %s\n", attr->value);
|
||||
}
|
||||
|
||||
// Fill in the other PCL header info
|
||||
@@ -415,14 +415,14 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
{
|
||||
if (err == PLUGIN_LIBRARY_MISSING)
|
||||
fputs ("STATE: +hplip.plugin-error\n", stderr);
|
||||
- dbglog ("m_Job initialization failed with error = %d", err);
|
||||
+ dbglog ("m_Job initialization failed with error = %d\n", err);
|
||||
ppdClose(m_ppd);
|
||||
m_ppd = NULL;
|
||||
return err;
|
||||
}
|
||||
|
||||
if (m_iLogLevel & BASIC_LOG) {
|
||||
- dbglog("HPCUPS: returning NO_ERROR from startPage");
|
||||
+ dbglog("HPCUPS: returning NO_ERROR from startPage\n");
|
||||
}
|
||||
|
||||
m_pPrinterBuffer = new BYTE[cups_header->cupsWidth * 4 + 32];
|
||||
@@ -509,7 +509,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -519,7 +519,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
diff -up hplip-3.11.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.5/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.11.5/prnt/hpcups/Lidil.cpp.dbglog-newline 2011-05-09 02:59:11.000000000 +0200
|
||||
+++ hplip-3.11.5/prnt/hpcups/Lidil.cpp 2011-05-12 13:23:52.000000000 +0200
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.dbglog-newline 2011-12-19 12:16:37.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:22:02.957245073 +0100
|
||||
@@ -432,7 +432,7 @@ DRIVER_ERROR HPCupsFilter::startPage (cu
|
||||
m_DBusComm.sendEvent(EVENT_PRINT_FAILED_MISSING_PLUGIN, "Plugin missing", m_JA.job_id, m_JA.user_name);
|
||||
|
||||
}
|
||||
- dbglog ("m_Job initialization failed with error = %d", err);
|
||||
+ dbglog ("m_Job initialization failed with error = %d\n", err);
|
||||
ppdClose(m_ppd);
|
||||
m_ppd = NULL;
|
||||
return err;
|
||||
@@ -525,7 +525,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()", err);
|
||||
+ dbglog("HPCUPS: processRasterData returned %d, calling closeFilter()\n", err);
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 1;
|
||||
@@ -535,7 +535,7 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
close(fd);
|
||||
}
|
||||
if (m_iLogLevel & BASIC_LOG)
|
||||
- dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()");
|
||||
+ dbglog("HPCUPS: StartPrintJob end of job, calling closeFilter()\n");
|
||||
closeFilter();
|
||||
cupsRasterClose(cups_raster);
|
||||
return 0;
|
||||
@@ -670,7 +670,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
//Need to revisit to crosscheck if it is a firmware issue.
|
||||
|
||||
*m_pPrinterBuffer = 0x01;
|
||||
- dbglog("First raster data plane.." );
|
||||
+ dbglog("First raster data plane..\n" );
|
||||
}
|
||||
|
||||
if (this->isBlankRaster((BYTE *) m_pPrinterBuffer, &cups_header)) {
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Lidil.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Lidil.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Lidil.cpp 2011-12-19 12:16:39.063294307 +0100
|
||||
@@ -103,7 +103,7 @@ DRIVER_ERROR Lidil::Configure(Pipeline *
|
||||
if (m_pPM->BaseResX != m_pQA->horizontal_resolution ||
|
||||
m_pPM->BaseResY != m_pQA->vertical_resolution)
|
||||
@ -111,9 +94,9 @@ diff -up hplip-3.11.5/prnt/hpcups/Lidil.cpp.dbglog-newline hplip-3.11.5/prnt/hpc
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.11.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.5/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.11.5/prnt/hpcups/Pcl3.cpp.dbglog-newline 2011-05-09 02:59:11.000000000 +0200
|
||||
+++ hplip-3.11.5/prnt/hpcups/Pcl3.cpp 2011-05-12 13:21:10.000000000 +0200
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Pcl3.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Pcl3.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Pcl3.cpp 2011-12-19 12:16:39.107293756 +0100
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3::Configure(Pipeline **
|
||||
|
||||
if (!selectPrintMode())
|
||||
@ -157,9 +140,9 @@ diff -up hplip-3.11.5/prnt/hpcups/Pcl3.cpp.dbglog-newline hplip-3.11.5/prnt/hpcu
|
||||
return false;
|
||||
}
|
||||
|
||||
diff -up hplip-3.11.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.11.5/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.11.5/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2011-05-09 02:59:11.000000000 +0200
|
||||
+++ hplip-3.11.5/prnt/hpcups/Pcl3Gui.cpp 2011-05-12 13:21:10.000000000 +0200
|
||||
diff -up hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp.dbglog-newline 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/Pcl3Gui.cpp 2011-12-19 12:16:39.156293143 +0100
|
||||
@@ -66,13 +66,13 @@ DRIVER_ERROR Pcl3Gui::Configure(Pipeline
|
||||
|
||||
if (!selectPrintMode())
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff -up hplip-3.10.9/toolbox.py.dbus-threads hplip-3.10.9/toolbox.py
|
||||
--- hplip-3.10.9/toolbox.py.dbus-threads 2010-12-15 10:54:17.178739842 +0000
|
||||
+++ hplip-3.10.9/toolbox.py 2010-12-15 10:57:09.923712662 +0000
|
||||
@@ -100,8 +100,11 @@ if ui_toolkit == 'qt3':
|
||||
try:
|
||||
from dbus import SessionBus
|
||||
import dbus.service
|
||||
- from dbus.mainloop.glib import DBusGMainLoop
|
||||
+ from dbus.mainloop.glib import DBusGMainLoop, threads_init
|
||||
from gobject import MainLoop
|
||||
+ import glib
|
||||
+ glib.threads_init();
|
||||
+ dbus.mainloop.glib.threads_init()
|
||||
except ImportError:
|
||||
log.error("Unable to load dbus - Automatic status updates in HPLIP Device Manager will be disabled.")
|
||||
disable_dbus = True
|
File diff suppressed because it is too large
Load Diff
@ -1,25 +0,0 @@
|
||||
diff -up hplip-3.10.9/ui4/setupdialog.py.emit-SIGNAL hplip-3.10.9/ui4/setupdialog.py
|
||||
--- hplip-3.10.9/ui4/setupdialog.py.emit-SIGNAL 2010-12-14 15:51:43.579041162 +0000
|
||||
+++ hplip-3.10.9/ui4/setupdialog.py 2010-12-14 15:52:02.631111875 +0000
|
||||
@@ -867,8 +867,8 @@ class SetupDialog(QDialog, Ui_Dialog):
|
||||
self.printer_fax_names_same = False
|
||||
self.printer_name_ok = True
|
||||
|
||||
- self.FaxNameLineEdit.emit(SIGNAL("textChanged(const QString &)"),
|
||||
- (self.FaxNameLineEdit.text(),))
|
||||
+ self.FaxNameLineEdit.emit(SIGNAL("textEdited(const QString &)"),
|
||||
+ self.FaxNameLineEdit.text())
|
||||
|
||||
self.setIndicators()
|
||||
self.setAddPrinterButton()
|
||||
@@ -899,8 +899,8 @@ class SetupDialog(QDialog, Ui_Dialog):
|
||||
self.printer_fax_names_same = False
|
||||
self.fax_name_ok = True
|
||||
|
||||
- self.PrinterNameLineEdit.emit(SIGNAL("textChanged(const QString&)"),
|
||||
- (self.PrinterNameLineEdit.text(),))
|
||||
+ self.PrinterNameLineEdit.emit(SIGNAL("textEdited(const QString &)"),
|
||||
+ self.PrinterNameLineEdit.text())
|
||||
|
||||
self.setIndicators()
|
||||
self.setAddPrinterButton()
|
@ -1,33 +0,0 @@
|
||||
diff -up hplip-3.10.9/fax/fax.py.fab-root-crash hplip-3.10.9/fax/fax.py
|
||||
--- hplip-3.10.9/fax/fax.py.fab-root-crash 2010-11-12 10:36:30.504796972 +0000
|
||||
+++ hplip-3.10.9/fax/fax.py 2010-11-12 10:38:39.906166234 +0000
|
||||
@@ -203,17 +203,19 @@ class FaxAddressBook(object): # Pickle b
|
||||
self.load()
|
||||
|
||||
def load(self):
|
||||
- self._fab = os.path.join(prop.user_dir, "fab.pickle")
|
||||
- #old_fab = os.path.join(prop.user_dir, "fab.db")
|
||||
+ self._fab = "/dev/null"
|
||||
+ if prop.user_dir != None:
|
||||
+ self._fab = os.path.join(prop.user_dir, "fab.pickle")
|
||||
+ #old_fab = os.path.join(prop.user_dir, "fab.db")
|
||||
+
|
||||
+ # Load the existing pickle if present
|
||||
+ if os.path.exists(self._fab):
|
||||
+ pickle_file = open(self._fab, "r")
|
||||
+ self._data = cPickle.load(pickle_file)
|
||||
+ pickle_file.close()
|
||||
|
||||
- # Load the existing pickle if present
|
||||
- if os.path.exists(self._fab):
|
||||
- pickle_file = open(self._fab, "r")
|
||||
- self._data = cPickle.load(pickle_file)
|
||||
- pickle_file.close()
|
||||
-
|
||||
- else:
|
||||
- self.save() # save the empty file to create the file
|
||||
+ else:
|
||||
+ self.save() # save the empty file to create the file
|
||||
|
||||
|
||||
def set(self, name, title, firstname, lastname, fax, groups, notes):
|
@ -29,7 +29,7 @@ diff -up hplip-3.11.10/scan/sane/hpaio.c~ hplip-3.11.10/scan/sane/hpaio.c
|
||||
+ }
|
||||
+ else
|
||||
+ {
|
||||
DBG6("unsupported scantype=%d %s\n", ma.scantype, cups_printer[i]);
|
||||
DBG(6,"unsupported scantype=%d %s\n", ma.scantype, cups_printer[i]);
|
||||
- }
|
||||
- free(cups_printer[i]);
|
||||
+ }
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up hplip-3.10.9/io/hpmud/hpmud.c.hpaio-segfault hplip-3.10.9/io/hpmud/hpmud.c
|
||||
--- hplip-3.10.9/io/hpmud/hpmud.c.hpaio-segfault 2010-12-13 16:53:16.470306314 +0000
|
||||
+++ hplip-3.10.9/io/hpmud/hpmud.c 2010-12-13 16:53:17.423332321 +0000
|
||||
@@ -305,6 +305,7 @@ static int new_device(const char *uri, e
|
||||
{
|
||||
BUG("invalid uri %s\n", uri);
|
||||
*result = HPMUD_R_INVALID_URI;
|
||||
+ index = 0;
|
||||
goto bugout;
|
||||
}
|
||||
msp->device[i].io_mode = mode;
|
16
hplip-makefile-chgrp.patch
Normal file
16
hplip-makefile-chgrp.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up hplip-3.11.12/Makefile.in.chgrp hplip-3.11.12/Makefile.in
|
||||
--- hplip-3.11.12/Makefile.in.chgrp 2011-12-09 12:23:55.000000000 +0100
|
||||
+++ hplip-3.11.12/Makefile.in 2011-12-19 15:16:53.907090155 +0100
|
||||
@@ -8582,10 +8582,10 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
|
||||
install-dist_hplip_LogDATA:
|
||||
@FULL_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
-@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
+#@FULL_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
@FULL_BUILD_TRUE@ chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
@HPLIP_BUILD_TRUE@ test -z "$(DESTDIR)$(hplip_Logdir)" || mkdir -p $(DESTDIR)$(hplip_Logdir)
|
||||
-@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
+#@HPLIP_BUILD_TRUE@ chgrp "lp" -R $(DESTDIR)$(hplip_Logdir)
|
||||
@HPLIP_BUILD_TRUE@ chmod 774 $(DESTDIR)$(hplip_Logdir)
|
||||
|
||||
install-data-hook:
|
@ -1,30 +1,30 @@
|
||||
diff -up hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir 2010-02-26 12:07:47.170265651 +0000
|
||||
+++ hplip-3.10.2/prnt/hpcups/HPCupsFilter.cpp 2010-02-26 12:09:13.647265807 +0000
|
||||
@@ -443,26 +443,6 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
getLogLevel();
|
||||
m_JA.job_id = atoi(argv[1]);
|
||||
- FILE *fp;
|
||||
- char dFileName[32];
|
||||
- memset(dFileName, 0, sizeof(dFileName));
|
||||
- m_JA.job_id = atoi(argv[1]);
|
||||
- snprintf (dFileName, sizeof(dFileName), "/var/spool/cups/d%05d-001", m_JA.job_id);
|
||||
- if ((fp = fopen (dFileName, "r")))
|
||||
- {
|
||||
- char line[258];
|
||||
- for (int i = 0; i < 10; i++)
|
||||
- {
|
||||
- fgets (line, 256, fp);
|
||||
- if (!strncmp (line, "%%Pages:", 8))
|
||||
- {
|
||||
- sscanf (line+9, "%d", &m_JA.total_pages);
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- fclose (fp);
|
||||
- }
|
||||
-
|
||||
m_ppd = ppdOpenFile(getenv("PPD"));
|
||||
if (m_ppd == NULL) {
|
||||
dbglog("DEBUG: ppdOpenFile failed for %s\n", getenv("PPD"));
|
||||
diff -up hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp.mucks-with-spooldir 2011-12-09 12:17:50.000000000 +0100
|
||||
+++ hplip-3.11.12/prnt/hpcups/HPCupsFilter.cpp 2011-12-19 12:02:03.581239338 +0100
|
||||
@@ -466,26 +466,6 @@ int HPCupsFilter::StartPrintJob(int arg
|
||||
|
||||
getLogLevel();
|
||||
m_JA.job_id = atoi(argv[1]);
|
||||
- FILE *fp;
|
||||
- char dFileName[32];
|
||||
- memset(dFileName, 0, sizeof(dFileName));
|
||||
- m_JA.job_id = atoi(argv[1]);
|
||||
- snprintf (dFileName, sizeof(dFileName), "/var/spool/cups/d%05d-001", m_JA.job_id);
|
||||
- if ((fp = fopen (dFileName, "r")))
|
||||
- {
|
||||
- char line[258];
|
||||
- for (int i = 0; i < 10; i++)
|
||||
- {
|
||||
- fgets (line, 256, fp);
|
||||
- if (!strncmp (line, "%%Pages:", 8))
|
||||
- {
|
||||
- sscanf (line+9, "%d", &m_JA.total_pages);
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- fclose (fp);
|
||||
- }
|
||||
-
|
||||
m_ppd = ppdOpenFile(getenv("PPD"));
|
||||
if (m_ppd == NULL) {
|
||||
dbglog("DEBUG: ppdOpenFile failed for %s\n", getenv("PPD"));
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp.newline hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp.newline 2011-05-12 16:10:02.000000000 +0200
|
||||
+++ hplip-3.11.5/prnt/hpcups/HPCupsFilter.cpp 2011-05-12 16:13:06.000000000 +0200
|
||||
@@ -618,7 +618,7 @@ int HPCupsFilter::processRasterData(cups
|
||||
dbglog("10......\n");
|
||||
}
|
||||
|
||||
- fprintf(stderr, "PAGE: %d %s", current_page_number, m_argv[4]);
|
||||
+ fprintf(stderr, "PAGE: %d %s\n", current_page_number, m_argv[4]);
|
||||
// Iterating through the raster per page
|
||||
for (int y = 0; y < (int) cups_header.cupsHeight; y++) {
|
||||
cupsRasterReadPixels (cups_raster, m_pPrinterBuffer, cups_header.cupsBytesPerLine);
|
@ -1,22 +0,0 @@
|
||||
diff -up hplip-3.11.10/prnt/hpcups/HPCupsFilter.cpp.top-margins-not-respected hplip-3.11.10/prnt/hpcups/HPCupsFilter.cpp
|
||||
--- hplip-3.11.10/prnt/hpcups/HPCupsFilter.cpp.top-margins-not-respected 2011-10-02 05:03:50.000000000 +0200
|
||||
+++ hplip-3.11.10/prnt/hpcups/HPCupsFilter.cpp 2011-11-14 16:49:39.073220429 +0100
|
||||
@@ -544,18 +544,10 @@ bool HPCupsFilter::isBlankRaster(BYTE *i
|
||||
return true;
|
||||
}
|
||||
|
||||
- if(header->cupsColorSpace == CUPS_CSPACE_K){
|
||||
- if (*input_raster == 0x00 &&
|
||||
- !(memcmp(input_raster + 1, input_raster, length_in_bytes - 1))) {
|
||||
- return true;
|
||||
- }
|
||||
- }
|
||||
- else{
|
||||
if (*input_raster == 0xFF &&
|
||||
!(memcmp(input_raster + 1, input_raster, length_in_bytes - 1))) {
|
||||
return true;
|
||||
}
|
||||
- }
|
||||
return false;
|
||||
}
|
||||
|
@ -1,29 +1,23 @@
|
||||
diff -up hplip-3.11.7/data/rules/56-hpmud_support.rules.udev-rules hplip-3.11.7/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.11.7/data/rules/56-hpmud_support.rules.udev-rules 2011-07-24 21:04:13.000000000 +0200
|
||||
+++ hplip-3.11.7/data/rules/56-hpmud_support.rules 2011-07-25 13:52:09.379058787 +0200
|
||||
@@ -6,10 +6,11 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
diff -up hplip-3.11.12/data/rules/56-hpmud_support.rules.udev-rules hplip-3.11.12/data/rules/56-hpmud_support.rules
|
||||
--- hplip-3.11.12/data/rules/56-hpmud_support.rules.udev-rules 2011-12-09 12:19:54.000000000 +0100
|
||||
+++ hplip-3.11.12/data/rules/56-hpmud_support.rules 2011-12-19 17:23:29.769128810 +0100
|
||||
@@ -6,6 +6,7 @@ SUBSYSTEM!="usb_device", GOTO="hpmud_rul
|
||||
|
||||
LABEL="pid_test"
|
||||
|
||||
+ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
|
||||
# Check for LaserJet products (0x03f0xx17).
|
||||
-SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="??17", ENV{hp_model}="$sysfs{product}", ENV{hp_test}="yes"
|
||||
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attr{product}", ENV{hp_test}="yes"
|
||||
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??17", ENV{hp_model}="$attrs{product}", ENV{hp_test}="yes"
|
||||
# Check for LaserJet products (0x03f0xx2a).
|
||||
-SYSFS{idVendor}=="03f0", SYSFS{idProduct}=="??2a", ENV{hp_model}="$sysfs{product}", ENV{hp_test}="yes"
|
||||
+ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="??2a", ENV{hp_model}="$attr{product}", ENV{hp_test}="yes"
|
||||
ENV{hp_test}=="yes", RUN+="/bin/sh -c '/usr/bin/hp-mkuri -c &'"
|
||||
|
||||
LABEL="hpmud_rules_end"
|
||||
diff -up hplip-3.11.10/Makefile.in.udev-rules hplip-3.11.10/Makefile.in
|
||||
--- hplip-3.11.10/Makefile.in.udev-rules 2011-10-02 05:11:49.000000000 +0200
|
||||
+++ hplip-3.11.10/Makefile.in 2011-10-24 14:23:17.336002785 +0200
|
||||
@@ -4093,7 +4093,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
diff -up hplip-3.11.12/Makefile.in.udev-rules hplip-3.11.12/Makefile.in
|
||||
--- hplip-3.11.12/Makefile.in.udev-rules 2011-12-09 12:23:55.000000000 +0100
|
||||
+++ hplip-3.11.12/Makefile.in 2011-12-19 17:24:14.204573291 +0100
|
||||
@@ -4106,7 +4106,7 @@ cups_drv = prnt/drv/hpcups.drv
|
||||
@HPLIP_BUILD_TRUE@hp_mkuri_CFLAGS = -DCONFDIR=\"$(hplip_confdir)\"
|
||||
|
||||
# hpmud.rules
|
||||
-@HPLIP_BUILD_TRUE@rulesdir = /etc/udev/rules.d
|
||||
+@HPLIP_BUILD_TRUE@rulesdir = /lib/udev/rules.d
|
||||
@HPLIP_BUILD_TRUE@dist_rules_DATA = data/rules/56-hpmud_support.rules \
|
||||
@HPLIP_BUILD_TRUE@ data/rules/86-hpmud_plugin.rules \
|
||||
@HPLIP_BUILD_TRUE@ $(am__append_2) $(am__append_3)
|
||||
@HPLIP_BUILD_TRUE@halpredir = /usr/share/hal/fdi/preprobe/10osvendor
|
||||
|
79
hplip.spec
79
hplip.spec
@ -1,7 +1,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.11.10
|
||||
Release: 11%{?dist}
|
||||
Version: 3.11.12
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+ and MIT
|
||||
Group: System Environment/Daemons
|
||||
Conflicts: system-config-printer < 0.6.132
|
||||
@ -34,21 +34,16 @@ Patch17: hplip-deviceIDs-ppd.patch
|
||||
Patch18: hplip-skip-blank-lines.patch
|
||||
Patch19: hplip-dbglog-newline.patch
|
||||
Patch20: hplip-no-system-tray.patch
|
||||
Patch22: hplip-ppd-ImageableArea.patch
|
||||
Patch25: hplip-raw_deviceID-traceback.patch
|
||||
Patch26: hplip-UnicodeDecodeError.patch
|
||||
Patch27: hplip-emit-SIGNAL.patch
|
||||
Patch28: hplip-fab-root-crash.patch
|
||||
Patch29: hplip-addprinter.patch
|
||||
Patch30: hplip-dbus-exception.patch
|
||||
Patch31: hplip-hpaio-segfault.patch
|
||||
Patch32: hplip-newline.patch
|
||||
Patch33: hplip-dbus-threads.patch
|
||||
Patch34: hplip-notification-exception.patch
|
||||
Patch35: hplip-CVE-2010-4267.patch
|
||||
Patch36: hplip-wifisetup.patch
|
||||
Patch37: hplip-hpaio-localonly.patch
|
||||
Patch38: hplip-top-margins-not-respected.patch
|
||||
Patch21: hplip-ppd-ImageableArea.patch
|
||||
Patch22: hplip-raw_deviceID-traceback.patch
|
||||
Patch23: hplip-UnicodeDecodeError.patch
|
||||
Patch24: hplip-addprinter.patch
|
||||
Patch25: hplip-dbus-exception.patch
|
||||
Patch26: hplip-notification-exception.patch
|
||||
Patch27: hplip-CVE-2010-4267.patch
|
||||
Patch28: hplip-wifisetup.patch
|
||||
Patch29: hplip-makefile-chgrp.patch
|
||||
Patch30: hplip-hpaio-localonly.patch
|
||||
|
||||
Requires(pre): /sbin/service
|
||||
Requires(post): /sbin/chkconfig
|
||||
@ -257,59 +252,45 @@ done
|
||||
%patch20 -p1 -b .no-system-tray
|
||||
|
||||
# Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
|
||||
for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
do
|
||||
gunzip ${ppd_file#*/}.gz
|
||||
done
|
||||
%patch22 -p1 -b .ImageableArea
|
||||
for ppd_file in $(grep '^diff' %{PATCH22} | cut -d " " -f 4);
|
||||
%patch21 -p1 -b .ImageableArea
|
||||
for ppd_file in $(grep '^diff' %{PATCH21} | cut -d " " -f 4);
|
||||
do
|
||||
gzip -n ${ppd_file#*/}
|
||||
done
|
||||
|
||||
# Fixed traceback on error condition in device.py (bug #628125).
|
||||
%patch25 -p1 -b .raw_deviceID-traceback
|
||||
%patch22 -p1 -b .raw_deviceID-traceback
|
||||
|
||||
# Avoid UnicodeDecodeError in printsettingstoolbox.py (bug #645739).
|
||||
%patch26 -p1 -b .UnicodeDecodeError
|
||||
|
||||
# Don't emit SIGNALs in ui4.setupdialog.SetupDialog the PyQt3 way (bug #623834).
|
||||
%patch27 -p1 -b .emit-SIGNAL
|
||||
|
||||
# Prevent hp-fab traceback when run as root.
|
||||
%patch28 -p1 -b .fab-root-crash
|
||||
%patch23 -p1 -b .UnicodeDecodeError
|
||||
|
||||
# Call cupsSetUser in cupsext's addPrinter method before connecting so
|
||||
# that we can get an authentication callback (bug #538352).
|
||||
%patch29 -p1 -b .addprinter
|
||||
%patch24 -p1 -b .addprinter
|
||||
|
||||
# Catch D-Bus exceptions in fax dialog (bug #645316).
|
||||
%patch30 -p1 -b .dbus-exception
|
||||
|
||||
# Prevent hpaio segfaulting on invalid URIs (bug #649092).
|
||||
%patch31 -p1 -b .hpaio-segfault
|
||||
|
||||
# Another missing newline in filter output (Ubuntu #418053).
|
||||
%patch32 -p1 -b .newline
|
||||
|
||||
# Enable D-Bus threading (and require pygobject2) (bug #600932).
|
||||
%patch33 -p1 -b .dbus-threads
|
||||
%patch25 -p1 -b .dbus-exception
|
||||
|
||||
# Catch GError exception when notification showing failed (bug #665577).
|
||||
%patch34 -p1 -b .notification-exception
|
||||
%patch26 -p1 -b .notification-exception
|
||||
|
||||
# Applied patch to fix CVE-2010-4267, remote stack overflow
|
||||
# vulnerability (bug #670252).
|
||||
%patch35 -p1 -b .CVE-2010-4267
|
||||
%patch27 -p1 -b .CVE-2010-4267
|
||||
|
||||
# Avoid KeyError in ui4/wifisetupdialog.py (bug #680939).
|
||||
%patch36 -p1 -b .wifisetup
|
||||
%patch28 -p1 -b .wifisetup
|
||||
|
||||
# Don't run 'chgrp lp /var/log/hp' in makefile
|
||||
%patch29 -p1 -b .chgrp
|
||||
|
||||
# Pay attention to the SANE localOnly flag in hpaio (bug #743593).
|
||||
%patch37 -p1 -b .hpaio-localonly
|
||||
%patch30 -p1 -b .hpaio-localonly
|
||||
|
||||
# revert prnt/hpcups/HPCupsFilter.cpp 3.11.5->3.11.7 change (bug #738089).
|
||||
%patch38 -p1 -b .top-margins-not-respected
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
@ -394,9 +375,11 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%defattr(-,root,root)
|
||||
%doc COPYING doc/*
|
||||
%{_bindir}/hp-align
|
||||
%{_bindir}/hp-check-plugin
|
||||
%{_bindir}/hp-clean
|
||||
%{_bindir}/hp-colorcal
|
||||
%{_bindir}/hp-devicesettings
|
||||
%{_bindir}/hp-diagnose_plugin
|
||||
%{_bindir}/hp-fab
|
||||
%{_bindir}/hp-faxsetup
|
||||
%{_bindir}/hp-firmware
|
||||
@ -425,9 +408,11 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_datadir}/cups/mime/pstotiff.convs
|
||||
# Files
|
||||
%{_datadir}/hplip/align.py*
|
||||
%{_datadir}/hplip/check-plugin*
|
||||
%{_datadir}/hplip/clean.py*
|
||||
%{_datadir}/hplip/colorcal.py*
|
||||
%{_datadir}/hplip/devicesettings.py*
|
||||
%{_datadir}/hplip/diagnose_plugin*
|
||||
%{_datadir}/hplip/fab.py*
|
||||
%{_datadir}/hplip/fax
|
||||
%{_datadir}/hplip/faxsetup.py*
|
||||
@ -465,6 +450,7 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%{_datadir}/hplip/prnt/plugins
|
||||
%{_datadir}/hplip/scan
|
||||
%{_localstatedir}/lib/hp
|
||||
%dir %attr(0774,root,lp) %{_localstatedir}/log/hp
|
||||
|
||||
%files common
|
||||
%defattr(-,root,root,-)
|
||||
@ -537,6 +523,9 @@ fi
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Dec 19 2011 Jiri Popelka <jpopelka@redhat.com> 3.11.12-1
|
||||
- 3.11.12
|
||||
|
||||
* Mon Nov 21 2011 Tim Waugh <twaugh@redhat.com> 3.11.10-11
|
||||
- Added IEEE 1284 Device ID for Designjet T770 (bug #747957).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user