Fixed incorrect name in function call in makeURI when a parallel port device is used (bug #1159161).
Resolves: rhbz#1159161
This commit is contained in:
parent
39efc1aed2
commit
1eea8c448d
12
hplip-device_open.patch
Normal file
12
hplip-device_open.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up hplip-3.14.10/base/device.py.device_open hplip-3.14.10/base/device.py
|
||||||
|
--- hplip-3.14.10/base/device.py.device_open 2014-10-31 09:28:43.675181974 +0000
|
||||||
|
+++ hplip-3.14.10/base/device.py 2014-10-31 09:28:56.579250180 +0000
|
||||||
|
@@ -400,7 +400,7 @@ def makeURI(param, port=1):
|
||||||
|
mq = queryModelByURI(d)
|
||||||
|
|
||||||
|
result_code, device_id = \
|
||||||
|
- hpmudext.device_open(d, mq.get('io-mode', hpmudext.HPMUD_UNI_MODE))
|
||||||
|
+ hpmudext.open_device(d, mq.get('io-mode', hpmudext.HPMUD_UNI_MODE))
|
||||||
|
|
||||||
|
if result_code == hpmudext.HPMUD_R_OK:
|
||||||
|
result_code, data = hpmudext.get_device_id(device_id)
|
11
hplip.spec
11
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.14.10
|
Version: 3.14.10
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
License: GPLv2+ and MIT
|
License: GPLv2+ and MIT
|
||||||
|
|
||||||
Url: http://hplip.sourceforge.net/
|
Url: http://hplip.sourceforge.net/
|
||||||
@ -34,6 +34,7 @@ Patch17: hplip-codec.patch
|
|||||||
Patch18: hplip-log-stderr.patch
|
Patch18: hplip-log-stderr.patch
|
||||||
Patch19: hplip-avahi-parsing.patch
|
Patch19: hplip-avahi-parsing.patch
|
||||||
Patch20: hplip-reportlab.patch
|
Patch20: hplip-reportlab.patch
|
||||||
|
Patch21: hplip-device_open.patch
|
||||||
|
|
||||||
%global hpijs_epoch 1
|
%global hpijs_epoch 1
|
||||||
Requires: hpijs%{?_isa} = %{hpijs_epoch}:%{version}-%{release}
|
Requires: hpijs%{?_isa} = %{hpijs_epoch}:%{version}-%{release}
|
||||||
@ -252,6 +253,10 @@ done
|
|||||||
# reportlab (bug #1121433).
|
# reportlab (bug #1121433).
|
||||||
%patch20 -p1 -b .reportlab
|
%patch20 -p1 -b .reportlab
|
||||||
|
|
||||||
|
# Fixed incorrect name in function call in makeURI when a parallel
|
||||||
|
# port device is used (bug #1159161).
|
||||||
|
%patch21 -p1 -b .device_open
|
||||||
|
|
||||||
sed -i.duplex-constraints \
|
sed -i.duplex-constraints \
|
||||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||||
prnt/drv/hpcups.drv.in
|
prnt/drv/hpcups.drv.in
|
||||||
@ -488,6 +493,10 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%postun libs -p /sbin/ldconfig
|
%postun libs -p /sbin/ldconfig
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 31 2014 Tim Waugh <twaugh@redhat.com> - 3.14.10-2
|
||||||
|
- Fixed incorrect name in function call in makeURI when a parallel
|
||||||
|
port device is used (bug #1159161).
|
||||||
|
|
||||||
* Tue Oct 07 2014 Jiri Popelka <jpopelka@redhat.com> - 3.14.10-1
|
* Tue Oct 07 2014 Jiri Popelka <jpopelka@redhat.com> - 3.14.10-1
|
||||||
- 3.14.10
|
- 3.14.10
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user