get out of hp-setup if the device is a standalone scanner
This commit is contained in:
parent
bfad24d925
commit
0f40a3baaa
48
hplip-hpsetup-noscanjets.patch
Normal file
48
hplip-hpsetup-noscanjets.patch
Normal file
@ -0,0 +1,48 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 5d48aaa..88e663f 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -399,9 +399,19 @@ else: # INTERACTIVE_MODE
|
||||
#log.warning("Cannot setup fax - device does not have fax feature.")
|
||||
setup_fax = False
|
||||
|
||||
+ norm_model = models.normalizeModelName(model).lower()
|
||||
+
|
||||
+ # get out if the found model is standalone scanner, hp-setup is printer/fax setup tool
|
||||
+ if 'scanjet' in norm_model:
|
||||
+ log.error('The device {} is a standalone scanner. '
|
||||
+ 'hp-setup is a printer/MFD setup tool, '
|
||||
+ 'not scanner installation tool. '.format(model))
|
||||
+ log.info(log.bold('Scanners do not need a installation, but they may '
|
||||
+ 'require a binary plugin (install by \'hp-plugin -i\').'))
|
||||
+ clean_exit(1)
|
||||
+
|
||||
# ******************************* PLUGIN
|
||||
|
||||
- norm_model = models.normalizeModelName(model).lower()
|
||||
plugin = mq.get('plugin', PLUGIN_NONE)
|
||||
|
||||
if ignore_plugin_check is False and plugin > PLUGIN_NONE:
|
||||
diff --git a/ui5/setupdialog.py b/ui5/setupdialog.py
|
||||
index c6f234b..a5041c1 100644
|
||||
--- a/ui5/setupdialog.py
|
||||
+++ b/ui5/setupdialog.py
|
||||
@@ -1326,6 +1326,18 @@ class SetupDialog(QDialog, Ui_Dialog):
|
||||
self.mq = device.queryModelByURI(self.device_uri)
|
||||
back_end, is_hp, bus, model, serial, dev_file, host, zc, port = device.parseDeviceURI(self.device_uri)
|
||||
self.model = models.normalizeModelName(model).lower()
|
||||
+ if 'scanjet' in self.model:
|
||||
+ FailureUI(self,
|
||||
+ self.__tr('<b>The device {} is a standalone '
|
||||
+ 'scanner.</b> <p>\'hp-setup\' is a tool '
|
||||
+ 'for installing printers and multifunction '
|
||||
+ 'devices. Scanners supported by HPLIP '
|
||||
+ 'work out-of-the-box after HPLIP installation, '
|
||||
+ 'or they may require a binary plugin, which you '
|
||||
+ 'can install by \'hp-plugin -i\'.</p>'.format(model)))
|
||||
+ self.displayPage(PAGE_DEVICES)
|
||||
+ return
|
||||
+
|
||||
self.showAddPrinterPage()
|
||||
|
||||
elif p == PAGE_ADD_PRINTER:
|
10
hplip.spec
10
hplip.spec
@ -172,6 +172,10 @@ Patch59: hplip-check-userperms.patch
|
||||
# getOpenFileName returns a tuple, but hp-fab expects a simple variable
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/1914743
|
||||
Patch60: hplip-fab-import.patch
|
||||
# if an user tries to install scanner via hp-setup (printer/fax utility)
|
||||
# it fails further down - break out earlier with a message
|
||||
# reported upstream as https://bugs.launchpad.net/hplip/+bug/1916114
|
||||
Patch61: hplip-hpsetup-noscanjets.patch
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui if you want to have GUI
|
||||
@ -462,6 +466,9 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
%patch59 -p1 -b .check-userperms
|
||||
# 1919556 - hp-fab crashed: QFileDialog.getOpenFileName is not used correctly
|
||||
%patch60 -p1 -b .fab-import
|
||||
# if an user tries to install scanner via hp-setup (printer/fax utility)
|
||||
# it fails further down - break out earlier with a message
|
||||
%patch61 -p1 -b .hpsetup-noscanjets
|
||||
|
||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||
# mention hplip-gui should be installed if you want GUI
|
||||
@ -810,6 +817,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Fri Feb 19 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.20.11-6
|
||||
- get out of hp-setup if the device is a standalone scanner
|
||||
|
||||
* Thu Feb 18 2021 Zdenek Dohnal <zdohnal@redhat.com> - 3.20.11-6
|
||||
- remove the old search algorithm
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user