1626877 - Fix AttributeError when connecting to printer via wifi
This commit is contained in:
parent
7d33d3ab0b
commit
0ed8259627
19
hplip-wifisetup.patch
Normal file
19
hplip-wifisetup.patch
Normal file
@ -0,0 +1,19 @@
|
||||
commit 7cdc26da185db2335f1efdc6716804266caa1712
|
||||
Author: Tomas Korbar <tkorbar@redhat.com>
|
||||
Date: Thu Sep 20 15:04:47 2018 +0200
|
||||
|
||||
Fix wifi printer setup
|
||||
|
||||
diff --git a/ui5/wifisetupdialog.py b/ui5/wifisetupdialog.py
|
||||
index 74cc0ef..8daff7d 100644
|
||||
--- a/ui5/wifisetupdialog.py
|
||||
+++ b/ui5/wifisetupdialog.py
|
||||
@@ -570,7 +570,7 @@ class WifiSetupDialog(QDialog, Ui_Dialog):
|
||||
try:
|
||||
self.ip,_,addressmode, subnetmask, gateway, pridns, sec_dns= self.wifiObj.getIPConfiguration(self.dev, self.adapterName)
|
||||
if self.ip == "0.0.0.0":
|
||||
- self.ip, subnetmask, gateway, pri_dns, sec_dns, addressmode = self.wifiobj.getwifiotherdetails(self.dev,self.adapterName)
|
||||
+ self.ip, subnetmask, gateway, pridns, sec_dns, addressmode = self.wifiObj.getwifiotherdetails(self.dev,self.adapterName)
|
||||
vsa_codes = self.wifiObj.getVSACodes(self.dev, self.adapterName)
|
||||
ss_max, ss_min, ss_val, ss_dbm = self.wifiObj.getSignalStrength(self.dev, self.adapterName,self.network, self.adaptor_id)
|
||||
self.hn = self.wifiObj.getHostname(self.dev)
|
11
hplip.spec
11
hplip.spec
@ -7,7 +7,7 @@
|
||||
Summary: HP Linux Imaging and Printing Project
|
||||
Name: hplip
|
||||
Version: 3.18.6
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
License: GPLv2+ and MIT and BSD and IJG and Public Domain and GPLv2+ with exceptions and ISC
|
||||
|
||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||
@ -51,6 +51,7 @@ Patch31: hplip-use-binary-str.patch
|
||||
Patch32: hplip-colorlaserjet-mfp-m278-m281.patch
|
||||
Patch33: hplip-error-print.patch
|
||||
Patch34: hplip-hpfax-importerror-print.patch
|
||||
Patch35: hplip-wifisetup.patch
|
||||
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: python3-pillow
|
||||
@ -265,6 +266,11 @@ rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
|
||||
# bug caused by more arguments than argument specifiers in formatted string
|
||||
%patch34 -p1 -b .hpfax-import-error-print
|
||||
|
||||
# 'WifiSetupDialog' object has no attribute 'wifiobj' (bug #1626877)
|
||||
# upstream bug: https://bugs.launchpad.net/hplip/+bug/1752060
|
||||
# bug caused by typo in wifisetupdialog wifiObj property call
|
||||
%patch35 -p1 -b .wifisetup-bad-call-fix
|
||||
|
||||
sed -i.duplex-constraints \
|
||||
-e 's,\(UIConstraints.* \*Duplex\),//\1,' \
|
||||
prnt/drv/hpcups.drv.in
|
||||
@ -550,6 +556,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||
|
||||
%changelog
|
||||
* Mon Oct 01 2018 Tomas Korbar <tkorbar@redhat.com> - 3.18.6-8
|
||||
- 1626877 - Fix AttributeError when connecting to printer via wifi
|
||||
|
||||
* Tue Sep 25 2018 Tomas Korbar <tkorbar@redhat.com> - 3.18.6-7
|
||||
- 1566938 - Fix TypeError when printing ImportError message in hpfax
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user