2079740 - hplip-3.22.4 is available
This commit is contained in:
parent
121a2286ef
commit
0933ecaffa
1
.gitignore
vendored
1
.gitignore
vendored
@ -105,3 +105,4 @@ hplip-3.10.6.tar.gz
|
|||||||
/hplip-3.21.2-repack.tar.gz
|
/hplip-3.21.2-repack.tar.gz
|
||||||
/hplip-3.21.12-repack.tar.gz
|
/hplip-3.21.12-repack.tar.gz
|
||||||
/hplip-3.22.2-repack.tar.gz
|
/hplip-3.22.2-repack.tar.gz
|
||||||
|
/hplip-3.22.4-repack.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/base/exif.py b/base/exif.py
|
|
||||||
index 2b8c447..38dca63 100644
|
|
||||||
--- a/base/exif.py
|
|
||||||
+++ b/base/exif.py
|
|
||||||
@@ -798,7 +798,7 @@ class EXIF_header:
|
|
||||||
tag_name=tag_entry[0]
|
|
||||||
if len(tag_entry) != 1:
|
|
||||||
# optional 2nd tag element is present
|
|
||||||
- if isinstance(tag_entry[1], collections.Callable):
|
|
||||||
+ if isinstance(tag_entry[1], collections.abc.Callable):
|
|
||||||
# call mapping function
|
|
||||||
printable=tag_entry[1](values)
|
|
||||||
else:
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/base/smart_install.py b/base/smart_install.py
|
|
||||||
index ec30aef..dd95e09 100755
|
|
||||||
--- a/base/smart_install.py
|
|
||||||
+++ b/base/smart_install.py
|
|
||||||
@@ -226,7 +226,7 @@ def disable(mode, ui_toolkit='qt4', dialog=None, app=None, passwordObj = None):
|
|
||||||
dialog.init(printer_names, "", QUEUES_SMART_INSTALL_ENABLED)
|
|
||||||
else: # If QT object is not created, creating QT app
|
|
||||||
try:
|
|
||||||
- from ui4.queuesconf import QueuesDiagnose
|
|
||||||
+ from ui5.queuesconf import QueuesDiagnose
|
|
||||||
except ImportError:
|
|
||||||
log.error("Unable to load Qt4 support. Is it installed?")
|
|
||||||
else: # app = QApplication(sys.argv) # caller needs to inoke this, if already QApplication object is not created.
|
|
15
hplip.spec
15
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.22.2
|
Version: 3.22.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -192,12 +192,6 @@ Patch59: hplip-gpgdir-perms.patch
|
|||||||
Patch60: hplip-plugin-udevissues.patch
|
Patch60: hplip-plugin-udevissues.patch
|
||||||
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938504
|
# reported upstream https://bugs.launchpad.net/hplip/+bug/1938504
|
||||||
Patch61: hplip-osname-mismatch.patch
|
Patch61: hplip-osname-mismatch.patch
|
||||||
# 2015428 - python3.10 has Callable in collections.abc
|
|
||||||
# reported as https://bugs.launchpad.net/hplip/+bug/1948801
|
|
||||||
Patch62: hplip-py310-collections-abc.patch
|
|
||||||
# 2015910 - [GUI] hp-setup crashes when loading smart_install module
|
|
||||||
# reported as https://bugs.launchpad.net/hplip/+bug/1957891
|
|
||||||
Patch63: hplip-qt5-smart-install.py
|
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -514,10 +508,6 @@ done
|
|||||||
%patch60 -p1 -b .hpplugin-udevperms
|
%patch60 -p1 -b .hpplugin-udevperms
|
||||||
# upstream bug https://bugs.launchpad.net/hplip/+bug/1938504
|
# upstream bug https://bugs.launchpad.net/hplip/+bug/1938504
|
||||||
%patch61 -p1 -b .osname-mismatch
|
%patch61 -p1 -b .osname-mismatch
|
||||||
# 2015428 - python3.10 has Callable in collections.abc
|
|
||||||
%patch62 -p1 -b .abc
|
|
||||||
# 2015910 - [GUI] hp-setup crashes when loading smart_install module
|
|
||||||
%patch63 -p1 -b .qt5-smart
|
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui should be installed if you want GUI
|
# mention hplip-gui should be installed if you want GUI
|
||||||
@ -873,6 +863,9 @@ rm -f %{buildroot}%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 11 2022 Zdenek Dohnal <zdohnal@redhat.com> - 3.22.2-3
|
||||||
|
- 2079740 - hplip-3.22.4 is available
|
||||||
|
|
||||||
* Mon Mar 28 2022 Zdenek Dohnal <zdohnal@redhat.com> - 3.22.2-2
|
* Mon Mar 28 2022 Zdenek Dohnal <zdohnal@redhat.com> - 3.22.2-2
|
||||||
- make libsane-hpaio only suggested to prevent possible duplicated scanner devices
|
- make libsane-hpaio only suggested to prevent possible duplicated scanner devices
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (hplip-3.22.2-repack.tar.gz) = ab7e0bb4eaaa04aa4be4ee8d1ea5825d3856e93f9a2108149f7282c988c079949668dacfd5b69af0e2a812d2ebc01ff2205d2548336ce43faf6591a98f80e874
|
SHA512 (hplip-3.22.4-repack.tar.gz) = 33b228ee29536060918d0d15ff563c77e189d1ba1dd728b3038d202714a5d8d7742effb6ad8a2b1e5ea104784bc5d995bf793e4b61ab26552737e09aad318f3e
|
||||||
|
Loading…
Reference in New Issue
Block a user