2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
This commit is contained in:
parent
363dc1639d
commit
031349c9fd
13
hplip-fix-parsing-lpstat.patch
Normal file
13
hplip-fix-parsing-lpstat.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/base/queues.py b/base/queues.py
|
||||||
|
index 2f56c8a..0818574 100755
|
||||||
|
--- a/base/queues.py
|
||||||
|
+++ b/base/queues.py
|
||||||
|
@@ -101,7 +101,7 @@ def parseQueues(mode):
|
||||||
|
try:
|
||||||
|
match = LPSTAT_PATTERN.search(p)
|
||||||
|
printer_name = match.group(1)
|
||||||
|
- device_uri = match.group(2)
|
||||||
|
+ device_uri = match.group(3)
|
||||||
|
cups_printers.append((printer_name, device_uri))
|
||||||
|
except AttributeError:
|
||||||
|
pass
|
11
hplip.spec
11
hplip.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: HP Linux Imaging and Printing Project
|
Summary: HP Linux Imaging and Printing Project
|
||||||
Name: hplip
|
Name: hplip
|
||||||
Version: 3.23.5
|
Version: 3.23.5
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv2+ and MIT and BSD and IJG and GPLv2+ with exceptions and ISC
|
License: GPLv2+ and MIT and BSD and IJG and GPLv2+ with exceptions and ISC
|
||||||
|
|
||||||
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
Url: https://developers.hp.com/hp-linux-imaging-and-printing
|
||||||
@ -221,6 +221,9 @@ Patch65: hplip-sclpml-strcasestr.patch
|
|||||||
# - this looks as incompatible conditional for Fedora, so the files are removed,
|
# - this looks as incompatible conditional for Fedora, so the files are removed,
|
||||||
# hplip repacked and this patch removes its mentions in Makefile.am
|
# hplip repacked and this patch removes its mentions in Makefile.am
|
||||||
Patch66: hplip-nocdmfilter.patch
|
Patch66: hplip-nocdmfilter.patch
|
||||||
|
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
||||||
|
# https://bugs.launchpad.net/hplip/+bug/2027972
|
||||||
|
Patch67: hplip-fix-parsing-lpstat.patch
|
||||||
|
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
# mention hplip-gui if you want to have GUI
|
# mention hplip-gui if you want to have GUI
|
||||||
@ -558,6 +561,9 @@ done
|
|||||||
# C99 compatibility patch by fweimer - undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
# C99 compatibility patch by fweimer - undefined strcasestr() in sclpml.c - build with _GNU_SOURCE
|
||||||
%patch -P 65 -p1 -b .sclpml-strcasestr
|
%patch -P 65 -p1 -b .sclpml-strcasestr
|
||||||
%patch -P 66 -p1 -b .nocdmfilter
|
%patch -P 66 -p1 -b .nocdmfilter
|
||||||
|
# 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
||||||
|
# https://bugs.launchpad.net/hplip/+bug/2027972
|
||||||
|
%patch -P 67 -p1 -b .lpstat-parse
|
||||||
|
|
||||||
# Fedora specific patches now, don't put a generic patches under it
|
# Fedora specific patches now, don't put a generic patches under it
|
||||||
%if 0%{?fedora} || 0%{?rhel} <= 8
|
%if 0%{?fedora} || 0%{?rhel} <= 8
|
||||||
@ -929,6 +935,9 @@ find doc/images -type f -exec chmod 644 {} \;
|
|||||||
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
%config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 17 2023 Zdenek Dohnal <zdohnal@redhat.com> - 3.23.5-3
|
||||||
|
- 2192131 - parseQueues() doesn't get device uri from 'lpstat -v', because parsing pattern changed
|
||||||
|
|
||||||
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 3.23.5-2
|
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 3.23.5-2
|
||||||
- Rebuilt for Python 3.12
|
- Rebuilt for Python 3.12
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user