hostname/hostname-rh.patch
Jiri Popelka e3a1fc7b82 remove some rh-specific bits from rh.patch as they are no longer valid (#881913)
- remove outdated de & pt man pages
- /usr move: use _bindir macro
2012-11-30 11:26:08 +01:00

102 lines
3.4 KiB
Diff

diff -up hostname/hostname.1.rh hostname/hostname.1
--- hostname/hostname.1.rh 2012-02-16 15:58:45.000000000 +0100
+++ hostname/hostname.1 2012-11-30 11:02:00.520205938 +0100
@@ -84,6 +84,28 @@ complete FQDN of the system is returned
.B "THE FQDN"
below).
+.LP
+The function
+.BR gethostname(2)
+is used to get the hostname. When the
+.BR "hostname \-a, \-d, \-f or \-i"
+is called will
+.BR gethostbyname(3)
+be called. The difference in
+.BR gethostname(2)
+and
+.BR gethostbyname(3)
+is that
+.BR gethostbyname(3)
+is network aware, so it consults
+.IR /etc/nsswitch.conf
+and
+.IR /etc/host.conf
+to decide whether to read information in
+.IR /etc/hostname
+or
+.IR /etc/hosts
+
.SS "SET NAME"
When called with one argument or with the
.B \-\-file
@@ -109,8 +131,7 @@ command (see
.B "THE FQDN"
below).
.LP
-The host name is usually set once at system startup in
-.I /etc/init.d/hostname.sh
+The host name is usually set once at system startup
(normally by reading the contents of a file which contains
the host name, e.g.
.IR /etc/hostname ).
@@ -207,7 +228,7 @@ order of the output.
Display the short host name. This is the host name cut at the first dot.
.TP
.I "\-v, \-\-verbose"
-Be verbose and tell what's going on.
+Verbose output was removed.
.TP
.I "\-V, \-\-version"
Print version information on standard output and exit successfully.
diff -up hostname/Makefile.rh hostname/Makefile
--- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100
+++ hostname/Makefile 2012-11-30 11:21:16.427798533 +0100
@@ -3,30 +3,35 @@ CFLAGS+=-O2 -Wall
# uncomment the following line if you want to install to a different base dir.
#BASEDIR=/mnt/test
+BINDIR:=/bin
+
OBJS=hostname.o
hostname: $(OBJS)
$(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS) -lnsl
- ln -fs hostname dnsdomainname
- ln -fs hostname domainname
- ln -fs hostname ypdomainname
- ln -fs hostname nisdomainname
install: hostname
install -d ${BASEDIR}/usr/share/man/man1
- install -o root -g root -m 0644 hostname.1 ${BASEDIR}/usr/share/man/man1
+ install -m 0644 hostname.1 ${BASEDIR}/usr/share/man/man1
+
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/dnsdomainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/domainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/ypdomainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/nisdomainname.1
#install -o root -g root -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
+ install -d ${BASEDIR}/usr/share/man/fr/man1
+ install -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/dnsdomainname.1
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/domainname.1
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/ypdomainname.1
+ ln -fs hostname.1 ${BASEDIR}/usr/share/man/fr/man1/nisdomainname.1
- install -d ${BASEDIR}/bin
- install -o root -g root -m 0755 hostname ${BASEDIR}/bin
- ln -f hostname ${BASEDIR}/bin/dnsdomainname
- ln -f hostname ${BASEDIR}/bin/domainname
- ln -f hostname ${BASEDIR}/bin/nisdomainname
- ln -f hostname ${BASEDIR}/bin/ypdomainname
+ install -d ${BASEDIR}$(BINDIR)
+ install -m 0755 hostname ${BASEDIR}$(BINDIR)
+ ln -fs hostname ${BASEDIR}$(BINDIR)/dnsdomainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/domainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/nisdomainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/ypdomainname
clean:
-rm -f $(OBJS) hostname dnsdomainname domainname nisdomainname ypdomainname