remove void -v option from --help
This commit is contained in:
parent
1ed87e22e1
commit
ace53b46d6
@ -1,6 +1,6 @@
|
||||
diff -up hostname/hostname.1.rh hostname/hostname.1
|
||||
--- hostname/hostname.1.rh 2012-12-06 16:18:46.000000000 +0100
|
||||
+++ hostname/hostname.1 2013-03-08 12:12:35.068011173 +0100
|
||||
+++ hostname/hostname.1 2013-03-26 12:39:24.303468313 +0100
|
||||
@@ -84,6 +84,28 @@ complete FQDN of the system is returned
|
||||
.B "THE FQDN"
|
||||
below).
|
||||
@ -40,18 +40,73 @@ diff -up hostname/hostname.1.rh hostname/hostname.1
|
||||
(normally by reading the contents of a file which contains
|
||||
the host name, e.g.
|
||||
.IR /etc/hostname ).
|
||||
@@ -225,7 +246,7 @@ order of the output.
|
||||
@@ -224,9 +245,6 @@ order of the output.
|
||||
.I "\-s, \-\-short"
|
||||
Display the short host name. This is the host name cut at the first dot.
|
||||
.TP
|
||||
.I "\-v, \-\-verbose"
|
||||
-.I "\-v, \-\-verbose"
|
||||
-Be verbose and tell what's going on.
|
||||
+Verbose output was removed.
|
||||
.TP
|
||||
-.TP
|
||||
.I "\-V, \-\-version"
|
||||
Print version information on standard output and exit successfully.
|
||||
.TP
|
||||
diff -up hostname/hostname.c.rh hostname/hostname.c
|
||||
--- hostname/hostname.c.rh 2012-12-06 16:18:46.000000000 +0100
|
||||
+++ hostname/hostname.c 2013-03-26 12:40:44.233038695 +0100
|
||||
@@ -146,16 +146,16 @@ void
|
||||
usage(FILE *stream)
|
||||
{
|
||||
fprintf(stream,
|
||||
- "Usage: hostname [-v] [-b] {hostname|-F file} set host name (from file)\n"
|
||||
- " hostname [-v] [-a|-A|-d|-f|-i|-I|-s|-y] display formatted name\n"
|
||||
- " hostname [-v] display host name\n"
|
||||
+ "Usage: hostname [-b] {hostname|-F file} set host name (from file)\n"
|
||||
+ " hostname [-a|-A|-d|-f|-i|-I|-s|-y] display formatted name\n"
|
||||
+ " hostname display host name\n"
|
||||
"\n"
|
||||
- " {yp,nis,}domainname [-v] {nisdomain|-F file} set NIS domain name (from file)\n"
|
||||
- " {yp,nis,}domainname [-v] display NIS domain name\n"
|
||||
+ " {yp,nis,}domainname {nisdomain|-F file} set NIS domain name (from file)\n"
|
||||
+ " {yp,nis,}domainname display NIS domain name\n"
|
||||
"\n"
|
||||
- " dnsdomainname [-v] display dns domain name\n"
|
||||
+ " dnsdomainname display dns domain name\n"
|
||||
"\n"
|
||||
- " hostname -V|--version|-h|--help print info and exit\n"
|
||||
+ " hostname -V|--version|-h|--help print info and exit\n"
|
||||
"\n"
|
||||
"Program name:\n"
|
||||
" {yp,nis,}domainname=hostname -y\n"
|
||||
@@ -447,7 +447,6 @@ main(int argc, char **argv)
|
||||
{"long", no_argument, 0, 'f'},
|
||||
{"short", no_argument, 0, 's'},
|
||||
{"version", no_argument, 0, 'V'},
|
||||
- {"verbose", no_argument, 0, 'v'},
|
||||
{"alias", no_argument, 0, 'a'},
|
||||
{"ip-address", no_argument, 0, 'i'},
|
||||
{"all-ip-addresses", no_argument, 0, 'I'},
|
||||
@@ -467,7 +466,7 @@ main(int argc, char **argv)
|
||||
else if (!strcmp(progname, "nisdomainname"))
|
||||
type = NIS_DEF;
|
||||
|
||||
- while((o = getopt_long(argc, argv, "aAdfbF:h?iIsVvy", long_options, NULL)) != -1)
|
||||
+ while((o = getopt_long(argc, argv, "aAdfbF:h?iIsVy", long_options, NULL)) != -1)
|
||||
switch (o) {
|
||||
case 'd':
|
||||
type = DNS;
|
||||
@@ -499,9 +498,6 @@ main(int argc, char **argv)
|
||||
case 'F':
|
||||
file = optarg;
|
||||
break;
|
||||
- case 'v':
|
||||
- /* Does not do anything. */
|
||||
- break;
|
||||
case 'V':
|
||||
printf("hostname %s\n", VERSION);
|
||||
return 0;
|
||||
diff -up hostname/Makefile.rh hostname/Makefile
|
||||
--- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100
|
||||
+++ hostname/Makefile 2013-03-08 12:14:23.884487035 +0100
|
||||
+++ hostname/Makefile 2013-03-26 12:39:24.303468313 +0100
|
||||
@@ -3,30 +3,29 @@ CFLAGS+=-O2 -Wall
|
||||
# uncomment the following line if you want to install to a different base dir.
|
||||
#BASEDIR=/mnt/test
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: Utility to set/show the host name or domain name
|
||||
Name: hostname
|
||||
Version: 3.12
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://packages.qa.debian.org/h/hostname.html
|
||||
@ -30,6 +30,9 @@ make BASEDIR=%{buildroot} install
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Tue Mar 26 2013 Jiri Popelka <jpopelka@redhat.com> - 3.12-4
|
||||
- remove void -v option from --help
|
||||
|
||||
* Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 3.12-3
|
||||
- do not ship outdated french man pages (#919198)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user