3.13: -v references removed upstream

This commit is contained in:
Jiri Popelka 2013-06-18 19:10:03 +02:00
parent ace53b46d6
commit 7a91da9a21
4 changed files with 8 additions and 68 deletions

1
.gitignore vendored
View File

@ -7,3 +7,4 @@ hostname_3.04.tar.gz
/hostname_3.10.tar.gz /hostname_3.10.tar.gz
/hostname_3.11.tar.gz /hostname_3.11.tar.gz
/hostname_3.12.tar.gz /hostname_3.12.tar.gz
/hostname_3.13.tar.gz

View File

@ -40,70 +40,6 @@ diff -up hostname/hostname.1.rh hostname/hostname.1
(normally by reading the contents of a file which contains (normally by reading the contents of a file which contains
the host name, e.g. the host name, e.g.
.IR /etc/hostname ). .IR /etc/hostname ).
@@ -224,9 +245,6 @@ order of the output.
.I "\-s, \-\-short"
Display the short host name. This is the host name cut at the first dot.
.TP
-.I "\-v, \-\-verbose"
-Be verbose and tell what's going on.
-.TP
.I "\-V, \-\-version"
Print version information on standard output and exit successfully.
.TP
diff -up hostname/hostname.c.rh hostname/hostname.c
--- hostname/hostname.c.rh 2012-12-06 16:18:46.000000000 +0100
+++ hostname/hostname.c 2013-03-26 12:40:44.233038695 +0100
@@ -146,16 +146,16 @@ void
usage(FILE *stream)
{
fprintf(stream,
- "Usage: hostname [-v] [-b] {hostname|-F file} set host name (from file)\n"
- " hostname [-v] [-a|-A|-d|-f|-i|-I|-s|-y] display formatted name\n"
- " hostname [-v] display host name\n"
+ "Usage: hostname [-b] {hostname|-F file} set host name (from file)\n"
+ " hostname [-a|-A|-d|-f|-i|-I|-s|-y] display formatted name\n"
+ " hostname display host name\n"
"\n"
- " {yp,nis,}domainname [-v] {nisdomain|-F file} set NIS domain name (from file)\n"
- " {yp,nis,}domainname [-v] display NIS domain name\n"
+ " {yp,nis,}domainname {nisdomain|-F file} set NIS domain name (from file)\n"
+ " {yp,nis,}domainname display NIS domain name\n"
"\n"
- " dnsdomainname [-v] display dns domain name\n"
+ " dnsdomainname display dns domain name\n"
"\n"
- " hostname -V|--version|-h|--help print info and exit\n"
+ " hostname -V|--version|-h|--help print info and exit\n"
"\n"
"Program name:\n"
" {yp,nis,}domainname=hostname -y\n"
@@ -447,7 +447,6 @@ main(int argc, char **argv)
{"long", no_argument, 0, 'f'},
{"short", no_argument, 0, 's'},
{"version", no_argument, 0, 'V'},
- {"verbose", no_argument, 0, 'v'},
{"alias", no_argument, 0, 'a'},
{"ip-address", no_argument, 0, 'i'},
{"all-ip-addresses", no_argument, 0, 'I'},
@@ -467,7 +466,7 @@ main(int argc, char **argv)
else if (!strcmp(progname, "nisdomainname"))
type = NIS_DEF;
- while((o = getopt_long(argc, argv, "aAdfbF:h?iIsVvy", long_options, NULL)) != -1)
+ while((o = getopt_long(argc, argv, "aAdfbF:h?iIsVy", long_options, NULL)) != -1)
switch (o) {
case 'd':
type = DNS;
@@ -499,9 +498,6 @@ main(int argc, char **argv)
case 'F':
file = optarg;
break;
- case 'v':
- /* Does not do anything. */
- break;
case 'V':
printf("hostname %s\n", VERSION);
return 0;
diff -up hostname/Makefile.rh hostname/Makefile diff -up hostname/Makefile.rh hostname/Makefile
--- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100 --- hostname/Makefile.rh 2012-02-16 16:00:52.000000000 +0100
+++ hostname/Makefile 2013-03-26 12:39:24.303468313 +0100 +++ hostname/Makefile 2013-03-26 12:39:24.303468313 +0100

View File

@ -1,7 +1,7 @@
Summary: Utility to set/show the host name or domain name Summary: Utility to set/show the host name or domain name
Name: hostname Name: hostname
Version: 3.12 Version: 3.13
Release: 4%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Base Group: System Environment/Base
URL: http://packages.qa.debian.org/h/hostname.html URL: http://packages.qa.debian.org/h/hostname.html
@ -15,7 +15,7 @@ This package provides commands which can be used to display the system's
DNS name, and to display or set its hostname or NIS domain name. DNS name, and to display or set its hostname or NIS domain name.
%prep %prep
%setup -q -n hostname %setup -q
%patch1 -p1 -b .rh %patch1 -p1 -b .rh
%build %build
@ -30,6 +30,9 @@ make BASEDIR=%{buildroot} install
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
* Tue Jun 18 2013 Jiri Popelka <jpopelka@redhat.com> - 3.13-1
- 3.13: -v references removed upstream
* Tue Mar 26 2013 Jiri Popelka <jpopelka@redhat.com> - 3.12-4 * Tue Mar 26 2013 Jiri Popelka <jpopelka@redhat.com> - 3.12-4
- remove void -v option from --help - remove void -v option from --help

View File

@ -1 +1 @@
f7965b63320f66cc1cbd5fa031d1bcd7 hostname_3.12.tar.gz ff2e7b7534999dcbaa0d420991ce353a hostname_3.13.tar.gz