This commit is contained in:
Jiri Popelka 2013-11-04 10:22:52 +01:00
parent 8172be0169
commit 585d2a4a10
4 changed files with 37 additions and 49 deletions

1
.gitignore vendored
View File

@ -9,3 +9,4 @@ hostname_3.04.tar.gz
/hostname_3.12.tar.gz /hostname_3.12.tar.gz
/hostname_3.13.tar.gz /hostname_3.13.tar.gz
/hostname_3.14.tar.gz /hostname_3.14.tar.gz
/hostname_3.15.tar.gz

View File

@ -1,6 +1,33 @@
diff -up hostname/Makefile.rh hostname/Makefile
--- hostname/Makefile.rh 2013-11-04 10:12:59.670379153 +0100
+++ hostname/Makefile 2013-11-04 10:15:04.957314495 +0100
@@ -10,21 +10,17 @@ OBJS=hostname.o
hostname: $(OBJS)
$(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS) -lnsl
- ln -fs hostname dnsdomainname
- ln -fs hostname domainname
- ln -fs hostname ypdomainname
- ln -fs hostname nisdomainname
install: hostname
install -d ${BASEDIR}$(MANDIR)/man1
- install -o root -g root -m 0644 hostname.1 ${BASEDIR}$(MANDIR)/man1
+ install -m 0644 hostname.1 ${BASEDIR}$(MANDIR)/man1
ln -fs hostname.1 ${BASEDIR}$(MANDIR)/man1/dnsdomainname.1
ln -fs hostname.1 ${BASEDIR}$(MANDIR)/man1/domainname.1
ln -fs hostname.1 ${BASEDIR}$(MANDIR)/man1/ypdomainname.1
ln -fs hostname.1 ${BASEDIR}$(MANDIR)/man1/nisdomainname.1
install -d ${BASEDIR}$(BINDIR)
- install -o root -g root -m 0755 hostname ${BASEDIR}$(BINDIR)
+ install -m 0755 hostname ${BASEDIR}$(BINDIR)
ln -fs hostname ${BASEDIR}$(BINDIR)/dnsdomainname
ln -fs hostname ${BASEDIR}$(BINDIR)/domainname
ln -fs hostname ${BASEDIR}$(BINDIR)/nisdomainname
diff -up hostname/hostname.1.rh hostname/hostname.1 diff -up hostname/hostname.1.rh hostname/hostname.1
--- hostname/hostname.1.rh 2013-09-06 12:04:07.000000000 +0200 --- hostname/hostname.1.rh 2013-11-03 15:24:23.000000000 +0100
+++ hostname/hostname.1 2013-09-08 19:59:45.343534437 +0200 +++ hostname/hostname.1 2013-11-04 10:12:59.670379153 +0100
@@ -80,6 +80,28 @@ complete FQDN of the system is returned @@ -80,6 +80,28 @@ complete FQDN of the system is returned
.B "THE FQDN" .B "THE FQDN"
below). below).
@ -40,46 +67,3 @@ diff -up hostname/hostname.1.rh hostname/hostname.1
(normally by reading the contents of a file which contains (normally by reading the contents of a file which contains
the host name, e.g. the host name, e.g.
.IR /etc/hostname ). .IR /etc/hostname ).
diff -up hostname/Makefile.rh hostname/Makefile
--- hostname/Makefile.rh 2013-09-08 19:59:45.343534437 +0200
+++ hostname/Makefile 2013-09-08 20:05:50.763966053 +0200
@@ -3,30 +3,28 @@ CFLAGS+=-O2 -Wall
# uncomment the following line if you want to install to a different base dir.
#BASEDIR=/mnt/test
+BINDIR:=/bin
+
OBJS=hostname.o
hostname: $(OBJS)
$(CC) $(CFLAGS) -o $@ $(OBJS) $(LDFLAGS) -lnsl
- ln -fs hostname dnsdomainname
- ln -fs hostname domainname
- ln -fs hostname ypdomainname
- ln -fs hostname nisdomainname
install: hostname
install -d ${BASEDIR}/usr/share/man/man1
- install -o root -g root -m 0644 hostname.1 ${BASEDIR}/usr/share/man/man1
+ install -m 0644 hostname.1 ${BASEDIR}/usr/share/man/man1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/dnsdomainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/domainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/ypdomainname.1
ln -fs hostname.1 ${BASEDIR}/usr/share/man/man1/nisdomainname.1
#install -o root -g root -m 0644 hostname.1.fr ${BASEDIR}/usr/share/man/fr/man1/hostname.1
- install -d ${BASEDIR}/bin
- install -o root -g root -m 0755 hostname ${BASEDIR}/bin
- ln -fs hostname ${BASEDIR}/bin/dnsdomainname
- ln -fs hostname ${BASEDIR}/bin/domainname
- ln -fs hostname ${BASEDIR}/bin/nisdomainname
- ln -fs hostname ${BASEDIR}/bin/ypdomainname
+ install -d ${BASEDIR}$(BINDIR)
+ install -m 0755 hostname ${BASEDIR}$(BINDIR)
+ ln -fs hostname ${BASEDIR}$(BINDIR)/dnsdomainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/domainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/nisdomainname
+ ln -fs hostname ${BASEDIR}$(BINDIR)/ypdomainname
clean:
-rm -f $(OBJS) hostname dnsdomainname domainname nisdomainname ypdomainname

View File

@ -1,7 +1,7 @@
Summary: Utility to set/show the host name or domain name Summary: Utility to set/show the host name or domain name
Name: hostname Name: hostname
Version: 3.14 Version: 3.15
Release: 3%{?dist} Release: 1%{?dist}
License: GPLv2+ License: GPLv2+
Group: System Environment/Base Group: System Environment/Base
URL: http://packages.qa.debian.org/h/hostname.html URL: http://packages.qa.debian.org/h/hostname.html
@ -19,7 +19,7 @@ DNS name, and to display or set its hostname or NIS domain name.
%patch1 -p1 -b .rh %patch1 -p1 -b .rh
%build %build
make CFLAGS="$RPM_OPT_FLAGS $CFLAGS" make CFLAGS="%{optflags} $CFLAGS"
%install %install
make BASEDIR=%{buildroot} BINDIR=%{_bindir} install make BASEDIR=%{buildroot} BINDIR=%{_bindir} install
@ -30,6 +30,9 @@ make BASEDIR=%{buildroot} BINDIR=%{_bindir} install
%{_mandir}/man1/* %{_mandir}/man1/*
%changelog %changelog
* Mon Nov 04 2013 Jiri Popelka <jpopelka@redhat.com> - 3.15-1
- 3.15
* Wed Oct 16 2013 Jiri Popelka <jpopelka@redhat.com> - 3.14-3 * Wed Oct 16 2013 Jiri Popelka <jpopelka@redhat.com> - 3.14-3
- use BINDIR - use BINDIR

View File

@ -1 +1 @@
4674720aeed0326a53ca397a664f69c4 hostname_3.14.tar.gz f93c87de2517850de5f47234e3bcb563 hostname_3.15.tar.gz